التركيب المسبق والتداخل والعرض المسبق

تاريخ آخر تحديث 29‏/10‏/2026

نبذة عن التركيب المسبق والتداخل

إذا أردت تجميع بعض الطبقات الموجودة بالفعل في تركيب، فيمكنك التركيب المسبق لهذه الطبقات.يؤدي التركيب المسبق للطبقات إلى وضعها في تركيب جديد، يحل محل الطبقات في التركيب الأصلي. ويصبح التركيب المتداخل الجديد هو المصدر لطبقة واحدة في التركيب الأصلي. يظهر التركيب الجديد في لوحة Project ويكون متاحًا للعرض أو للاستخدام في أي تركيب آخر. يمكنك تداخل التركيبات عن طريق إضافة تركيب موجود إلى تركيب آخر، تمامًا كما تضيف أي عنصر لقطات آخر إلى تركيب. يفيد التركيب المسبق لطبقة واحدة في إضافة خصائص التحويل إلى الطبقة والتأثير في ترتيب عرض عناصر التركيب.

يشير التداخل إلى تضمين تركيب داخل تركيب آخر. يظهر التركيب المتداخل كطبقة في التركيب الذي يحتويه.

يُطلق أحيانًا على التركيب المتداخل اسم التركيب المسبق، ويُختصر أحيانًا في الاستخدام غير الرسمي إلى precomp أو pre-comp. عندما يُستخدم التركيب المسبق بوصفه عنصر لقطات المصدر لطبقة، تُسمى الطبقة طبقة تركيب مسبق.

أثناء العرض، يمكن القول إن بيانات الصورة والمعلومات الأخرى تتدفق من كل تركيب متداخل إلى التركيب الذي يحتويه.ولهذا السبب، يُشار أحيانًا إلى التركيبات المتداخلة على أنها في المنبع بالنسبة إلى التركيبات التي تحتويها، ويُقال إن التركيبات الحاوية تقع في المصب بالنسبة إلى التركيبات المتداخلة التي تحتويها. تُسمى مجموعة التركيبات المتصلة عبر التداخل شبكة التركيبات. يمكنك التنقل داخل شبكة التركيبات باستخدام Composition Navigator وMini-Flowchart. اعرف المزيد حول فتح التركيبات المتداخلة والتنقل فيها.

تلميح

تشبه التركيبات المسبقة في After Effects عناصر Smart Objects في Adobe Photoshop.

استخدامات التركيب المسبق والتداخل

يساعد التركيب المسبق والتداخل في إدارة التركيبات المعقدة وتنظيمها. من خلال التركيب المسبق والتداخل، يمكنك تنفيذ ما يلي:

  • تطبيق تغييرات معقدة على تركيب كامل: يمكنك إنشاء تركيب يضم طبقات متعددة، ثم تداخل التركيب داخل التركيب العام، وتحريكه وتطبيق التأثيرات على التركيب المتداخل بحيث تتغير كل الطبقات بالطريقة نفسها وخلال الفترة الزمنية نفسها.
  • أعِد استخدام أي شيء تنشئه: يمكنك إنشاء حركة في تركيب مستقل ثم سحب هذا التركيب إلى تراكيب أخرى بعدد المرات التي تريدها.
  • حدّث في خطوة واحدة: عندما تُجري تغييرات على تركيب متداخل، تؤثر هذه التغييرات في كل تركيب يُستخدم فيه، تمامًا مثلما تؤثر التغييرات التي تُجرى على عنصر لقطات المصدر في كل تركيب يُستخدم فيه.
  • غيّر ترتيب العرض الافتراضي للطبقة: يمكنك تحديد أن يقوم After Effects بعرض تحويل (مثل التدوير) قبل عرض التأثيرات حتى يُطبَّق التأثير على اللقطات المُدوَّرة.
  • أضف مجموعة أخرى من خصائص التحويل إلى طبقة: للطبقة التي تمثل التركيب خصائصها الخاصة بالإضافة إلى خصائص الطبقات التي تحتوي عليها. يتيح لك هذا تطبيق مجموعة إضافية من التحويلات على طبقة أو مجموعة من الطبقات.

التفضيلات وإعدادات التركيب التي تؤثر في التراكيب المتداخلة

لأن التركيب المسبق هو نفسه طبقة، يمكنك التحكم في سلوكه باستخدام مفاتيح تبديل الطبقة ومفاتيح تبديل التركيب في لوحة Timeline.يمكنك اختيار ما إذا كانت التغييرات التي تُجرى على مفاتيح التبديل في التركيب الحاوي تنتقل إلى التركيب المتداخل. لمنع مفاتيح تبديل الطبقة من التأثير في التراكيب المتداخلة، حدّد تحرير > التفضيلات > التركيب (Windows) أو After Effects > الإعدادات > التركيب (macOS)، ثم ألغِ تحديد تؤثر مفاتيح التبديل في التراكيب المتداخلة.

في علامة التبويب متقدم ضمن مربع الحوار إعدادات التركيب (تركيب > إعدادات التركيب)، حدّد الحفاظ على الدقة عند التداخل أو الحفاظ على معدل الإطارات عند التداخل أو في قائمة انتظار العرض لكي يحتفظ التركيب بدقته أو معدل إطاراته الخاصة، وألا يرث هذه الإعدادات من التركيب الحاوي.على سبيل المثال، إذا كنت قد استخدمت عمدًا معدل إطارات منخفضًا في أحد التراكيب لإنشاء نتيجة متقطعة تشبه التحريك اليدوي، فيجب أن تحافظ على معدل الإطارات لذلك التركيب عند تداخله. وبالمثل، قد تبدو نتائج rotoscoping غير صحيحة عند تحويلها إلى معدل إطارات أو دقة مختلفين.استخدم هذا الإعداد بدلًا من تأثير Posterize Time، لأنه أقل كفاءة.

يؤدي تغيير الوقت الحالي في إحدى اللوحات إلى تحديث الوقت الحالي في اللوحات الأخرى المرتبطة بذلك التركيب. بشكل افتراضي، يُحدَّث الوقت الحالي أيضًا لجميع التراكيب المرتبطة بالتركيب الحالي من خلال التداخل. لمنع التراكيب المرتبطة عبر التداخل من تحديث أوقاتها الحالية عند تغيير الوقت الحالي في أحد التراكيب، ألغِ تحديد التفضيل مزامنة وقت كل العناصر المرتبطة (تحرير > التفضيلات > التركيب (Windows) أو After Effects > الإعدادات > التركيب (macOS)).

الإنشاء المسبق للطبقات

يضع الإنشاء المسبق للطبقات هذه الطبقات في تركيب جديد، ويُشار إليه غالبًا باسم تركيب مسبق أو precomp.يستبدل هذا الإجراء الطبقات المحددة في التركيب الأصلي بطبقة واحدة تمثل التركيب المسبق الجديد. يفيد الإنشاء المسبق لطبقة واحدة في إضافة خصائص التحويل إلى طبقة والتأثير في الترتيب الذي تُعرض به عناصر التركيب.

حدّد الطبقات في لوحة Timeline، ثم حدّد طبقة > إنشاء مسبق أو اضغط على Ctrl+Shift+C (Windows) أو Command+Shift+C (macOS).

حدّد أحد الخيارات التالية:

اترك كل السمات كما هي

يُبقي خصائص الطبقة المُنشأة مسبقًا وإطاراتها الرئيسية في التركيب الأصلي، مع تطبيقها على الطبقة الجديدة التي تمثل التركيب المسبق. حجم الإطار في التركيب الجديد هو نفسه حجم الطبقة المحددة. لا يتوفر هذا الخيار عند تحديد أكثر من طبقة واحدة أو طبقة نص أو طبقة الشكل.

انقل كل الخصائص إلى التركيب الجديد

ينقل الخصائص والإطارات الرئيسية لطبقات التركيب المُسبق إلى مستوى أبعد عن التركيب الجذري ضمن التسلسل الهرمي للتركيب. عند استخدام هذا الخيار، تبقى التغييرات التي طبّقتها على خصائص الطبقات مع كل طبقة على حدة داخل التركيب المُسبق. يكون حجم إطار التركيب الجديد مطابقًا لحجم إطار التركيب الأصلي.

يمكن أن تتضمن التأثيرات أقنعة وتأثيرات لطبقات أخرى

التأثيرات التي تستخدم طبقات كإدخال، مثل Set Matte وDisplacement Map، تستهدف الأقنعة والتأثيرات الخاصة بطبقة الإدخال. يمكنك استخدام هذه الطبقات من دون إنشاء تركيب مُسبق لها بغرض الإشارة إليها بواسطة تأثير. 

يشبه عنصر التحكم هذا وظيفة القائمة View الموجودة أسفل لوحة العارض Layer، والتي تتيح لك عرض الطبقة من مواضع مختلفة في ترتيب العرض، سواء من المصدر أو من أقنعتها أو من تأثيراتها الفردية.

بالنسبة إلى التأثيرات التي تحتوي على خصائص طبقة، افتح قائمة Input Parameter الموجودة إلى يمين تحديد الطبقة، ثم اختر طبقة الإدخال المستهدفة، مثل:

  • Source: يستهدف مصدر الطبقة فقط. يتم تجاهل الأقنعة والتأثيرات.
  • Masks: يستهدف الطبقة بعد تطبيق أقنعتها. يتم تجاهل التأثيرات.
  • Effects & Masks: يستهدف الطبقة بعد تطبيق أقنعتها وتأثيراتها.

فتح التركيبات المتداخلة والتنقل بينها

يُشار أحيانًا إلى التركيبات المتداخلة على أنها تقع upstream بالنسبة إلى التركيبات التي تحتويها، ويُقال إن التركيبات الحاوية تقع downstream بالنسبة إلى التركيبات المتداخلة التي تتضمنها.يُعد التركيب الجذري الأبعد في اتجاه downstream، بينما يكون التركيب الأكثر تداخلًا هو الأبعد في اتجاه upstream. يمثل مسار تدفق التركيب سلسلة من التركيبات المرتبطة ببعضها بعضًا من خلال احتواء أحدها للآخر أو تداخل أحدها داخل الآخر. تمثل شبكة التركيبات المجموعة الكاملة من التركيبات المرتبطة ببعضها بعضًا عبر التداخل.

يوفر After Effects عدة طرق لفتح تركيب متداخل (تركيب مُسبق):

  • انقر نقرًا مزدوجًا على إدخال التركيب في لوحة Project.
  • انقر نقرًا مزدوجًا على طبقة تركيب مُسبق في لوحة Timeline. انقر نقرًا مزدوجًا مع الضغط على Alt (في Windows) أو Option (في macOS) لفتح طبقة التركيب المُسبق كطبقة في لوحة Layer.
ملاحظة

يؤدي النقر المزدوج على طبقة تركيب مُسبق عند تنشيط أداة الطلاء أو أداة Roto Brush إلى فتح الطبقة في لوحة Layer.

  • لفتح أحدث تكوين أساسي في شبكة التكوينات نفسها التي يوجد بها التكوين الأساسي الحالي، استخدم Shift+Esc.

  • استخدم Composition Navigator.

  • استخدم Composition Mini-Flowchart.

Composition Navigator

يُعد Composition Navigator شريطًا يمتد على الحافة العلوية من لوحة Composition، ويعرض التكوين النشط في ذلك العارض بالنسبة إلى التكوينات الأخرى في شبكة التكوينات نفسها.التكوينات المعروضة هي أحدث التكوينات النشطة في مسار التدفق للتكوين النشط الحالي.

Composition Navigator

A. سهم لفتح Composition Mini-Flowchart  B. زر قائمة اللوحة C. التكوين النشط (الحالي) 

تشير الأسهم بين أسماء التكوينات إلى الاتجاه الذي تتدفق فيه معلومات البكسل لمسار التدفق هذا. الإعداد الافتراضي هو عرض التكوينات في شريط Composition Navigator مع ظهور التكوينات اللاحقة على اليسار والتكوينات السابقة على اليمين.يُشار إلى هذا الإعداد الافتراضي بواسطة خيار Flow Right To Left في قائمة لوحة Composition. لعرض التكوينات بالترتيب الآخر، حدد Flow Left To Right. هذا الإعداد هو تفضيل عام، ينطبق على جميع التكوينات وعلى عرض Composition Mini-Flowchart.

تظهر أسماء التكوينات اللاحقة باهتة للإشارة إلى أن محتواها غير مُستخدم أو معروض في التكوين الأساسي.

  • لعرض شريط Composition Navigator أو إخفائه، حدد Show Composition Navigator من قائمة لوحة Composition.

  • لتنشيط أي تكوين معروض في شريط Composition Navigator، حدد اسم التكوين.

  • إذا كان مسار التدفق طويلًا جدًا بحيث لا يمكن عرضه في لوحة Composition، يظهر زر علامة الحذف عند الحافة اليسرى أو اليمنى لشريط Composition Navigator. لعرض مسار التدفق بالكامل بشكل مؤقت، حدد زر علامة الحذف.

ملاحظة

للتمرير خلال مسار تدفق طويل، ضع المؤشر فوق زر تكوين في Composition Navigator وقم بتدوير عجلة التمرير بالماوس.

المخطط الانسيابي المصغر للتركيبة

Composition Mini-Flowchart هو عنصر تحكم مؤقت يمكنك استخدامه للتنقل بسرعة داخل شبكة التجميعات. عند فتح Composition Mini-Flowchart، يعرض التجميعات التي تسبق وتتبع التجميع المحدد مباشرةً.

تعتمد الألوان في Composition Mini-Flowchart على ألوان التصنيفات المخصصة للتجميعات في لوحة مشروع. إذا تم استخدام تجميع عدة مرات داخل تجميع واحد، تظهر الحالات المتعددة للتجميع المتداخل كإدخال واحد مع رقم بين قوسين يشير إلى عدد الحالات.

لفتح Composition Mini-Flowchart، نفّذ أحد الإجراءات التالية:

يكون Composition Mini-Flowchart مفتوحًا ويعرض التجميعات التي تسبق وتتبع التجميع المحدد مباشرةً.

A. مؤشر يوضح أن التجميع لا يتدفق إلى تجميعات أخرى B. اتجاه التدفق C. التجميع النشط (الحالي) 

  • استخدم مفتاح Tab عندما تكون لوحة Composition أو الطبقة أو جدول زمني أساسية.
  • حدد السهم الموجود إلى يمين اسم التجميع في شريط Composition Navigator.

  • حدد Composition Mini-Flowchart من قائمة Composition، أو من قائمة لوحة Composition، أو من قائمة لوحة Timeline.

  • حدد زر Composition Mini-Flowchart الموجود في أعلى لوحة Timeline.

كما هو الحال مع Composition Navigator، يمكنك اختيار إظهار اتجاه التدفق من اليسار إلى اليمين أو من اليمين إلى اليسار. تشير الأسهم إلى اتجاه التدفق. إذا كان هناك بجانب التجميع بدلاً من سهم، فإن ذلك يعني أن التجميع لا تتدفق إليه أي تجميعات أو لا يتدفق إلى أي تجميعات أخرى.

يتم ترتيب التجميعات السابقة في Composition Mini-Flowchart من الأعلى إلى الأسفل، أبجديًا أو حسب ترتيب الطبقة. للتبديل بين ترتيبي الفرز هذين، اضغط على مفتاح S عندما يكون Composition Mini-Flowchart مفتوحًا. عند الفرز حسب ترتيب الطبقة، يتم ترتيب التجميع المستخدم عدة مرات وفقًا لأعلى حالة له في ترتيب التكديس. يتم ترتيب التجميعات اللاحقة دائمًا أبجديًا.

للتنقل بين التجميعات وتحديدها في Composition Mini-Flowchart، استخدم مفاتيح الأسهم أو حدد السهم أو أزرار الموجودة على جانبي التجميع. لتنشيط التجميع المحدد، استخدم مفتاح المسافة أو Enter (Windows) أو Return (macOS). لإغلاق Composition Mini-Flowchart دون اتخاذ أي إجراء، استخدم Esc، أو Shift، أو حدد خارج Composition Mini-Flowchart.

إجراء عرض مسبق لتركيب متداخل

قد يستغرق عرض تركيب متداخل معقد وقتًا طويلًا، سواءً للمعاينات أو للإخراج النهائي. إذا كان لديك تركيب متداخل لا تتوقع إجراء مزيد من العمل عليه، يمكنك توفير الوقت أثناء كل عملية عرض من خلال إجراء عرض مسبق للتركيب المتداخل إلى ملف فيديو واستبدال التركيب بالفيديو الذي تم عرضه. لا يزال بإمكانك تعديل التركيب المتداخل الأصلي لأنه يظل موجودًا في لوحة Project. إذا أجريت تغييرًا مهمًا على التركيب المتداخل الأصلي، فأعد عرضه مرة أخرى.

يكون العرض المسبق للتركيب المتداخل مفيدًا بشكل خاص عند استخدامه عدة مرات في مشروع.

ملاحظة

طبّق إعدادات الإخراج النهائي عند إجراء عرض مسبق للتركيب المتداخل.

حدد التركيب في لوحة Project أو Composition.

حدد Composition > Pre-render.

يضيف الأمر Pre-render التركيب إلى قائمة انتظار العرض ويضبط إجراء ما بعد العرض Import & Replace Usage لاستبدال التركيب بالفيديو الذي تم عرضه.

خيار Output Module مفتوح، وتم تعيين إجراء ما بعد العرض حاليًا إلى Import & Replace Usage.
استورد الملف الذي تم عرضه مرة أخرى إلى مشروعك تلقائيًا واستبدل التركيب الأصلي أو اللقطات الأصلية.

في لوحة Render Queue، عدّل الإعدادات حسب الحاجة، ثم حدد زر Render لعرض التركيب.

ملاحظة

يتمثل بديل استبدال التركيب بالفيديو في استخدام الفيديو المُعروض كوكيل للتركيب المتداخل.

ترتيب العرض وطيّ التحويلات

يتكون التركيب من طبقات مكدسة فوق بعضها بعضًا في لوحة Timeline. عند عرض التركيب، سواءً للمعاينة أو للإخراج النهائي، يتم عرض الطبقة السفلية أولًا. داخل كل طبقة نقطية (غير متجهة)، يتم تطبيق العناصر بالترتيب التالي: الأقنعة، والتأثيرات، والتحويلات، وأنماط الطبقات. بالنسبة إلى الطبقات المتجهة ذات التنقيط المستمر، يكون ترتيب العرض الافتراضي هو الأقنعة، تليها التحويلات والتأثيرات.

تشير Transformations إلى التغييرات التي تطرأ على الخصائص المُجمَّعة ضمن فئة Transform في لوحة Timeline، بما في ذلك Anchor Point وPosition وScale وRotation وOpacity.ما تراه في لوحة Layer هو نتيجة العرض قبل تنفيذ التحويلات.

ملاحظة

للحصول على تحكم إضافي في وقت تنفيذ التحويلات، يمكنك تطبيق تأثير Transform وإعادة ترتيبه بالنسبة إلى التأثيرات الأخرى.

في مجموعة من التأثيرات أو الأقنعة، تتم معالجة العناصر من الأعلى إلى الأسفل. على سبيل المثال، إذا طبّقت تأثير Circle ثم طبّقت تأثير Magnify، فسيتم تكبير الدائرة. ومع ذلك، إذا سحبت تأثير Magnify إلى أعلى تأثير Circle (قبله) في لوحة Effect Controls أو Timeline، فسيتم رسم الدائرة بعد التكبير ولن يتم تكبيرها.

بعد عرض الطبقة، يبدأ عرض الطبقة التالية.يمكن استخدام الطبقة المعروضة أسفل كمدخل لعرض الطبقة أعلاها، على سبيل المثال، لتحديد نتيجة وضع الدمج.

إذا كان التركيب يحتوي على تركيبات أخرى متداخلة ضمنه، يتم عرض التركيب المتداخل قبل الطبقات الأخرى في التركيب المحتوي.

ملاحظة

تتجاهل بعض التأثيرات الأقنعة الموجودة على الطبقة التي يتم تطبيقها عليها.لجعل تأثير كهذا يعمل على طبقة بها قناع، قم بتكوين الطبقة مسبقًا مع تطبيق القناع عليها، ثم طبّق التأثير على الطبقة المُكوَّنة مسبقًا.

طي التحويلات

إذا تم تحديد مفتاح طي التحويلات لتكوين متداخل، فلن يتم تنفيذ التحويلات الخاصة بالتكوين المتداخل إلا بعد عرض الأقنعة والتأثيرات الخاصة بالتكوين المحتوي له.يسمح ترتيب العرض هذا بدمج التحويلات الخاصة بالتكوين المتداخل والتكوين المحتوي له، أو طيّها، وتنفيذها معًا.ينطبق الأمر نفسه على الطبقات المتجهة التي لا تتم رسترتها بصورة مستمرة.

ملاحظة

بدلًا من مفتاح طي التحويلات، تحتوي الطبقات المتجهة على مفتاح الرسترة المستمرة في نفس الموضع.تشمل الطبقات المتجهة طبقات الشكل وطبقات النص والطبقات التي تحتوي على ملفات رسم متجه بصفتها لقطات المصدر.تتم رسترة طبقات النص وطبقات الشكل دائمًا بصورة مستمرة.

يمكن أن يحافظ طي التحويلات، على سبيل المثال، على الدقة عندما يتم تصغير حجم الطبقة بمقدار النصف في تكوين متداخل، ثم تكبير حجم التكوين المتداخل بمعامل اثنين في التكوين المحتوي له.في هذه الحالة، بدلًا من تنفيذ كلا التحويلين وفقدان بيانات الصورة، يمكن تنفيذ تحويل واحد فقط، لا يقوم بأي شيء لأن التحويلات الفردية تلغي بعضها بعضًا.

إذا لم يتم طي التحويلات، يتم عرض التكوين المتداخل الذي يحتوي على طبقات ثلاثية الأبعاد كصورة ثنائية الأبعاد للترتيب ثلاثي الأبعاد باستخدام كاميرا التكوين الافتراضية.يمنع هذا العرض التكوين المتداخل من التقاطع مع الطبقات ثلاثية الأبعاد، أو إسقاط ظلال عليها، أو استقبال ظلال منها في التكوين المحتوي له.كما لا يتم التحكم في التكوين المتداخل بواسطة كاميرات وأضواء التكوين المحتوي له.

إذا تم طي التحويلات، يتم إظهار الخصائص ثلاثية الأبعاد لطبقات التكوين المتداخل للتكوين المحتوي له.بالتالي، يمكن أن يتقاطع التكوين المتداخل مع الطبقات ثلاثية الأبعاد، ويُسقط ظلالًا عليها، ويستقبل ظلالًا منها في التكوين المحتوي له.يمكن للكاميرا والأضواء أيضًا التحكم في التكوين المتداخل للتكوين.

بشكل أساسي، يُخبر طيّ التحويلات لتكوين متداخل برنامج After Effects بعدم تسوية الطبقات في التكوين واقتصاصها.بما أن طبقة التعديل تعمل على مُجمّع كل الطبقات الموجودة أسفلها ضمن التكوين نفسه، فإن طبقة التعديل الموجودة ضمن تكوين متداخل ذي تحويلات مطوية ستفرض التسوية والاقتصاص اللذين يمنعهما طي التحويلات عادةً.

عند تطبيق قناع مغلق (بوضع قناع غير بلا)، أو نمط طبقات، أو تأثير على تكوين متداخل ذي تحويلات مطوية، يتم عرض طبقات التكوين المتداخل بمفردها أولًا، ثم يتم تطبيق الأقنعة والتأثيرات، ثم يتم تجميع النتيجة في التكوين الرئيسي.يعني ترتيب العرض هذا أنه لا يتم تطبيق أوضاع الدمج للطبقات المتداخلة على أي طبقات أساسية في التكوين الرئيسي، وأن الطبقات ثلاثية الأبعاد الموجودة أعلى وأسفل الطبقة المطوية لا يمكنها التقاطع أو إسقاط الظلال على بعضها بعضًا.