Security updates available for Adobe Flash Player

Release date: November 25, 2014

Vulnerability identifier: APSB14-26

Priority: See table below

CVE number: CVE-2014-8439

Platform: All Platforms

Summary

Adobe has released security updates for Adobe Flash Player for Windows, Macintosh and Linux.  These updates provide additional hardening against CVE-2014-8439, which was mitigated in the October 14, 2014 release (reference http://helpx.adobe.com/security/products/flash-player/apsb14-22.html).   

Adobe recommends users update their product installations to the latest versions: 

  • Users of the Adobe Flash Player desktop runtime for Windows and Macintosh should update to Adobe Flash Player 15.0.0.239. 

  • Users of the Adobe Flash Player Extended Support Release should update to Adobe Flash Player 13.0.0.258. 

  • Users of Adobe Flash Player for Linux should update to Adobe Flash Player 11.2.202.424. 

  • Adobe Flash Player installed with Google Chrome, as well as Internet Explorer on Windows 8.x will be automatically updated to the current version. 

Affected software versions

  • Adobe Flash Player 15.0.0.223 and earlier versions 

  • Adobe Flash Player 13.0.0.252 and earlier 13.x versions 

  • Adobe Flash Player 11.2.202.418 and earlier versions for Linux 

To verify the version of Adobe Flash Player installed on your system, access the About Flash Player page, or right-click on content running in Flash Player and select "About Adobe (or Macromedia) Flash Player" from the menu. If you use multiple browsers, perform the check for each browser you have installed on your system.

Solution

 

Adobe recommends users update their software installations by following the instructions below: 

 

  • Adobe recommends users of the Adobe Flash Player desktop runtime for Windows and Macintosh update to Adobe Flash Player 15.0.0.239 by visiting the Adobe Flash Player Download Center, or via the update mechanism within the product when prompted. 

  • Adobe recommends users of the Adobe Flash Player Extended Support Release should update to version 13.0.0.258 by visiting http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

  • Adobe recommends users of Adobe Flash Player for Linux update to Adobe Flash Player 11.2.202.424 by visiting the Adobe Flash Player Download Center. 

  • Adobe Flash Player installed with Google Chrome will be automatically updated to the latest Google Chrome version, which will include Adobe Flash Player 15.0.0.239 on Windows and 15.0.0.242 on Macintosh. 

  • Adobe Flash Player installed with Internet Explorer for Windows 8.x will be automatically updated to the latest version, which will include Adobe Flash Player 15.0.0.239.

Priority and severity ratings

Adobe categorizes these updates with the following priority ratings and recommends users update their installation to the newest version:

Product Affected versions Platform Priority rating
Adobe Flash Player Desktop Runtime 15.0.0.223 and earlier
Windows and Macintosh
2
Adobe Flash Player Extended Support Release 13.0.0.252 and earlier Windows and Macintosh
2
Adobe Flash Player for Google Chrome  15.0.0.223 and earlier Windows, Macintosh and Linux
2
Adobe Flash Player for Internet Explorer 10 and Internet Explorer 11 15.0.0.223 and earlier Windows 8.0 and 8.1 2
Adobe Flash Player 11.2.202.418 and earlier Linux 3

These updates address a critical vulnerability in the software.

Details

Adobe has released security updates for Adobe Flash Player for Windows, Macintosh and Linux.  These updates provide additional hardening against CVE-2014-8439, which was mitigated in the October 14, 2014 release (reference http://helpx.adobe.com/security/products/flash-player/apsb14-22.html).   

  • Users of the Adobe Flash Player desktop runtime for Windows and Macintosh should update to Adobe Flash Player 15.0.0.239. 

  • Users of the Adobe Flash Player Extended Support Release should update to Adobe Flash Player 13.0.0.258. 

  • Users of Adobe Flash Player for Linux should update to Adobe Flash Player 11.2.202.424. 

  • Adobe Flash Player installed with Google Chrome, as well as Internet Explorer on Windows 8.x will be automatically updated to the current version.  

These updates provide additional hardening against a vulnerability in the handling of a dereferenced memory pointer that could lead to code execution (CVE-2014-8439).  A mitigation was previously introduced for this issue in the October 14, 2014 release. 

Affected Software Recommended Player Update Availability
Flash Player Desktop Runtime
15.0.0.239

Flash Player Download Center

Flash Player Distribution

Flash Player Extended Support Release 13.0.0.258 Extended Support
Flash Player for Linux 11.2.202.424 Flash Player Download Center
Flash Player for Google Chrome

15.0.0.239 (Windows)

15.0.0.242 (Macintosh)

Google Chrome Releases
Flash Player for Internet Explorer 10 and Internet Explorer 11 15.0.0.239
Microsoft Security Advisory

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issue and for working with Adobe to help protect our customers:

  • Sébastien Duquette of ESET, Timo Hirvonen of F-Secure and Kafeine (CVE-2014-8439)