Değişen özellikler nelerdir?

Photoshop'ta komut dosyası tarafından oluşturulan kullanıcı arabirimi artık Flex yerine Mondo tabanlıdır. Mondo kullanıcı arabirimi çerçevesi; Web için Kaydet, Photoshop Filtre Galerisi vb. gibi birçok dahili eklentide kullanılmak amacıyla kullanıcı arabirimi oluşturmak üzere Photoshop'un bazı sürümlerinde kullanılmaktadır. Bu özellik; komut dosyası tabanlı kullanıcı arabiriminin, kullanıcı arabirimi oluşturmak için Mondo çerçevesini kullanmasına olanak tanır.

Bu değişikliğin amacı nedir?

Bu değişiklik sayesinde komut dosyaları ile oluşturulan kullanıcı arabirimi, HiDPI/Retina ekranlarını destekleyebilecek ve uygulama kullanıcı arabirimi ile daha tutarlı görünecektir.

Etkilenen iletişimlerin listesi

Bu değişiklikten etkilenen uygulamalardaki iletişimlerin listesini aşağıda bulabilirsiniz:

İletişim kutusuMenü
Kontak Sayfası IIDosya > Otomatikleştir > Kontak Sayfası II
Koşullu Mod DeğişikliğiDosya > Otomatikleştir > Koşullu Mod Değişikliği
Görüntüyü SığdırDosya > Otomatikleştir > Görüntüyü Sığdır
Mercek DüzeltmesiDosya > Otomatikleştir > Mercek Düzeltme
HDR Pro ile BirleştirDosya > Otomatikleştir > HDR Pro ile Birleştir
PhotomergeDosya > Otomatikleştir > Photomerge
Renk Aramayı Dışa Aktar  Dosya > Dışa Aktar > Renk Arama Tabloları
Katman Kompozisyonlarından DosyalaraDosya > Dışa Aktar > Katman Kompozisyonlarından Dosyalara
Katman Kompozisyonlarından PDF'eDosya > Dışa Aktar > Katman Kompozisyonlarından PDF'e
Çalışma Yüzeylerinden PDF'eDosya > Dışa Aktar > Çalışma Yüzeylerinden PDF'e
Katmanları Dosyalara Aktar
Dosya > Dışa Aktar > Katmanlardan Dosyalara
Görüntü İşlemciDosya > Komut Dosyaları > Görüntü İşlemci
Komut Dosyası Olay YöneticisiDosya > Komut Dosyası > Komut Dosyası Olay Yöneticisi
Katmanları YükleDosya > Komut Dosyaları > Dosyaları Yığına Yükle
Görüntü İstatistikleriDosya > Komut Dosyaları > İstatistikler
Ölçüm Ölçeği İşaretleyicisiGörüntü > Analiz > Ölçek İşaretleyicisini Yerleştir
AlevFiltre > Görüntüyü Oluştur > Alev
Resim ÇerçevesiFiltre > Görüntüyü Oluştur > Resim Çerçevesi
AğaçFiltre > Görüntüyü Oluştur > Ağaç
Sketchfab'a Yükle3B > Sketchfab'de 3B Katman Paylaş
Hazır Ayarları Dışa Aktar/İçe AktarDüzenle > Hazır Ayarlar > Hazır Ayarları Dışa Aktar/İçe Aktar
Tuğla Dolgusu

Düzenle > Dolgu

İçerikler açılır listesinden "Desen" seçeneğini belirleyin

"Komut Dosyası" seçeneğini belirleyin

Komut Dosyaları açılır listesinden bir seçenek belirleyin

Çapraz Dokuma
Yol Boyunca Yerleştir
Rastgele Dolgu
Simetri Dolgusu
  

Kullanıcı Arabirimi Mizanpajı: Mondo - Flex karşılaştırması

Kullanıcı arabirimleri oluştururken API'lerin komut dosyasının oluşturulmasında herhangi bir değişiklik yoktur. Ancak Mondo'da gruplama bileşeni işleri farklı şekilde gerçekleştirilir.

Flex'te “grup” bileşeni mizanpaj mekanizması gibi kullanılır ve tamamen görünmez olarak kullanılır. Mondo'da, “grup” kendi arka planına sahip bir bileşendir ve diğer bileşenlerle çakışmaz.

Örneğin, her birinde bileşenleri birbiri üzerine düzenlenmiş 2 grup varsa ve her gruptaki söz konusu bileşenler diğerindekiyle çakışmıyorsa tüm bileşenler Flex'te görünür olur.

Grup bileşeni - Flex

Ancak Mondo'da aynı senaryo söz konusu olursa, üstteki grup alttaki grubu engeller.

Grup bileşeni - Mondo

Not:

Bazı kullanıcılar bu nedenden dolayı mevcut komut dosyalarının Mondo'da yanlış kullanıcı arabirimi mizanpajına sahip oldukları sonucuna varabilirler. Bu türden tüm komut dosyaları, “grup” bileşenleri arasındaki çakışmaları kaldırarak değiştirilmelidir. Mondo'da yeni oluşturulan veya Mondo'da çalıştırılmak üzere değiştirilen komut dosyaları Flex'de de sorunsuzca çalışır.

HiDPI desteği

Bu değişiklik sayesinde artık komut dosyası kullanıcı arabirimi HiDPI ekranlarını destekler. Ayrıca HiDPI ekranlarında çalışmasını sağlamak için komut dosyalarında herhangi bir değişiklik yapmanız gerekmez. Sadece 2x görüntü varlığını, aynı dosya adına sahip 1x görüntü varlığının yanına sonek şeklinde “@2X” ifadesi ekleyerek 1x görüntü varlığındaki gibi yerleştirmeniz gerekir.

Örneğin 1x görüntü varlığının dosya adı imageFile.png ise 2x görüntü varlığı  imageFile@2X.png olarak adlandırılmalıdır ve dosya aynı konuma konulmalıdır.

Not:

2x görüntü varlığı bulunmazsa, 1x görüntü varlığı kullanılır.

Bilinen sorunlar

  • Flash Player bileşeni artık desteklenmemektedir. SWF/Flash/Flex dosyaları artık komut dosyası kullanıcı arabirimi ile oynatılamaz.
  • Treeview bileşeni desteklenmemektedir.
  • Grafik çizimi Checkbox ve Radiobutton bileşenlerinde desteklenmez.
  • Düğmenin arka plan rengi değiştirilemez.
  • Grafiklerle çizilen şekiller yumuşak değildir.
     

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi