關於 Adobe Illustrator AI 檔案

Animate 可讓您匯入 Adobe® Illustrator® AI 檔案,並大幅保留圖稿的可編輯性和視覺真實度。AI 匯入工具同時可讓您充分掌握將 Illustrator 圖稿匯入 Animate 的方式,並讓您指定特定物件匯入 AI 檔案的方式。

Animate AI 匯入工具會提供下列重要功能:

  • 將最常用 Illustrator 效果的可編輯性保留成為 Animate 濾鏡。

  • 保留 Animate 和 Illustrator 共有之混合模式的可編輯性。

  • 保留漸層填色的真實度和可編輯性。

  • 維護 RGB (紅色、綠色、藍色) 的外觀。

  • 將 Illustrator 元件匯入成 Animate 元件。

  • 保留貝茲控制點的數目和位置。

  • 保留片段遮色片的真實度。

  • 保留圖樣筆畫和填色的真實度。

  • 保留物件透明度。

  • 將 AI 檔案的圖層轉換成個別的 Animate 圖層、關鍵影格或單一 Animate 圖層。您也可以將 AI 檔案匯入成單一點陣圖影像,而在此情況下,Animate 會將檔案平面化 (點陣化)。

  • 在 Illustrator 和 Animate 之間提供改良的複製和貼上工作流程。複製和貼上對話方塊會提供一些設定,以便套用至貼入 Animate 舞台上的 AI 檔案。

Animate 和 Illustrator 之間的相容性

某些視覺特質可能無法正確匯入,或者這些特質在匯入之後,會喪失在 Animate 編寫環境中進一步編輯的功能。AI 匯入工具會提供許多匯入和放置圖稿的選項,以便有效維持其視覺外觀及可編輯性。不過,您無法保留某些視覺特質。您可以使用下列方針來改善匯入 Animate 之 AI 檔案的外觀:

  • Animate 僅支援 RGB 色域,而且不支援在列印時常用的 CMYK 色域。Animate 可以將 CMYK 影像轉換成 RGB。不過,如果您在 Illustrator 中,將這些顏色轉換成 RGB,保留顏色的效果較佳。

  • 為了將投影、內光暈、外光暈和高斯模糊的 AI 效果保留成可編輯的 Animate 濾鏡,Animate 會將套用這些效果的物件匯入成 Animate 影片片段。如果您嘗試將物件當成影片片段以外的東西匯入這些特質中,Animate 會顯示不相容警告,並建議將物件匯入為影片片段。

使用 Illustrator 和 Animate

您可以將 Illustrator 圖稿移入 Animate 編輯環境,或直接移入 Flash Player 中。您可以拷貝及貼上圖稿、將檔案儲存成 SWF 格式,或將圖稿直接轉存至 Animate。此外,Illustrator 還提供對 Animate 動態文字及影片片段元件的支援。

貼上 Illustrator 圖稿

您可以在 Illustrator 中建立具豐富圖像的圖稿,並簡單、快速且完美地拷貝及貼入 Animate 中。

當您將 Illustrator 圖稿貼入 Animate 時,會保留下列屬性:

  • 路徑和形狀

  • 可調適性

  • 筆畫寬度

  • 漸層定義

  • 文字 (包括 OpenType 字體)

  • 連結的影像

  • 符號

  • 混合模式

此外,Illustrator 和 Animate 會以下列方式支援貼上的圖稿:

  • 當您在 Illustrator 圖稿中選取整個頂端圖層,並將它們貼入 Animate 時,會同時保留圖層及其屬性 (可見度及鎖定)。

  • 非 RGB 的 Illustrator 色彩 (CMYK、灰階和自訂) 在 Animate 中會轉換成 RGB。RGB 色彩則會如預期一樣貼上。

  • 當您匯入或貼上 Illustrator 圖稿時,您可以使用各種選項來保留效果 (例如文字上的陰影),如同 Animate 濾鏡一樣。

  • Animate 會保留 Illustrator 遮色片。

從 Illustrator 轉存 SWF 檔案

您可以從 Illustrator 轉存 SWF 檔案,而且 SWF 檔案的品質及壓縮和從 Animate 匯出的 SWF 檔案完全相同。

在轉存時,您可以從各種預設集中選擇,以確保最佳的輸出,同時您可以指定要如何處理多層畫板、符號、圖層、文字及遮色片。例如,您可以指定是否將 Illustrator 符號轉存成影片片段或圖像,或者您可以選擇從 Illustrator 圖層建立 SWF 符號。

將 Illustrator 檔案匯入 Animate

當您想要在 Illustrator 中建立完整的版面,然後以一個步驟將它們匯入 Animate 時,您可以將圖稿儲存成原生 Illustrator 格式 (AI),並在 Animate 中使用「檔案 > 匯入至舞台」或「檔案 > 匯入至元件庫」命令,以高精確度將圖稿匯入 Animate 中。

如果您的 Illustrator 檔案包含多層畫板,您可以在 Animate 的「匯入」對話方塊中選擇要匯入的畫板,並指定該畫板中所有圖層的設定。所選畫板上的所有物件可以匯入成 Animate 中的單一或多個 Animate 圖層或關鍵影格。

當您將 Illustrator 圖稿匯入成 AI、EPS 或 PDF 檔案時,Animate 會保留與貼上 Illustrator 圖稿時一樣的屬性。此外,當匯入的 Illustrator 檔案包含圖層時,您可以使用下列任何方式來匯入圖層:

  • 將 Illustrator 圖層轉換成 Animate 圖層

  • 將 Illustrator 圖層轉換成 Animate 影格

  • 將所有 Illustrator 圖層轉換成單一 Animate 圖層

符號工作流程

Illustrator 中的元件工作流程與 Animate 中的元件工作流程很類似。

文字轉換

如果 AI 檔案包含文字,您可以將文字轉換成:

  • 可編輯的文字 
  • 向量外框
  • 平面化的點陣圖影像

圖層轉換

Animate CC 可讓您將匯入之 AI 檔案中的圖層轉換成:

  • 單一平面化點陣圖檔案
  • 可編輯的路徑和效果

(僅適用於 Flash Professional CS6 及更早版本) 元件屬性和連結

您可以使用「符號」面板或「控制」面板,輕鬆指定符號範例的名稱、中斷範例和符號之間的連結、將符號範例與另一個符號交換,或建立符號的拷貝。 在 Animate 中,「元件庫」面板中的編輯功能也是以類似的方式運作。

(僅適用於 Flash Professional CS6 及更早版本) 靜態、動態和輸入文字物件

當您從 Illustrator 將靜態文字帶入 Animate 時,Animate 會將文字轉換成外框。此外,您可以在 Illustrator 中將文字設定為動態文字。 動態文字可讓您在 Animate 中以程式設計的方式編輯文字內容,並輕鬆管理需要當地語系化成多種語言的專案。

在 Illustrator 中,您可以將個別的文字物件指定為靜態、動態或輸入文字。 Illustrator 和 Animate 中的動態文字物件具有類似的屬性。例如,這兩者都使用會影響文字區塊中所有字元 (而非影響個別字元) 的特殊字距,都以相同方式消除文字鋸齒,並且都可以連結至包含文字的外部 XML 檔。

關於將 AI 檔案匯入 Animate 元件庫

將 AI 檔案匯入元件庫的過程與匯入「舞台」上差不多,差別在於整個 AI 檔案會被封裝成一個 Animate 元件。此內容會匯入元件庫,然後由 AI 檔案的圖層和群組結構加以組織。

當您將 AI 檔案匯入元件庫時,根資料夾會使用此 AI 檔案的名稱。在 AI 檔案匯入元件庫之後,您就可以變更此根資料夾的名稱,或是將圖層移出資料夾。

注意:「元件庫」面板會按照英文字母順序排列已匯入之 AI 檔案的內容。階層式群組和資料夾結構會維持不變,但是此元件庫會按照英文字母順序重新排列這些項目。

 

當您將 AI 圖層轉換為關鍵影格時,會將 AI 檔匯入為影片片段;若是將 AI 圖層轉換為 Flash 圖層或是單一 Flash 播放程式,則會將 AI 檔匯入為圖像元件。此時會建立影片片段或圖像元件,其中包含匯入時間軸之 AI 檔案的所有內容,如同內容已匯入「舞台」一樣。幾乎所有影片片段都具有關聯的點陣圖或其他資源。為了將混淆情形和命名衝突減至最少,這些資源會與影片片段儲存在相同資料夾的 Assets 資料夾中。

注意:當您匯入到元件庫時,AI 檔案的內容就會匯入到影片片段的時間軸,而非主要的 Animate 時間軸。

 

匯入 AI 檔案後的「元件庫」面板

(僅適用於 Flash Professional CS6 及更早版本) AI 檔案匯入工具的偏好設定

「Animate 偏好設定」對話方塊可讓您設定 AI 檔案的匯入偏好設定以及「AI 檔案匯入」對話方塊。您針對匯入 AI 檔案所指定的偏好設定會影響「AI 匯入」對話方塊最初填入的 Illustrator 物件類型選項。

註解:

若要以逐物件的方式覆寫針對不同圖層類型指定的偏好設定,請使用「AI 匯入」對話方塊。選取圖層、物件或群組以變更其匯入選項,然後指定必要的選項。

一般

這些偏好設定會影響 AI 檔案匯入時,AI 匯入工具的反應行為:

顯示匯入對話方塊

指定「AI 檔案匯入」對話方塊必須顯示。

從裁切區排除物件

將落在工作區域或裁切區外面的 Illustrator 畫布上物件排除。

讀入隱藏圖層

指定預設匯入隱藏的圖層。

將文字匯入為

讓您指定文字物件的下列匯入偏好設定:

可編輯的文字

指定匯入的 Illustrator 文字為可編輯的 Animate 文字。為了維持文字的可編輯性,可能會損害文字的外觀。

向量外框

將文字轉換成向量路徑。您可以使用這個選項來保留文字的視覺外觀。如果文字匯入成影片片段,某些視覺特效可能會有所犧牲 (例如不支援的混合模式和濾鏡),但是視覺特質 (例如路徑上的文字) 會保留下來。雖然文字本身無法再進行編輯,但是不透明度和相容的混合模式會維持其可編輯性。

注意:若要將套用至文字的投影、內光暈、外光暈和高斯模糊等 AI 效果保留成可編輯的 Animate 濾鏡,請選取「建立影片片段匯入」,以便將文字匯入成影片片段。

點陣圖

將文字點陣化成點陣圖,以便保留文字原本在 Illustrator 中呈現的確切外觀。如果套用了與 Animate 不相容的濾鏡或其他效果,將文字匯入成點陣圖就會保留視覺外觀。點陣化的文字無法再進行編輯。

建立影片片段

指定將文字物件匯入到影片片段中。若要在 Illustrator 與 Animate 之間維持支援的混合模式、AI 效果和少於 100% 的透明度,請指定將文字物件匯入成影片片段。

將路徑匯入為

讓您指定下列路徑的匯入偏好設定:

可編輯的路徑

建立可編輯的向量路徑。雖然支援的混合模式、效果和物件透明度會保留下來,但是 Animate 中不支援的特質會被捨棄。

點陣圖

將路徑點陣化成點陣圖,以便保留路徑原本在 Illustrator 中呈現的確切外觀。點陣化的影像無法再進行編輯。

建立影片片段

指定將路徑物件匯入到影片片段中。

影像

讓您指定影像的匯入偏好設定:

將點陣圖平面化以維持外觀

將影像點陣化成點陣圖,以便保留 Animate 中不支援之混合模式和效果的外觀。點陣化的影像無法再進行編輯。

建立影片片段

指定將影像匯入到影片片段中。

群組

讓您指定群組的匯入偏好設定:

匯入為點陣圖

將群組點陣化成點陣圖,以便保留這些物件原本在 Illustrator 中呈現的外觀。當群組轉換成點陣圖之後,您就無法選取或重新命名該群組中的物件。

建立影片片段

指定將群組中的所有物件封裝成單一影片片段。

圖層

讓您指定圖層的匯入偏好設定:

匯入為點陣圖

將圖層點陣化成點陣圖,以便保留這些物件原本在 Illustrator 中呈現的外觀。

建立影片片段

指定將圖層封裝到影片片段中。

影片片段註冊

針對所建立的影片,指定其全域註冊點。此設定將套用至所有物件類型的註冊點上。您可以在「AI 檔案匯入」對話方塊中針對每個物件個別更改此選項;此設定為所有物件類型的初始設定。如需影片片段註冊的詳細資訊,請參閱編輯元件

匯入 Adobe Illustrator 檔案

當您想要在 Illustrator 中建立完整的版面,然後以一個步驟將它們匯入 Animate 時,您可以將圖稿儲存成原生 Illustrator 格式 (AI),並在 Animate 中使用「檔案 > 匯入至舞台」或「檔案 > 匯入至元件庫」命令,以高精確度將圖稿匯入 Animate 中。

如果您的 Illustrator 檔案包含多層畫板,您可以在 Animate 的「匯入」對話方塊中選擇要匯入的畫板,並指定該畫板中所有圖層的設定。所選畫板上的所有物件可以匯入成 Animate 中的單一或多個 Flash 圖層或關鍵影格。

當您將 Illustrator 圖稿匯入成 AI、EPS 或 PDF 檔案時,Animate 會保留與貼上 Illustrator 圖稿時一樣的屬性。此外,當匯入的 Illustrator 檔案包含圖層時,您可以使用下列任何方式來匯入圖層:

  • 將 Illustrator 圖層轉換成 Flash 圖層
  • 將 Illustrator 圖層轉換成 Flash 影格
  • 將所有 Illustrator 圖層轉換成單一 Flash 圖層

符號工作流程

Illustrator 中的元件工作流程與 Animate 中的元件工作流程很類似。

文字轉換

如果 AI 檔案包含文字,您可以將文字轉換成:

  • 可編輯的文字 
  • 向量外框
  • 平面化的點陣圖影像

圖層轉換

Animate CC 可讓您將匯入之 AI 檔案中的圖層轉換成:

  • 單一平面化點陣圖檔案
  • 可編輯的路徑和效果

(僅適用於 Flash Professional CS6 及更早版本) 元件屬性和連結

您可以使用「符號」面板或「控制」面板,輕鬆指定符號範例的名稱、中斷範例和符號之間的連結、將符號範例與另一個符號交換,或建立符號的拷貝。 在 Animate 中,「元件庫」面板中的編輯功能也是以類似的方式運作。

(僅適用於 Flash Professional CS6 及更早版本) 靜態、動態和輸入文字物件

當您從 Illustrator 將靜態文字帶入 Animate 時,Animate 會將文字轉換成外框。此外,您可以在 Illustrator 中將文字設定為動態文字。 動態文字可讓您在 Animate 中以程式設計的方式編輯文字內容,並輕鬆管理需要當地語系化成多種語言的專案。

在 Illustrator 中,您可以將個別的文字物件指定為靜態、動態或輸入文字。 Illustrator 和 Animate 中的動態文字物件具有類似的屬性。例如,這兩者都使用會影響文字區塊中所有字元 (而非影響個別字元) 的特殊字距,都以相同方式消除文字鋸齒,並且都可以連結至包含文字的外部 XML 檔。

AI 匯入進階選項:舞台

  1. AI 匯入進階選項:元件庫

    選取「檔案 > 匯入至舞台」或「匯入至元件庫」。

  2. 瀏覽到要匯入的 AI 檔案、選取該檔案,然後按一下「確定」。「將 Illustrator 文件匯入至舞台」或「將 Illustrator 文件匯入至元件庫」對話方塊隨即顯示。

    此對話方塊會提供一些匯入 Illustrator 檔案的選項。可用的選項會根據您要匯入之 Illustrator 檔案中的物件類型而有所不同。

  3. (選擇性) 若要產生 AI 檔案中與 Animate 不相容之項目的清單,請按一下「不相容性報表」。只有當與 Animate 的不相容性存在 AI 檔案中時,才會顯示「不相容性報表」按鈕。

    不相容性報表會分析 Illustrator 與 Animate 之間各種可能的不相容性。「AI 匯入」對話方塊的「匯入選項」區域 (在「警告」按鈕旁) 會顯示相關建議,針對任何不相容的項目取得最大相容性。

    不相容性報表包括「套用建議的匯入設定」核取方塊。如果您核取了這個方塊,則 Animate 會自動將建議的匯入選項套用至 AI 檔案裡任何不相容的物件中 (除非當 AI 文件大小超出 Animate 所支援的大小範圍,以及當 AI 文件使用 CMYK 顏色模式時)。若要修正任何一項不相容性,請在 Illustrator CS3 中重新開啟文件後調整文件大小,或是將顏色模式更改為 RGB。

  4. 在「匯入」畫面中,選取下列選項:

    • 選取 Illustrator 工作區域:讓您選取要匯入的工作區域。
    • 匯入為點陣圖:為匯入的 AI asset.c3 建立點陣圖。
    • 建立影片片段:指定影像圖層匯入 Animate 時要轉換為影片片段。如果您不想將所有的影像圖層都轉換為影片片段,可以透過「AI 匯入」對話方塊,針對個別圖層變更此選項。
    • 註冊:讓您為影片片段設定註冊點。
    • 將圖層轉換成 Animate 圖層、單一 Animate 圖層和關鍵影格:
      • Animate 圖層:在「選取 Photoshop 圖層」清單中選取的圖層會位於自己的圖層上。每個圖層都會使用 Photoshop 檔案中的圖層名稱標示。
      • 單一 Animate 圖層:所有 AI 圖層都會位於單一 Animate 圖層上。
      • 關鍵影格:在「選取 Illustrator 圖層」清單中選取的所有圖層都會位於新圖層的個別關鍵影格中。
    • 將物件放回原始位置:AI 檔案的內容會保留在原本在 Illustrator 中的確切位置。例如,某個物件在 Illustrator 中位於 X = 100 且 Y = 50 的位置,它就會在 Animate「舞台」上採用相同的座標 (未顯示在「匯入至元件庫」選項中)。
    • 匯入為單一點陣圖影像:將 AI 圖層平面化成單一點陣圖。
    • 匯入未使用的元件:匯入還未使用過的元件。
    • 將舞台設成 Illustrator 工作區域大小:將舞台設成 Illustrator 工作區域大小。所選工作區域的尺寸也會一同顯示。
    • 選取「匯入」即可匯入檔案,選取「取消」可取消程序,選取「隱藏進階選項」則會顯示基本選項。
    AI 基本選項:元件庫

    AI 基本選項:舞台

  5. 在「基本」選項中,選取「圖層轉換」、「文字轉換」和「轉換圖層」中的選項。

    • 選取 Illustrator 工作區域:讓您可以選取要匯入的工作區域。當您在「基本」選項中變更工作區域時,「進階選項」中的樹狀結構配置會根據所選的工作區域而更新。
    • 匯入為點陣圖:為匯入的 AI 資源建立點陣圖。
    • 維持可編輯路徑和效果:運用向量內剪裁的點陣圖建立可編輯的向量形狀。支援的混合模式、濾鏡和不透明度都會保留下來。
    • 單一平面化的影像:將形狀點陣化成點陣圖,以便保留形狀圖層原本在 Illustrator 中呈現的確切外觀。
    • 可編輯的文字:根據選定 Illustrator 圖層上的文字,建立可編輯的文字物件。為了維持文字的可編輯性,可能會損害文字的外觀。
    • 向量外框:將文字轉換成向量路徑,以便保留文字的視覺外觀。
    • 平面化的點陣圖影像:將文字點陣化成點陣圖,以便保留文字圖層原本在 Illustrator 中呈現的確切外觀。點陣化的文字無法再進行編輯。
    • Animate 圖層:在「選取 Illustrator 圖層」清單中選取的圖層會位於自己的圖層上。每個圖層都會使用 Illustrator 檔案中的圖層名稱標示。
    • 單一 Animate 圖層:所有 AI 圖層都會位於單一 Animate 圖層上。
    • 關鍵影格:在「選取 Illustrator 圖層」清單中選取的所有圖層都會位於新圖層的個別關鍵影格中。
    • 將物件放回原始位置:保留在原本在 Illustrator 中的確切位置。例如,某個物件在 Illustrator 中位於 X = 100 且 Y = 50 的位置,它就會在 Animate「舞台」上採用相同的座標 (未顯示在「匯入至元件庫」選項中)。
    • 匯入為單一點陣圖影像:將 AI 圖層平面化成單一點陣圖。
    • 匯入未使用的元件:將匯入還未使用過的元件。
    • 將舞台設成 Illustrator 工作區域大小 (612x792):選取後,會將舞台設成 Illustrator 工作區域大小 (若是「匯入至元件庫」則不會顯示)。
  6. 步驟文字
  7. 選取「匯入」以匯入檔案,選取「取消」以取消程序,或者選取「顯示進階選項」以顯示進階選項。

    元件庫中的 AI 檔案

Illustrator 物件匯入選項

圖層會管理組成 Illustrator 圖稿的所有項目。根據預設,所有項目都會在單一父圖層中組織。您可以將指定之父圖層中的所有項目匯入成單一平面化點陣圖,或者個別選取每個物件,並指定其所屬物件類型 (文字、路徑、群組等等) 的專有匯入選項。「AI 匯入工具」會提供一些選項,讓您選取要匯入之圖稿中的圖層,並根據在 Animate 中保留物件的視覺外觀或可編輯性,指定個別的匯入選項。

更正不相容的圖像特效

  1. 若要產生不相容性報表,請按一下「不相容性報表」。不相容性報表會列出與 Animate 不相容的 AI 檔案項目。

  2. 選取「變更匯入選項以便解決物件不相容性」。使用不相容性報表以及「AI 匯入」對話方塊之「匯入選項」區域中提供的匯入建議事項,即可自動更正 Illustrator 與 Animate 之間的許多不相容性。

選取個別的物件

  1. 選取要指定匯入選項的物件。您可以選取的 Illustrator 物件包括圖層、群組、個別路徑、文字和影像。
  2. 針對您在此對話方塊之物件選項區段中選取的物件類型,檢視可用的匯入選項。請注意是否有列出任何不相容性,以及針對匯入物件所提供的建議更正方式。
  3. 選取所需的匯入選項,然後選取要指定匯入選項的另一個物件,或按一下「確定」。

(僅適用於 Flash Professional CS6 及更早版本) 選取圖層

「圖層」面板會列出文件中的物件。根據預設,每個 Illustrator 文件都至少包含一個圖層,而且給定檔案中的每個物件都會列於該圖層底下。

當「圖層」面板中的項目包含其他項目時,該項目名稱的左邊就會顯示一個三角形。若要顯示或隱藏內容,請按一下此三角形。如果沒有顯示三角形,就表示該圖層沒有包含其他項目。

注意:您可以使用「AI 匯入工具」快顯選單來展開或收合所有的群組與圖層。按一下右鍵以顯示快顯選單,然後選取「全部展開」或「全部收合」。

選取範圍欄

控制是否已選取要匯入的項目。如果項目已核取,您就可以選取該圖層並指定匯入選項;如果沒有核取「編輯」,該圖層就會呈現灰色,而且您無法針對該圖層中的項目指定任何匯入設定。

物件類型欄

圖示會指出進行匯入時,位於該圖層上的 Animate 物件類型為何,而且如果顯示的話,就表示該項目已選取。物件類型包括:

  • 文字

  • 路徑

  • 群組

  • 影片片段

  • 圖像元件

  • 影像

文字匯入選項

Animate 可讓您將文字匯入成可編輯文字、向量外框或平面化的點陣圖。若要在 Illustrator 與 Animate 之間維持支援的混合模式、AI 效果和少於 100% 的透明度,請將文字匯入成影片片段。將文字匯入成影片片段可保留相容視覺特效的可編輯性。

可編輯的文字

根據預設,Illustrator 文字會匯入成可編輯的 Animate 文字。為了維持文字的可編輯性,可能會損害文字的外觀。

向量外框

將文字轉換成向量路徑。您可以使用這個選項來保留文字的視覺外觀。如果文字匯入成影片片段,某些視覺特效可能會有所犧牲 (例如不支援的混合模式和濾鏡),但是視覺特質 (例如路徑上的文字) 會保留下來。雖然文字本身無法再進行編輯,但是不透明度和相容的混合模式會維持其可編輯性。

注意:若要將套用至文字的投影、內光暈、外光暈和高斯模糊等 AI 效果保留成可編輯的 Animate 濾鏡,請選取「建立影片片段匯入」,以便將文字匯入成影片片段。

 

點陣圖

將文字點陣化成點陣圖,以便保留文字原本在 Illustrator 中呈現的確切外觀。如果套用了與 Animate 不相容的濾鏡或其他效果,將文字匯入成點陣圖就會保留視覺外觀。點陣化的文字無法再進行編輯。

路徑匯入選項

路徑就是在 Illustrator 中繪圖所產生的線條。路徑可以是開放路徑 (例如弧形) 或封閉路徑 (例如圓形)。若為開放路徑,路徑的開始和結束錨點就稱為端點。雖然可編輯的路徑可匯入 Animate,但是如果某些混合模式、濾鏡或其他效果套用至此路徑,這些效果可能會與 Animate 不相容。

點陣圖

將路徑點陣化成點陣圖,以便保留路徑原本在 Illustrator 中呈現的確切外觀。點陣化的影像無法再進行編輯。

可編輯的路徑

建立可編輯的向量路徑。雖然支援的混合模式、效果和物件透明度會保留下來,但是 Animate 中不支援的特質會被捨棄。

影像匯入選項

點陣圖影像是連續色調影像 (例如相片或數位繪圖) 最常見的電子媒體。Illustrator 會使用濾鏡、效果和圖像樣式來建立點陣圖效果。雖然這些效果中有許多效果與 Animate 相容,但是某些效果可能需要平面化 (或點陣化),才能保留其視覺外觀。

注意:如果已連結 Illustrator 中的點陣檔案,則只有 JPEG、GIF 或 PNG 會在匯入時保留原生格式。所有其他檔案類型都會在 Animate 中轉換成 PNG 格式。此外,轉換成 PNG 的作業會根據電腦上安裝的 QuickTime® 版本而有所不同。

 

將點陣圖平面化以維持外觀

將影像點陣化成點陣圖,以便保留 Animate 中不支援之混合模式和效果的外觀。點陣化的影像無法再進行編輯。

建立影片片段

將 Illustrator 影像匯入成影片片段。

(僅適用於 Flash Professional CS6 及更早版本) 群組匯入選項

群組是指會被視為單一單位的圖像物件集合。群組可讓您將一些物件移動或變形,而不會影響其特質或相對位置。例如,您可能會將標誌設計中的物件組成群組,以便將此標誌當做一個單位來移動和縮放。您也可以巢狀化群組。也就是說,它們可以在其他物件或群組中組成群組,以便形成更大的群組。

在「匯入」面板中,群組會顯示成 <群組> 項目。當某個項目 (例如群組) 包含其他項目時,該項目名稱的左邊就會顯示一個三角形。按一下此三角形,即可顯示或隱藏該群組的內容。如果沒有顯示三角形,就表示該項目沒有包含其他項目。

匯入為點陣圖

將群組點陣化成點陣圖,以便保留這些物件原本在 Illustrator 中呈現的外觀。當群組轉換成點陣圖之後,您就無法選取或重新命名該群組中的物件。

建立影片片段

將群組中的所有物件封裝成單一影片片段。

在 Illustrator 與 Animate 之間複製和貼上

如果您在 Illustrator 與 Animate 之間複製和貼上 (或拖放) 圖稿,「貼上」對話方塊就會顯示,此對話方塊會提供所要複製 (或貼上) 之 AI 檔案的匯入設定。

貼上為點陣圖

將正在複製的檔案平面化成單一點陣圖物件。

使用 AI 檔案匯入工具的偏好設定貼上

使用 Animate 偏好設定 (「編輯 > 偏好設定」) 中指定的 AI 檔案匯入設定匯入檔案。

套用建議的匯入設定來解決不相容性

當選取「使用 AI 檔案匯入工具的偏好設定貼上」時,預設情況下會啟用。自動修正在 AI 檔案中偵測到的任何不相容性。

維持圖層

當選取「使用 AI 檔案匯入工具的偏好設定貼上」時,預設情況下會啟用。指定要將 AI 檔案中的圖層轉換成 Animate 圖層 (與您在「AI 匯入」對話方塊中選取「轉換成 Flash 圖層」一樣)。如果取消選取,則所有圖層都會平面化成單一圖層。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策