Get Photos from your device into Bridge

Get photos from camera

Caution:

Before you begin importing your images using Photo Downloader, make sure that you have updated Bridge to the latest version. To check for updates, choose Help > Updates. To know how to update your app, see Update Creative Cloud apps.

  1. Connect your camera, card reader, or mobile device to the computer using a supported cable.

    Note:

    (macOS only) On your Mac machine, you can configure Adobe Bridge to automatically open Photo Downloader when a camera is connected to the computer. Choose Adobe Bridge > Preferences. In the Behavior area of the General panel, select When A Camera Is Connected, Launch Adobe Photo Downloader. Then, click OK.

  2. Do one of the following:
    • (Windows) Click Download Images - Use Adobe Bridge in the AutoPlay window, or choose File > Get Photos From Camera.

    • (macOS) In Adobe Bridge, choose File > Get Photos From Camera.

  3. A new Adobe Bridge CC Photo Downloader window appears. In this window, choose the name of the device from the Get Photos From menu.

    Adobe Bridge Photo Downloader
    Adobe Bridge Photo Downloader

    Note:

    If the Get Photos From drop-down in the Photo Downloader window doesn't list your connected device or displays 'No Valid Files Found' message after selecting your device, read the following instructions for the type of device that you want to connect:

    • Make sure that your device is turned on and you are using a supported USB cable.

    (iDevices)

    • When connecting an Apple mobile device to a Mac machine, if you see a Trust this Computer alert, unlock your device and tap Trust.
    • When connecting an Apple mobile device to a Windows machine, if you see an Allow this device to access photos and videos alert, unlock your device and tap Allow. In the Photo Downloader window, choose Refresh from the Get Photos From drop-down.

    (Android devices)

    • When connecting an Android mobile device to a Mac or Windows machine, if you see a USB For alert on your device, unlock your device and choose any one of the available USB connection modes — MTP, PTP, USB mass transfer. 
    • If you don't see the USB For alert, you can manually change the mode in your device. Go to your device Settings > USB Settings > Mode. If you can't locate this setting, refer to the device manufacturer's documentation for your device.
    • After selecting the USB transfer mode, choose Refresh from the Get Photos From drop-down in the Photo Downloader window, .

    (Digital cameras)

    • See the device manufacturer's documentation for connecting your camera to a computer.

  4. To view thumbnails of the images saved on device, click Advanced Dialog at the lower-right corner of the window. The Advanced Dialog allows you to select the media files that you want to import and also provides more import options.

    Adobe Bridge CC - Photo Downloader (Advanced Dialog)
    (Advanced Dialog) Adobe Bridge CC - Photo Downloader

    To remove a photo from the import batch, click the check box below the photo thumbnail to deselect it in Advanced Dialog. By default, all the photos are selected.

  5. Save Options

    Location:

    To change the default folder location where Bridge imports the selected media files, click the Browse button (Windows) or the Choose button (Mac OS) next to Location, and specify a new location.

  6. Create Subfolder(s):

    To import the photos into subfolder(s) within the Location specified above, select an option from the Create Subfolder(s) drop-down list. 

    • None doesn't create any subfolders and the photos are stored at the folder location specified above.
    • Custom Name creates a subfolder with the name you type.
    • Today’s Date creates a subfolder named with the current date.
    • Shot Date creates a subfolder named with the date and time you shot the photo. You can choose from any of the date format options available in the drop-down list.
  7. Rename Files:

    To rename the files as you import them, choose an option from the Rename Files menu. All the photos in the import batch share the same name based on Today's Date, Shot Date, and Custom Name, or a combination of Shot Date and Custom Name. Each photo also has a unique number attached at the end. 

    • If you do not want to rename your imported files, you can choose Do Not Rename Files from the drop-down list.
    • If you want to rename the files based on the sub-folder name that you specified in the previous step, choose Same As Subfolder Name from the drop-down list.

    The Example text below the Rename Files option displays how the renamed files will look like based on the options that you've selected. 

    To preserve the camera’s original filename in XMP metadata for later reference, check Preserve Current Filename In XMP. For more details, see Work with metadata in Adobe Bridge.

    (macOS only) In the Rename Files drop-down list, choose Advanced Rename to rename the files based on a custom combination of Text, New Extension, Preserved Filename, Sequence Number, Sequence Letter, Date Time, and Metadata. Choosing this option opens Photo Downloader - Advanced Rename window where you can create your custom combination.

    Photo Downloader - Advanced Rename. Available on macOS only.
    (macOS only) Photo Downloader - Advanced Rename

    In the New Filenames section:

    • Click (+) button to add a custom field and choose the type of custom field from the drop-down list -  Text, New Extension, Preserved Filename, Sequence Number, Sequence Letter, Date Time, and Metadata. Depending on the custom field that you've chosen, additional options appear corresponding to that field.
    • To remove a custom field, click (-) button.

    In the Options section:

    • You can select Windows and Unix options so that the renamed files are compatible on these operating systems.

    The Preview section displays how the renamed files (New filename) will look like based on the custom fields combination that you've created.

  8. Advanced Options

    Open Adobe Bridge

    Opens Adobe Bridge after you import photos.

    Select Convert To DNG

    Converts Camera Raw files to DNG as you import them. Click the Settings button to open DNG Conversion Settings window (explained below). To know more about DNG format, read Digital Negative (DNG).

    Delete Original Files

    Deletes the original photos from your camera, card reader, or mobile device after they’re imported.

    Save Copies To

    Saves copies of photos as you import them at a specified location.

    DNG Conversion Settings dialog in Adobe Bridge
    Specify DNG Conversion Settings when importing images into Bridge

    • JPEG Preview: Choose Medium size or Full Size to generate JPEG previews of the converted DNG images. If you do not want to generate JPEG previews, choose None from the drop-down list.
    • Compressed (lossless): Select this option reduce the file size of the converted image.
    • Image Conversion Method: Choose Preserve Raw Image to maximize the amount of data preserved in the converted DNG file. Otherwise, choose Convert to Linear Image.  
    • Embed Original Raw File: Select this option to embed your camera raw file (non-DNG) raw file inside the DNG file. This creates a larger DNG file, but it allows the original raw file to be extracted later if needed. 
  9. Apply Metadata

    (Optional) To apply metadata, choose Basic Metadata from the Template to Use drop-down list. Then, type information in the Creator and Copyright text boxes.

    Any custom metadata template that you've created in Bridge is also available in the Template To Use menu. For related details, see Work with metadata templates.

  10. Click Get Media. The photos appear in Adobe Bridge.

    Note:

    If you had selected the Open in Adobe Bridge check box, Bridge automatically opens the location where you have imported the media files and displays your photos or subfolders within this location in the Content panel. 

Import from device on macOS

On macOS, Bridge provides an additional option File > Import From Device to import media from devices. This option, which has limited import settings, can be used as an alternate to File > Get Photos From Camera option when you are working on macOS.

For devices connected in PTP or MTP mode (such as camera or Android-based devices)

Change the device mode from PTP/MTP to USB mode/Mass storage mode and then connect the device to your computer.

Note:

For instructions on how to change the mode, see the documentation provided by the manufacturer of the device.

Adobe Bridge now detects the device and you can begin importing media from the device. The steps are mentioned below.

For iDevices (such as iPad or iPhone)

  1. Connect your iDevice to your computer.

  2. Click File > Import From Device. The dialog that appears automatically recognizes the connected device.

  3. Select the media that you want to import, select the location where you want to Import To, and click Download.

    Import from device on macOS
    Import from device on macOS

    The selected media files are imported to Adobe Bridge.

  4. The selected media files are imported to Adobe Bridge. By default, the media files in Bridge are imported to /Users/<your username>/Pictures. You can locate this folder in the Folders panel.

    Folders panel

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy