Creating reviews for Adobe Captivate projects

After creating and editing an Adobe Captivate project, the author can publish the project for review on an internal server.

The project is published as a CREV file, a custom SWF file that is used for review.

Reviewers can review the CREV file by opening it in Adobe Captivate Reviewer, an AIR application. The installer for the application, AdobeCaptivateReviewer.air, is present in the location where you installed Adobe Captivate. You can also download it from the Adobe website: www.adobe.com/go/cp5_reviewerapp.

When you publish the project on an internal server for review, you can send the AIR application along with the e-mail notification for review. 

Note:

Reviewers can install Adobe Captivate Reviewer without installing Adobe Captivate on their computers. However, they need to install Adobe AIR before installing the application. Adobe AIR can be downloaded for free from the Adobe website http://get.adobe.com/air/. Installing the AIR application is a one-time effort.

In a shared review where the author and the reviewers are on a common network, each of them can view comments posted by the other. The author, in addition, can accept, reject, or ask for feedback for the comments posted by the reviewers.

Reviewers who are not a part of the shared network can export their comments to an XML file and send it to the author. The author can import the XML file into the project, and view comments in the timeline of the slides where the reviewers posted them.

During the review cycle, the author and reviewers can view the latest comments posted by refreshing the contents of the application.

Sharing projects for review on an internal server

  1. Select File > Send for Shared Review.

  2. In the Send for Shared Review dialog box, type a name for the review file (CREV file) and click Next.

  3. Use the following options to create the CREV file:

    Publish Folder

    The location where the CREV file is published. Click Browse if you want to specify a different location for the generated files.

    Project Comments Folder

    Select this option and choose a shared folder, either on your computer or on the network, for storing the comments. Ensure that you provide write permissions to the folder. The path to the shared location must begin with a double backslash (\\) on Windows. On Mac, prefix the path with smb://.

    If reviewers do not have access to a shared folder, you can choose not to specify a location for the comments. In this case, you can ask the reviewers to export their comments to an XML file and send the file to you.

    When there is no shared network, you can choose not to specify a location. The reviewer must export the comments and send them to you. When you import the contents of the XML file, the comments are embedded in your project.

  4. Select Send Mail, and do the following:

    • Select Attach Review (.CREV) File if you want to send the CREV file as an attachment along with the mail. Use this option when the size of the CREV file is small enough to be sent by e-mail. E-mail filters are configured to block e-mails that are larger than a specified size.

    • Select Attach Adobe Captivate Reviewer if you want to send the AIR installer as an attachment. Use this option the first time you send a CREV file to a reviewer.

     

  5. Click Email. A draft of the e-mail appears.

  6. Customize the body of the draft if you want to provide additional instructions to reviewers.

  7. Enter e-mail addresses of reviewers in the To and Cc fields, and click Send.

Note:

Do not edit the Adobe Captivate project during the review. If the project changes during the review, the posted comments might not appear at the intended locations. If you must edit the project, ask the reviewers to stop their work. Then start a fresh review after editing the project.

Set default project comments folder

You can set your preference for the Project Comments Folder in the Preferences dialog box. When you create new projects, this location is used when you publish a project for review on an internal server.

  1. Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).

  2. Select General Settings.

  3. Specify a location for the project comments folder in the Comments At field.

 

Reviewing Adobe Captivate projects

Ensure that you complete the following procedures before you review a project using the CREV file:

  • Install Adobe AIR on your computer. Adobe AIR can be downloaded for free from the Adobe website http://get.adobe.com/air/.

  • Install the Adobe Captivate Reviewer application on your computer. The installer is provided to you by the author of the Adobe Captivate project. If you have Adobe Captivate installed on your computer, you can locate the installer, AdobeCaptivateReviewer.air, at the location where you installed Adobe Captivate.

Install Adobe Captivate Reviewer

  1. Double-click the AdobeCaptivateReviewer.air installer.

  2. Click Install.

  3. (Optional) Customize your installation preferences, and specify a location on your computer where to install the Adobe Captivate Reviewer.

Open the CREV file using Adobe Captivate Reviewer

  1. Download the CREV file onto your computer.

  2. Do one of the following:

    • Double-click the CREV file .

    • Open Adobe Captivate Reviewer.

  3. Based on how the CREV file is shared by the author, the following prompts appear:

    • User details.
      Provide your name and email address. These details are used in your comments and helps authors to associate your name with your comments.

  4. Click Load Captivate Movie, and open the CREV file from your computer.

    If the author has not specified a location for storing comments, a dialog box appears indicating that the comments have to be exported manually. Click OK.

Add comments to the SWF file

  1. Click Play . The seek slider starts moving through the movie.

  2. Click Add Comment  at the point where you want to add your comment.

  3. Add your comment in the Add Comment window.

  4. Click Add to add the comment. A marker, indicated by a white dot, is added at this location in the commenting bar and the movie continues to play.

  5. Repeat steps 2, 3, and 4 to add more comments.

  6. Click Save Comments .

    If the CREV file is hosted on an internal server with a shared network folder, the comments are automatically published to this folder. If a folder is not shared on the network, export the comments into an XML file and send it to the author. For more information on exporting comments, see Export comments to an XML file.

Edit comments in the SWF file

Comments added to the project are indicated as markers (white dots) at the specific location in the seek bar. To locate the comment that you want to edit, move your pointer over the markers. The comment added at a location is displayed when the pointer moves over it.

  1. Click the marker on the seek bar whose comment you want to edit or delete. The comment is displayed in a pop-up window.

    Comment marker on seek bar
    Comment marker on seek bar

  2. Edit the comment.

    Note:

    If others have replied to a comment, only the latest comment in the comment thread can be edited.

Import comments from an XML file

Authors and reviewers can import comments from XML files sent to them. Comments imported from XML files appear at the same location in the Timeline if the author has not edited the file during the review process.

  1. Click Import Comments .

  2. Browse to the location of the XML file.

  3. Click Open.

Authors can alternatively import comments from XML files using the Comments panel in Adobe Captivate.

Export comments to an XML file

Reviewers can export comments to an XML file and send it to the author. The author can import the XML file, provide feedback, export the file, and send it to the reviewers.

  1. Click Export Comments.

  2. In the Browse For Folder dialog box, select the folder where you want to save the XML file, and click OK.

Authors can alternatively export comments to XML files using the Comments panel in Adobe Captivate.

View or sort comments in the AIR application

The author and reviewers can view and sort comments using the AIR application.

Do one of the following:

  • To view all comments added to the file, click Show All Comments.

  • To sort comments by reviewer name, click Filter Comments. In the Reviewers pop-up menu, select names of the reviewers to view comments posted by those reviewers.

View or sort comments in the Adobe Captivate project

Authors can view and sort comments in the Adobe Captivate project as well as the AIR application. Some of the options available for sorting are available only when the author uses Adobe Captivate to review the project.

  1. To view comments added to the file, select Window > Comments. The Comments panel appears. Comments posted by reviewers are displayed in the panel.

  2. In the View By menu, select one of the following options:

    1. Select Creation Time to sort comments chronologically.

    2. Select Reviewer to sort comments by the reviewers’ name.

    3. Select Status to sort comments according to their status (New, Accepted, or Rejected.)

View the latest comments

To view the latest comments posted by reviewers, click Refresh Comments.

Provide feedback on comments by reviewers

The author can accept, reject, or reply to comments posted by reviewers. Reviewers can view feedback posted by the author when they refresh the contents of their application. In the Filmstrip, a comment icon appears below the slides that contain comments.

Comments are also visible on the timeline of individual slides. Authors can use Preview > Play This Slide to view the exact location of comments.

  1. Open the project sent for review in Adobe Captivate.

  2. Select Window > Comments. The Comments panel appears. Comments posted by reviewers are displayed in the panel.

  3. Select one or more comments for which you want to provide feedback, and do one of the following:

    • Click the reject comments icon to ignore the comment. Optionally, enter a reason for ignoring the comment in the pop-up window, and click Submit.

    • Click the accept reviewer comments icon to accept the comment. Optionally, enter your feedback in the pop-up window, and click Submit.

      note: After you accept or reject a comment, the corresponding icon is displayed for the comment in the review application, along with any comments.

    • Click the Reply To Reviewers Comments icon to request clarification on the comment.

End reviews

In the Windows > Comments panel, click the End Review icon.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy