将插图放到 Flash 中

关于将插图导入到 Flash 中

Adobe Flash Professional 可以使用在其他应用程序中创建的插图。可以导入各种文件格式的矢量图形和位图。如果您的系统安装了 QuickTime® 4 或更高版本,则可以导入更多的矢量或位图文件格式。可以将 Adobe® FreeHand® 文件(MX 版本和更低版本)和 Adobe® Fireworks® PNG 文件直接导入到 Flash Professional 中,并且保留这些格式的属性。

导入到 Flash Professional 中的图形文件的大小不能小于 2 x 2 像素。

若要在运行时将 JPEG 文件加载到 Flash Professional SWF 文件,请使用 loadMovie 动作或方法。 有关详细信息,请参阅《ActionScript 2.0 语言参考》中的 loadMovie (MovieClip.loadMovie method) 或《ActionScript 3.0 开发人员指南》中的“使用影片剪辑”

Flash Professional 可以导入矢量图形、位图和图像序列,如下所示:

  • 将 Adobe® Illustrator® 和 Adobe® Photoshop® 文件导入到 Flash Professional 中时,可以指定可让您保留大部分插图可视数据的导入选项,以及通过 Flash Professional 创作环境保持某些可视属性的可编辑性的功能。

  • 将矢量图像从 FreeHand 导入到 Flash Professional 中时,可以选择用于保留 FreeHand 图层、页面和文本块的选项。

  • 从 Fireworks 导入 PNG 图像时,可以将文件作为能够在 Flash Professional 中修改的可编辑对象进行导入,或作为可以在 Fireworks 中编辑和更新的平面化文件进行导入。

  • 选择用于保留图像、文本和辅助线的选项。

    注意:如果通过剪切和粘贴从 Fireworks 导入 PNG 文件,该文件将转换为位图。

  • 可以直接导入到 Flash Professional 文档(而不是库)中的 SWF 和 Windows® 元文件格式 (WMF) 文件中的矢量图像是作为当前图层中的一个组导入的。

  • 可以直接导入到 Flash Professional 文档中的位图(扫描的照片、BMP 文件)是作为当前图层中的单个对象导入的。Flash Professional 保留导入位图的透明度设置。因为导入位图可能会增大 SWF 文件的文件大小,所以应考虑压缩导入的位图。

    注意:通过拖放操作将位图从应用程序或桌面导入 Flash Professional 时,将不能保留位图透明度。 若要保留透明度,请使用“文件”>“导入到舞台”或“导入到库”命令进行导入。

  • 直接导入到 Flash Professional 文档中的任何图像序列(例如,PICT 或 BMP 序列)都是作为当前图层的连续关键帧导入的。

支持的导入文件格式

注意:

有关 Flash 支持的可供导入、导出或编辑的各种文件格式的完整列表,请参阅支持的文件格式技术说明。

图形格式

Flash Professional 可以导入不同的矢量或位图文件格式,具体取决于系统是否安装了 QuickTime 4 或更高版本。在作者既使用 Windows 平台,也使用 Macintosh 平台的合作项目中,使用附带 QuickTime 4 的 Flash Professional 尤其有用。QuickTime 4 扩展了这两种平台对某些文件格式(包括 PICT、QuickTime 影片以及其他类型)的支持。

无论是否安装了 QuickTime 4,都可以将以下矢量或位图文件格式导入到 Flash Professional 8 或更高版本中:

文件类型

扩展名

Windows

Macintosh

Adobe Illustrator(版本 10 或更低版本)

.ai

Adobe Photoshop

.psd

AutoCAD® DXF

.dxf

位图

.bmp

增强的 Windows 元文件

.emf

FutureSplash Player

.spl

GIF 和 GIF 动画

.gif

JPEG

.jpg

PNG

.png

Flash Player 6/7

.swf

Windows 元文件

.wmf

Adobe XML 图形文件

.fxg

只有安装了 QuickTime 4 或更高版本,才能将以下位图文件格式导入 Flash Professional:

文件类型

扩展名

Windows

Macintosh

QuickTime 图像

.qtif

TIFF

.tif

声音格式

Flash 可以导入以下音频格式:

文件类型

扩展名

Windows

Macintosh

Adobe Soundbooth

.asnd

波形

.wav

音频交换文件格式

.aiff

MP3

.mp3

仅在安装了 QuickTime 4 或更高版本的情况下,Flash 才能导入以下音频格式:

文件类型

扩展名

Windows

Macintosh

音频交换文件格式

.aiff

Sound Designer II

.sd2

只有声音的 QuickTime 影片

.mov、.qt

Sun AU

.au

System 7 声音

.snd

波形

.wav

视频格式

Flash 可以导入以下视频格式:

文件类型

扩展名

Windows

Macintosh

Adobe Flash 视频

.flv、.f4v

QuickTime 影片

.mov、.qt

Windows 视频

.avi

MPEG

.mpg、.m1v、.m2p、.m2t、.m2ts、.mts、.tod、.mpe、.mpeg

MPEG-4

.mp4、.m4v、.avc

数字视频

.dv、.dvi

适用于移动设备的 3GPP/3GPP2

.3gp、.3gpp、.3gp2、.3gpp2、.3p2

在 Flash 中导入插图

Flash Professional 可将各种文件格式的插图直接导入到舞台或库。

将文件导入到 Flash 中

  1. 请执行下列操作之一:
    • 要将文件直接导入到当前 Flash Professional 文档中,请选择“文件”>“导入”>“导入到舞台”。

    • 要将文件导入到当前 Flash Professional 文档的库中,请选择“文件”>“导入”>“导入到库”。(若要使用文档中的库项目,直接将它拖到舞台上即可。))

  2. 从“文件类型”(Windows) 或“显示”(Macintosh) 弹出菜单中选择文件格式。
  3. 定位到所需的文件,然后选择它。 如果导入的文件具有多个图层,则 Flash Professional 可能会创建新图层(取决于导入文件的类型)。任何新图层都显示在时间轴上。
  4. 单击“打开”。
  5. 如果所导入的文件名以数字结尾,并且在同一文件夹中还有其他按顺序编号的文件,请执行下列操作之一:

    注意:(仅限 Windows 8)在选中“矢量轮廓”选项的情况下,如果导入的 PSD 文件包含文本,则您无法编辑矢量对象的锚点。对于使用 Windows 8 中不支持的字体来创建的 PSD 文件也是如此。

    • 若要导入所有的连续文件,请单击“是”。

    • 若要只导入指定的文件,请单击“否”。

      下面是可以用作序列的文件名的示例:

      Frame001.gif、Frame002.gif、Frame003.gif

      Bird 1、Bird 2、Bird 3

      Walk-001.ai、Walk-002.ai、Walk-003.ai

将其他应用程序中的位图直接粘贴到当前 Flash 文档中

  1. 复制其他应用程序中的图像。
  2. 在 Flash Professional 中,选择“编辑”>“粘贴到中心位置”。

导入 FXG 文件

FXG 格式允许 Flash 与其他 Adobe 应用程序(例如 Adobe Illustrator、Fireworks 和 Photoshop)交换图形,并可保留所有复杂图形信息。Flash 允许您导入 FXG 文件(仅限 2.0 版本)以及以 FXG 格式保存在舞台(或整个舞台)上选择的对象。有关 FXG 文件的详细信息,请参阅关于 FXG 文件

  • 要导入 FXG 文件,请选择“文件”>“导入”>“导入到舞台”或“导入到库”,并选择要打开的 FXG 文件。

关于 AutoCAD DXF 文件

Flash Professional 支持 AutoCAD 10 中的 AutoCAD® DXF 格式。

DXF 文件不支持标准系统字体。 Flash Professional 会尝试正确地映射字体,但是结果无法预知,特别是对于文本对齐。

因为 DXF 格式不支持实心填充,所以填充区域只作为轮廓导出。 因此,DXF 格式最适合线条画,例如平面图和地图。

可以将二维 DXF 文件导入到 Flash Professional 中。 Flash Professional 不支持三维 DXF 文件。

尽管 Flash Professional 不支持在 DXF 文件中进行缩放,但是所有导入的 DXF 文件都会产生一个 12 x 12 英寸的文件,您可以使用“修改”>“变形”>“缩放”命令对其进行缩放。 此外,Flash Professional 只支持 ASCII DXF 文件。如果 DXF 文件是二进制的,请将其转换为 ASCII,然后再导入 Flash Professional。

使用 ActionScript 加载插图

借助 ActionScript,您可以在运行时从库中加载外部图像文件或资源。

有关在 ActionScript 中使用图像和资源的信息,请参阅以下文章:

Adobe 徽标

登录到您的帐户