“字形”面板概述

使用“字形”面板输入字形。该面板最初显示光标所在处的字体字形,但您可以查看不同字体、查看字体中的文字样式(例如,Light、Regular 或 Bold)以及在面板中显示字体字形的子集(例如,数学符号、数字或标点符号)。

“字形”面板
“字形”面板

A. 搜索框 B. 显示字形子集 C. 显示字形 ID、Unicode 和名称的工具提示 D. 字体列表 E. 字体样式 

通过在字形上移动指针,可在工具提示中读取其 CID/GID 值、Unicode 值和名称。

打开字形面板

  1. 选择“文字”>“字形”或“窗口”>“文字和表”>“字形”。

更改“字形”面板视图

  • 单击圆形工具(位于“字形”面板中“字形”一词的左侧)以更改面板视图。单击该工具可连续显示下列视图:折叠面板、整个面板以及不显示最近使用的字形的面板。
  • 单击“字形”面板右下角的“放大”“缩小”按钮。
  • 拖动“字形”面板的右下角以调整其大小。

过滤出现的字形

  1. 在“显示”列表中执行下列操作之一,以确定在“字形”面板中显示哪些字形:
    • 选择“整个字体”以显示字体中可用的所有字形。

    • 选择“整个字体”中的选项,使列表中仅显示字形的某个子集。例如,“标点”仅显示标点字形;“数学符号”将仅显示数学符号的选项。

对字形面板中的字形排序

  1. 选择“按 CID/GID”或“按 Unicode”,以确定如何在“字形”面板中对字形排序。

在“字形”面板中搜索字形

  1. 在“字形”面板中,单击搜索框内部,然后输入搜索查询。

    搜索字形

    默认情况下,InCopy 使用通用搜索来基于字形名称、Unicode 或字形 ID 执行搜索。

  2. 不过,您可以指定搜索参数来进一步过滤搜索结果。

    为此,请单击搜索框左侧的下拉箭头,然后选择所需的搜索参数。

插入字形和特殊字符

字形是特殊形式的字符。例如,在某些字体中,大写字母 A 具有多种形式,如花饰字和小型大写字母。可使用“字形”面板找到字体中的任何字形。

OpenType 字体(如 Adobe Caslon™ Pro)为很多标准字符提供了多种字形。要在文档中插入这些替代字形时,可使用“字形”面板。还可以使用“字形”面板查看和插入 OpenType 属性,如花饰字、分数字和连笔字。

插入特殊字符

可以插入常用字符,如全角破折号和半角破折号、注册商标符号和省略号。

  1. 使用“文字工具”,在希望插入字符的地方放置插入点。
  2. 选择“文字”>“插入特殊字符”,然后选择菜单中任意类别中的选项。

如果您重复使用的特殊字符未出现在特殊字符列表中,则将它们添加到您创建的字形集中。

从指定字体中插入字形

  1. 使用“文字工具”,在希望键入字符的地方单击以放置插入点。
  2. 选择“文字”>“字形”以显示“字形”面板。
  3. 要在“字形”面板中显示不同的字符集,执行以下操作之一:
    • 选择不同的字体和文字样式(如果有)。从“显示”菜单中选择“整个字体”。或者,如果选择了 OpenType 字体,则可从多个 OpenType 类别中进行选择。

    • 从“显示”菜单选择自定字形集。(请参阅创建和编辑自定字形集。)

  4. 滚动以显示所有字符,直至看到要插入的字形。如果已选择 OpenType 字体,可以单击并按住字形框,以显示替代字形的弹出菜单。
  5. 双击要插入的字符。字符将出现在文本插入点处。

插入最近使用的字形

InCopy 会跟踪您插入的前 35 种不同字形,并在“字形”面板第一行“最近使用的字形”下显示它们(必须展开该面板,才能看到第一行中全部 35 种字形)。

  1. 执行以下操作之一:
    • 在“最近使用的字形”下双击一种字形。

    • 在“显示”列表中选择“最近使用的字形”,以便在“字形”面板的主正文中显示最近使用的所有字形,然后双击一种字形。

清除最近使用的字形

  • 要从“最近使用的字形”部分中清除所选字形,请在“最近使用的字形”部分中右键单击 (Windows®) 或按住 Control 键单击 (Mac OS) 一种字形,然后选择“从‘最近使用的字形’中删除字形”。
  • 要清除最近使用的所有字形,请选择“清除所有最近使用的字形”。

用替代字形替换字符

如果字符包含替代字形,该字符显示在“字形”面板中时,其右下角会显示一个三角图标。可以在“字形”面板中单击并按住该字符,以显示替代字形的弹出菜单,也可以在“字形”面板中显示替代字形。

iu_13
选择 OpenType 字体的替代字形

  1. 选择“文字”>“字形”以显示“字形”面板。
  2. 从“显示”列表中选择“所选字体的替代字”。
  3. 使用“文字工具”,在文档中选择一个字符。
  4. 执行下列操作之一,替换文档中的选定字符:
    • 双击“字形”面板中的字形。

    • 在菜单中选择一种字形。

在“字形”面板中显示 OpenType 字形属性

为了便于选择,“字形”面板允许仅针对选定 OpenType 属性显示字符。可以从“字形”面板的“显示”菜单中选择各种选项。

注意:

不要将这些选项与“字形”面板菜单中显示的选项混淆,后者用于对所选文本应用格式。(请参阅应用 OpenType 字体属性。)

iu_glyphs_popup_en
显示“字形”面板中的菜单选项

  1. 在“字形”面板中,从字体列表中选择 OpenType 字体。
  2. 从“显示”菜单中选择选项。

显示的选项因选择的字体不同而有所差异。有关应用 OpenType 字体属性的信息,请参阅应用 OpenType 字体属性。有关 OpenType 字体的更多信息,请参阅 www.adobe.com/go/opentype_cn

突出显示文本中的替代字形

  1. 选择“编辑”>“首选项”>“排版”(Windows) 或“InCopy”>“首选项”>“排版”(Mac OS)。
  2. 选择“被替代的字形”,然后单击“确定”。文本中被替代的字形以非打印的黄色突出显示。

创建和编辑自定字形集

字形集是指定的一个或多个字体的字形集合。将常使用的字形存储在字形集中,可防止在每次需要使用字形时进行查找。字形集并未连接到任何特定文档;它们随其他 InDesign 首选项一起存储在一个可共享的单独文件中。

可确定是否记住添加的字形所使用的字体。记住字体非常有用,例如,在使用其他字体中可能不显示的花饰字符时。如果记住字形的字体,但这种字体缺失,则“字形”面板和“编辑字形集”对话框中的字体方框将以粉红色显示。如果未记住所添加字形的字体,则该字形旁会出现一个“u”,表示这种字体的 Unicode 值将决定字形的外观。

创建自定字形集

  1. 选择“文字”>“字形”。
  2. 执行以下操作之一:
    • 从“字形”面板菜单中,选择“新建字形集”。

    • 从“字形”面板中打开上下文菜单,然后选择“新建字形集”。

  3. 键入字形集的名称。
  4. 选择将字形添加到字形集的插入顺序,然后单击“确定”:

    在前面插入

    每个新字形列出为字形集中的第一个字形。

    在结尾处追加

    每个新字形列出为字形集中的最后一个字形。

    Unicode 顺序

    按照所有字形的 Unicode 值的顺序列出字形。

  5. 要将字形添加到自定集,请在“字形”面板底部选择包含该字形的字体,单击该字形以选中它,然后从“字形”面板菜单的“添加到字形集”菜单中,选择自定字形集的名称。

查看自定字形集

  1. 在“字形”面板中执行下列操作之一:
    • 从“显示”列表中选择字形集。

    • 在“字形”面板菜单上,选择“查看字形集”,然后选择字形集的名称。

编辑自定字形集

  1. 从“字形”面板菜单中选择“编辑字形集”,然后选择自定字形集。
  2. 选择要编辑的字形,执行下列任一操作,然后单击“确定”:
    • 要将字形绑定到它的字体,请选择“记住字形的字体”。将记住其字体的字形插入到文档中的选定文本中时,该字形将忽略应用于该文本的字体。该字形还将忽略它自己在“字形”面板中指定的字体。如果取消选择此选项,则使用当前字体的 Unicode 值。

    • 要查看其他字形,请选择另一字体或样式。如果字形未定义字体,则无法选择另一字体。

    • 要从自定字形集中删除字形,请选择“从集中删除”。

    • 要更改将字形添加到集中的顺序,请选择“插入顺序”选项。如果在创建字形集时选择了“在前面插入”或“在结尾处追加”,则“Unicode 顺序”不可用。

从自定字形集中删除字形

  1. 在“字形”面板中,从“显示”菜单中选择“自定字形集”。
  2. 右键单击 (Windows) 或按住 Control 键单击 (Mac OS) 一种字形,然后选择“从集中删除字形”。

删除自定字形集

  1. 执行以下操作之一:
    • 从“字形”面板菜单中,选择“删除字形集”。

    • 从上下文菜单中选择“删除字形集”。

  2. 单击自定字形集的名称。
  3. 单击“是”确认。

存储并载入字形集

自定字形集存储在“Presets”文件夹的“Glyph Sets”子文件夹中存储的文件中。可以将字形集文件复制到其他计算机,从而使其他用户可使用自定字形集。将字形集文件复制到下列文件夹并从中复制字形集文件,从而与其他用户共享:

Mac OS

用户\[用户名]\资源库\Preferences\Adobe InCopy\[版本]\[语言]\Glyph Sets

Windows XP

Documents and Settings\[用户名]\Application Data\Adobe\InCopy\[版本]\[语言]\Glyph Sets

Windows Vista 和 Windows 7

用户\[用户名]\AppData\Roaming\Adobe\InCopy\[版本]\[语言]\Glyph Sets

使用引号

可以为不同的语言指定不同的引号。如果在“首选项”对话框的“文字”部分选择了“使用弯引号”选项,则在键入时将自动显示这些引号字符。

指定要使用的引号

  1. 选择“编辑”>“首选项”>“词典”(Windows),或“InCopy”>“首选项”>“词典”(Mac OS)。
  2. 从“语言”菜单中选择语言。
  3. 执行下列任一操作,然后单击“确定”:
    • 对于“双引号”,请选择一对引号,或键入要使用的字符对。

    • 对于“单引号”,请选择一对引号,或键入要使用的字符对。

插入直引号

  1. 执行以下操作之一:
    • 选择“文字”>“插入特殊字符”>“引号”>“直双引号”或“直单引号(撇号)”。

    • 取消选择“首选项”对话框中“文字”部分的“使用弯引号”选项,然后键入引号或撇号。

    • 按 Shift+Ctrl+Alt+' (Windows) 或 Shift+Command+Option+' (Mac OS) 以在打开和关闭“使用弯引号”首选项之间进行切换。

注意:

单撇号常用于表示英尺、弧分度或时间中的分钟。它看起来像一个斜撇号。双撇号常用于表示英寸、弧秒度或时间中的秒。这些符号与撇号和双引号有所不同。某些字体包含单撇号和双撇号。使用“字形”面板可以插入这些符号。如果字体不包含单撇号和双撇号,请插入直双引号,然后将其斜体化。

插入空格字符

空格字符是出现在字符之间的空白区。可将空格字符用于多种不同的用途,如防止两个单词在行尾断开。

  1. 使用“文字工具”,在希望插入特定大小的空格的地方放置插入点。
  2. 选择“文字”>“插入空格”,然后在上下文菜单中选择一个间距选项(如“全角空格”)。

注意:

选择“文字”>“显示隐藏的字符”后,会显示空格字符的代表性符号。

空格选项

下列选项显示在“文字”>“插入空格”菜单上:

表意字空格 

这是一个基于亚洲语言的全角字符的空格。它与其他全角字符一起时会绕排到下一行。

全角空格 

宽度等于文字大小。在大小为 12 点的文字中,一个全角空格的宽度为 12 点。

半角空格 

宽度为全角空格的一半。

不间断空格 

此可变宽度与按下空格键时的宽度相同,但是它可防止在出现空格字符的地方换行。

不间断空格(固定宽度) 

固定宽度的空格可防止在出现空格字符的地方换行,但在对齐的文本中不会扩展或压缩。固定宽度的空格与在 InCopy CS2 中插入的不间断空格字符相同。

三分之一空格 

宽度为全角空格的 1/3。

四分之一空格 

宽度为全角空格的 1/4。

六分之一空格 

宽度为全角空格的 1/6。

右齐空格 

将大小可变的空格添加到完全对齐的段落的最后一行,在最后一行对齐文本时该选项非常有用。(请参阅更改字距调整设置。)

细空格 

宽度为全角空格的 1/24。

窄空格 

宽度为全角空格的 1/8。在全角破折号或半角破折号的任一侧,可能需要使用窄空格 (1/8)。

数字空格 

宽度与字体中数字的宽度相同。使用数字空格有助于对齐财务报表中的数字。

标点空格 

与字体中的感叹号、句号或冒号等宽。

关于 Adobe SING Glyphlet Manager

Adobe SING Glyphlet Manager 是一种用于安装和搜索字形的实用程序。Adobe Creative Suite 5 中没有提供该软件。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略