Vytváření a správa příruček

Naposledy aktualizováno 29. 9. 2026

Naučte se vytvářet, upravovat, organizovat a sdílet vodítka v aplikaci Adobe After Effects pro přesné zarovnání prvků napříč vašimi projekty.

Vodítka v aplikaci After Effects vám pomohou přesně zarovnat vrstvy, text a další prvky v panelech Kompozice, Vrstva a Záběr. Vodítka můžete umístit podle pixelů nebo procent, připnout je k jakémukoli okraji, přiřadit jim barvy pro lepší organizaci a kdykoli je upravit.

Vodítka v aplikaci After Effects jsou úzce sladěna s chováním v aplikaci Adobe Premiere, což vytváří konzistentní zážitek při přechodu mezi aplikacemi.

After Effects podporuje následující:

  • Vodítka založená na procentech: Umožňuje umístit vodítka relativně ke kompozici nebo zobrazení místo pevných pixelových hodnot, díky čemuž jsou rozvržení odolná vůči změnám rozlišení a poměru stran.
  • Připínání vodítek: Umožňuje připnout vodítka ke spodnímu nebo pravému okraji (kromě horního a levého), což zajišťuje stabilitu rozvržení při změnách rozměrů.
  • Ovládání barev jednotlivých vodítek: Zlepšuje viditelnost a organizaci tím, že umožňuje barevné kódování jednotlivých vodítek.
  • Úpravy vodítek: Umožňuje kliknutím pravým tlačítkem myši upravit pozici, změnit jednotky mezi pixely a procenty, upravit chování připnutí a přiřadit barvu.Navíc import a export vodítek již nepřevádí vodítka založená na procentech na pixelové hodnoty, což usnadňuje opětovné použití responzivních rozvržení napříč aplikacemi.

Nejnovější aktualizace vodítek přinášejí umísťování založené na procentech, připínání k okrajům, vlastní barvy vodítek a vylepšené ovládací prvky pro úpravy vodítek.

V aplikaci After Effects jsou vodítka specifická pro zobrazení, takže mohou existovat samostatně v panelech Kompozice, Záběr a Vrstva. Následující příklady ukazují, jak můžete použít různá vodítka v různých zobrazeních a panelech v rámci stejného projektu pro podporu konkrétních úkolů:

Vodítka v panelu Kompozice

Panel Vrstva má přidána vodítka se zobrazenými pravítky.

Panel Vrstva má přidána vodítka, která pomohou zarovnat prvky pouze v této konkrétní vrstvě.

Guides v panelu Záběr

Panel Záběr má přidána vodítka se zobrazenými pravítky.

Panel Záběr má přidaná vodítka pro zarovnání zdrojového záběru bez vlivu na panel Kompozice.

Poznámka

Nyní jsou k dispozici nové přístupové objekty skriptování vodítek. Naučte se řídit viditelnost a chování vodítek ve vašich skriptech — aktuální beta doplňky a původní podpora skriptování.

Přidat vodítka do zobrazení

Otevřete panel, ve kterém chcete vodítka, například panel Kompozice, Vrstva nebo Záběr.

Vyberte Zobrazení > Zobrazit pravítka, aby byla pravítka viditelná. 

Chcete-li vytvořit směrovou čáru, přetáhněte z horního pravítka a přidejte tak vodorovnou příručku nebo z levého pravítka a přidejte svislou příručku. Můžete ji přesunout přetažením pomocí nástroje Výběr.

Klikněte pravým tlačítkem na příručky a vyberte Upravit příručku pro spuštění dialogového okna Upravit příručku. 

 

Případně můžete také přejít na Zobrazení > Přidat vodítko a otevřít tak dialogové okno Přidat vodítko.

Upravte hodnotu Pozice a zadejte přesné umístění vodítka v rámci zobrazení měřené v Pixelech nebo Procentech od vybrané referenční hrany.Dostupné možnosti se liší v závislosti na výběru v rozevírací nabídce Orientace.

U svislých příruček:

  • Vlevo: Když je svislá příručka nastavena na Vlevo, její vzdálenost se měří od levé hrany rámce. Zachovává stejnou vzdálenost od levé strany, i když se rámeček rozšiřuje nebo zužuje.
  • Vpravo: Když je svislá příručka nastavena na Vpravo, její vzdálenost se měří od pravé hrany rámce. Zachovává stejnou vzdálenost od pravé strany, i když se velikost rámce změní.

U vodorovných příruček:

  • Nahoře: Když je vodorovná příručka nastavena na Nahoře, její vzdálenost se měří od horní hrany rámce. Zachovává stejnou vzdálenost shora, i když se rámeček stane vyšším nebo nižším.
  • Dole: Když je vodorovná příručka nastavena na Dole, její vzdálenost se měří od spodní hrany rámce. Zachovává stejnou vzdálenost zdola, i když se velikost rámce změní.

Vyberte způsob měření pozice příručky pomocí rozevírací nabídky Jednotka a vyberte jednu z následujících možností:

  • Pixely: Pro pevné číselné umístění
  • Procenta: Pro proporcionální umístění relativní k velikosti rámce
Dialogové okno Upravit příručku je otevřené a rozevírací nabídka Jednotky je otevřená s možnostmi výběru Pixely nebo Procenta.

Vyberte jako jednotku pixely nebo procenta a definujte, jak se měří pozice vodítka relativně ke kompozici.

Pomocí možnosti Barva nastavte barvu zobrazení vybrané příručky pro lepší viditelnost a organizaci.

Pomocí rozevírací nabídky Orientace určete směr, ve kterém je příručka nakreslena:

  • Vodorovné: Vodítko, které vede zleva doprava a lze ho použít k zarovnání objektů podél osy y (umístění shora dolů)
  • Svislé: Vodítko, které vede shora dolů a používá se k zarovnání objektů podél osy X (umístění zleva doprava).

Vyberte OK.

Při práci s průvodci je třeba znát několik věcí:

  • Pozice vodítek vždy zobrazují jednotku: Hodnoty se zobrazují jako 150 px nebo 50 %, takže vždy víte, zda je vodítko umístěno v pixelech nebo procentech, aniž byste museli hádat.
  • Změna jednotek neposune průvodce: Pokud v dialogovém okně Přidat průvodce nebo Upravit průvodce změníte z pixelů na procenta (nebo naopak), průvodce zůstane přesně tam, kde je.Změní se pouze způsob vyjádření pozice, nikoli skutečné umístění.
  • Při přetahování se zobrazuje aktuální údaj: Když přetahujete vodítko, na obrazovce se zobrazí malý popisek s jeho přesnou pozicí (například 150 px nebo 50 %) při pohybu.Pokud je průvodce připnutý k okraji, zobrazuje také popisek Připnuté, který označuje, že je ukotven.
  • Při přetahování používejte klávesové zkratky:
    • Při přetahování podržte klávesu Alt (Windows) / Option (macOS), abyste okamžitě přepínali mezi pixely a procenty.
    • Při přetahování podržte klávesu Ctrl (Windows) / Command (macOS), abyste přepínali vodítko mezi připnutým a nepřipnutým.Průvodce zůstane vizuálně na místě a změní se pouze jeho kotevní okraj.

Ovládací prvky viditelnosti

  • Pro zobrazení nebo skrytí bezpečných zón, mřížek, vodítek nebo pravítek vyberte tlačítko Zvolit možnosti mřížky a vodítek a zvolte příslušnou položku nebo použijte příkaz nabídky nebo klávesovou zkratku v nabídce Zobrazit.
  • Pro přepínání mezi zobrazením a skrytím bezpečných zón klikněte na tlačítko Zvolit možnosti mřížky a průvodců se stisknutou klávesou Alt (Windows) nebo Option (macOS).

Chování přichytávání

Vyberte Zobrazit > Přichytit k mřížce nebo Zobrazit > Přichytit k vodítkům, aby se okraje vrstvy a okraje masky přichytávaly k mřížkám nebo vodítkům.

Ovládací prvky pravítka

  • Pro nastavení nulového bodu (počátku) pro pravítka přetáhněte nitkový kříž z průsečíku dvou pravítek (v levém horním rohu) do oblasti kompozice.
  • Nulový bod resetujete dvojitým kliknutím na průsečík pravítek. 

Pozice ukazatele měřená od nového nulového bodu se zobrazuje na panelu Informace jako souřadnice X a Y.

Import a export průvodců

After Effects umožňuje uložit vodítka a importovat je do jiných kompozic, projektů a vrstev aplikace After Effects.Tyto průvodce můžete také exportovat do aplikace Premiere, kde je mohou editori používat k udržení konzistence v projektech.

Chcete-li importovat existující Guides do aplikace After Effects, vyberte Zobrazení > Import Guides.Chcete-li exportovat Guides, vyberte Zobrazení > Export Guides.

Když exportujete Guides, vytvoří se soubor šablony (.guides), který můžete sdílet nebo importovat do jiného projektu nebo do jiného zobrazení kompozice, vrstvy či záběru ve stejném projektu.Soubor šablony Guides obsahuje data JSON, která zaznamenávají atributy Guides. Aplikace After Effects exportuje všechny Guides v aktuálním zobrazení.Import Guides přidá Guides do aktuálního zobrazení. Zachová všechny existující Guides v zobrazení. 

Můžete importovat Guides z aplikace After Effects do aplikace Premiere 13.1 a importovat Guides z aplikace Premiere do aplikace After Effects.Nejnovější verze After Effects 26.5x nyní zachovává barvy vodítek z aplikace Premiere a zachovává režim polohování Pixel nebo Procento vodítek, včetně chování při připnutí a odpnutí.

Barvy Guides se změní na barvu definovanou v nabídce Předvolby > Grids & Guides.

  • Guides definované buď procentuálně, nebo připnuté na opačnou stranu (vpravo nebo dole) jsou umístěny na příslušnou hodnotu pixelu pro aktuální prohlížeč, ale nejsou založeny na procentech ani připnuty, pokud se změní rozměry kompozice, vrstvy nebo záběru.