Podrobnější informace a pokyny hledejte na následujících odkazech.

Import XML a metody rozvržení

Po importu dat XML se importovaný obsah zobrazí jako elementy (základní stavební kameny XML) v panelu Struktura. InDesign při importu XML nevytváří nové rámečky ani stránky.

Přidat nebo sloučit?

XML můžete importovat ve dvou režimech: přidat nebo sloučit. Zvolená metoda závisí na pracovním postupu (ručním nebo automatickém), na zamýšleném způsobu zpracování existujícího obsahu v dokumentu a na tom, zda pro zpracování importovaných dat chcete využít pokročilejší volby.

Režim Přidat

Když importovaný obsah přidáte, existující struktura a obsah dokumentu zůstanou stejné; nový obsah XML je umístěn do spodní části panelu Struktura ve formě elementů.

Režim Sloučit

Když importovaný obsah sloučíte, InDesign srovná vstupní XML se strukturou a názvy elementů, které již dokument obsahuje. Pokud se elementy shodují, importovaná data nahradí existující obsah dokumentu, který je sloučen do správně tagovaných rámečků (nebo vyhrazených míst) v rozvržení. (Elementy, pro které InDesign nemůže nalézt odpovídající název a úroveň v hierarchii, jsou umístěny do panelu Struktura a můžete je umístit ručně.) Režim sloučení neumožňuje provádět jen automatické rozvržení, ale poskytuje také pokročilejší volby importu, včetně možnosti filtrovat vstupní text a klonovat elementy pro opakující se data.

Rozvržení obsahu

Po naimportování musíte obsah XML umístit do dokumentu. Obsah můžete umístit ručně, automaticky nebo pomocí skriptu. Zvolená metoda závisí na importovaném obsahu, rozvržení dokumentu a pracovních postupech.

Ruční umístění obsahu

Při ruční metodě přetahujete elementy z panelu Struktura na stránky dokumentu nebo do rámečků. Tato metoda vyžaduje drobné nastavení nebo plánování. Tuto metodu použijte, pokud je importovaný obsah různorodý nebo pokud načítáte obsah z více zdrojů.

Ruční umístění importovaného obsahu XML
Ruční umístění importovaného obsahu XML

Automatické umístění obsahu

Na základě plánování můžete automatizovat proces umístění dat XML do rozvržení. Chcete-li obsah XML umístit automaticky, musíte nejprve připravit dokument – musíte vytvořit tagované vyhrazené rámečky pro vstupní XML. Pokud se struktura XML a názvy tagů pro vstupní obsah shodují s názvy tagů a strukturou vyhrazených rámečků, InDesign může umístit importované XML do dokumentu automaticky. InDesign může také klonovat elementy pro zpracování opakujících se dat, jako je například seznam adres a materiály pro katalog. Použijte metodu automatického rozvržení jako součást strukturovaného pracovního procesu, chcete-li zkrátit dobu výroby a zvýšit efektivitu.

Vybraný vyhrazený rámeček je tagovaný elementem Story (článek)
Vybraný vyhrazený rámeček (nahoře) je tagovaný elementem Story (článek). Po importu dat XML (dole) se vyhrazený rámeček elementu Story (článek) automaticky naplní obsahem elementu Story (článek).

Poznámka:

InDesign rozlišuje speciální atributy jmenných prostorů, které mohou v XML určovat odstavcové nebo znakové styly. Další informace naleznete v technické referenční příručce pro XML.

O sloučení

Data XML můžete do dokumentu umístit v režimu sloučení nebo přidávání. Režim sloučení umožňuje automatizovat umístění obsahu. Můžete také filtrovat data v souboru XML, chcete-li umístit pouze některé části obsahu.

Vstupní obsah XML slučte, když:

  • Dokument obsahuje vyhrazené rámečky, které chcete vyplnit importovaným obsahem XML.

  • Dokument obsahuje obsah XML, který chcete nahradit importovaným obsahem XML.

  • Dokument neobsahuje žádnou strukturu XML a chcete, aby InDesign nahradil výchozí kořen kořenem vstupního souboru XML.

Režim sloučení porovnává vstupní data XML s elementy, který již dokument obsahuje. Prochází souborem element po elementu a porovnává následujícím způsobem vstupní elementy s existujícími:

1. InDesign nejprve porovná kořenový element

  • Pokud se kořenové prvky importovaného souboru XML a dokumentu aplikace InDesign neshodují a panel Struktura neobsahuje žádnou existující strukturu, InDesign nahradí kořen dokumentu InDesign kořenem příchozího souboru XML a importuje soubor.

  • Pokud se kořenové elementy neshodují a panel Struktura již obsahuje elementy, InDesign připojí soubor na konec existující struktury.

  • Pokud se kořenové elementy shodují, proces slučování (a porovnávání) pokračuje.

2. InDesign pokračuje dalším elementem pod kořenem

InDesign začne elementem hned pod kořenem ve vstupním souboru XML a hledá odpovídající elementy v panelu Struktura. Aby se vyskytla shoda, vstupní element XML musí mít stejný název jako existující element v panelu Struktura a oba elementy musí být v hierarchii na stejné úrovni.

  • Pokud InDesign najde odpovídající element v panelu Struktura, nahradí element v panelu Struktura elementem ze vstupního souboru XML.

  • Jestliže odpovídající protějšek nenajde, vloží vstupní element do počátečního místa hledání v panelu Struktura. Pokud vyhledávání začne například pod kořenem a shoda není nalezena, vstupní element je umístěn pod kořen.

3. InDesign pokračuje v porovnávání elementů

Element po elementu, InDesign pokračuje ve srovnávání vstupního XML s existující strukturou. Počáteční místo hledání v panelu Struktura se v průběhu hledání mění, každé hledání začíná pod posledním vloženým nebo nahrazeným elementem. InDesign se vždy posunuje dolů od aktuální pozice; nikdy nenahrazuje elementy nad dříve vloženým nebo nahrazeným elementem.

Import a přidávání dat XML

Když importujete obsah XML, nové elementy se objeví v panelu Struktura. Odsud můžete elementy přetáhnout a umístit do dokumentu.

  1. Otevřete dokument aplikace InDesign nebo vytvořte nový dokument, abyste mohli načíst obsah XML.
  2. Otevřete panel Struktura. (Zvolte Zobrazení > Struktura > Zobrazit Strukturu.)
  3. Vyberte Soubor > Importovat XML (nebo vyberte Importovat XML v nabídce panelu Struktura) a vyberte soubor XML, který chcete importovat.
  4. Vyberte Zobrazit volby importu XML.
  5. Vyberte Přidat obsah a pak klikněte na Otevřít.
  6. Chcete-li spojit obsah XML s původním souborem XML, vyberte Vytvořit vazbu.

    Soubor XML se zobrazí v panelu Vazby v aplikaci InDesign a při změně souboru XML se u něj zobrazí žlutý výstražný trojúhelník.

  7. Klikněte na tlačítko OK.

Ruční sazba XML

Obsah XML můžete ručně umístit do rozvržení dokumentu, když přetáhnete elementy z panelu struktura na stránku nebo do existujícího rámečku. Když umístíte element, umístí se s ním i jeho dceřiné elementy (a také všechny další dceřiné elementy, pokud nějaké existují).

Pokud jste element do dokumentu již umístili, v panelu Struktura se u ikony elementu zobrazuje modrý kosočtverec specifický pro strukturu; u elementů, které jste neumístili, se zobrazuje ikonu neumístění.

Poznámka:

Pokud jste XML importovali pomocí volby Sloučit obsah, některé elementy již mohou být v rozvržení. Když sloučíte importovaný obsah, InDesign automaticky umístí elementy do existujících rámečků, pokud jsou identicky strukturované a tagované.

  1. Otevřete panel Struktura (Zobrazení> Struktura > Zobrazovat strukturu) a vyberte element, který chcete rozvrhnout.
  2. Pro každý element, který chcete umístit do svého dokumentu, proveďte jeden z následujících postupů:
    • Přetáhněte element na stránku. InDesign vytvoří pro element rámeček.

    • Přetáhněte element do existujícího rámečku. Pokud je v rámečku obsah, bude tento obsah nahrazen obsahem dat XML.

  3. Chcete-li formátovat rozvržené položky, proveďte jeden z následujících postupů:
    • Namapujte tagy XML na odstavec, znak, tabulku a styly buněk.

    • Použijte styly na elementy.

    • Formátujte vybraný obsah ručně tím, že zvolíte volby textu v ovládacím panelu.

Mapování tagů XML na styly

Tagy XML jsou pouze popisem dat, neobsahují žádné formátovací pokyny. Obsah XML musíte po importování a rozvržení naformátovat. Jedním ze způsobů je mapovat tagy XML na styly odstavců, znaků, tabulek nebo buněk. Například tag Podtitulek můžete mapovat na znakový styl Autor, aby se veškerému importovanému a umístěnému obsahu XML, který je tagován jako Podtitulek, automaticky přiřadil znakový styl Autor. Mapování tagů na styly usnadňuje formátování importovaného obsahu XML a šetří čas.

Nemusíte mapovat každý tag na styl odstavce nebo znaku. Některé elementy se v rozvržení nemusejí zobrazit a jiné může být jednodušší formátovat po jednom. Dceřiné elementy navíc přebírají styl odstavce nebo znaků přiřazený rodičovským elementům, což může vést ke zmatku, pokud nejste opatrní a nemapujete rodičovské a dceřiné elementy odděleně.

Poznámka:

Příkaz Mapovat tagy na styly opakovaně používá styly v celém dokumentu, někdy s nežádoucími výsledky. Když mapujete tag na styl, může v závislosti na tagu XML dojít k přiřazení dalšího stylu k textu, kterému již byl dříve přiřazený jiný styl. Pokud jste již nějaký text zformátovali, možná dáte přednost ruční aplikaci stylů, aby nedošlo k přepsání vašich voleb stylů odstavců a znaků.

  1. Zvolte Mapovat tagy na styly z nabídky panelu Tagy nebo panelu Struktura.
    Dialogové okno Mapovat tagy na styly
    Nabídka stylů se zobrazí u každého tagu v dialogovém okně Mapovat tagy na styly

  2. Proveďte libovolný z následujících úkonů:
    • Chcete-li importovat definice stylů, tagů a mapování z jiného dokumentu, klikněte na Načíst, zvolte dokument a klikněte na Otevřít.

    • Chcete-li mapovat tagy na styly jednotlivě, klikněte do sloupce Styl vedle tagu a ze zobrazené nabídky zvolte odstavcový nebo znakový styl. (Značka odstavce označuje v nabídce odstavcové styly; písmeno „A“ označuje znakové styly.) Postup opakujte pro všechny tagy, které chcete mapovat.

    • Chcete-li automaticky mapovat tagy na styly se stejnými názvy, klikněte na Mapovat podle názvu. Styly s názvy, které jsou stejné jako názvy tagů, se vyberou ve sloupci Styl. Má-li se tag a styl shodovat, nestačí stejný název, musí se shodovat také velikost písmen; například H1h1 se nepovažuje za shodu. (Pokud dvě různé skupiny stylů obsahují stejný název stylu, Mapovat podle názvu nebude fungovat a budete vyzváni, abyste jeden styl přejmenovali.)

  3. Klikněte na tlačítko OK.

O automatickém rozvržení

InDesign umožňuje automaticky umístit importovaný obsah XML do rozvržení. Nejprve musíte vytvořit vyhrazené rámečky nebo tabulky a označit je stejnými tagy jako elementy XML, které do nich chcete umístit. Pak do vyhrazeného místa importujte obsah XML v režimu sloučení. Když se tagy shodují podle názvu a podle hierarchie ve struktuře, InDesign sloučí obsah XML a nahradí existující obsah dokumentu.

Tato technika je užitečná, když chcete použít stejné rozvržení pro různé sady obsahu. Například týdeník může mít každý týden stejné rozvržení, ale každé vydání nabídne jiný obsah.

Aby bylo importované XML sloučeno přímo do rozvržení, dokumenty musejí splňovat tyto požadavky:

  • Rámečky (nebo tabulky) v dokumentu musí být označeny názvy identickými s názvy prvků v souboru XML, který chcete importovat.

  • Struktura dokumentu (zobrazená v panelu Struktura) musí odpovídat struktuře importovaného souboru XML. Jinými slovy, identicky pojmenované elementy musí být nalezeny ve stejném místě v hierarchické struktuře obou souborů. Chcete-li této shody struktury dosáhnout, může být třeba změnit uspořádání a pořadí elementů (a jejich dceřiných elementů) v panelu Struktura nebo použít volbu Aplikovat XSLT, když importujete soubor XML.

Poznámka:

InDesign naplní sloučený obsah XML pouze do existujících rámečků. Z každého obsahu elementu, který se nevejde do rámečku (nebo řady zřetězených rámečků), se stane přesahující text.

Práce s opakujícími se daty

XML se opakuje, pokud se v řádku vícekrát objevuje stejná konfigurace elementů, ale každý výskyt obsahuje jedinečná data. Například databázové záznamy se opakují. Adresy v databázové tabulce obsahují opakující se informace – jméno, ulici, město, stát, PSČ – pro mnoho různých osob.

Při importu obsahu XML můžete v dialogovém okně Možnosti importu XML vybrat položku Klonovat opakující se elementy textu. Výběrem této možnosti dáte aplikaci InDesign pokyn ke klonování opakujících se prvků ve struktuře. Klonování umožňuje sloučit opakující se data XML do dokumentu bez nutnosti vytvářet vyhrazené elementy v panelu Struktura (nebo vyhrazený text v rámečku) pro každý jednotlivý záznam. Chcete-li například importovat seznam adres s 25 položkami, vytvořte odpovídající strukturu elementů pro jednu položku v panelu Struktura. Když celý seznam importujete, InDesign tuto strukturu klonuje, aby vytvořil elementy pro všech 25 položek.

Opakující se obsah XML je naplněn jako jeden článek, když je sloučený s dokumentem. Pokud byly vyhrazené rámečky zřetězené, obsah je naplněn do rámečků postupně. Pokud pro obsah XML není ve vyhrazených rámečcích dostatek místa, můžete zbylý obsah automaticky natéct, když vytvoříte a zřetězíte více rámečků. Nemusíte ručně přetahovat elementy z panelu Struktura do jednotlivých rámečků.

Rozvržení
Zřetězené vyhrazené místo v rozvržení (vlevo) a rozvržení po importu (vpravo)

Vytvoření vyhrazeného místa pro automatické rozvržení

Vytvořte vyhrazené rámečky nebo tabulky v dokumentu, chcete-li, aby InDesign automaticky sloučil importované XML s vaším rozvržením.

Poznámka:

InDesign naplní sloučený obsah XML pouze do existujících rámečků. Obsah, který se nevejde do dostupných rámečků, se stane přesahujícím textem.

Můžete také vytvořit zástupný text a zajistit tak, že data XML budou na stránce umístěna a naformátována správně. Zástupný text lze použít také k vložení tabulek, mezer nebo popisků (tzv. statického textu) mezi elementy XML, které se zobrazí v rámečku.

Tagovaný zástupný text a rozvržení po importu
Tagovaný zástupný text (vlevo) a rozvržení po importu (vpravo)

A. Znaky konce řádku a statický text přidaný mezi elementy B. Zástupný text 

Pokud například importujete a umísťujete informace o výrobcích, je možné oddělit název produktu, popis a cenu tabulátorem a vložit slova, například „Produkt:“ nebo „Cena:“ před položky zástupného textu pro tyto elementy. Když se data XML sloučí do rámečku, statické popisky, mezery a tabulátory se mezi elementy obsahu zachovají.

Poznámka:

Pokud do dokumentu sloučíte opakující se data XML a necháte InDesign klonovat opakující se elementy, statický text a mezery jsou klonovány pro každý výskyt dat.

Vytvoření vyhrazených rámečků

  1. Pomocí textového nástroje vytvořte textový rámeček pro obsah XML.

    Poznámka:

    Pokud chcete, aby importovaný obsah XML přetékal z jednoho rámečku do druhého, vytvořte více rámečků a zřetězte je.

  2. Otevřete panel Struktura (Zobrazení > Struktura > Zobrazovat strukturu) a panel Tagy (Okna > Pomůcky > Tagy).
  3. Pokud panel Tagy neobsahuje tagy s názvy identickými s elementy XML, které chcete importovat, vytvořte potřebné tagy nebo tagy načtěte ze souboru XML.
  4. Označte vyhrazený rámeček příslušným tagem z panelu Tagy. (Když označíte rámeček tagem, všem zřetězeným rámečkům se přiřadí stejný tag.)
  5. Pokud je to nutné, uspořádejte nebo přidejte elementy v panelu Struktura, aby odpovídaly elementům a struktuře XML, které budete importovat.

Vytvoření vyhrazené tabulky

Elementy XML můžete importovat do vyhrazeného rámečku i do vyhrazené tabulky. V tabulce je každá buňka reprezentována elementem. InDesign umístí obsah XML do tabulky buňku po buňce, element po elementu, postupuje při tom od levého horního rohu tabulky a přiřazuje elementy tagovaným buňkám. Při vytváření vyhrazených tabulek musíte tagy označit tabulku i každou buňku. (Sloučené buňky se považují za jednu buňku.)

Protože InDesign při importu nerozlišuje řádky a sloupce, počet sloupců ve vyhrazeném místě se musí shodovat s počtem sloupců v importovaném obsahu. Všechny elementy buněk tabulky musí být obsažené v jednom elementu tabulky. Jinými slovy, buňky jsou sourozenecké elementy se stejným rodičem.

Vyhrazená tabulka
Vyhrazená tabulka (nahoře) a natečený obsah XML do vyhrazené tabulky (dole)

  1. Otevřete panel Tagy (Okna > Pomůcky > Tagy) a panel Struktura (Zobrazení > Struktura > Zobrazovat strukturu).
  2. Pokud panel Tagy neobsahuje názvy tagů identické s názvy elementů tabulky XML, které chcete importovat, načtěte tagy z existujícího dokumentu nebo tagy vytvořte.

    Poznámka:

    Přinejmenším musíte mít tagy pro rodičovský element buněk tabulky, buňky tabulky a element, ve kterém bude tabulka umístěna.

  3. Vytvořte tabulku obsahující příslušný počet sloupců pro obsah XML. Není nutné vytvořit přesný počet řádků, InDesign je v případě potřeby do tabulky přidá.
  4. Pomocí textového kurzoru v tabulce zvolte Tabulka > Vybrat > Tabulka a vyberte příslušný tag v panelu Tagy.
  5. Požadovaným tagem označte každou buňku tabulky. Podle struktury obsahu XML můžete buňky vybrat a označit tagy jednotlivě nebo můžete vybrat celý řádek nebo sloupec – například pokud chcete tagem označit první řádek nebo řádek záhlaví – a všechny vybrané buňky označit stejným tagem.
  6. Podle potřeby uspořádejte a přidejte elementy v panelu Struktura, aby váš dokument obsahoval stejné elementy a strukturu jako soubor XML, který budete importovat.

Vytvoření vyhrazené struktury pro opakující se data

Pravidla pro sloučení XML platí i pro sloučení opakujícího se XML: struktura elementů v panelu Struktura musí odpovídat struktuře importovaných dat XML a všechny vyhrazené rámečky musí být označeny tagy se stejnými názvy tagů jako rodičovské elementy v souboru XML.

Panel Struktura zobrazující strukturu zástupného textu
Panel Struktura zobrazující strukturu zástupného textu

A. Element, který bude obsahovat všechny opakující se elementy B. Element, který bude klonován, když bude importován opakující se obsah XML C. Dceřiné elementy pro data obsažená v opakujícím se elementu 
  1. Nejprve potřebujete rodičovský nebo kořenový element, který popisuje sadu informací nebo záznamů, které budete importovat.

    Například element Kapitola, který bude obsahovat několik receptů.

  2. Pod rodičovským elementem vytvoříte jeden element, který bude popisovat opakující se informace (nebo záznam).

    Například pod elementem Kapitola můžete vytvořit element Recept. Tento element bude klonován pro každý záznam v importovaném XML.

  3. Pod tímto elementem vytvořte dceřiné elementy pro popis jednotek informací (nebo polí), které tvoří záznam.

    Například pod elementem Recept můžete vytvořit elementy Nazevreceptu, Ingredience, Instrukce, PoznamkyServirovani.

Poznámka:

Chcete-li do opakujících se dat XML zahrnout popisky, konce odstavců nebo tabulátory mezi „poli“, vytvořte vyhrazené elementy v rámečku, do kterého se bude importovaný obsah slučovat. Přidejte mezi vyhrazená místa mezery a popisky podle potřeby.

Vytvoření zástupného textu

  1. Otevřete existující dokument nebo vytvořte nový dokument pro XML.
  2. Otevřete panel Tagy (Okna > Pomůcky > Tagy) a panel Struktura (Zobrazení > Struktura > Zobrazovat strukturu).
  3. Ujistěte se, že panel Tagy obsahuje názvy tagů identické s názvy elementů, které budete importovat v souboru XML, a pokud je to nutné, načtěte potřebné tagy nebo vytvořte tagy nové.

    Poznámka:

    Import vzorku obsahu XML je nejsnadnější způsob, jak získat všechny nezbytné tagy a zajistit, že struktura dokumentu bude odpovídat souboru XML.

  4. Podle potřeby vytvořte vyhrazené rámečky (a zřetězte je) pro obsah XML.
  5. Pomocí textového nástroje klikněte do prvního rámečku, abyste umístili textový kurzor, a zadejte zástupný text pro každý element, který chcete do tohoto rámečku sloučit. Zahrňte libovolnou mezeru, kterou chcete mezi elementy, a také libovolný statický text.

    Poznámka:

    Pokud budete importovat opakující se data, stačí vytvořit jednu instanci zástupného textu pro elementy, které se budou opakovat.

  6. Zformátujte text tak, jak má vypadat v konečném dokumentu.
  7. Označte tagem textový rámeček pro rodičovský element, který bude obsahovat elementy (nebo opakující se data), které chcete do tohoto rámečku importovat.
  8. Umístěte textový kurzor do zástupného textu a zvolte Úpravy > Upravit v editoru článku.
  9. Zvolte Zobrazení > Struktura > Zobrazovat značky tagů.
  10. Zvolte Úpravy > Vybrat vše.
  11. V panelu Tagy vyberte Přidat tag a klikněte na tag, který jste rámečku přiřadili.

    InDesign ohraničí zástupný text tagem a přidá element do panelu Struktura.

  12. Vyberte text představující první dceřiný element a klikněte na jeho tag v panelu Tagy. Postup opakujte, dokud nebude celý dceřiný zástupný text označený tagy.

    Poznámka:

    Při tagování zástupného textu nevybírejte mezery ani statický text, které chcete mezi elementy zachovat. Označte tagy pouze text, který chcete nahradit obsahem XML.

  13. V panelu Struktura zkontrolujte hierarchii vytvořenou při tagování, abyste se ujistili, že odpovídá struktuře obsahu XML, který budete importovat.

Import a sloučení XML

Po vytvoření a tagování vyhrazených rámečků, tabulek a zástupného textu zkontrolujte, že dokument a vstupní soubor XML mají stejné tagy a strukturu. Pak můžete obsah XML importovat do rozvržení.

Chcete-li importovat XML do vyhrazených míst (nebo nahradit existující obsah v dokumentu), musíte použít volbu Sloučit obsah. Při slučování obsahu InDesign nahrazuje identicky tagované a strukturované elementy v dokumentu importovanými elementy XML. Můžete využít další volby importu (tj. filtr), a vyloučit tak importovaný obsah, který neodpovídá struktuře dokumentu, odstranit položky dokumentu, které se neshodují nebo nejsou nahrazeny importovaným XML, a klonovat opakující se elementy XML.

Pokud importovaný soubor XML obsahuje elementy, které nejsou v dokumentu nalezeny, InDesign tyto elementy umístí do panelu Struktura, ale neumístí je do rozvržení dokumentu.

Chcete-li XML úspěšně sloučit do vyhrazených míst, mějte na paměti tato pravidla:

  • Označte vyhrazená místa tagy identickými s elementy XML, které je nahradí (nebo do nich budou natékat).

  • V zástupném textu zkontrolujte, že mezery, konce odstavů, tabulátory a statický text jsou vně tagů elementů vyhrazených míst, ale uvnitř rodičovského elementu pro daný článek.

  • Když importujete XML, vyberte Neimportovat obsah elementů, které obsahují pouze různé typy mezer. (Tato volba zachovává mezery a statický text, když se importované elementy XML skládají pouze z mezer.)

Sloučení XML do existujícího obsahu nebo vyhrazených míst

  1. Otevřete dokument aplikace InDesign, který obsahuje vyhrazená místa pro obsah XML.
  2. Otevřete panel Struktura (Zobrazení > Struktura > Zobrazovat strukturu).
  3. Vyberte Soubor > Importovat XML (nebo vyberte Importovat XML v nabídce panelu Struktura) a pak vyberte soubor XML, který chcete importovat.
  4. Vyberte Zobrazit volby importu XML.
  5. Vyberte Sloučit obsah a pak klikněte na OK.
  6. Chcete-li spojit obsah XML s původním souborem XML, vyberte Vytvořit vazbu.

    Soubor XML se zobrazí v panelu Vazby v aplikaci InDesign a při změně zdrojového souboru XML se u něj zobrazí žlutý výstražný trojúhelník.

  7. V případě potřeby vyberte další volby importu:

    Klonovat opakující se elementy textu

    Pokud importujete opakující se XML, klonuje jeden vyhrazený element, aby se vytvořil kontejner pro každý záznam souboru.

    Importovat pouze elementy, které odpovídají existující struktuře

    Filtruje vstupní XML tak, že se neimportují elementy, které v panelu Struktura neexistují.

    Neimportovat obsah elementů, které obsahují pouze různé typy mezer

    Zachovává mezery nebo statický text vložený mezi elementy ve vyhrazeném rámečku.

    Odstranit elementy, rámečky a obsah, které nesouhlasí s importovaným XML

    Po importu XML se odstraní všechny elementy nebo vyhrazená místa v dokumentu, která neodpovídala vstupním datům (nebo jimi nebyla nahrazena).

  8. Klikněte na tlačítko OK.

InDesign sloučí obsah do dokumentu počínaje prvním odpovídajícím elementem v souboru XML.

Volby importu XML

Když importujete a umísťujete data XML pomocí volby Sloučit obsah, dialogové okno Volby importu XML nabízí následující volby:

Vytvořit vazbu

Vytvoří vazbu na soubor XML, aby v případě aktualizace souboru XML bylo možné aktualizovat i data XML v dokumentu aplikace InDesign.

Aplikovat XSLT

Použije seznam stylů pro definici transformace importovaného XML. Vyberte Procházet (Windows) nebo Vybrat (Mac OS), abyste mohli v souborovém systému vybrat soubor XSLT (.xsl nebo .xslt). Použití standardní volby Použít seznam stylů z XML způsobí, že InDesign pro transformaci dat XML použije příkaz pro zpracování XSLT, pokud soubor XML takový příkaz obsahuje.

Klonovat opakující se elementy textu

Vytvoří kopii rozvržení použitého na tagovaný zástupný text pro opakující se obsah. Vytvořte jeden výskyt formátování (například adresu) a použijte jeho rozvržení pro automatické vytvoření dalších výskytů. (Viz Práce s opakujícími se daty.)

Importovat pouze elementy, které odpovídají existující struktuře

Filtruje importovaný obsah XML, importují se pouze elementy z importovaného souboru XML s odpovídajícími elementy v dokumentu.

Importovat textové elementy do tabulek, pokud souhlasí tagy

Importuje elementy do tabulky, pokud tagy odpovídají tagům použitým na tabulku vyhrazující místo a na její buňky. Použijte tuto volbu například v případě, že do tabulky chcete umístit databázové záznamy, když vytváříte ceník nebo inventurní soupisky.

Neimportovat obsah elementů, které obsahují pouze různé typy mezer

Zachová existující obsah beze změny, pokud odpovídající obsah XML obsahuje pouze mezery (například znaky konce řádku nebo tabulátoru). Tuto volbu použijte, pokud jste mezi elementy do vyhrazených rámečků vložili text a chcete tento text zachovat. Když například vytváříte rozvržení pro recepty generované z databáze, můžete přidat popisky, například „Ingredience“ nebo „Pokyny“. Pokud rodičovský element, který obaluje každý recept, obsahuje pouze mezery, InDesign ponechá popisek na místě.

Odstranit elementy, rámečky a obsah, které nesouhlasí s importovaným XML

Odstraní elementy z panelu Struktura a z rozvržení dokumentu, pokud neodpovídají žádným elementům v importovaném souboru XML. Tuto volbu použijte, chcete-li filtrovat data dokumentu. Když například importujete jména a adresy, můžete mít zástupný text pro element s názvem společnosti. Pokud jedno ze jmen neobsahuje element společnosti, InDesign odstraní element se zástupným textem.

Importovat tabulky CALS jako tabulky aplikace InDesign

Importuje tabulky CALS v souboru XML jako tabulky aplikace InDesign.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online