O znakových a odstavcových stylech

Znakový styl je sada atributů formátování znaků, kterou lze aplikovat na text jedním krokem. Odstavcový styl zahrnuje atributy formátování znaků i odstavců a lze ho aplikovat na odstavec nebo skupinu odstavců. Odstavcové styly a znakové styly jsou v samostatných panelech. Odstavcovým a znakovým stylům se někdy říká textové styly.

V nastavení formátu mřížky rámečku se dá použít na mřížku formát pojmenované mřížky. (Viz Přehled panelu Pojmenované mřížky.) Také můžete vytvořit objektový styl s charakteristikami mřížky. (Viz O objektových stylech.)

Když změníte formátování stylu, veškerý text, na který je tento styl aplikovaný, se aktualizuje podle nového formátu.

Styly můžete vytvářet, upravovat a odstraňovat v samostatných dokumentech Adobe InCopy nebo v obsahu InCopy, který je připojený k dokumentu Adobe InDesign Při aktualizaci obsahů v aplikaci InDesign se do dokumentu aplikace InDesign přidávají nové styly, ale změny stylu provedené v InCopy se přepíší styly aplikace InDesign. Pro připojený obsah je nejlepší spravovat styly v aplikaci InDesign.

Styl [Základní odstavec]

Standardně každý nový dokument obsahuje styl [Základní odstavec], který se aplikuje na text, který píšete. Tento styl můžete upravit, ale nemůžete ho přejmenovat nebo odstranit. Styly, které vytvoříte, pak přejmenovat a odstranit můžete. Můžete také vybrat jiný výchozí styl, který chcete aplikovat na text.

Atributy znakového stylu

Znakové styly na rozdíl od odstavcových stylů neobsahují všechny formátovací atributy vybraného textu. Když vytvoříte znakový styl, InDesign začlení do stylu pouze ty atributy, které jsou rozdílné od formátování vybrané části textu. Tímto způsobem můžete vytvořit znakový styl, který při aplikování na text změní pouze některé atributy, například rodinu a velikost písma, a bude ignorovat všechny ostatní znakové atributy. Pokud chcete, aby součástí stylu byly další atributy, přidejte je, když styl upravujete.

Následující styl

Styly se mohou při psaní textu aplikovat automaticky. Pokud například chcete, aby v dokumentu ze nadpisem se stylem „nadpis 1“ následoval styl „základní text“, můžete nastavit ve stylu „nadpis 1“ volbu Následující styl na „základní text“. Poté, co napíšete odstavec se stylem „nadpis 1“, stisknutím klávesy Enter nebo Return začnete nový odstavec se stylem „základní text“.

Pokud použijete při aplikování stylu na dva nebo více odstavců kontextovou nabídku, můžete aplikovat rodičovský styl pro první odstavec a Následující styl pro další odstavce. (Viz Aplikování stylů.)

Chcete-li použít funkci Následující styl, zvolte styl z nabídky Následující styl při vytváření stylu nebo jeho úpravě.

Jeff Witchel publikuje výukový videokurz o používání funkce Následující styl na stránce Using the Next Style feature.

Panel Styly – přehled

Použijte panel Znakové styly, chcete-li vytvořit, pojmenovat a aplikovat znakové styly na text uvnitř odstavce; použijte panel Odstavcové styly, chcete-li vytvořit, pojmenovat a aplikovat odstavcové styly na celé odstavce. Styly se ukládají s dokumentem a zobrazí se v panelu při každém otevření dokumentu.

Když vyberete text nebo umístíte textový kurzor, styl, který jste na tento text aplikovali, se zvýrazní v obou panelech stylů, pokud tento styl není obsažen ve sbalené skupině stylů. Pokud vyberete oblast textu, která obsahuje více stylů, v panelu Styly se nezvýrazní žádný styl. Pokud vyberete rozsah textu, na který je aplikováno více stylů, zobrazí se v panelu Styly text „(různé).”

Otevření panelu Odstavcové styly

  1. Zvolte Text > Odstavcové styly nebo klikněte na záložku Odstavcové styly, která se se standardně zobrazuje na pravé straně okna aplikace.

Otevření panelu Znakové styly

  1. Zvolte Text > Znakové styly nebo klikněte na záložku Znakové styly na pravé straně okna aplikace.

Přidávání odstavcových a znakových stylů

Pokud požadované styly existují v jiném dokumentu aplikace InDesign, InCopy nebo textového editoru, můžete tyto styly importovat a použít v aktuálním dokumentu. Pokud pracujete se samostatným článkem, můžete také definovat znakové a odstavcové styly v InCopy.

Definování odstavcových a znakových stylů

  1. Pokud chcete vytvořit styl na základě formátování existujícího textu, vyberte text nebo do něj umístěte textový kurzor.

    Pokud je v panelu stylů vybraná skupina, nový styl je součástí této skupiny.

  2. Zvolte Nový odstavcový styl z nabídky panelu Odstavcové styly nebo Nový znakový styl z nabídky panelu Znakové styly.

  3. Do pole Název stylu zadejte název nového stylu.

  4. Ze seznamu Odvozen od vyberte styl, na kterém bude aktuální styl založen.

    Poznámka:

    Pomocí volby Odvozen od můžete styly vzájemně propojit, takže změny v definici jednoho stylu se projeví ve všech stylech, které jsou na něm založené. Nové odstavcové styly jsou standardně odvozeny z volby [Bez odstavcového stylu], nové znakové styly z volby [Žádný], případně ze stylu aktuálně vybraného textu.

  5. Pro Následující styl (pouze v panelu Odstavcové styly) určete styl, který se použije za aktuálním stylem po stisknutí klávesy Enter nebo Return.

  6. Chcete-li přidat klávesovou zkratku, umístěte textový kurzor do pole Zkratka a zajistěte, aby byla zapnutá klávesa NumLock. Pak podržte stisknutou libovolnou kombinaci kláves Shift, Alt a Ctrl (Windows) nebo Shift, Option a Command (Mac OS) a stiskněte klávesu s číslem na číselné klávesnici. Pro definování zkratek stylů nemůžete použít písmena ani jiná čísla, než z číselné klávesnice. Pokud nemáte na klávesnici klávesu NumLock, nemůžete do stylů přidávat klávesové zkratky.

  7. Chcete-li aplikovat nový styl na vybraný text, vyberte Aplikovat styl na výběr.

  8. Chcete-li určit atributy formátování, na levé straně klikněte na kategorii (například Základní znakové formáty) a nastavte atributy, které chcete do stylu přidat.

    Poznámka:

    Když určujete barvu znaků v dialogovém okně Volby stylu, můžete dvojitým kliknutím na pole výplně nebo tahu vytvořit novou barvu.

  9. Pro znakové styly platí, že atributy, které neurčíte, se budou ignorovat; při aplikování stylu si text pro takový atribut zachová formátování z odstavcového stylu. Chcete-li odstranit nastavení atributu ze znakového stylu:

    • Z nabídky nastavení zvolte (Ignorovat).

    • V textovém poli odstraňte text volby.

    • V zaškrtávacím poli klikněte tolikrát, dokud neuvidíte malý čtvereček (Windows) nebo pomlčku (-) (Mac OS).

    • Pro barvu znaků podržte stisknutou klávesu Ctrl (Windows) nebo Command (Mac OS) a klikněte na pole barvy.

  10. Až dokončíte nastavování atributů formátování, klikněte na OK.

Styly, které vytvoříte, se objeví pouze v aktuálním dokumentu. Pokud není otevřený žádný dokument, vytvořené styly se objeví ve všech nových dokumentech.

Odvození jednoho odstavcového nebo znakového stylu od druhého

Mnoho návrhů dokumentů obsahuje hierarchii stylů, které sdílejí určité atributy. Například nadpisy a podnadpisy často používají stejné písmo. Mezi podobnými styly můžete snadno vytvořit vazbu vytvořením základního neboli rodičovského stylu. Když upravíte rodičovský styl, změní se také odvozené styly. Odvozené styly pak můžete upravit a odlišit je od rodičovského stylu.

Poznámka:

Chcete-li vytvořit styl, který je téměř stejný jako jiný styl, ale bez vztahu rodič-potomek, použijte příkaz Duplikovat styl a pak upravte kopii.

  1. Vytvořte nový styl.
  2. V dialogovém okně Nový odstavcový styl nebo Nový znakový styl vyberte rodičovský styl v nabídce Odvozen od. Nový styl se stane odvozeným stylem.

    Nové styly jsou standardně odvozené z [Bez odstavcového stylu] nebo [Žádný] nebo ze stylu právě vybraného textu.

  3. Určením formátování odlište nový styl od stylu, od kterého je odvozen. Můžete například chtít, aby bylo písmo použité v podnadpisu trochu menší než písmo použité v (rodičovském) stylu nadpisu.

Poznámka:

Pokud provedete změny formátování odvozeného stylu a rozhodnete se začít znovu, klikněte na tlačítko Obnovit na základní. Tím formátování odvozeného stylu obnovíte, takže bude shodné se stylem, od kterého je odvozen. Pak můžete určit nové formátování. Podobně pokud změníte styl Odvozen od v odvozeném stylu, aktualizuje se definice odvozeného stylu, aby odpovídala novému rodičovskému stylu.

Import stylů z jiných dokumentů

Do aktivního dokumentu můžete importovat odstavcové styly a znakové styly z jiného dokumentu aplikace InDesign (jakékoliv verze). Při importu můžete určit, které styly se načtou, a co se má stát, pokud se název načteného stylu shoduje s názvem stylu v aktuálním dokumentu. Můžete také importovat styly z dokumentu InCopy.

Odstavcové styly a znakové styly můžete importovat z dokumentu aplikace InDesign nebo InCopy do samostatného dokumentu InCopy nebo do obsahu InCopy připojeného k aplikaci InDesign. Můžete určit, které styly se načtou a co se má stát, pokud se název načteného stylu shoduje s názvem stylu v aktuálním dokumentu.

Poznámka:

Pokud importujete styly do připojeného obsahu, nové styly se přidají do dokumentu aplikace InDesign při aktualizaci obsahu a libovolný styl, u kterého došlo ke konfliktu názvu, se přepíše stylem aplikace InDesign se stejným názvem.

  1. V panelu Znakové styly nebo Odstavcové styly proveďte jeden z následujících úkonů:
    • Z nabídky panelu Styly zvolte Načíst znakové styly nebo Načíst odstavcové styly.

    • Z nabídky panelu Styly zvolte Načíst všechny textové styly, chcete-li načíst znakové styly i odstavcové styly.

  2. Dvojitě klikněte na dokument aplikace InDesign obsahující styly, které chcete importovat.
  3. V dialogovém okně Načíst styly zaškrtněte pole vedle stylů, které chcete importovat. Pokud se název některého importovaného stylu shoduje s názvem stávajícího stylu, vyberte ze seznamu Konflikt s existujícím stylem jednu z následujících položek a pak klikněte na OK:

    Použít definici vstupního stylu

    Přepíše stávající styl načteným stylem a aplikuje jeho nové atributy na veškerý text v aktuálním dokumentu, který používal starý styl. Definice vstupního a stávajícího stylu se zobrazí v dolní části dialogového okna Načíst styly, takže je můžete porovnat.

    Automaticky přejmenovat

    Přejmenuje načtený styl. Pokud například oba dokumenty obsahují styl Podnadpis, přejmenuje se načtený styl v aktuálním dokumentu na „Podnadpis kopie“.

Chcete-li sdílet styly, můžete také použít funkci Kniha. (Viz Synchronizace dokumentů knihy.)

Mapování stylů do tagů exportu | CC, CS6, CS5.5

Úvod k tagům exportu

Použijte funkci Tagování exportu pro určení označení textu se styly InDesign v HTML, EPUB nebo v tagovaném výstupu PDF.

Můžete také zadat názvy třídy CSS, které budou přidány do exportovaného dokumentu. Třídy CSS se při exportování formátů EPUB/HTML používají k rozlišovaní malých odchylek ve stylech. Není třeba zadávat název třídy. Aplikace InDesign vytvoří název automaticky na základě názvu stylu.

Náhled Tagování exportu nelze v rozvržení aplikace InDesign zobrazit, protože ovlivňuje pouze exportovaný soubor EPUB, HTML nebo PDF.

Možnost Upravit všechny tagy exportu vám umožňuje efektivní zobrazení a změnu mapování v jednom dialogovém okně.

Definování mapování stylů na tagy

  1. U mapování stylů otevřete dialogové okno Volby pro odstavec, znak nebo styl objektu.
  2. Klikněte na možnost Tagování exportu v levém podokně a postupujte jedním z následujících kroků:
    • Vyberte tag, který chcete mapovat pro výstup EPUB a HTML.

    • Určete třídu, kterou chcete mapovat pro výstup EPUB a HTML. Názvy tříd se používají pro generování definic stylů pro výchozí tagy.

    • Chcete-li zahrnout tento styl do CSS, zaškrtněte políčko Vytvořit CSS. Pokud toto políčko nezaškrtnete, nevytvoří se pro tento styl žádná třída CSS. Pokud jste jedné třídě přiřadili dva nebo více stylů, zobrazí aplikace InDesign při exportu chybovou zprávu/upozornění. Tato volba je k dispozici jen v aplikaci InDesign CC.

    • Vyberte tag, který chcete mapovat pro výstup PDF. Tato volba je k dispozici jen pro styly odstavce.

Úprava všech tagů exportu

Všechny tagy exportu lze zobrazit a měnit v jednom okně.

  1. Vyberte možnost Upravit všechny tagy exportu v nabídce panelu pro odstavec, znak nebo styl objektu.
  2. Klikněte na možnost EPUB a HTML, nebo PDF.
  3. Klikněte na tag odpovídající stylu. Po jeho převedení na seznam vyberte novou hodnotu.

Převod stylů aplikace Word na styly aplikace InDesign

Při importu dokumentu aplikace Microsoft Word do aplikace InDesign nebo InCopy můžete mapovat každý styl použitý v aplikaci Word na odpovídající styl v aplikaci InDesign nebo InCopy. Tím určíte, jaké styly se použijí pro formátování importovaného textu. Dokud importovaný styl neupravíte v aplikaci InDesign, zobrazuje se u každého importovaného stylu aplikace Word ikona .

  1. Proveďte jeden z následujících úkonů:
    • Chcete-li přidat dokument aplikace Word do existujícího textu v aplikaci InDesign nebo InCopy, zvolte Soubor > Umístit. Vyberte Zobrazit volby importu a pak dvojitě klikněte na dokument aplikace Word.

    • Chcete-li otevřít dokument aplikace Word v samostatném dokumentu InCopy, spusťte InCopy, zvolte Soubor > Otevřít a pak dvojitě klikněte na soubor aplikace Word.

  2. Vyberte Zachovat styly a formátování textu a tabulek
  3. Vyberte Nastavit import stylů a pak klikněte na Mapování stylů.
  4. V dialogovém okně Mapování stylů vyberte styl aplikace Word a pak vyberte volbu z nabídky pod stylem InDesignu. Můžete zvolit některou z následujících voleb:
    • Pokud nedošlo ke konfliktu názvu stylu, zvolte Nový odstavcový styl, Nový znakový styl nebo vyberte existující styl InDesignu.

    • Pokud došlo ke konfliktu názvu stylu, zvolte Předefinovat styl InDesignu, aby se importovaný text se stylem formátoval stylem aplikace Word. Zvolte stávající styl InDesignu, chcete-li zformátovat importovaný text se stylem pomocí s použitím stylu InDesignu. Zvolte Automaticky přejmenovat, chcete-li přejmenovat styl aplikace Word.

  5. Kliknutím na OK zavřete dialogové okno Mapování stylů a pak kliknutím na OK importujte dokument.

Aplikování stylů

Standardně se při aplikování odstavcového stylu neodstraní žádné existující formátování znaků ani znakové styly aplikované na část odstavce, ale při aplikování stylu máte možnost existující formátování odstranit. Vedle platného odstavcového stylu se v panelu Styly zobrazí znak plus (+), pokud vybraný text používá znakový nebo odstavcový styl a také další formátování, které není součástí aplikovaného stylu. Tomuto přídavnému formátování se říká lokální změna nebo lokální formátování.

Znakové styly odstraňují nebo obnovují znakové atributy existujícího textu, pokud jsou příslušné atributy ve stylu definované.

Aplikování znakového stylu

  1. Vyberte znaky, na které chcete aplikovat styl.
  2. Proveďte jeden z následujících úkonů:
    • Klikněte na název znakového stylu v panelu Znakové styly.

    • Vyberte název znakového stylu z rozbalovacího seznamu v ovládacím panelu.

    • Stiskněte klávesovou zkratku, kterou jste stylu přiřadili. (Musí být zapnutý zámek číslic NumLock.)

Aplikování odstavcového stylu

  1. Klikněte na odstavec nebo vyberte všechen text nebo část textu v odstavcích, na které chcete aplikovat styl.
  2. Proveďte jeden z následujících úkonů:
    • Klikněte na název odstavcového stylu v panelu Odstavcové styly.

    • Vyberte název odstavcového stylu z nabídky v ovládacím panelu.

    • Stiskněte klávesovou zkratku, kterou jste stylu přiřadili. (Musí být zapnutý zámek číslic NumLock.)

  3. Pokud v textu zůstane nechtěné formátování, z panelu Odstavcové styly zvolte Odstranit lokální změny.

Aplikování posloupnosti stylů na více odstavců

Volba Následující styl určuje, který styl se automaticky použije po stisknutí klávesy Enter nebo Return po aplikování určitého stylu. Umožňuje vám také použít různé styly na více odstavců najednou.

Předpokládejme například, že máte tři styly pro formátování novinového sloupku: Titul, Podtitulek a Základní text. Styl Titul používá styl Podtitulek jako následující styl, styl Podtitulek používá jako následující styl Základní text a styl Základní text má jako následující styl nastavení [Stejný styl]. Pokud vyberete celý článek včetně titulu, podtitulu se jménem autora a odstavců článku a potom aplikujete styl Titul pomocí speciálního příkazu „Další titul“ v místní nabídce, zformátuje se první odstavec článku stylem Titul druhý odstavec článku stylem Podtitulek a všechny ostatní odstavce se zformátují stylem HlavniText.

Před a po aplikování stylu s nastaveným následujícím stylem
Před a po aplikování stylu s nastaveným následujícím stylem.

  1. Vyberte odstavce, na které chcete aplikovat styly.
  2. V panelu Odstavcové styly klikněte pravým tlačítkem (Windows) nebo s klávesou Ctrl (Mac OS) na rodičovský styl a potom zvolte Aplikovat [název stylu], pak následující styl.

Pokud text obsahuje lokální změny formátování nebo znakové styly, můžete pomocí kontextové nabídky odstranit také lokální změny, znakové styly nebo obojí.

Úpravy znakových a odstavcových stylů

Jednou z výhod používání stylů je, že když změníte definici stylu, veškerý text formátovaný tímto stylem se změní podle nové definice stylu.

Poznámka:

Pokud upravíte styly v obsahu InCopy, který je připojený k dokumentu aplikace InDesign, provedené změny se přepíšou při aktualizaci připojeného obsahu.

Úprava stylu pomocí dialogového okna

  1. Proveďte jeden z následujících úkonů:
    • Pokud nechcete styl aplikovat na vybraný text, klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac OS) na název stylu v panelu stylů a zvolte Upravit [název stylu].

    • V panelu Styly dvojitě klikněte na název stylu nebo styl vyberte a zvolte Volby stylu v nabídce panelu stylů. Tím také aplikujete styl na vybraný text nebo textový rámeček nebo nastavíte styl jako výchozí pro text napsaný v nových rámečcích, pokud není vybraný žádný text ani textový rámeček.

  2. Upravte nastavení v dialogovém okně a pak klikněte na OK.

Předefinování stylu, aby odpovídal vybranému textu

Po aplikování stylu můžete lokálně změnit kterékoliv jeho nastavení. Pokud se rozhodnete, že se vám provedené úpravy líbí, můžete styl předefinovat, aby odpovídal formátování upraveného textu.

Poznámka:

Pokud předefinujete styly v obsahu InCopy připojeném k dokumentu aplikace InDesign, provedené změny se přepíšou při aktualizaci propojeného obsahu.

  1. Textovým nástrojem vyberte text formátovaný stylem, který chcete předefinovat.
  2. Proveďte změny atributů odstavce nebo znaků podle potřeby.
  3. Z nabídky panelu Styly zvolte Předefinovat styl.

Odstranění znakových nebo odstavcových stylů

Když odstraňujete styl, můžete vybrat jiný styl, kterým ho chcete nahradit, a můžete zvolit, zda chcete zachovat formátování. Když odstraníte skupinu stylů, odstraníte všechny styly uvnitř této skupiny. Postupně se zobrazí výzvy k nahrazení jednotlivých stylů ve skupině.

  1. Vyberte název stylu v panelu Styly.
  2. Proveďte jeden z následujících úkonů:
    • V nabídce panelu zvolte Odstranit styl nebo klikněte na ikonu Odstranit dole v panelu.

    • Klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac OS) na styl a pak zvolte Odstranit styl. Tato metoda je obzvláště vhodná pro odstranění stylu bez jeho aplikování na text.

  3. V dialogovém okně Odstranit odstavcový styl vyberte styl, kterým ho chcete nahradit.

    Pokud vyberete [Bez odstavcového stylu] jako náhradu za odstavcový styl nebo [Žádný] jako náhradu za znakový styl, vyberte Zachovat formátování, chcete-li zachovat formátování textu, na který byl styl aplikovaný. Text si zachová formátování, ale nebude již nadále spojen se stylem.

  4. Klikněte na OK.

Poznámka:

Chcete-li odstranit všechny nepoužité styly, z nabídky panelu Styly zvolte Vybrat všechny nepoužité a pak klikněte na ikonu Odstranit. Při odstraňování nepoužitého stylu nebudete vyzváni k jeho nahrazení.

Lokální změny znakových a odstavcových stylů

Když aplikujete odstavcový styl, znakové styly a ostatní dřívější formátování zůstanou beze změny. Po aplikování stylu můžete lokálně změnit libovolné z jeho nastavení aplikováním formátování, které není součástí tohoto stylu. Pokud text s aplikovaným stylem používá formátování, které není součástí tohoto stylu, nazývá se toto formátování lokální změna nebo lokální formátování. Když vyberete text s lokálními změnami, objeví se vedle názvu stylu znak plus (+). Ve znakových stylech se lokální změna zobrazí pouze v případě, že aplikovaný atribut je součástí stylu. Pokud například znakový styl mění pouze barvu textu, aplikování jiné velikosti písma textu se jako lokální změna nezobrazí.

Při aplikování stylu můžete odstranit znakové styly a lokální změny formátování. Můžete také odstranit lokální změny z odstavce, na který byl styl již aplikován.

Poznámka:

Pokud se vedle názvu stylu zobrazuje znak plus (+), podržením ukazatele nad stylem zobrazíte popis atributů lokální změny.

Zachování nebo odstranění lokálních změn při aplikaci odstavcových stylů

  • Chcete-li aplikovat odstavcový styl a zachovat znakové styly, ale odstranit lokální změny, podržte při kliknutí na název stylu v panelu Odstavcové styly stisknutou klávesu Alt (Windows) nebo Option (Mac OS).
  • Chcete-li aplikovat odstavcový styl a odstranit znakové styly i lokální změny, stiskněte klávesy Alt+Shift (Windows) nebo Option+Shift (Mac OS) při kliknutí na název stylu v panelu Odstavcové styly.

Poznámka:

Klikněte na název stylu v panelu Odstavcové styly pravým tlačítkem (Windows) nebo se stisknutou klávesou Ctrl (Mac OS) a pak vyberte volbu z kontextové nabídky. Při aplikování stylu můžete odstranit lokální změny, znakové styly nebo obojí.

Zvýraznění změn odstavcového a znakového stylu 

Pokud chcete identifikovat změny odstavcového a znakového stylu použité v dokumentu, postupujte takto:

  1. Otevřete panel odstavcových nebo znakových stylů.

  2. Proveďte jeden z následujících úkonů:

    • Klikněte na ikonu Zvýrazňovač přepsání stylu .
    • V nabídce vyberte možnost Přepnout zvýrazňovač přepsání stylu.

Zvýrazňovač přepsání stylu zvýrazní všechny změny odstavcového a znakového stylu v dokumentu.

Poznámka:

S možností Přepnout zvýrazňovač přepsání stylu můžete asociovat klávesovou zkratku, abyste k ní měli snadný přístup. Další informace naleznete v části Přizpůsobení nabídek a klávesových zkratek.

Vymazání lokálních změn odstavcového stylu

  1. Vyberte text obsahující lokální změny. Můžete vybrat i více odstavců s různými styly.
  2. V panelu Odstavcové styly proveďte libovolný z následujících úkonů:
    • Chcete-li odstranit formátování odstavců a znaků, klikněte na ikonu Odstranit lokální změny nebo z panelu Odstavcové styly zvolte Odstranit lokální změny.

    • Chcete-li odstranit lokální změny znaků, ale zachovat lokální změny formátování odstavců, podržte při kliknutí na ikonu Odstranit lokální změny stisknutou klávesu Ctrl (Windows) nebo Command (Mac OS).

    • Chcete-li odstranit lokální změny na úrovni odstavců, ale zachovat lokální změny na úrovni znaků, podržte stisknuté klávesy Ctrl+Shift (Windows) nebo Command+Shift (Mac OS) při kliknutí na ikonu Odstranit lokální změny v panelu Odstavcové styly.

    Poznámka:

    Při odstranění lokálních změn se lokální změny na úrovni odstavce odstraní z celého odstavce bez ohledu na to, jaká jeho část je vybraná. Lokální změny na úrovni znaků se odstraní pouze z vybraného textu.

    Odstranění lokálních změn neodstraní formátování znakového stylu. Chcete-li odstranit formátování znakového stylu, vyberte text obsahující znakový styl a v panelu Znakové styly klikněte na styl [Žádný].

Po přerušení vazby mezi textem a stylem si text zachová aktuální formátování. Budoucí změny stylu se ale v textu, který byl od stylu odpojen, již nijak neprojeví.

  1. Vyberte text se stylem, který od něj chcete odpojit.
  2. Z nabídky panelu Styly zvolte Zrušit vazbu na styl.

Pokud při volbě příkazu Zrušit vazbu na styl není vybraný žádný text, bude dále psaný text používat formátování vybraného stylu, ale nebude mít přiřazený žádný styl.

Převedení odrážek a číslování ze stylu na text

Když vytvoříte styl, který k odstavcům přidává odrážky nebo číslování, mohou se tyto odrážky a číslování ztratit, pokud text kopírujete nebo exportujete do jiné aplikace. Chcete-li tomuto problému zabránit, převeďte tyto odrážky a číslování ze stylu na text.

Poznámka:

Pokud převedete odrážky stylu v článku InCopy připojeném k rozvržení aplikace InDesign, provedená změna se může přepsat při aktualizaci obsahu v aplikaci InDesign.

  1. V panelu Odstavcové styly vyberte styl, který obsahuje odrážky nebo číslování.
  2. V nabídce panelu Odstavcové styly zvolte Převést „[styl]“ odrážky a číslování na text.

Pokud převedete odrážky a číslování na text ve stylu, na kterém je založen jiný styl (v rodičovském stylu), převedou se na text také odrážky a číslování v odvozeném stylu.

Když převedete číslování na text, možná budete muset po úpravě textu čísla aktualizovat ručně.

Hledání a nahrazování znakových a odstavcových stylů

Pomocí dialogového okna Hledat a nahradit můžete vyhledat výskyty určitého stylu a nahradit je jiným stylem.

  1. Zvolte Úpravy > Hledat a nahradit.
  2. V poli Prohledat vyberte Dokument, chcete-li změnit styl v celém dokumentu.
  3. Pole Hledat a Změnit na nechte prázdná. Pokud se nezobrazí pole Hledat formát a Změnit formát ve spodní části dialogového okna, klikněte na Více voleb.
  4. Kliknutím do pole Hledat formát zobrazte dialogové okno Najít nastavení formátu. V sekci Volby stylu vyberte znakový nebo odstavcový styl, který chcete hledat, a pak klikněte na OK.
  5. Kliknutím do pole Změnit formát zobrazte dialogové okno Změnit nastavení formátu. V sekci Volby stylu vyberte znakový nebo odstavcový styl, kterým ho chcete nahradit, a pak klikněte na OK.
  6. Klikněte na Hledat a pak styl nahraďte pomocí tlačítek Nahradit, Nahradit a hledat nebo Nahradit vše.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online