Zřetězení textu

  1. Příručka uživatele aplikace InDesign
  2. Seznámení se s aplikací InDesign
    1. Úvod do aplikace InDesign
      1. Co je v aplikaci InDesign nového
      2. Systémové požadavky
      3. Běžné dotazy
      4. Používání knihoven Creative Cloud
    2. Pracovní plocha
      1. Základy práce s pracovní plochou
      2. Panel nástrojů
      3. Nastavení předvoleb
      4. Dotyková pracovní plocha
      5. Výchozí klávesové zkratky
      6. Obnovení dokumentu a vrácení akce
      7. Rozšíření Capture
  3. Vytváření a rozložení dokumentů
    1. Dokumenty a stránky
      1. Vytváření dokumentů
      2. Práce se vzorovými stránkami
      3. Práce se stránkami dokumentu
      4. Nastavení velikosti stránky, okrajů a spadávky
      5. Práce se soubory a šablonami
      6. Vytváření souborů knih
      7. Přidání základního číslování stran
      8. Číslování stránek, kapitol a oddílů
      9. Převod dokumentů QuarkXPress a PageMaker
      10. Sdílení obsahu
      11. Základy práce se spravovanými soubory
      12. Ukládání dokumentů
    2. Mřížky
      1. Mřížky
      2. Formátování mřížek
    3. Pomůcky k rozvržení
      1. Pravítka
  4. Přidání obsahu
    1. Text
      1. Přidání textu do rámečků
      2. Zřetězení textu
      3. Arabské a hebrejské funkce v aplikaci InDesign
      4. Vytvoření textu na cestě
      5. Odrážky a číslování
      6. Glyfy a speciální znaky
      7. Sazba textu
      8. Textové proměnné
      9. Vytváření kódů QR
      10. Úpravy textu
      11. Zarovnání textu
      12. Obtékání textu kolem objektů
      13. Ukotvené objekty
      14. Připojený obsah
      15. Formátování odstavců
      16. Formátování znaků
      17. Hledání a nahrazování
      18. Kontrola pravopisu a jazykové slovníky
    2. Typografie
      1. Používání písem v aplikaci InDesign
      2. Vyrovnání párů a prostrkání
    3. Formátování textu
      1. Formátování textu
      2. Tabulátory a odsazení
    4. Kontrola textu
      1. Sledování a posouzení změn
      2. Přidání redakčních poznámek v aplikaci InDesign
      3. Import poznámek souboru PDF
    5. Přidání odkazů
      1. Vytváření tabulky obsahu
      2. Poznámky pod čarou
      3. Vytvoření rejstříku
      4. Poznámky na konci
      5. Popisky
    6. Styly
      1. Odstavcové a znakové styly
      2. Styly objektů
      3. Iniciály a vnořené styly
      4. Práce se styly
      5. Proklad
    7. Tabulky
      1. Formátování tabulek
      2. Vytváření tabulek
      3. Styly tabulek a buněk
      4. Výběr a úpravy tabulek
      5. Tahy a výplně tabulky
    8. Interaktivita
      1. Hypertextové odkazy
      2. Dynamické dokumenty PDF
      3. Záložky
      4. Tlačítka
      5. Formuláře
      6. Animace
      7. Křížové odkazy
      8. Struktura souborů PDF
      9. Přechody stránky
      10. Filmy a zvuky
      11. Formuláře
    9. Grafika
      1. Cesty a tvary
      2. Kreslení nástrojem tužka
      3. Kreslení nástrojem pero
      4. Použití nastavení čar (tahů) 
      5. Složené cesty a tvary
      6. Úpravy cest
      7. Ořezové cesty
      8. Změna vzhledu rohu
      9. Zarovnání a rozmístění objektů
      10. Propojená a vložená grafika
      11. Integrace datových zdrojů AEM
    10. Barvy a průhlednost
      1. Použití barvy
      2. Použití barev z importované grafiky
      3. Práce se vzorky barev
      4. Míchání tiskových barev
      5. Odstíny
      6. Přímé a výtažkové barvy
      7. Prolnutí barev
      8. Přechody
      9. Sloučení průhledné kresby
      10. Použití efektů průhlednosti
  5. Sdílení
    1. Sdílení a spolupráce        
    2. Sdílení kvůli hodnocení
    3. Recenze sdíleného dokumentu aplikace InDesign
    4. Správa zpětné vazby 
  6. Publikování
    1. Export a publikování
      1. Publish Online
      2. Export obsahu do formátu EPUB
      3. Možnosti Adobe PDF
      4. Exportování obsahu do HTML
      5. Export do Adobe PDF
      6. Export do formátu JPEG
      7. Export do formátu HTML
      8. Přehled řešení DPS a AEM Mobile
    2. Tisk
      1. Tisk brožur
      2. Tiskové značky a spadávky
      3. Tisk dokumentů
      4. Tiskové barvy, výtažky a hustota rastru
      5. Přetisk
      6. Vytváření souborů PostScript a EPS
      7. Kontrola souborů před výstupem používaná před předáním souborů
      8. Tisk miniatur a dokumentů nadměrné velikosti
      9. Příprava souborů PDF pro poskytovatele služeb
      10. Příprava tisku barevných výtažků
  7. Rozšíření aplikace InDesign
    1. Automatizace
      1. Sloučení dat
      2. Zásuvné moduly
      3. Rozšíření Capture v aplikaci InDesign
      4. Skriptování
Poznámka:

Spravedlivý jazyk: Od verze InDesign 2022 (verze 17.0) nahrazujeme neinkluzivní jazyk tak, aby ten nový vyjadřoval základní hodnoty inkluzivity ve společnosti Adobe. Jakýkoli odkaz na Master page (vzorovou stránku) je v našich článcích nápovědy pro anglické, dánské, maďarské, španělské, italské, brazilské, portugalské a japonské národní prostředí nahrazen pojmem Parent page (vzorová stránka).

Zřetězení textových rámečků

Text v rámečku může být nezávislý na jiných rámečcích nebo může protékat propojenými rámečky. Aby text přetékal mezi propojenými rámečky (zvanými také textová pole), musíte rámečky nejprve spojit. Propojené rámečky mohou být na stejné stránce nebo dvojstránce nebo na jiné stránce dokumentu. Proces propojení textu mezi rámečky se nazývá zřetězení textu. Tato operace se jinak nazývá navázání textových rámečků nebo navázání textových polí.

Každý textový rámeček má vstupní bod a výstupní bod, které se používají pro jeho propojení s dalšími textovými rámečky. Prázdný vstupní nebo výstupní bod označuje počátek nebo konec článku. Šipka v tomto bodu označuje, že je rámeček propojený s jiným rámečkem. Červený znak plus (+) ve výstupním bodě označuje, že v článku je více textu, ale neexistují další textové rámečky pro jeho umístění. Tento zbývající neviditelný text se nazývá přesahující text.

Zřetězené rámečky

A. Vstupní bod na začátku článku B. Výstupní bod označující zřetězení k dalšímu rámečku C. Zřetězení textu D. Vstupní bod označující zřetězení z předcházejícího rámečku E. Výstupní bod označující přesahující text 

Zvolte Zobrazení > Zobrazovat netištěné > Zobrazovat zřetězení textu, abyste viděli vizuální znázornění zřetězení rámečků. Textové rámečky můžete zřetězit bez ohledu na to, zda obsahují nebo neobsahují text.

Přidání nového rámečku do zřetězení

  1. Pomocí nástroje pro výběr  vyberte textový rámeček a pak klikněte na jeho vstupní nebo výstupní bod. Objeví se ikona načteného textu.

    Kliknutím na vstupní bod přidáte rámeček před vybraný rámeček; kliknutím na výstupní bod přidáte rámeček za vybraný rámeček.

  2. Umístěte ikonu načteného textu  na místo, kde chcete umístit nový textový rámeček, a pak kliknutím nebo tažením vytvořte nový textový rámeček.
Poznámka:

Když je ikona načteného textu aktivní, můžete provádět mnoho operací, například obracet stránky, vytvářet nové stránky a zvětšovat nebo zmenšovat zobrazení. Pokud začnete zřetězovat dva rámečky a pak si to rozmyslíte, můžete zřetězení zrušit kliknutím na libovolný nástroj v paletě nástrojů. Žádný text se neztratí.

Přidání existujícího rámečku do zřetězení

  1. Pomocí nástroje pro výběr vyberte textový rámeček a pak klikněte na jeho vstupní nebo výstupní bod. Objeví se ikona načteného textu.
  2. Umístěte ikonu načteného textu nad rámeček, ke kterému chcete vybraný rámeček připojit. Ikona načteného textu se změní na ikonu zřetězení.
    Přidání existujícího rámečku do zřetězení

  3. Klikněte uvnitř druhého rámečku, abyste ho zřetězili s prvním rámečkem.

Když zřetězíte mřížku rámečku s prostým textovým rámečkem nebo s jinou mřížkou rámečku s odlišným nastavením mřížky, bude textový rámeček zřetězeného rámečku předefinován tak, aby odpovídal nastavením mřížky rámečku, ze které bylo provedeno zřetězení

Poznámka:

Můžete přidat automatické odkazy „pokračování na“ nebo „pokračování z“, které sledují tok zřetězených článků z rámečku do rámečku. (Viz Přidání automatických čísel stránek pro pokračování článku.)

Přidání rámečku do řady zřetězených rámečků

  1. Nástrojem pro výběr klikněte na výstupní bod v místě článku, kam chcete přidat rámeček. Po uvolnění tlačítka myši se objeví ikona načteného textu.
  2. Tažením vytvořte nový rámeček nebo vyberte jiný textový rámeček. InDesign zřetězí rámeček do řady navázaných rámečků, obsahujících článek.
Přidání rámečku do zřetězení (nahoře) a výsledek (dole)

Rozpojení zřetězených textových rámečků

Když zrušíte zřetězení textového rámečku, přerušíte propojení mezi tímto rámečkem a všemi následujícími zřetězenými rámečky. Všechen text, který byl předtím v těchto rámečcích, se změní na přesahující text (žádný text se neztratí). Všechny následující rámečky budou prázdné.

  1. S nástrojem pro výběr proveďte jeden z následujících úkonů:
    • Dvojitým kliknutím na vstupní nebo výstupní bod přerušte propojení mezi rámečky.
    • Klikněte na vstupní nebo výstupní bod, který představuje zřetězení s jiným rámečkem. Například při zřetězení dvou rámečků klikněte na výstupní bod prvního rámečku nebo na vstupní bod druhého rámečku. Umístěte ikonu načteného textu nad předcházející nebo následující rámeček. Zobrazí se ikona zrušení zřetězení . klikněte do rámečku, který chcete odstranit ze zřetězení.
    Odstranění rámečku ze zřetězení

Poznámka:

Chcete-li rozdělit jeden článek na dva články, vyjměte text, který bude patřit do druhého článku, přerušte propojení mezi rámečky a pak vložte text do prvního rámečku druhého článku.

Vyjmutí nebo odstranění zřetězených textových rámečků

Když vyjmete nebo odstraníte textové rámečky, neodstraní se žádný text; text se zachová v řetězci.

Vyjmutí rámečku ze zřetězení

Rámeček můžete vyjmout ze zřetězení a vložit ho jinam. Rámeček se vyjme s kopií textu, ale z původního článku se žádný text neodstraní. Když vyjmete a vložíte řadu zřetězených textových rámečků najednou, zachovají si vložené rámečky propojení mezi sebou, ale ztratí spojení s ostatními rámečky původního článku.

  1. Nástrojem pro výběr vyberte jeden nebo více rámečků (klikněte se stisknutou klávesou Shift, chcete-li vybrat více objektů).
  2. Zvolte Úpravy > Vyjmout. Rámeček zmizí a text v něm obsažený přeteče do následujícího rámečku článku. Když vyjmete poslední rámeček článku, text se uloží do předcházejícího rámečku jako přesahující text.
  3. Pokud chcete použít odpojený rámeček jinde v dokumentu, přejděte na stránku, kde chcete odpojený text přidat, a zvolte Úpravy > Vložit.

Odstranění rámečku ze zřetězení

Když odstraníte textový rámeček, který je částí zřetězení, neztratí se žádný text: buď se změní na přesahující text nebo nateče do následujícího rámečku. Pokud textový rámeček není propojený s žádným jiným rámečkem, odstraní se rámeček i text.

  1. Jedním z následujících úkonů vyberte textový rámeček:
    • Klikněte na rámeček nástrojem pro výběr.
    • Při používání textového nástroje stiskněte klávesu Ctrl (Windows) nebo Command (Mac OS) a pak klikněte na textový rámeček.
  2. Stiskněte klávesu Backspace nebo Delete.

Natékání textu ručně nebo automaticky

Po umístění textu nebo kliknutí na vstupní nebo výstupní bod se ukazatel změní na ikonu načteného textu . Pomocí ikony načteného textu můžete určovat natékání textu na stránky. Podržením modifikační klávesy můžete určit, jak bude text natékat. Ikona načteného textu mění vzhled podle toho, kde je umístěna.

Když umístíte ikonu načteného textu nad textový rámeček, ikona se zobrazí v závorkách . Když umístíte ikonu načteného textu do vzdálenosti přitahování k vodítku nebo k lince mřížky, černý ukazatel se změní na bílý .

Pro natékaní textu můžete použít čtyři metody:

Metoda

Jak funguje

Ruční natékání textu

Přidá pokaždé jeden textový rámeček. Chcete-li pokračovat v natékání textu, musíte ikonu textu znovu naplnit.

Poloautomatické natékání textu , když při kliknutí podržíte stisknutou klávesu Alt (Windows) nebo Option (Mac OS).

Funguje podobně jako ruční natékání textu, ale kurzor se změní na ikonu načteného textu pokaždé, když text dosáhne konce rámečku, dokud není v dokumentu umístěn celý text.

Automatické natékání textu , když při kliknutí podržíte stisknutou klávesu Shift.

Přidává stránky a rámečky, dokud není v dokumentu umístěný celý text.

Automatické natékání na existující stránky , když při kliknutí podržíte stisknuté klávesy Shift+Alt (Windows) nebo Shift+Option (Mac OS).

Veškerý text nateče do dokumentu, podle potřeby jsou přidány rámečky (ale ne stránky). Případný zbývající text bude přesahovat.

Aby bylo možné provést natékání textu v rámečcích, detekuje aplikace InDesign vodorovný nebo svislý typ. Když text natéká pomocí poloautomatického nebo automatického toku, natéká podle typu rámečku a směru nastaveného na panelu Článek. Ikona uživatele vizuálně informuje o směru, kterým bude text natékat.

Natékání textu ručně

  1. Pomocí příkazu Umístit vyberte soubor nebo klikněte na výstupní bod  vybraného textového rámečku.
  2. Proveďte jeden z následujících úkonů:
    • Umístěte ikonu načteného textu kamkoliv do existujícího rámečku nebo cesty a pak klikněte. Text nateče do rámečku a do všech ostatních s ním propojených rámečků. Text začíná vyplňovat rámeček vždy v levém sloupci nahoře, i když kliknete do jiného sloupce.
    • Umístěte ikonu načteného textu do sloupce stránky, chcete-li vytvořit textový rámeček se stejnou šířkou jako má tento sloupec. Horní okraj rámečku se objeví v místě, kde kliknete.
    • Táhněte ikonou načteného textu, chcete-li tažením nastavit šířku a výšku vytvářeného textového rámečku.
  3. Pokud existuje více textu, který chcete umístit, klikněte na výstupní bod rámečku a opakujte kroky 1 a 2, dokud neumístíte celý text.
Poznámka:

Když umístíte text do rámečku, který je zřetězený s jinými rámečky, text automaticky nateče do těchto zřetězených rámečků bez ohledu na zvolenou metodu natékání textu.

Natékání textu poloautomaticky

  1. S ikonou načteného textu klikněte se stisknutou klávesou Alt (Windows) nebo Option (Mac OS) na stránku nebo na rámeček.

Text nateče vždy do jednoho sloupce stejně jako u ručního natékání, ale ikona načteného textu se po každém umístění sloupce automaticky objeví znovu.

Natékání textu automaticky

  1. Se zobrazenou ikonou načteného textu podržte stisknutou klávesu Shift a proveďte jeden z následujících úkonů:
    • Klikněte ikonou načteného textu do sloupce, chcete-li vytvořit rámeček se stejnou šířkou jako má tento sloupec. InDesign vytváří nové textové rámečky a nové stránky dokumentu tak dlouho, než se do dokumentu vloží celý text.
    • klikněte uvnitř textového rámečku, který je založen na základním textovém rámečku. Text automaticky nateče do rámečku na stránce dokumentu a podle potřeby generuje nové stránky s atributy vzorového rámečku. (Viz O vzorech, pořadí překrývání a vrstvách.)

Natékání textu automaticky bez přidávání stránek

  1. Se zobrazenou ikonou načteného textu stiskněte klávesy Shift+Alt (Windows) nebo Shift+Option (Mac OS).

Použití Inteligentního přeformátování textu

Můžete použít funkci Inteligentní přeformátování textu k přidání nebo odebrání stránek při psaní a úpravě textu. Tato funkce je užitečná v případě, kdy používáte aplikaci InDesign jako textový editor a chcete přidat novou stránku automaticky poté, co napíšete více textu, než kolik se ho vejde na aktuální stránku. Může také pomoci předcházet vytváření přesahujícího textu nebo prázdných stránek v situacích, kdy se formátování textu mění kvůli úpravám textu, zobrazení nebo skrytí podmíněného textu nebo provádění jiných změn formátování textu.

Ve výchozím nastavení je funkce Inteligentní přeformátování textu omezena na základní textové rámečky: textové rámečky, které jsou na vzorové stránce. Pokud dokument obsahuje protilehlé stránky, musí levá i pravá vzorová stránka obsahovat základní textové rámečky. Aby funkce Inteligentní přeformátování textu fungovala, musí být základní textové rámečky zřetězené.

Můžete změnit nastavení a povolit přidání nebo odstranění stránek při práci s textovými rámečky, které nejsou založeny na vzorové stránce. Textový rámeček musí být zřetězený s alespoň jedním dalším textovým rámečkem na jiné stránce, aby funkce Inteligentní přeformátování textu fungovala.

Nastavení funkce Inteligentní přeformátování textu se nachází v nabídce předvoleb textu. Tato nastavení se použijí na aktuální dokument. Chcete-li určit výchozí nastavení pro nové dokumenty, zavřete všechny dokumenty a určete nastavení.

  1. Zvolte Úpravy > Předvolby > Text (Windows) nebo InDesign > Předvolby > Text (Mac OS).

  2. Zvolte Inteligentní přeformátování textu.

  3. Zadejte některou z následujících voleb a klikněte na OK.

Přidat stránky na

Tato volba se používá k určení, kde se vytvoří nová stránka. Předpokládejme, že máte třístránkový dokument s textovými rámečky na prvních dvou stránkách a celostránkovou grafiku na třetí stránce. Pokud píšete text na konci druhé stránky, můžete určit, zda se nová stránka přidá před nebo za celostránkovou grafiku na třetí stránce. Zvolte Konec článku, pokud chcete přidat novou stránku za druhou stránku. Zvolte Konec dokumentu, pokud chcete přidat novou stránku za stránku s celostránkovou grafikou.

V dokumentu s více oddíly můžete zvolit Konec oddílu, pokud chcete přidat stránku na konec oddílu.

Omezit na základní textové rámečky

Pokud je tato volba vypnuta, můžete rovněž přidat nebo odebrat stránky při úpravách textových rámečků, které nejsou založeny na vzorové stránce. Aby se zabránilo nechtěnému přeformátování textu, funkce Inteligentní přeformátování textu se použije pouze, pokud textový rámeček, který upravujete, je zřetězený s alespoň jedním dalším textovým rámečkem na jiné stránce.

Poznámka: Při použití funkce Inteligentní přeformátování textu v textových rámečcích, které nejsou založeny na vzorové stránce, se přidají stránky s celostránkovými textovými rámečky s jedním sloupcem, bez ohledu na atributy textového rámečku, se kterým je nový rámeček zřetězen.

Zachovat protilehlé dvojstránky

Tato volba určuje, zda se protilehlé dvojstránky zachovají, pokud bude přeformátován text uprostřed dokumentu. Pokud je tato volba vybrána při přeformátování textu uprostřed dokumentu, přidá se nová dvojstránka. Pokud tato volba není vybrána, přidá se jedna nová stránka a následující stránky budou přemístěny.

Pokud rozvržení obsahuje návrhové elementy specifické pro pravou nebo levou část dvojstránky, tuto volbu zapněte. Pokud jsou levá a pravá stránka zaměnitelné, můžete tuto volbu vypnout. Pokud aktivní dokument neobsahuje protilehlé stránky, nebude tato volba k dispozici.

Odstranit prázdné stránky

Vyberte tuto volbu, pokud se mají odstranit stránky při úpravě textu nebo skrytí podmínky. Stránky se odstraní pouze v případě, že na stránce zůstane již jen prázdný textový rámeček.

Poznámka:

Chcete-li se dozvědět, jak lze s pomocí funkce Inteligentní přeformátování textu používat aplikaci InDesign jako textový editor, vytvořte dokument s vypnutou volbou Protilehlé stránky a s vybranou volbou Základní textový rámeček. V předvolbách textu zapněte Inteligentní přeformátování textu a Odstranit prázdné stránky. Na první stránce přidržte klávesy Ctrl+Shift (Windows) nebo Command+Shift (Mac OS) a potom kliknutím změňte základní textový rámeček. Jakmile napíšete dostatečné množství textu, které vyplní textový rámeček, automaticky se přidá nová stránka a textový rámeček. Pokud odstraníte dostatečné množství textu, stránka se odstraní.

Logo Adobe

Přihlaste se ke svému účtu.