Importér SVG-filer

Sidst opdateret den 30. sep. 2026

Lær, hvordan du importerer SVG-filer som native, redigerbare formlag, der er klar til at animere uden nødvendig konvertering.

Dobbeltklik inde i projektpanelet, eller brug Fil > Importér > Fil til at gennemse og importere SVG-filen.

Note

Den nyeste version af After Effects lader dig importere filen som footage eller en komposition.

Træk og slip den importerede SVG-fil ind i Timeline-panelet.

Vælg laget for at bruge sektionen Lagindhold i panelet Egenskaber til at se SVG'ens struktur.

Egenskaber-panelet er åbent, og under Lagindhold er SVG-indholdet opført.
Brug Egenskaber-panelet til at se SVG-filens indhold og justere deres egenskaber.

Du kan også vælge pilen ved siden af laget for at folde det ud og derefter udvide sektionen Indhold.Du vil se alle de enkelte elementer og deres egenskaber, såsom Sti, Fyld og Transformér.

Laget med SVG-filen er valgt, og Indhold-sektionen er udvidet for at vise dens egenskaber, inklusive Sti, Fyld og Transformér.
Udvid Indhold-sektionen af SVG-laget for at få adgang til og redigere dens egenskaber, inklusive Sti, Fyld og Transformér.

Du kan bruge disse egenskaber til at animere ligesom ethvert andet formlag.For eksempel:

  • Animer Stien for at skabe morphing-effekter
  • Skift fyldfarve over tid for dynamiske overgange
  • Brug Transform-egenskaber til at skalere, rotere eller flytte elementer uafhængigt

Hvis lagene har forløbsfyld og strøg, kan du bruge egenskaberne Skalér og Rotation til at animere forløbet.

Et af lagene med et forløbselement er valgt, og Forløbsfyld 1 er fremhævet.
Brug Forløbsfyld-egenskaberne til at justere forløbet eller animere dem.

Importér SVG-fil som footage eller som en komposition

SVG-import i After Effects tilbyder fleksibel og bedre kontrol over, hvordan SVG-filer importeres i dit projekt.Med den nyeste version kan du, når du importerer en SVG-fil, vælge at bringe den ind som footage eller som en komposition.

Importér som optagelse

Importér som komposition

Importerer SVG'en som et enkelt, kontinuerligt rasteriserbart vektorlag.

Importerer SVG'en som en komposition lavet af redigerbare formlag.

Opretholder en forbindelse til den eksterne SVG-fil.

Hvert element konverteres til sin egen redigerbare form.

Godt til enkeltlags vektorgrafik, når du ikke skal opdele værket i dele.

Godt til redigering af stier, former og detaljer på lagniveau, når du skal animere individuelle elementer.

Du kan kontrollere, hvilken importmetode der anvendes som standard ved import af SVG-filer ved at indstille indstillingen Træk flere filer som under Import-præferencerne.

  • macOS: After Effects > Indstillinger > Import > Træk flere filer som
  • Windows: Rediger > Præferencer > Import > Træk flere filer som
Dialogboksen Præferencer er åben.Under fanen Import er rullemenuen Træk flere filer som åben og tilbyder indstillinger til valg af importmetode.
Indstil standardpræferencen for import af en SVG-fil, og vælg om den skal importeres som optagelse eller som komposition.

Dobbeltklik inde i projekt-panelet eller brug Fil > Import > Fil for at gennemse og importere SVG-filen.

Brug rullemenuen Importér som i dialogboksen Importér fil til at vælge en af følgende:

  • Optagelse
  • Komposition - Bevar lagstørrelser

Vælger du Optagelse, importeres filen som et enkelt fladt lag uden adgang til individuelle elementer, hvilket gør det velegnet til statisk brug eller når der ikke kræves animation.Vælger du Komposition – Bevar lagstørrelser, oprettes en ny komposition, hvor hvert kildelag importeres separat og tilpasses sit faktiske indhold, hvilket gør ankerpunkter renere og transformeringer lettere for animation.

macOS

Dialogboksen Importér fil er åben, og der er indstillinger til at importere filen som optagelse eller som komposition.

Windows

Dialogboksen Importér fil er åben, og der er indstillinger til at importere filen som optagelse eller som komposition.

Vælg følgende indstillinger, hvis relevant:

  • Opret komposition: Opretter en ny komposition ved hjælp af standardindstillinger og placerer automatisk den importerede SVG enten som optagelse eller som komposition med formlag på tidslinjen, hvilket sparer dig for manuelt at oprette en komposition og trække SVG-filen ind i den.
  • Scalable Vector Graphics-sekvens: Importerer flere nummererede SVG-filer og behandler dem som en billede-for-billede vektorbilledsekvens.

Brug sektionen Lagindhold i panelet Egenskaber eller sektionen Indhold for laget på tidslinjen til at se og arbejde med individuelle elementer og deres egenskaber, hvis du har importeret SVG-filen som en komposition. Hvis den er importeret som footage, opfører den sig som et almindeligt lag og kan justeres ved hjælp af de standard transformér-egenskaber.

Som med Illustrator-filer, hvis vektorfilen er importeret som footage, kan du vælge laget på tidslinjen, højreklikke og vælge opret > opret Former og Tekst fra Vektorlag for at konvertere det til redigerbare lag, så du kan animere individuelle stier, strøg og fyldninger. I den seneste After Effects Beta kan tekst i kildefilen konverteres til redigerbare tekstlag, der bevarer skrifttype, størrelse, fyldning, position, stilarter, strøg og indstillinger for Variabel skrifttype. 

Når du importerer en SVG som footage, bevarer After Effects et direkte link til den oprindelige fil, så eventuelle ændringer, du foretager i den SVG uden for appen, opdateres automatisk i dit projekt.

Konvertér Illustrator-tekst til redigerbare tekstlag

Brug nye beta-funktioner

Redigerbar tekst fra Illustrator-filer er nu tilgængelig til test og feedback. Prøv det nu i After Effects (Beta).

I den seneste After Effects beta konverteres enhver tekst i kildefilen til sit eget redigerbare tekstlag i stedet for at blive fladgjort til formkonturer, når et Illustrator-lag importeres som footage.Dette betyder, at skrifttype, størrelse, fyldning, position, stilarter (såsom fed og kursiv), strøg og indstillinger for variabel skrifttype alle bevares, så du kan fortsætte med at redigere teksten direkte i After Effects i stedet for at genskabe den fra bunden eller gå tilbage til Illustrator for at foretage ændringer.

Vælg Fil > Import > Fil og derefter den Illustrator-fil, du vil importere.

I dialogboksen Importér fil skal du sikre dig, at Importér som er indstillet til Footage, når du vælger den fil, der skal importeres.

I importdialogboksen skal du bekræfte, at Importtype er indstillet til Footage og vælge Lagindstillinger baseret på, hvad du vil importere fra Illustrator-filen.

Træk den importerede fil til panelet Tidslinje.

Højreklik på Illustrator-laget og vælg Opret > Opret former og tekst fra vektorlag, eller brug Lag > Opret > Opret former og tekst fra vektorlag.

Lag > opret undermenu med opret Former og Tekst fra Vektorlag fremhævet, konvertering af vektortekst til redigerbare tekstlag.
Vælg Opret former og tekst fra vektorlag for at konvertere Illustrator-tekst til redigerbare After Effects-tekstlag i stedet for former.

Teksten konverteres til et redigerbart tekstlag, der nøje matcher skrifttype, størrelse, udfyldning og position i den oprindelige fil.Du kan derefter redigere og justere teksten direkte i After Effects.

Lysstyrke tekstlag over en flammegrafik med Tegnpanel, der viser skrifttypen Adobe Clean Italic, størrelse 74px og Fyld aktiveret.
Efter konvertering forbliver teksten fuldt redigerbar — skrifttype, stil, størrelse og fyld kan stadig ændres i Tegnpanelet.

Note

Tekst, der kun har strøg, konverteres stadig som stier i stedet for et redigerbart tekstlag. 

Ikke-tekst vektorindhold konverteres stadig til formlag som før, og hvis Illustrator-filen indeholder begge dele, får du en blanding af tekst- og formlag.

Deltag i samtalen i vores After Effects (Beta) community om understøttelse af redigerbar tekst fra Illustrator-filer.

Kopiér og indsæt Illustrator- og SVG-indhold

SVG-indhold i udklipsholderen kan nu indsættes i After Effects ved hjælp af Rediger > Indsæt. Indholdet importeres som oprindelige, redigerbare formlag, der er klar til at animere, uden at der kræves et mellemliggende importtrin.

Kopiér indhold fra Illustrator

Åbn dit kunstværk i Adobe Illustrator.

Bekræft, at Inkludér SVG-kode indstillingen er valgt.

  • macOS: Vælg Illustrator > Indstillinger > Udklipsholderhåndtering og vælg Inkludér SVG-kode.
  • Windows: Vælg Rediger > Indstillinger > Udklipsholderhåndtering og vælg Inkludér SVG-kode.
Dialogboksen Indstillinger er åben i Illustrator, og funktionen Inkludér SVG-kode er valgt.
Aktivér Inkludér SVG-kode for at holde dit kunstværk redigerbart og i høj kvalitet i andre Adobe-apps.

Vælg det kunstværk, du vil kopiere.

Tip

Konvertér enhver SVG-tekst til kurver før kopiering, da SVG-tekst ikke understøttes ved indsættelse.

Vælg Rediger > Kopiér.

Skift til After Effects og gør et af følgende afhængigt af din projekttilstand:

  • Hvis intet projekt er åbent, skal du vælge Rediger > Indsæt for at oprette et nyt projekt med en komposition, der indeholder SVG-indholdet som et formlag.
  • Hvis et projekt er åbent, men ingen komposition er valgt, skal du vælge Rediger > Indsæt for at oprette en ny komposition i det aktuelle projekt, der indeholder det indsatte indhold.
Funktionen Rediger > Indsæt er valgt, og indholdet importeres som oprindelige, redigerbare formlag, der er klar til at animere.
Rediger > Indsæt henter indhold som redigerbare formlag, klar til animation.

Hvis en komposition er valgt i After Effects, skal du vælge Rediger > Indsæt for at tilføje SVG-indholdet som et nyt formlag i denne komposition.

Indsæt SVG fra andre apps

SVG-indhold kopieret fra enhver app, der skriver SVG til systemets udklipsholder, kan indsættes ved hjælp af det samme Rediger > Indsæt arbejdsforløb. Understøttelse afhænger af, om kildeappen placerer gyldige SVG-data i udklipsholderen.