Importación de imágenes en Flash

Adobe Flash Professional puede utilizar ilustraciones creadas en otras aplicaciones. Puede importar gráficos vectoriales y mapas de bits en una gran variedad de formatos de archivo. Si tiene QuickTime® o posterior instalado en su sistema, podrá importar formatos de archivo vectoriales o de mapa de bits adicionales. Se pueden importar archivos de Adobe® FreeHand® (versión MX y anteriores) y archivos PNG de Adobe® Fireworks® directamente en Flash Professional conservando los atributos de dichos formatos.

El tamaño de los archivos gráficos que se importan a Flash Professional debe ser al menos de 2 píxeles por 2 píxeles.

Para cargar archivos JPEG en un archivo SWF de Flash Professional durante el tiempo de ejecución, utilice la acción o el método loadMovie. Para obtener información detallada, consulte loadMovie (método MovieClip.loadMovie) en la Referencia del lenguaje ActionScript 2.0 o Trabajo con clips de película en la Guía del desarrollador de ActionScript 3.0.

Flash Professional importa gráficos vectoriales, mapas de bits y secuencias de imágenes tal como se describe a continuación:

  • Cuando se importan archivos de Adobe® Illustrator® y Adobe® Photoshop® en Flash Professional, se pueden especificar opciones de importación que permitan conservar la mayoría de los datos visuales de la ilustración, así como la editabilidad de ciertos atributos visuales en el entorno de edición de Flash Professional.

  • Al importar imágenes vectoriales a Flash Professional desde FreeHand, puede seleccionar opciones para conservar las capas, páginas y bloques de texto de FreeHand.

  • Al importar imágenes PNG desde Fireworks, importe los archivos como objetos editables que se pueden modificar en Flash Professional o como archivos alisados que se pueden editar y actualizar en Fireworks.

  • Seleccione opciones para conservar imágenes, texto y guías.

    nota: si importa un archivo PNG desde Fireworks cortando y pegando, el archivo se convertirá en un mapa de bits.

  • Las imágenes vectoriales de los archivos SWF y WMF (Windows® Metafile Format, formato de metarchivo de Windows) que importa directamente a un documento de Flash Professional (en lugar de una biblioteca) se importan como un grupo de la capa activa.

  • Los mapas de bits (fotografías digitalizadas, archivos BMP) que importa directamente a un documento de Flash Professional se importan como objetos individuales de la capa activa. Flash Professional mantiene la configuración de transparencia de los mapas de bits importados. Puesto que importar un mapa de bits puede aumentar el tamaño del archivo SWF, es recomendable comprimir los mapas de bits importados.

    nota: es posible que no se conserve la transparencia de los mapas de bits cuando se importan mediante el método de arrastrar y soltar desde una aplicación o escritorio a Flash Professional. Para conservar la transparencia, utilice para importar el comando Archivo > Importar a escenario o Importar a biblioteca.

  • Las secuencias de imágenes (por ejemplo, una secuencia PICT o BMP) importadas directamente a un documento de Flash Professional se importan como fotogramas clave sucesivos de la capa activa.

Formatos de archivo admitidos para importación

Nota:

Para obtener una lista completa de todos los formatos de archivo que Flash permite importar, exportar y editar, consulte la nota técnica Formatos de archivo compatibles

Formatos gráficos

Flash Professional puede importar distintos formatos de archivo de mapa de bits o vectoriales, según si tiene QuickTime 4 o posterior instalado en el sistema. La utilización de Flash Professional con QuickTime 4 es especialmente útil en los proyectos de colaboración en los que los editores trabajan en plataformas Windows y Macintosh. QuickTime 4 amplía la compatibilidad con ciertos formatos de archivos (incluidos PICT, película QuickTime y otros) para ambas plataformas.

Se pueden importar los siguientes formatos de archivo de mapa de bits o vectoriales a Flash Professional 8 y versiones posteriores, independientemente de si tiene QuickTime 4 instalado:

Tipo de archivo

Extensión

Windows

Macintosh

Adobe Illustrator (versión 10 o anterior)

.ai

Adobe Photoshop

.psd

DXF de AutoCAD®

.dxf

Mapa de bits

.bmp

Metarchivo mejorado de Windows

.emf

Reproductor FutureSplash

.spl

GIF y GIF animado

.gif

JPEG

.jpg

PNG

.png

Flash Player 6/7

.swf

Metarchivo de Windows

.wmf

Archivo gráfico XML de Adobe

.fxg

Los siguientes formatos de archivo de mapa de bits solamente se pueden importar a Flash Professional si está instalado QuickTime 4 o una versión posterior:

Tipo de archivo

Extensión

Windows

Macintosh

Imagen de QuickTime

.qtif

TIFF

.tif

Formatos de sonido

Flash puede importar los siguientes formatos de audio:

Tipo de archivo

Extensión

Windows

Macintosh

Adobe Soundbooth

.asnd

Onda

.wav

Formato de archivo de intercambio de audio

.aiff

MP3

.mp3

Flash puede importar los siguientes formatos de audio únicamente si está instalado QuickTime 4 o posterior:

Tipo de archivo

Extensión

Windows

Macintosh

Formato de archivo de intercambio de audio

.aiff

Sound Designer II

.sd2

Películas de QuickTime sólo con sonido

.mov, .qt

Sun AU

.au

Sonidos de System 7

.snd

Onda

.wav

Formatos de vídeo

Flash puede importar los siguientes formatos de vídeo:

Tipo de archivo

Extensión

Windows

Macintosh

Vídeo de Adobe Flash

.flv, .f4v

Película QuickTime

.mov, .qt

Video para Windows

.avi

MPEG

.mpg, .m1v, .m2p, .m2t, .m2ts, .mts, .tod, .mpe, .mpeg

MPEG-4

.mp4, .m4v, .avc

Vídeo digital

.dv, .dvi

3GPP/3GPP2 para dispositivos móviles

.3gp, .3gpp, .3gp2, .3gpp2, .3p2

Importación de ilustraciones en Flash

Flash Professional permite importar ilustraciones en varios formatos de archivo, directamente al escenario o a la biblioteca.

Importación de un archivo a Flash

  1. Realice uno de los siguientes pasos:
    • Para importar un archivo directamente al documento de Flash Professional actual, seleccione Archivo > Importar > Importar a escenario.

    • Para importar un archivo a la biblioteca del documento de Flash Professional actual, seleccione Archivo > Importar > Importar a biblioteca. Para utilizar un elemento de la biblioteca en un documento, arrástrelo hasta el escenario. ).

  2. Seleccione un formato de archivo en el menú emergente Tipo de archivo (Windows) o Mostrar (Macintosh).
  3. Busque el archivo deseado y selecciónelo. Si un archivo importado tiene varias capas, Flash Professional puede crear nuevas capas (según el tipo de archivo importado). Las nuevas capas aparecen en la línea de tiempo.
  4. Haga clic en Abrir.
  5. Si el nombre del archivo que va a importar acaba con un número y existen archivos adicionales numerados secuencialmente en la misma carpeta, siga uno de los siguientes procedimientos:

    Nota: (Sólo Windows 8) si un archivo PSD con texto se importa con la opción Contornos vectoriales seleccionada, no es posible editar los puntos de ancla del objeto vectorial. Esto se observa con archivos PSD creados con fuentes no disponibles en Windows 8.

    • Haga clic en Sí para importar todos los archivos de la secuencia.

    • Haga clic en No para importar sólo el archivo especificado.

      A continuación se muestran ejemplos de nombres de archivos que pueden utilizarse como secuencias:

      Foto001.gif, Foto002.gif, Foto003.gif

      Pájaro 1, Pájaro 2, Pájaro 3

      Mar-001.ai, Mar-002.ai, Mar-003.ai

Cómo pegar un mapa de bits de otra aplicación directamente en el documento de Flash activo

  1. Copie la imagen en la otra aplicación.
  2. En Flash Professional, seleccione Edición > Pegar en el centro.

Importación de archivos FXG

El formato FXG permite a Flash intercambiar gráficos con otras aplicaciones de Adobe como Adobe Illustrator, Fireworks y Photoshop y conservar toda la compleja información gráfica. Flash permite importar archivos FXG (sólo versión 2.0) y guardar las selecciones de objetos del escenario o todo el escenario en formato FXG. Para obtener más información sobre los archivos FXG, consulte Archivos FXG.

  • Para importar un archivo FXG, elija Archivo > Importar > Importar a escenario o Importar a biblioteca y seleccione el archivo FXG que quiera abrir.

Archivos DFX de AutoCAD

Flash Professional acepta el formato DXF de AutoCAD® en AutoCAD 10.

Los archivos DXF no admiten las fuentes estándar del sistema. Flash Professional intenta realizar una asignación correcta de las fuentes pero el resultado es impredecible, en particular en la alineación del texto.

Las áreas rellenas se exportan como contornos, ya que el formato DXF no admite rellenos sólidos. Por ello, es más apropiado para dibujos lineales tales como planos de planta y mapas.

Flash Professional permite la importación de archivos DXF bidimensionales, pero no admite archivos DXF tridimensionales.

Aunque no es posible cambiar la escala de los archivos DXF en Flash Professional, todos los archivos DXF importados producen archivos de 12 por 12 pulgadas que puede cambiar con el comando Modificar > Transformar > Escala. Flash Professional solo admite archivos DXF ASCII. Si utiliza archivos DXF binarios, conviértalos a ASCII antes de importarlos a Flash Professional.

Carga de ilustraciones con ActionScript

Con ActionScript, se pueden cargar activos o archivos de imagen externos de la Biblioteca en tiempo de ejecución.

Para obtener información sobre el trabajo con imágenes y activos en ActionScript, consulte el siguiente artículo:

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea