關於將圖案匯入 Flash

Adobe Flash Professional 可以使用在其他應用程式中建立的圖案。您可以匯入各種檔案格式的向量圖像和點陣圖。如果系統上安裝了 QuickTime® 4 或更新版本,您還能匯入其他的向量或點陣圖檔案格式。您可以將 Adobe® FreeHand® 檔案 (MX 版或更早的版本) 和 Adobe® Fireworks® PNG 檔案直接匯入 Flash Professional,以保留這些格式的特質。

匯入 Flash Professional 的圖像檔案大小最少必須具有 2 x 2 像素。

若要在執行階段將 JPEG 檔案載入 Flash Professional SWF 檔案,請使用 loadMovie 動作或方法。如需詳細資訊,請參閱 ActionScript 2.0 語言參考中的 loadMovie (MovieClip.loadMovie 方法),或 ActionScript 3.0 開發人員指南中的使用影片片段

Flash Professional 匯入向量圖像、點陣圖和連續影像的方式如下:

  • 當您將 Adobe® Illustrator® 和 Adobe® Photoshop® 檔案匯入 Flash Professional 時,可以指定匯入選項,以便保留大部分圖案的視覺資料,以及使用 Flash Professional 編寫環境時維持特定視覺特質的可編輯性。

  • 從 FreeHand 將向量影像匯入 Flash Professional 時,您可以透過選取某些選項,以保留 FreeHand 的圖層、頁面和文字區塊。

  • 當您從 Fireworks 匯入 PNG 影像時,請將檔案匯入成可編輯的物件 (以便在 Flash Professional 中修改),或匯入成平面化檔案 (以便在 Fireworks 中編輯和更新)。

  • 您可以透過選取某些選項,以保留影像、文字和導引線。

    注意:如果您用剪下和貼上的方式從 Fireworks 匯入 PNG 檔案,該檔案會被轉換成點陣圖。

  • 將 SWF 和 Windows® 中繼檔格式 (WMF) 檔案直接匯入 Flash Professional 文件 (而非匯入元件庫) 所產生的向量影像,會匯入成目前圖層中的群組。

  • 直接匯入 Flash Professional 文件的點陣圖 (掃描的相片、BMP 檔案),會匯入成目前圖層中的單一物件。Flash Professional 會保留匯入之點陣圖的透明度設定。因為匯入點陣圖可能會增加 SWF 檔的檔案大小,所以請考慮壓縮匯入的點陣圖。

    注意:用拖放方式將點陣圖從應用程式或桌面匯入 Flash Professional 時,可能不會保留點陣圖的透明度。若要保留透明度,請使用「檔案 > 匯入至舞台」或「匯入至元件庫」命令來進行匯入。

  • 直接匯入 Flash Professional 文件的連續影像 (例如,PICT 或 BMP 序列),會匯入成目前圖層的連續關鍵影格。

支援的匯入檔案格式

註解:

如需 Flash 支援的匯入、匯出或編輯的檔案格式完整清單,請參閱支援的檔案格式 TechNote。

圖像格式

依據您的系統上是否已安裝了 QuickTime 4 或更新版本,Flash Professional 可以匯入不同的向量或點陣圖檔案格式。當作者同時在 Windows 和 Macintosh 平台上作業時,這種共同作業專案特別適合安裝了 QuickTime 4 的 Flash Professional。QuickTime 4 會擴充這兩種平台對於某些檔案格式 (包括 PICT、QuickTime 影片及其他格式) 的支援。

不管是否已安裝 QuickTime 4,您都可以將下列向量或點陣圖檔案格式匯入 Flash Professional 8 或更新版本:

檔案類型

副檔名

Windows

Macintosh

Adobe Illustrator (第 10 版或更早的版本)

.ai

Adobe Photoshop

.psd

AutoCAD® DXF

.dxf

點陣圖

.bmp

加強型 Windows 中繼檔

.emf

FutureSplash Player

.spl

GIF 和 GIF 動畫

.gif

JPEG

.jpg

PNG

.png

Flash Player 6/7

.swf

Windows 中繼檔

.wmf

Adobe XML 圖像檔案

.fxg

只有在已安裝 QuickTime 4 或更新版本時,您才可以將下列點陣圖檔案格式匯入 Flash Professional 中:

檔案類型

副檔名

Windows

Macintosh

QuickTime 影像

.qtif

TIFF

.tif

聲音格式

Flash 可匯入下列音效格式:

檔案類型

副檔名

Windows

Macintosh

Adobe Soundbooth

.asnd

波浪

.wav

音效交換檔案格式

.aiff

MP3

.mp3

只有在已安裝 QuickTime 4 或更新版本時,Flash 才能匯入下列音效格式:

檔案類型

副檔名

Windows

Macintosh

音效交換檔案格式

.aiff

Sound Designer II

.sd2

只有聲音的 QuickTime 影片

.mov, .qt

Sun AU

.au

System 7 聲音

.snd

波浪

.wav

視訊格式

Flash 可匯入下列視訊格式:

檔案類型

副檔名

Windows

Macintosh

Adobe Flash 視訊

.flv, .f4v

QuickTime 影片

.mov, .qt

Windows 視訊

.avi

MPEG

.mpg, .m1v, .m2p, .m2t, .m2ts, .mts, .tod, .mpe, .mpeg

MPEG-4

.mp4, .m4v, .avc

數位視訊

.dv, .dvi

行動裝置適用的 3GPP/3GPP2

.3gp, .3gpp, .3gp2, .3gpp2, .3p2

將圖案匯入 Flash

Flash Professional 可讓您將各種檔案格式的圖案直接匯入「舞台」或匯入元件庫。

將檔案匯入 Flash

  1. 請執行下列其中一項:
    • 若要將檔案直接匯入目前的 Flash Professional 文件中,請選取「檔案 > 匯入 > 匯入至舞台」。

    • 若要將檔案匯入目前 Flash Professional 文件的元件庫中,請選取「檔案 > 匯入 > 匯入至元件庫」。(若要在文件中使用元件庫項目,請將它拖曳到「舞台」上)

  2. 從「檔案類型」(Windows) 或「顯示」(Macintosh) 彈出式選單中選取檔案格式。
  3. 瀏覽至您想要的檔案,然後選取該檔案。如果匯入的檔案具有多個圖層,Flash Professional 可能會建立新的圖層 (依據匯入檔案的類型而定)。任何新的圖層都會顯示在「時間軸」中。
  4. 按一下「開啟」。
  5. 如果匯入的檔案名稱以數字結尾,而相同的資料夾中還有其他連續編號的檔案,請執行下列其中一項動作:

    注意:(僅適用於 Windows 8) 如果匯入包含文字的 PSD 檔案時選取了「向量外框」,您就無法編輯向量物件的錨點。這種情況會出現在使用 Windows 8 未提供之字體所建立的 PSD 檔案中。

    • 若要匯入所有連續的檔案,請按一下「是」。

    • 若只要匯入指定的檔案,請按一下「否」。

      下面是可用來做為序列的檔案名稱範例:

      Frame001.gif、Frame002.gif、Frame003.gif

      Bird 1、Bird 2、Bird 3

      Walk-001.ai、Walk-002.ai、Walk-003.ai

您可以從另一個應用程式將點陣圖直接貼入目前的 Flash 文件中

  1. 複製其他應用程式中的影像。
  2. 在 Flash Professional 中,選取「編輯 > 在中央貼上」。

匯入 FXG 檔案

FXG 格式允許 Flash 與 Adobe Illustrator、Fireworks 及 Photoshop 等其他 Adobe 應用程式交換圖像,並且保留所有複雜的圖像資訊。Flash 可讓您匯入 FXG 檔案 (僅 2.0 版),並以 FXG 格式儲存「舞台」上的選取物件或是整個舞台。如需 FXG 檔案的詳細資訊,請參閱關於 FXG 檔案

  • 若要匯入 FXG 檔案,請選擇「檔案 > 匯入 > 匯入至舞台 (或匯入至元件庫)」,然後選取您要開啟的 FXG 檔案。

關於 AutoCAD DXF 檔案

Flash Professional 支援 AutoCAD 10 中的 AutoCAD® DXF 格式。

DXF 檔案不支援標準系統字體。Flash Professional 會嘗試正確地對應字體,但無法預期結果,特別是文字對齊的問題。

由於 DXF 格式不支援基本色填色,所以填色區域只能匯出為外框。因此,DXF 格式最適合用於線段繪圖,例如樓面配置和地圖。

您可以將二維 DXF 檔案匯入 Flash Professional 中。Flash Professional 不支援三維 DXF 檔案。

雖然 Flash Professional 不支援 DXF 檔案中的縮放功能,但是所有匯入的 DXF 檔案仍會產生 12 英吋 x 12 英吋的檔案,讓您可以藉由「修改 > 變形 > 縮放」進行縮放。此外,Flash Professional 僅支援 ASCII DXF 檔案。如果您的 DXF 檔案為二進位,請先將它們轉換成 ASCII,然後再匯入 Flash Professional。

使用 ActionScript 載入圖案

您可以利用 ActionScript,在執行階段載入外部影像檔案或元件庫資源。

如需在 ActionScript 中使用影像與資源的資訊,請參閱下列文章:

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策