使用 Dreamweaver 下載和上傳伺服器檔案,以及管理檔案傳輸

如果在共同作業的環境中工作,請使用「存回/取出」系統在本機和遠端網站之間傳送檔案。不過,如果您是唯一在遠端網站上工作的人,則可以使用「下載」和「上傳」命令傳送檔案,而不需存回或取出它們。

如需有關存回和取出檔案的詳細資訊,請參閱「存回和取出檔案」。

使用「檔案」面板在本機與遠端資料夾之間傳送文件時,您可以選擇傳送文件相關檔案。相關檔案是指文件會參考到的影像、外部樣式表以及其他檔案,當瀏覽器載入文件時也會載入這些檔案。

註解:

取出新檔案時最好一併下載相關檔案,但是當本機磁碟上已經有相關檔案的最新版本時,就沒有必要再下載了。這個情況同時適用在上傳與存回檔案上:如果最新的檔案副本都已經位於遠端網站上,就沒必要這麼做。

圖庫項目也視為相關檔案。

當您上傳圖庫項目時,有些伺服器會報告發生錯誤。不過,您可以遮罩這些檔案,這樣就不會傳送這些檔案。

關於背景檔案傳輸

您可以在下載或上傳檔案期間執行其他和伺服器無關的活動。背景檔案傳輸適用於 Dreamweaver 支援的所有傳輸通訊協定:FTP、SFTP、LAN、WebDAV、 和 RDS。

和伺服器無關的活動包括一般作業,例如鍵入文字、編輯外部樣式表、產生全站台的報告以及建立新的網站。

Dreamweaver 無法在進行檔案傳輸時,執行某些與伺服器相關的活動,這些活動包括:

  • 上傳/下載/存回/取出檔案

  • 還原取出

  • 建立資料庫連線

  • 繫結動態資料

  • 在「即時檢視」中預覽資料

  • 插入網路服務

  • 刪除遠端檔案或資料夾

  • 在測試伺服器的瀏覽器中預覽

  • 將檔案儲存到遠端伺服器

  • 插入來自遠端伺服器的影像

  • 開啟遠端伺服器的檔案

  • 儲存時自動上傳檔案

  • 將檔案拖曳到遠端網站

  • 在遠端網站上執行剪下、複製或貼上檔案的動作

  • 重新整理「遠端」檢視

預設情況下,在檔案傳輸期間會開啟「背景檔案活動」對話方塊。您可以按一下右上角的「最小化」按鈕,將這個對話方塊最小化。若在檔案傳輸期間關閉對話方塊,將導致取消作業。

從遠端伺服器取得檔案

您可以透過下列其中一種方式,從遠端網站將檔案複製到本機網站︰

在進行傳送時,Dreamweaver 會建立檔案活動的記錄檔,可供您檢視和儲存。

註解:

您無法關閉背景檔案傳輸功能。如果您在「背景檔案活動」對話方塊中打開了詳細資料記錄,可以將其關閉以提升效能。

Dreamweaver 也會記錄所有 FTP 檔案的傳送活動。如果使用 FTP 傳送檔案時發生錯誤,網站 FTP 記錄可以協助您判斷問題出在哪裡。

使用檔案面板從遠端伺服器取得檔案

  1. 在「檔案」面板 (「視窗 > 檔案」) 中,選取您想要下載的檔案。

    通常是在「遠端」檢視中選取這些檔案,不過如果您願意,也可以在「本機」檢視中選取對應的檔案。如果「遠端」檢視是作用中,Dreamweaver 則會將選取的檔案複製到本機網站;如果「本機」檢視是作用中,Dreamweaver 則會將所選本機檔案的遠端版本複製到本機網站。

    註解:

    如果只要下載遠端版本比本機版本新的檔案,請使用「同步化」選項。

  2. 請執行下列其中一項作業以下載檔案:
    • 按一下「檔案」面板工具列中的「下載」按鈕。

    • 在「檔案」面板中,以右鍵按一下 (Windows) 或 Control+ 按一下 (Macintosh) 檔案,然後從快顯選單選取「下載」。

  3. 在「相關檔案」對話方塊中按一下「是」下載「相關檔案」;如果您已經有相關檔案的本機複本,請按「否」。預設為不要下載相關檔案。您可以在「編輯 > 偏好設定 > 網站」中設定這個選項。

    Dreamweaver 會下載選取的檔案,如下所示:

    • 如果您要使用「存回/取出」系統,下載檔案將會取得檔案的唯讀本機複本;遠端網站或測試伺服器上的檔案仍然可供其他小組成員取出。

    • 如果您不使用「存回/取出」系統,下載檔案將會產生同時具有「讀取和寫入」權限的複本。

    註解:

    如果您是在共同作業的環境中工作 (也就是說,其他人也在同樣的檔案上工作),您就不可以關閉「啟動檔案存回和取出」。如果其他人要對網站使用「存回/取出」系統,那麼您也應該使用這個系統。

    任何時候若要停止檔案傳輸,請按一下「背景檔案活動」對話方塊中的「取消」按鈕。 

使用文件視窗從遠端伺服器取得檔案

  1. 請確定文件在「文件」視窗中為作用中。
  2. 請執行下列其中一項作業以下載檔案:
    • 選取「網站>下載」。

    • 按一下「文件」視窗工具列中的「檔案管理」圖示,然後從選單選取「下載」。

    註解:

    如果目前的檔案不屬於「檔案」面板中目前的網站,Dreamweaver 會嘗試判斷目前的檔案屬於哪一個本機定義的網站。如果目前的檔案只屬於某一個本機網站,Dreamweaver 便會開啟該網站,然後執行下載作業。

顯示 FTP 記錄

  1. 按一下「檔案」面板右上角的「選項」選單。
  2. 選取「檢視網站的 FTP 記錄」。

註解:

在展開的「檔案」面板中,按一下「FTP 記錄」按鈕就可以顯示記錄。

上傳檔案到遠端伺服器

您可以從本機網站將檔案上傳到遠端網站,通常不會變更檔案的已取出狀態。

在下列兩種常見的情況下,您應該使用「上傳」命令而不要使用「存回」:

  • 您不是在共同作業的環境中工作,而且也沒有使用「存回/取出」系統。
  • 您想要將檔案的目前版本上傳到伺服器,但是還會持續編輯它。

註解:

如果您上傳遠端網站先前沒有的檔案,而且使用了「存回/取出」系統,這個檔案會複製到遠端網站,然後再取出給您,讓您能夠繼續進行編輯。

您可以使用「檔案」面板或「文件」視窗來上傳檔案。在進行傳送時,Dreamweaver 會建立檔案活動的記錄檔,可供您檢視和儲存。

註解:

您無法關閉背景檔案傳輸功能。如果您在「背景檔案活動」對話方塊中打開了詳細資料記錄,可以將其關閉以提升效能。 

Dreamweaver 也會記錄所有 FTP 檔案的傳送活動。如果使用 FTP 傳送檔案時發生錯誤,網站 FTP 記錄可以協助您判斷問題出在哪裡。

如需在遠端伺服器中上傳檔案的教學課程,請參閱 www.adobe.com/go/vid0163_tw

如需疑難排解發佈問題的教學課程,請參閱 www.adobe.com/go/vid0164_tw

使用檔案面板上傳檔案到遠端或測試伺服器

  1. 在「檔案」面板 (「視窗>檔案」) 中,選取要上傳的檔案。

    通常是在「本機」檢視中選取這些檔案,不過如果您願意,也可以在「遠端」檢視中選取對應的檔案。

    註解:

    您可以只上傳本機版本比遠端版本新的檔案。

  2. 請執行下列其中一項作業,將檔案上傳到遠端伺服器:
    • 按一下「檔案」面板工具列中的「上傳」按鈕。

    • 在「檔案」面板中,以右鍵按一下 (Windows) 或 Control+按一下 (Macintosh) 檔案,然後從快顯選單選取「上傳」。

  3. 如果檔案還沒有儲存,便會出現對話方塊 (如果您已在「偏好設定」對話方塊的「網站」類別中設定這個偏好設定),讓您在上傳檔案到遠端伺服器之前先儲存檔案。按一下「是」儲存檔案,或按「否」上傳先前儲存的版本到遠端伺服器。

    註解:

    如果不儲存檔案,則您在上次儲存後所進行的任何變更都不會上傳至遠端伺服器。但是,這個檔案會保持開啟,讓您將檔案上傳到伺服器之後仍然能儲存變更 (如果您要的話)。

  4. 按一下「是」,將相關檔案與選取的檔案一起上傳;或按一下「否」,不要上傳相關檔案。預設為不要上傳相關檔案。您可以在「編輯 > 偏好設定 > 網站」中設定這個選項。

    註解:

    存回新檔案時,最好一併上傳相關檔案,但是當遠端伺服器上已經有相關檔案的最新版本時,就沒有必要再上傳了。

    任何時候若要停止檔案傳輸,請按一下「背景檔案活動」對話方塊中的「取消」按鈕。

使用文件視窗將檔案上傳至遠端伺服器

  1. 請確定文件在「文件」視窗中為作用中。
  2. 請執行下列其中一項作業以上傳檔案:
    • 選取「網站>上傳」。

    • 按一下「文件」視窗工具列中的「檔案管理」圖示,然後從選單選取「上傳」。

    註解:

    如果目前的檔案不屬於「檔案」面板中目前的網站,Dreamweaver 會嘗試判斷目前的檔案屬於哪一個本機定義的網站。如果目前的檔案只屬於某一個本機網站,Dreamweaver 便會開啟該網站,然後執行上傳作業。

顯示 FTP 記錄

  1. 按一下「檔案」面板右上角的「選項」選單。
  2. 選取「檢視網站的 FTP 記錄」。

註解:

在展開的「檔案」面板中,按一下「FTP 記錄」按鈕就可以顯示記錄。

管理檔案傳輸

您可以檢視檔案傳輸作業的狀態,以及已傳輸檔案的清單與傳輸結果 (傳輸成功、略過或失敗), 也可以儲存這類檔案活動的記錄。

註解:

Dreamweaver 可以讓您在與某個伺服器進行檔案傳輸的時候,執行其他和伺服器無關的活動。

取消檔案傳輸

  1. 按一下「背景檔案活動」對話方塊中的「取消」按鈕。如果目前未顯示該對話方塊,請按一下「檔案」面板下方的「檔案活動」按鈕。

在檔案傳輸時顯示背景檔案活動對話方塊

按一下「檔案」面板下方的「檔案活動」或「記錄」按鈕。

檢視上次檔案傳送的詳細資料

  1. 按一下「檔案」面版底部的「記錄」按鈕,開啟「背景檔案活動」對話方塊。
  2. 按一下「詳細資料」的展開箭頭。

儲存上次檔案傳送的記錄

  1. 按一下「檔案」面版底部的「記錄」按鈕,開啟「背景檔案活動」對話方塊。
  2. 按一下「儲存記錄」按鈕,將資訊儲存為文字檔。

    您可以使用 Dreamweaver 或任何文字編輯器開啟此記錄檔,檢視檔案活動。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策