Puoi registrare e acquisire la tua interpretazione per poterla applicare ai pupazzi di una scena. Ciascuna registrazione di uno specifico parametro di comportamento armato per un pupazzo viene chiamata una ripresa.

La timeline di una scena, indicata nel pannello Timeline, rappresenta ogni istanza del pupazzo come elemento traccia selezionabile. Se selezionato, il pannello Proprietà mostra i comportamenti dell'origine (definizione principale) del pupazzo, nonché i valori di tutti i parametri di comportamento impostati localmente per questa istanza specifica. È ad esempio possibile aggiungere più volte lo stesso pupazzo in una scena, impostando l'elemento traccia di ogni pupazzo su una trasformazione di posizione diversa per posizionarlo nella scena.

Per una scena è possibile scegliere tra tre modalità:

  • Interruzione: modalità in cui vengono aperte le scene. I comportamenti, ad eccezione di Respiro, Livelli in ciclo, Fisica, Fissa maniglia, Trasforma e Movimento continuo, non influiscono sul pupazzo a meno che non sia armato per la registrazione. Quando non è armato, viene utilizzata l'ultima ripresa registrata per un comportamento in corrispondenza dell'indicatore del tempo corrente (testina di riproduzione). Durante un'interruzione, neon viene riprodotto alcun audio importato, incluso l'audio nelle riprese. Puoi utilizzare questa modalità per provare i comportamenti, dal momento che non viene effettuata alcuna registrazione.
  • Riproduzione: modalità in cui vengono riprodotte le riprese e l'audio. L'indicatore del tempo corrente si sposta nel tempo. Le modifiche apportate ai valori dei parametri di comportamento non influiscono sui risultati se in un determinato momento esiste una ripresa dello stesso parametro. Se non esistono dati delle riprese, il valore del parametro viene utilizzato ma non registrato.
  • Registra: durante la registrazione, i valori per i parametri di comportamento armati vengono acquisiti come una ripresa per ogni parametro e tutte le riprese esistenti vengono riprodotte. Per acquisire meglio un'interpretazione, puoi anche registrare a una velocità inferiore. Per la riproduzione verrà sempre utilizzata la velocità normale.

Sono disponibili controlli di trasporto per queste modalità.  Utilizzando queste modalità, puoi eseguire la registrazione di base di un'interpretazione, riprodurre e verificare le riprese registrate, quindi registrare di nuovo un'interpretazione per correggere eventuali errori. In questo modo puoi eseguire una registrazione multitraccia di input diversi e disporre più riprese su livelli diversi.

Il pulsante Vai a inizio consente di riportare il tempo corrente all'inizio della scena (se interrotta) o all'inizio della riproduzione (se è attiva la modalità di riproduzione). I pulsanti Vai a fotogramma precedente e Vai a fotogramma successivo consentono di tornare indietro o avanzare nel tempo di un fotogramma alla volta (in modalità di riproduzione interrotta).

Quando apri gli spazi di lavoro Rigging o Flusso, i controlli di trasporto non sono inclusi nei controlli predefiniti del pannello. Per visualizzare i controlli di trasporto, seleziona l'opzione Mostra sempre i controlli di riproduzione e registrazione nelmenu dello spazio di lavoro Rigging oFlusso.

 

Nota:

I dispositivi di ingresso e uscita audio devono avere la stessa frequenza di campionamento.

Registrare le riprese

Con la registrazione di una ripresa puoi usare il movimento della tua testa per controllare il volto di un pupazzo, puoi trascinare una mano di un personaggio per farla muovere in segno di saluto ed eseguire altre azioni per acquisire un'interpretazione. Puoi eseguire queste attività nello spazio di lavoro Registra.

Timer per la registrazione

Per impostazione predefinita, prima dell'avvio della registrazione viene avviato un timer di 3 secondi. Utilizza questo tempo per prepararti alla registrazione o all'acquisizione di una posa specifica per il pupazzo. Per abilitare o disabilitare il timer, esegui questa operazione:

  • Apri Timeline e abilita l'opzione Timer prima di registrare
Timer prima di registrare
Timer prima di registrare

Registrare un'interpretazione per i pupazzi

  1. Calibra gli ingressi audio e video in base alle esigenze:

    • Per controllare i pupazzi tramite la webcam, verifica che il pulsante Da videocamera nel pannello Videocamera e microfono sia abilitato (icona blu). Per migliorare i risultati di tracciamento del volto, inoltre, imposta la posizione di riposo con il pulsante Imposta posizione di riposo.
    • Per registrare l'audio durante l'interpretazione, verifica che il pulsante Da microfono nel pannello Videocamera e microfono sia abilitato (impostazione predefinita). Quando è attivato, il controllo Livello audio controlla i livelli di ingresso audio da -48 dB a 0 dB. Il controllo diventa rosso a 0 dB. Se viene visualizzato il messaggio “Livello audio troppo basso”, prova ad alzare i livelli del microfono nel pannello di controllo Audio del sistema operativo o ad avvicinarti al microfono.
  2. Per armare la traccia per la registrazione, seleziona il pupazzo (ossia il nome del pupazzo o dell'elemento della traccia nell'intestazione della traccia sul lato sinistro del pannello).

    Se un pupazzo è selezionato/armato, la registrazione è limitata solo alla traccia di tale pupazzo. Per impostazione predefinita, quando si fa clic su un'intestazione o un elemento di traccia del pupazzo o si aggiunge un pupazzo a una scena, gli altri pupazzi nella scena vengono deselezionati/disarmati. Per selezionare più pupazzi da preparare alla registrazione, premi Comando/Ctrl e fai clic.  Una traccia di pupazzo armata è indicata dall'intestazione con sfondo rosso.

  3. Nel pannello Proprietà, abilita il pulsante Arma per registrazione (cerchietto accanto al nome del comportamento) per tutti i comportamenti che desideri registrare per il pupazzo.Inoltre abilita il pulsante Arma per registrazione per i singoli parametri di comportamento da acquisire nella ripresa.

    I comportamenti armati sono contraddistinti da un cerchio rosso pieno, simile a un piccolo pulsante di registrazione. Anche i parametri armati di un comportamento armato sono contraddistinti da un cerchio rosso accanto al nome del parametro. I valori dei parametri di comportamento armati nelle tracce armate vengono acquisiti. Per passare da un pupazzo all'altro da acquisire, puoi selezionare (armare) un'intestazione o un elemento traccia del pupazzo senza disarmare i comportamenti negli altri pupazzi.

    Quando il pulsante Arma per registrazione di un comportamento è di colore rosso attenuato, significa che nessun parametro è armato. I comportamenti disarmati non sono inclusi nella registrazione successiva.

  4. (Facoltativo) Per acquisire movimenti dettagliati per Trascinamento o altri comportamenti, imposta una velocità di registrazione inferiore alla velocità normale, ad esempio pari a metà (0,5x) della velocità normale.

    La registrazione avviene a una velocità inferiore, ma la riproduzione viene eseguita alla velocità normale.

    Nota:

    Disabilita l'opzione Da microfono, a meno che non desideri creare un effetto tipo “voce da criceto”.

  5. Imposta l'ora di inizio per la registrazione.

    Puoi partire dall'inizio della scena facendo clic sul pulsante Vai a inizio, riprodurre e quindi interrompere in corrispondenza di un valore temporale specifico. Puoi anche fare clic o trascinare lungo il righello temporale nella parte superiore del pannello Timeline.

    Nota:

    Per inserire un punto di entrata durante la riproduzione, è possibile iniziare a registrare (come descritto più avanti) senza prima effettuare una pausa.

  6. Per avviare la registrazione, fai clic sul pulsante Registra nel pannello Scena.

    Nota:

    Se registri nuovamente una scena e non vuoi che vengano incluse le riprese audio precedenti, utilizza le cuffie durante la registrazione.

  7. Esegui l'interpretazione utilizzando l'immissione da webcam, microfono, tastiera e mouse e modificando i valori dei parametri di comportamento armati.

    Nota:

    Se hai armato i parametri Da videocamera o Da audio per i comportamenti, ma i rispettivi pulsanti nel pannello Videocamera e microfono sono disabilitati, non verranno acquisite riprese per tali parametri. Analogamente, se hai armato i parametri Da mouse e Da tastiera ma non fai clic nel pannello Scena o non premi un tasto, le riprese non vengono acquisite.

  8. Per interrompere la registrazione, fai di nuovo clic su Registra o su Interrompi.

     

La ripresa registrata verrà salvata in una cartella Registrazioni su disco (nella sottocartella Ch Media della cartella del progetto attuale). La ripresa è inoltre importata nel pannello Progetto nella cartella Registrazioni e aggiunta alla scena. Se è stato registrato l'input da microfono, il file WAV corrispondente viene visualizzato come elemento di traccia audio.

La traccia del pupazzo, per impostazione predefinita, è compressa. Una barra riepilogativa della ripresa di colore più chiaro, che indica la presenza di riprese registrate, compare lungo la parte inferiore della barra dell'elemento di traccia del pupazzo.

Nota:

Per selezionare una videocamera, sceglila dal menu del pannello nel pannello Videocamera e microfono. Le videocamere sorgenti disponibili sono elencate per nome.

  • Se non è disponibile alcuna videocamera compatibile, il menu del pannello visualizzerà il messaggio Nessuna videocamera rilevata.
  • Se si verifica un ritardo nella ricezione del primo fotogramma video, il messaggio del menu del pannello visualizzerà In attesa di una videocamera.
  • Se è necessario selezionare una videocamera dal menu del pannello, oppure se non è presente alcuna videocamera disponibile, il messaggio del menu del pannello non visualizzerà Nessuna videocamera selezionata.
  • Se un'altra applicazione sta utilizzando la videocamera all'avvio di Character Animator, il messaggio indica La videocamera selezionata non è disponibile.
  • Se la videocamera selezionata non è più disponibile, ad esempio, se è stata scollegata, il messaggio visualizza La videocamera è stata disconnessa.

 

Se il pulsante Immissione da videocamera viene disabilitato a causa di un problema, fare clic su di esso (abilitandolo) consentirà di tentare nuovamente l'acquisizione video dalla videocamera selezionata.

Armare il pupazzo per la registrazione

Ogni traccia del pupazzo ha un proprio pulsante Arma per registrazione che può essere controllato separatamente dalla traccia del pupazzo che è selezionata.

Armare una traccia pupazzo per la registrazione
Armare una traccia pupazzo per la registrazione

Facendo clic sugli elementi di traccia o sulle intestazioni di traccia del pupazzo si trasferisce l'armamento al pupazzo. Se si deseleziona una traccia del pupazzo facendo clic su un punto al di fuori di essa (ad esempio, modificando una barra di visema o ripresa su un'altra traccia di pupazzo), le tracce pupazzo precedentemente armate non vengono disarmate.
Per armare più tracce pupazzo contemporaneamente, tieni premuto il tasto Maiusc o Comando/Ctrl e fai clic sui pulsanti Arma per registrazione di tali tracce. Per assicurarsi che le tracce del pupazzo non siano disarmate, seleziona solo le riprese o visemi su tracce pupazzo o tracce audio.

Selezione della videocamera

Per selezionare una videocamera, sceglila dal menu del pannello nel pannello Videocamera e microfono. Le videocamere sorgenti disponibili sono elencate per nome.

Seleziona la videocamera dalle opzioni
Seleziona la videocamera dalle opzioni

Se non è disponibile alcuna videocamera compatibile, il menu del pannello visualizzerà Nessuna videocamera rilevata. Se ci sono problemi con l'immissione da videocamera, nel pannello verrà visualizzato uno dei seguenti errori:

  • Se si verifica un ritardo nella ricezione del primo fotogramma video, il messaggio di errore indica In attesa di una videocamera.
  • Se è necessario selezionare una videocamera dal menu del pannello, oppure se non è presente alcuna videocamera disponibile, il messaggio indica Nessuna videocamera selezionata.
  • Se un'altra applicazione sta utilizzando la videocamera all'avvio di Character Animator, il messaggio indica La videocamera selezionata non è disponibile.
  • Se la videocamera selezionata non è più disponibile, ad esempio se è stata scollegata, il messaggio di errore indica La videocamera è stata disconnessa.

Se il pulsante Immissione da videocamera viene disabilitato a causa di un problema, fare clic su di esso (abilitandolo) consentirà di tentare nuovamente l'acquisizione video dalla videocamera selezionata.

Velocità di registrazione

Se devi acquisire i movimenti con maggior precisione, puoi registrare e recitare a una velocità inferiore rispetto alla frequenza fotogrammi della scena.

Per modificare la velocità di registrazione di una scena, effettua le seguenti operazioni:

  • Apri la scena nel pannello Scena, quindi modifica l'impostazione Velocità di registrazione nella parte inferiore del pannello.

Queste impostazioni della scena verranno utilizzate per la successiva scena creata.

Area di lavoro timeline

La timeline di una scena presenta un'area di lavoro che è possibile attivare per isolare le operazioni in un intervallo di fotogrammi in una scena. È possibile abilitare l'area di lavoro quando è necessaria e disattivarla quando non è necessaria.

Per attivare o disattivare l'area di lavoro, effettua le seguenti operazioni:

  • Fai clic sulla barra dell'area di lavoro nella parte superiore del righello temporale o attiva o disattiva il comando Attiva area di lavoro nel menu Timeline o nel menu di scelta rapida sopra la barra dell'area di lavoro.
  • Il trascinamento di una qualsiasi parte di una barra dell'area di lavoro disattivata la attiva.
A) Area di lavoro disattivata B) Area di lavoro attivata
A) Area di lavoro disattivata B) Area di lavoro attivata

Quando è attivata, l'area di lavoro è una barra di colore grigio più chiaro e l'intervallo di tempo è evidenziato nell'area della traccia. Quando è disattivata, la barra dell'area di lavoro presenta un colore grigio tenue più scuro.

Impostazione dell'area di lavoro

Per modificare il tempo di inizio o fine per l'area di lavoro, effettua una qualsiasi delle seguenti operazioni:

• Trascina il bordo sinistro (inizio) o il bordo destro (fine) della barra dell'area di lavoro.

• Posiziona la testina di riproduzioneal tempo di un fotogramma specifico, quindi scegli Imposta inizio area di lavoro alla testina (Opzione/Alt+I) o Imposta fine area di lavoro alla testina (Opzione/Alt+O) dal menu Timeline o dal menu di scelta rapida per la barra dell'area di lavoro.

Nota: non è possibile impostare il tempo di inizio oltre la fine dell'area di lavoro o viceversa.

Per impostare l'area di lavoro così da corrispondere alle tracce o alle barre delle riprese selezionate:

Scegli Imposta area di lavoro alla selezione (Opzione/Alt+/) dal menu Timeline o dal menu di scelta rapida per la barra dell'area di lavoro. L'area di lavoro comprenderà i primi e gli ultimi tempi nella selezione.

Per spostare l'area di lavoro nel tempo, effettua le seguenti operazioni:

Trascina orizzontalmente il centro della barra dell'area di lavoro. Il trascinamento dei bordi o del centro del barra dell'area di lavoro consentirà di agganciare l'inizio o la fine della barra dell'area di lavoro ai bordi delle barre di traccia, delle barre di ripresa e dei marcatori del pupazzo. Analogamente, il trascinamento dei bordi delle barre di traccia, delle barre di ripresa o dei marcatori del pupazzo consentirà di agganciarli all'inizio o alla fine della barra dell'area di lavoro.

Passare all'inizio o alla fine dell'area di lavoro

Per passare all'inizio o alla fine dell'area di lavoro, effettua le seguenti operazioni:

  • Fai clic con il pulsante destro del mouse sopra la barra dell'area di lavoro, quindi scegli Vai all'inizio dell'area di lavoro o Vai alla fine dell'area di lavoro dal menu di scelta rapida.
  • Utilizza la scelta rapida da tastiera Opzione/Alt+Freccia sinistra oppure Opzione/Alt+Freccia destra.

Modifica di riprese selezionate utilizzando l'area di lavoro

Quando l'area di lavoro è attivata, è possibile eseguire le seguenti modifiche:

  • Per eliminare il segmento della ripresa selezionata all'interno dell'area di lavoro, scegli Timeline > Cancella per lasciare uno spazio vuoto (nessuna registrazione nell'area di lavoro) o Timeline > Elimina salti per riempire lo spazio vuoto che si viene a creare spostando le riprese selezionate inizialmente dopo l'area di lavoro all'inizio dell'area di lavoro.
A) Prima B) Cancella C) Elimina salti
A) Prima B) Cancella C) Elimina salti
  • Per inserire un intervallo nella durata di tempo dell'area di lavoro per le riprese selezionate, scegli Timeline > Inserisci tempo.
A) Prima B) Inserisci tempo
A) Prima B) Inserisci tempo

I comandi Cancella, Elimina salti e Inserisci tempo sono inoltre disponibili nel menu di scelta rapida sopra la barra dell'area di lavoro.

Riproduzione ciclo continuo all'interno dell'area di lavoro

Quando l'area di lavoro è attivata, la riproduzione della scena avverrà automaticamente a ciclo continuo all'interno dell'area di lavoro. La riproduzione inizia al tempo corrente e viene avviata nuovamente quando la testina di riproduzione raggiunge la fine dell'area di lavoro. Se la testina di riproduzione si trova dopo l'area di lavoro, la riproduzione non verrà avviata nuovamente.

Registrazione di riprese utilizzando l'area di lavoro

Quando l'area di lavoro è attivata, il comando Timeline > Registra ripresa per l'area di lavoro (Cmd/Ctrl+3) crea una nuova ripresa. La nuova ripresa copre la durata dell'area di lavoro per i parametri di comportamento armati.

Esportazione dell'area di lavoro

Quando l'area di lavoro è attivata, i comandi di esportazione scena (File > Esporta > Video tramite Adobe Media Encoder e File > Esporta > Sequenza PNG e WAV) utilizzano solo il segmento di tempo all'interno dell'area di lavoro.

Nota: le scene con pupazzi che utilizzano simulazioni fisiche (Oscillazione, Collisione, Particelle) continueranno a richiedere il rendering dei fotogrammi prima dell'inizio dell'area di lavoro (ovvero, una preparazione) per esportare i risultati desiderati per i fotogrammi nell'area di lavoro.

Quando l'area di lavoro è disattivata, quei comandi esportano l'intera durata della scena.

Nota: l'area di lavoro viene ignorata se si trascina una scena in After Effects o Premiere Pro. La durata della scena viene utilizzata in questi flussi di lavoro di Dynamic Link

Taglio della scena all'area di lavoro

Quando l'area di lavoro è attivata, è possibile tagliare la scena solo al segmento temporale all'interno dell'area di lavoro scegliendo Timeline > Taglia scena all'area di lavoro o lo stesso comando nel menu di scelta rapida sopra la barra dell'area di lavoro.

Velocità di riproduzione

L'impostazione Velocità di riproduzione consente di esaminare movimenti o modifiche di un'interpretazione con maggior precisione riproducendo la scena a una velocità inferiore. Puoi utilizzare questo controllo con la velocità di registrazione controllabile.

Per modificare la velocità di riproduzione di una scena, apri la scena nel pannello Scena e modifica l'impostazione Velocità di riproduzione dal controllo Velocità riproduzione e registrazione. Questa opzione si trova nella parte inferiore del pannello.

Quando le velocità di riproduzione e registrazione sono diverse, vengono visualizzati entrambi i valori e la velocità di registrazione è indicata in rosso. Quando sono uguali, viene visualizzato un solo valore.

A differenza di altre proprietà della scena ma analogamente alla velocità di registrazione, per impostazione predefinita per le nuove scene verrà sempre ripristinata la velocità di riproduzione normale (1.0x), anziché quella utilizzata per ultima.

Riprodurre un'interpretazione

Dopo aver registrato le riprese, puoi riprodurre le registrazioni per controllare il tuo lavoro.

Per avviare la riproduzione in corrispondenza di un momento specifico nella scena,

fai clic o trascina lungo il righello temporale (nella parte superiore del pannello Timeline). Il trascinamento consente anche di scorrere l'audio nella scena.

Per avviare la riproduzione,

fai clic sul pulsante Riproduci o premi la barra spaziatrice. Le riprese registrate vengono riprodotte e il codice di tempo visualizzato viene aggiornato di conseguenza.

Per controllare la velocità di riproduzione di una scena,

apri la scena nel pannello Scena, quindi modifica l'impostazione Velocità di riproduzione nel controllo Velocità riproduzione e registrazione nella parte inferiore del pannello.

Quando le velocità di riproduzione e registrazione sono diverse, vengono visualizzati entrambi i valori e la velocità di registrazione è indicata in rosso. Quando le velocità sono uguali, viene visualizzato solo tale valore.

Per interrompere la riproduzione,

fai clic su Interrompi o premi di nuovo la barra spaziatrice.

La testina di riproduzione si aggancia ai limiti dei fotogrammi per impostazione predefinita. Se esegui uno zoom nel tempo nel pannello Timeline, puoi vedere la durata di un fotogramma in azzurro, simile a come viene visualizzata in After Effects e Photoshop.

Nota:

Nel pannello Scena la visualizzazione corrisponde al tempo centrale nella durata del fotogramma, ma l'audio può comunque essere riprodotto per tutta la durata del fotogramma. Le operazioni su tracce e riprese, come la registrazione, la divisione e l'aggancio, vengono comunque effettuate in corrispondenza della linea rossa (bordo sinistro).

Per annullare l'aggancio della testina di riproduzione dai limiti dei fotogrammi per un posizionamento o uno scorrimento dell'audio più accurato, tieni premuto Comando (Mac) o Ctrl (Windows) mentre trascini la testina.

Riproduzione dello stesso intervallo di tempo

Per impostazione predefinita, quando si interrompe la riproduzione, la testina di riproduzione resta nel punto in cui è stata interrotta, ma è possibile farla testina di riproduzione sul tempo iniziale precedente per riprodurre nuovamente lo stesso intervallo di tempo premendo il tasto Spazio. Questa opzione è utile per mettere a punto i tempi dei visemi per una parola o una frase.
Per riportare la testina di riproduzione sul tempo iniziale precedente al termine della riproduzione, procedi come segue:

  • Seleziona l'opzione Timeline > All'arresto, torna alla posizione di inizio.

Scorrimento del tempo tramite tastiera

Per spostarti nel tempo di una scena, puoi utilizzare le seguenti scelte rapide da tastiera.

  • Pagina su o Pagina giù: per scorrere verso sinistra o verso destra di una sezione alla volta nell'ambito dell'intervallo di tempo visibile.
  • Comando/Ctrl+Pagina su o Comando/Ctrl+Pagina giù: per scorrere verso sinistra o verso destra di meno di una sezione alla volta.

Scorrimento del contenuto del pannello Timeline durante la riproduzione e la registrazione

Al fine di mantenere visibile la testina di riproduzione , il contenuto del pannello Timeline si sposta durante la riproduzione o la registrazione.

Per evitare lo scorrimento del tempo durante la riproduzione e la registrazione, procedi come segue:

  • Deseleziona l'opzione Timeline > Scorri durante la riproduzione.

Riprese prolungate

Se desideri estendere la posa di un'interpretazione registrata (ripresa) di un personaggio in corrispondenza del tempo corrente, crea delle riprese prolungate. Le riprese prolungate duplicano i valori delle riprese selezionate in corrispondenza della testina di riproduzione, consentendoti di estenderle fino alla durata richiesta ed eventualmente di fonderle con riprese registrate in precedenza. Per creare le riprese prolungate, effettua le seguenti operazioni:

  1. Sposta la testina di riproduzione fino al fotogramma della posa che desideri prolungare.

    Suggerimento: disarma la traccia del pupazzo per vedere i risultati delle riprese registrate.

  2. Seleziona una o più riprese di cui desideri conservare i valori in corrispondenza del tempo corrente.

  3. Scegli Timeline > Nuova ripresa prolungata (Comando+Maiusc+Opzione+D/Ctrl+Maiusc+Alt+D).

Al di sopra di ogni ripresa selezionata è presente una nuova ripresa prolungata di un secondo. È possibile allungare e spostare le riprese prolungate e persino fonderle nelle riprese sottostanti per ottenere transizioni più omogenee. I segni di spunta lungo il bordo inferiore di ciascuna ripresa prolungata indicano che il valore è costante e si estende sia indietro che in avanti nel tempo.

Nota:

Le riprese prolungate per Sinc labiale o le riprese Trigger possono essere estese da entrambe le estremità, ma l'inizio delle barra di visemi o trigger non si estende automaticamente. È comunque possibile trascinarle manualmente come necessario.

Mostrare o nascondere le riprese registrate per un pupazzo

Per mostrare o nascondere le registrazioni del pupazzo, fai clic sul triangolo di espansione accanto al nome di un pupazzo nell'intestazione della traccia del pannello Timeline. Ogni parametro di comportamento registrato viene visualizzato come barra delle proiezioni separata che riepiloga le riprese in essa presenti. Se sotto l'elemento traccia di un pupazzo non è presente alcuna barra delle proiezioni, verifica di aver armato almeno un parametro di comportamento per la registrazione e di aver selezionato/armato la traccia prima della registrazione.

Puoi modificare tutte le riprese relative a un parametro dalla relativa barra delle proiezioni, oppure apportare regolazioni più precise a riprese specifiche facendo clic sul triangolo di espansione della barra di proiezione.

Nota:

Se per un parametro sono state registrate più riprese, viene utilizzata la barra delle riprese superiore per un dato momento; le informazioni delle barre delle riprese sottostanti vengono invece ignorate (e visualizzate senza colore, come se fossero ombreggiate). I punti di transizione tra le riprese relativi a un parametro sono indicati da una linea verticale sulla barra delle proiezioni del parametro.

Per avviare la riproduzione all'inizio della scena

fai clic sul pulsante Vai a inizio o premi il tasto Inizio.

Replay: registrazioni riutilizzabili e attivabili tramite trigger

I replay consentono di attivare tramite trigger le riprese registrate per un pupazzo, dal vivo o per una nuova registrazione. Utilizzali per rendere la registrazione e la riproduzione più facili ed efficienti. Per informazioni sui replay, consulta Replay: registrazioni riutilizzabili e attivabili tramite trigger.

Comportamento di registrazione nei gruppi di riprese

I gruppi di ripreseconsentonodi comporre insieme più interpretazioni per una maniglia specifica, senza influire sulle interpretazioni delle altre maniglie trascinate. Il comportamento Trascinamento registra ogni maniglia trascinabile che viene spostata come gruppo di riprese separato. Con il raggruppamento delle riprese di Trascinamento in base alle maniglie trascinate, non è quindi più necessario utilizzare più comportamenti Trascinamento per acquisire più maniglie trascinate. Nel pannello Timeline le singole riprese di Trascinamento sono raggruppate in base al nome della maniglia e contraddistinte dal nome “Maniglia (nome della maniglia)”.

Registrazione in più passaggi per acquisire riprese di uno o due fotogrammi

Puoi acquisire la posizione corrente di un personaggio, in particolare i parametri di comportamento armati per la registrazione, come riprese di uno o due fotogrammi per animare “su uno” o “su due”. Se ad esempio il parametro Dopo lo spostamento del comportamento Trascinamento è impostato su Mantieni in posizione, puoi posizionare le braccia di un personaggio, registrare una ripresa di un fotogramma, cambiare la posizione, registrare un'altra ripresa di un fotogramma e così via. Come qualsiasi ripresa registrata, in un secondo tempo potrai estenderne la durata, ad esempio per mantenere una posizione più a lungo.

Per registrare riprese di uno o due fotogrammi per i parametri armati, scegli Timeline > Registra ripresa di 1 fotogramma (Cmd/Ctrl+1) o Registra ripresa di 2 fotogrammi (Cmd/Ctrl+2).

Puoi fondere le interpretazioni all'inizio e alla fine di una ripresa per ottenere una transizione più uniforme tra le riprese esistenti e l'aspetto predefinito. Puoi inoltre personalizzare le durate delle fusioni o impostare rapidamente una ripresa in modo da creare una fusione con la durata predefinita. Per ulteriori informazioni, consulta Fondere le interpretazioni.

Regolare il tempo e riordinare il contenuto delle scene

Puoi modificare la temporizzazione e l'ordine dei pupazzi, delle riprese registrate e dell'audio per perfezionare il lavoro. I pupazzi e l'audio sono visualizzati come elementi traccia (barre più grandi), mentre le riprese registrate corrispondono alle barre più corte presenti sotto gli elementi traccia dei pupazzi. Puoi anche ingrandire o ridurre la visualizzazione del tempo per accedere più facilmente alle barre di traccia o per una panoramica temporale della scena.

Quando si ingrandisce la durata di un fotogramma di tempo nel pannello Timeline, il centro orizzontale del fotogramma è indicato da una linea tratteggiata che indica il tempo esatto del campionamento dell'elemento traccia o della ripresa.

Trascina il cursore Ingrandisci timeline oppure fai clic sul pulsante Ingrandisci timeline, Riduci timeline o Adatta timeline a intera scena, in basso a destra nel pannello Timeline. Per questi pulsanti sono disponibili anche delle scelte rapide da tastiera (–, =, \).

Scorrere il tempo nella visualizzazione ingrandita

Utilizza la barra di scorrimento orizzontale sotto l'area scorrevole del pannello Timeline oppure fai scorrere il dito in orizzontale sul trackpad.

Scorrere le varie tracce di pupazzi e audio

Utilizza la barra di scorrimento verticale oppure fai scorrere il dito in verticale sul trackpad.

Selezionare o deselezionare gli elementi traccia

  • Fai clic sul nome della traccia (per un pupazzo) o sulla barra dell'elemento traccia per selezionarlo. 
    Seleziona un elemento traccia relativo a un pupazzo per modificare i valori dei parametri di comportamento per l'istanza del pupazzo nella scena, ignorando i valori della definizione di origine (principale) del pupazzo. 
    Quando si seleziona la traccia di un pupazzo, questo viene armato automaticamente per la registrazione.
  • Per attivare/disattivare la selezione di un pupazzo, premi Maiusc oppure Comando/Ctrl e fai clic sull'elemento traccia del pupazzo o sul nome della traccia (intestazione traccia sul lato sinistro del pannello). In questo modo puoi selezionare più pupazzi contemporaneamente.
  • Per deselezionare tutti i contenuti, fai clic all'esterno di qualunque barra di elemento traccia.

Selezione gerarchica

Gli elementi traccia selezionati sono contraddistinti da un colore blu uniforme nel pannello Timeline. Quando è selezionata una barra di proiezione o di ripresa per un pupazzo (selezionata direttamente o dopo la registrazione di riprese), la barra diventa di colore blu uniforme e i contorni della traccia del pupazzo sono visualizzati in blu, per indicare che è stato selezionato un elemento nella gerarchia del pupazzo. Questa selezione gerarchica consente inoltre di vedere i parametri del comportamento del pupazzo nel pannello Proprietà e renderli modificabili subito dopo la regolazione delle riprese.

Selezionare o deselezionare le riprese

  • Fai clic per selezionare una ripresa e altre riprese acquisite durante lo stesso passaggio di registrazione. Queste riprese sono collegate perimpostazione predefinita, e possono essere trascinate e tagliate all'unisono. 
  • Per attivare/disattivare la selezione delle riprese collegate, fai clic su una ripresa tenendo premuto Maiusc o Comando/Ctrl.
Quando si registrano più parametri contemporaneamente, le relative riprese vengono collegate. Per impostazione predefinita, la selezione di una singola ripresa non implica la selezione o la modifica delle riprese collegate, ma è possibile gestire tutte le riprese collegate contemporaneamente facendo clic sul comando Selezione collegata nel menu Timeline.
Quando è selezionata una ripresa, la sezione corrispondente della barra di riepilogo (lungo la parte inferiore dell'elemento traccia del pupazzo) viene evidenziata in blu, per indicare che l'elemento traccia è compresso e non è possibile visualizzare le barre delle riprese.

Suddividere elementi traccia e riprese

Per abbreviare un elemento traccia audio o del pupazzo o una ripresa, puoi suddividerlo in corrispondenza della testina di riproduzione (ora corrente). Con questa operazione la selezione viene duplicata e le barre originali e nuove vengono tagliate.

Per suddividere elementi traccia o riprese:

  1. Seleziona gli elementi e porta la testina di riproduzione in corrispondenza del punto in cui inserire la suddivisione.
  2. Scegli Modifica > Suddividi (Maiusc+Comando/Ctrl+D).

Duplicare elementi traccia e riprese

Puoi creare una copia di un elemento traccia o riprese da utilizzare in futuro.

Per duplicare elementi traccia o riprese:

  1. Seleziona gli elementi o le riprese.
  2. Scegli Modifica > Duplica (Comando/Ctrl+D).

Regolare la temporizzazione di un elemento traccia o di una ripresa

  • Per spostarlo nel tempo, trascina in orizzontale la parte centrale della barra.
  • Per tagliare il tempo di inizio o fine, trascina l'estremità sinistra o destra della barra.

Se si estende una barra delle riprese da una delle estremità, i valori registrati della ripresa verranno mantenuti prima del punto di attacco originale e dopo il punto di stacco originale della ripresa.

Nota:

Se suddividi una ripresa, in seguito all'estensione dal punto di suddivisione viene visualizzata solo la parte tagliata.

Ignorare l'aggancio ai bordi per un maggiore controllo

Tieni premuto il tasto Comando/Ctrl mentre trascini un elemento traccia o una barra delle riprese.

Riordinare una traccia

Per riordinare una traccia, ad esempio per cambiare l'ordine dei pupazzi, seleziona la traccia, quindi scegli Timeline > Disponi > Sposta su o Sposta giù oppure premi Comando+Freccia su/Freccia giù o Ctrl+Freccia su/Freccia giù.

Eliminare un elemento traccia

Seleziona un elemento traccia, quindi scegli Modifica > Elimina oppure premi Canc o Backspace. L'eliminazione di un elemento traccia audio non implica la rimozione della relativa traccia.

Spostare una ripresa

Puoi spostare le riprese selezionate per lo stesso parametro verso l'alto o verso il basso tramite i comandi Timeline > Sposta su o Sposta giù. I comandi possono ancora essere utilizzati per le tracce selezionate.

Eliminare una ripresa

Seleziona la barra delle riprese e premi Canc oppure scegli Modifica > Elimina.

  • Per eliminare le riprese di un pupazzo, selezionale tutte e premi il tasto Canc.
  • Per eliminare la traccia del pupazzo, premi Canc dopo l'eliminazione delle riprese quando la selezione si trova nella traccia del pupazzo.

Riutilizzare le riprese in altri pupazzi e progetti

Tutti i tipi di riprese possono essere tagliati, copiati e incollati in altri pupazzi e progetti. Per riutilizzare le riprese, effettua le seguenti operazioni:

  1. Seleziona le riprese da riutilizzare.

    • Per rimuoverle dal pupazzo, scegli Modifica > Taglia (Comando/Ctrl+X). 
    • Per mantenere le riprese originali e duplicarle, scegli Modifica > Copia (Comando/Ctrl+C).
  2. Seleziona un altro elemento di traccia pupazzo nella Timeline, nel progetto attuale o in un altro. Riposiziona la testina di riproduzione fino al punto da cui desideri iniziare la ripresa, quindi scegli Modifica > Incolla (Comando/Ctrl+V).

La ripresa selezionata viene incollata in relazione alla testina di riproduzione. Eventuali comportamenti associati alle riprese copiate vengono applicati al pupazzo destinazione, se quest'ultimo non ha già tali comportamenti. Se il pupazzo ha più comportamenti (per la ripresa), ognuno di essi riceve una copia della ripresa. Puoi anche copiare più riprese, che verranno incollate nell'ordine in cui erano state selezionate.

Per ulteriori informazioni su come utilizzare i visemi di Character Animator in After Effects, per applicarli ad altri personaggi, consulta Sincronizzazione labiale: esportazione di riprese per After Effects.

Nota:

  • Quando si incolla un comportamento nascosto per impostazione predefinita ma che non è nascosto mentre lo si copia (Livelli in ciclo), la nuova istanza incollata è nascosta.
  • I comportamenti incollati vengono sempre aggiunti al livello superiore del pupazzo, anche se la ripresa copiata era per un comportamento in un livello inferiore nella struttura del pupazzo.
  • Nei comportamenti incollati non vengono mantenuti eventuali nomi di comportamento personalizzati.
  • Le riprese copiate per più istanze dello stesso comportamento (due istanze di Volto in posizioni diverse nella struttura del pupazzo) sono incollate in una singola istanza del comportamento.

Fondere le interpretazioni

Puoi fondere le interpretazioni all'inizio e alla fine di una ripresa per ottenere una transizione più uniforme tra l'aspetto predefinito di pupazzo e le relative interpretazioni registrate. Puoi inoltre personalizzare le durate delle fusioni o impostare rapidamente una durata predefinita.

Fusione della ripresa del parametro di un comportamento

1. Espandi la barra delle proiezioni e del pupazzo che contiene una ripresa adatta alla fusione. 

È possibile fondere le seguenti riprese:

  • Parametri numerici, ad esempio Intensità vento della proprietà Oscillazione o Scala della proprietà Trasforma
  • Parametri di angolazione, ad esempio Rotazione della proprietà Trasforma
  • Parametro Da videocamera della proprietà Volto
  • Parametro Da tocco e mouse della proprietà Trascinamento

2. Effettua una delle seguenti operazioni:

  • Per utilizzare una durata di fusione personalizzata, trascina verso l'interno il quadratino di uno degli angoli superiori della barra delle riprese. Quando si trova sul quadratino, il cursore assume l'aspetto di un dito con frecce a entrambi i lati. Più ti allontani dal bordo della barra, più gradualmente potrai entrare o uscire dall'interpretazione registrata.
  • Per utilizzare una durata di fusione predefinita (mezzo secondo), seleziona la barra delle riprese o delle proiezioni, quindi scegli il sottomenu Timeline > Fusione ripresa. Puoi fondere solo il lato in ingresso (Fusione in ingresso), il lato in uscita (Fusione in uscita) o entrambi i lati (Fusione in ingresso e uscita) della ripresa. Trascina i quadratini per personalizzare ulteriormente la durata.
  • Per scorrere le durate di fusione predefinite disponibili, scegli Timeline > Fusione ripresa > Fusione successiva (Comando/Ctrl+B) o Fusione precedente (Maiusc+Comando/Ctrl+B).

Quando tagli una ripresa, le durate di fusione in ingresso (lato sinistro) e in uscita (lato destro) non vengono modificate, a meno che la durata della barra delle riprese non diventi più breve delle durate di fusione.

Nota:

I comandi Timeline > Fusione ripresaimpostano una durata predefinita per le fusioni in ingresso e in uscita,ma non impostano la gradualità a uno specifico tipo di curva. L'impostazione predefinita è Ingresso e uscita graduale.

Per impostare la curva di andamento di fusione:

1. Fai clic con il pulsante destro del mouse sopra la fusione in ingresso e quindi scegli Curva di fusione in ingresso, sopra la fusione in uscita e quindi scegli Curva di fusione in uscita o al centro della barra di traccia e quindi scegli Fondi.

2. Scegli un tipo di andamento dal sottomenu: Nessun andamento (curva lineare), Andamento in ingresso (andamento in ingresso dalla fusione), Andamento in uscita (andamento in uscita dalla fusione) o Andamento in ingresso e uscita (andamento a entrambe le estremità della fusione).

Rimozione della fusione di una ripresa

Effettua una delle seguenti operazioni:

  • Scegli Timeline > Fusione ripresa > Rimuovi fusione.
  • Trascina il quadratino verso i bordi della barra delle riprese.

Marcatori

I marcatori consentono di contrassegnare modifiche specifiche nella timeline di una scena, ad esempio quando un personaggio guarda verso sinistra.  La riproduzione si interrompe in corrispondenza dei marcatori di arresto. Puoi passare in qualsiasi momento da un normale marcatore informativo a un marcatore di arresto.

Per creare un marcatore, sposta la testina di riproduzione al tempo indicato, quindi esegui una delle seguenti operazioni:

  • Per un marcatore normale, scegli Timeline > Aggiungi marcatore (Ctrl+8 su Mac, * da tastierino numerico su Windows).
  • Per un marcatore di arresto, seleziona Timeline > Aggiungi marcatore di arresto (Ctrl+Maiusc+8 su Mac, Maiusc+* da tastierino numerico su Windows). L'icona di un marcatore di arresto è un quadratino.

Nota: è possibile passare da un marcatore normale a un marcatore di arresto, o viceversa. Per cambiare tipo di marcatore, fai clic con il pulsante destro del mouse sul marcatore e attiva o disattiva l'opzione Arresta riproduzione in corrispondenza del marcatore.

  • Per rinominare un marcatore, fai doppio clic su di esso e premi Invio, quindi immetti un nuovo nome.
  • Per spostare un marcatore in una posizione diversa della timeline, trascinalo in orizzontale. I marcatori possono allinearsi ad altri elementi della timeline e viceversa.
  • Per eliminare un marcatore, selezionalo (tieni premuto Maiusc e fai clic per selezionarne più di uno), quindi scegli Modifica > Elimina.

Lavorare con i marcatori

Lavorare con i marcatori
Scopri come usare i marcatori

Ridimensionamento delle forme d'onda audio e delle tracce audio

La traccia audio mostra la forma d'onda del file audio, per aiutarti a regolare la temporizzazione di pupazzi, riprese e visemi in base all'audio. Per impostazione predefinita, l'altezza delle tracce audio è il doppio delle altre tracce e se necessario può essere ridimensionata trascinando in verticale il bordo inferiore della sua intestazione.

Ridimensionare le tracce audio
Ridimensionare le tracce audio

Comprimi vista delle riprese di un parametro

Per impostazione predefinita, più registrazioni per un parametro creano barre di ripresa su righe separate nel pannello Timeline, ma è possibile comprimerle in un'unica linea per ridurre lo scorrimento verticale e avere comunque accesso ad esse individualmente.

Fai clic sulla freccia a spirale per espandere o comprimere le riprese di un parametro. La freccia a spirale viene visualizzata solo se un parametro dispone di più riprese. 

Vista ridotta delle riprese
Vista ridotta delle riprese

Quando si esegue la compressione in un'unica linea, è possibile fare clic su parti diverse per selezionare le singole barre di ripresa. Quando è selezionata, le informazioni sulla ripresa vengono visualizzate alla sua barra, inoltre sono visibili le curve di fusione e possono essere regolate le maniglie di fusione.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online