• Adobe Flash®에서 사용하기 위해 Fireworks 벡터, 비트맵, 애니메이션 및 다중 상태 단추 그래픽을 쉽게 가져오거나 복사하여 붙여넣거나 내보낼 수 있습니다.

  • Flash의 TLF 텍스트가 Windows에서 실행 중인 Fireworks에 빈 비트맵 이미지로 복사됩니다. TLF 텍스트를 ASCII 텍스트로 변환하고 Fireworks로 가져옵니다.

  • 또한 실행 및 편집 기능을 통해 Flash 내에서 Fireworks 그래픽을 쉽게 편집할 수 있습니다. Flash에서 작업할 때는 Fireworks에서 설정한 실행 및 편집 환경 설정이 항상 적용됩니다.

  • Flash HTML 스타일은 팝업 메뉴 코드를 지원하지 않습니다. Fireworks 단추 비헤이비어 및 기타 상호 작용 유형은 Flash로 가져올 수 없습니다.

Flash에 Fireworks 그래픽 삽입

그래픽 및 애니메이션을 Flash에 추가하는 방식을 효과적으로 제어하려면 Fireworks PNG 파일을 가져오거나 복사하는 방법을 사용하는 것이 가장 좋습니다. Fireworks에서 내보낸 JPEG, GIF, PNG 및 SWF 파일을 가져올 수도 있습니다.

참고:

Fireworks 그래픽을 Flash로 가져오거나 복사하여 붙여넣으면 라이브 필터 및 텍스처 같은 일부 특성이 손실됩니다. 윤곽선 그레이디언트 효과는 Fireworks에서 Flash 문서로 가져오거나 복사하여 붙여넣을 수 없습니다. 또한 Flash에서는 단색 칠, 그레이디언트 칠 및 기본 획만 지원됩니다.

Fireworks PNG 파일을 Flash로 가져오기

Fireworks PNG 소스 파일을 다른 그래픽 형식으로 내보내지 않고 Flash로 직접 가져올 수 있습니다. 모든 Fireworks 벡터, 비트맵, 애니메이션 및 다중 상태 단추 그래픽을 Flash로 가져올 수 있습니다.

참고:

Fireworks 비헤이비어는 파일 형식과는 별도의 JavaScript를 통해 활성화되므로 Fireworks의 단추 비헤이비어와 다른 유형의 상호 작용 기능은 Flash로 가져올 수 없습니다. Flash에서는 내부 ActionScript 코드를 사용합니다.

  1. Fireworks에서 문서를 저장합니다.

  2. Flash의 열린 문서로 전환합니다.

  3. (선택 사항) Fireworks 내용을 가져올 키 상태와 레이어를 클릭합니다.

  4. [파일] > [가져오기]를 선택합니다.

  5. PNG 파일을 찾아서 선택합니다.

  6. Fireworks 문서 가져오기 대화 상자에서 다음 중 하나를 수행합니다.

    • [병합된 단일 비트맵으로 가져오기] 옵션을 선택합니다.

    • 두 개의 팝업 메뉴에서 가져오기 옵션을 선택합니다.

  7. 텍스트를 가져올 방식을 선택합니다.

  8. [확인]을 클릭합니다.

    참고:

    [Fireworks 문서 가져오기] 대화 상자의 선택 항목이 저장되고 기본 설정으로 사용됩니다.

Fireworks 그래픽, 벡터 객체 및 텍스트 가져오기 옵션

그래픽 가져오기 옵션

병합된 단일 비트맵으로 가져오기

편집할 수 없는 하나의 이미지를 가져옵니다.

모든 페이지를 새 상태에 동영상 클립으로 가져오기

PNG 파일의 모든 페이지를 PNG 파일 이름의 새 Flash 레이어에 가져옵니다. 현재 상태의 위치에 있는 새 레이어에 키 상태가 만들어지고 PNG 파일의 첫 번째 페이지가 이 상태에 동영상 클립으로 삽입되며 다른 모든 페이지는 그 뒤를 이어서 동영상 클립으로 상태에 삽입됩니다. PNG 파일 내의 레이어 계층과 상태는 유지됩니다.

페이지 1을 현재 상태에 동영상 클립으로 가져오기

선택한 페이지의 콘텐트를 동영상 클립으로 가져와 Flash 파일의 활성 상태와 레이어에 삽입합니다. PNG 파일 내의 레이어 계층과 상태는 유지됩니다.

모든 페이지를 새 장면에 동영상 클립으로 가져오기

PNG 파일의 모든 페이지를 가져와 각 페이지를 새 장면에 동영상 클립으로 매핑합니다. 페이지 내의 모든 레이어와 상태는 유지됩니다. 장면이 이미 Flash 파일에 있을 경우 가져오기 프로세스는 기존 장면 뒤에 새 장면을 추가합니다.

페이지 1을 새 레이어로 가져오기

선택한 페이지를 새 레이어로 가져옵니다. 상태는 별개의 상태로 타임라인에 가져옵니다.

벡터 객체 가져오기 옵션

모양 유지를 위해 비트맵으로 가져오기

Flash에서 지원하지 않는 특수한 칠, 획 또는 효과가 적용된 경우가 아니면 벡터 객체의 편집성을 그대로 유지합니다. 이러한 객체의 모양을 그대로 유지하기 위해 Flash는 객체를 편집할 수 없는 비트맵 이미지로 변환합니다.

편집 가능한 패스로 가져오기

모든 벡터 객체의 편집성을 그대로 유지합니다. 객체에 Flash에서 지원하지 않는 특수한 칠, 획 또는 효과가 적용된 경우 가져온 뒤에는 이러한 속성이 다르게 보일 수 있습니다.

텍스트 가져오기 옵션

모양 유지를 위해 비트맵으로 가져오기

Flash에서 지원하지 않는 특수한 칠, 획 또는 효과가 적용된 경우가 아니면 텍스트의 편집성을 그대로 유지합니다. 이러한 텍스트의 모양을 그대로 유지하기 위해 Flash는 텍스트를 편집할 수 없는 비트맵 이미지로 변환합니다.

참고:

Flash의 TLF 텍스트가 Fireworks에 빈 비트맵 이미지로 복사됩니다.

모든 텍스트를 편집 가능하도록 유지

모든 텍스트의 편집성을 유지합니다. 텍스트 객체에 Flash에서 지원하지 않는 특수한 칠, 획 또는 효과가 적용된 경우 가져온 뒤에는 이러한 객체가 다르게 보일 수 있습니다.

Fireworks 그래픽을 Flash로 복사 또는 드래그

그래픽을 Flash 8 이전의 Flash 버전으로 복사하려면 [편집] > [패스 외곽선 복사]를 선택합니다.

참고:

Flash에서 객체를 개별 벡터 객체로 편집할 수 있게 하려면 [수정] > [그룹 해제]를 사용하여 객체를 그룹 해제해야 할 수 있습니다.

  1. Fireworks에서 복사할 객체를 선택합니다.

  2. [편집] > [복사]를 선택하고 Flash 팝업 메뉴에서 [복사]를 선택합니다.

  3. Flash에서 새 문서를 만들고 [편집] > [붙여넣기]를 선택하거나 파일을 Fireworks에서 Flash로 직접 드래그합니다.

  4. [Fireworks 문서 가져오기] 대화 상자에서 [대상] 옵션을 선택합니다.

    현재 상태에 동영상 클립으로

    붙여넣은 내용을 동영상 클립으로 가져옵니다. 동영상 클립은 Flash 파일의 활성 상태와 레이어에 삽입됩니다. PNG 파일 내의 레이어 계층과 상태는 유지됩니다.

    새 레이어

    붙여넣은 내용을 새 레이어로 가져옵니다. 상태는 별개의 상태로 타임라인에 가져옵니다.

  5. 벡터 객체를 가져올 방법을 선택합니다.

  6. 텍스트를 가져올 방식을 선택합니다.

  7. [확인]을 클릭합니다.

    참고:

    [Fireworks 문서 가져오기] 대화 상자의 선택 항목이 저장되고 기본 설정으로 사용됩니다.

Flash 라이브러리 구조

Fireworks 객체는 Flash 라이브러리의 [Fireworks 객체] 폴더로 가져옵니다. 이 폴더 내의 구조는 다음과 같습니다.

파일 1 폴더 // Fireworks 파일 이름으로 이름 지정됨

  • 페이지 1 폴더 // 페이지 이름으로 이름 지정됨(둘 이상의 페이지가 있는 경우)

    — 페이지 1 // 페이지 이름으로 이름 지정됨

    — — 상태 1 폴더 // 상태 이름으로 이름 지정됨(둘 이상의 상태가 있는 경우)

    — — 상태 1 // 상태 이름으로 이름 지정됨

    — — — 상태 1의 심볼 1 // 심볼 이름에 기초하여 이름이 지정됨

    — — — 상태 1의 심볼 2

    ...

    — 공유 레이어 폴더 // 페이지 1의 여러 상태에서의 공유 레이어

    — — 공유 레이어 폴더 // 공유 레이어 이름으로 이름 지정됨

    — — 공유 레이어 심볼

  • 페이지 2 폴더

    — 페이지 2

    — 페이지 2의 심볼 1(상태가 없는 페이지의 경우)

    ...

  • MasterPage 폴더

    — MasterPage

    — MasterPage의 심볼 1

    ...

    — 공유 레이어 폴더 // 여러 페이지에서의 공유 레이어

    — — 공유 레이어 폴더 // 공유 레이어 이름으로 이름 지정됨

    — — 공유 레이어 심볼

Flash에서 Fireworks 심볼 가져오기

Flash에서 Fireworks 심볼을 가져올 때는 다음 문제를 고려하십시오.

  • 심볼에서 9슬라이스 크기 조절을 사용하는 경우에는 4개의 슬라이스 안내선이 Flash에 가져오기되고 유지됩니다. 하지만 애니메이션에 대해서는 9슬라이스 크기 조절이 유지되지 않습니다. 가져온 심볼은 Flash 라이브러리에 심볼로 저장됩니다.

  • 다기능 심볼에 적용되었던 경미한 편집은 손실됩니다. 심볼의 마스터 복사본을 가져옵니다.

  • 다기능 그래픽 심볼은 PNG 파일과 JSF 파일로 저장됩니다. PNG 파일만 가져옵니다. 심볼이 여러 패스로 구성된 경우 패스는 하나의 심볼로 결합됩니다.

  • Flash에서 다기능 심볼의 모든 기능이 필요한 경우에는 Flash 버전의 심볼로 바꿉니다.

가시성 및 잠금 유지

PNG 파일에서 숨겨진 객체와 레이어는 Flash로 가져와 숨겨진 상태로 유지됩니다. 그러나 다기능 그래픽 심볼의 볼 수 없는 부분은 가져오지 않습니다(예: 단추 [위에 놓기] 또는 [누름] 상태).

레이어가 잠겼거나 숨겨진 경우 레이어 내의 모든 객체와 하위 레이어는 잠김 또는 숨김 설정을 상속하고 Flash로 가져올 때 유지합니다.

단일 페이지를 Flash의 새 레이어로 가져오면 전체 페이지에 대해 하나의 레이어가 생성되고 모든 객체가 표시됩니다. 가시성과 잠금 특성은 유지되지 않습니다.

지원되는 Photoshop 레이어 효과

Photoshop 라이브 효과 - DropShadow

매핑은 다음과 같습니다.

  • 크기는 blurX, blurY로 매핑됨

  • 거리는 거리로 매핑됨

  • 색상은 색상으로 매핑됨

  • 각도는 180으로 매핑됨 - (Photoshop 효과 각도)

Photoshop 라이브 효과 - InnerShadow

매핑은 다음과 같습니다.

  • 크기는 blurX, blurY로 매핑됨

  • 거리는 거리로 매핑됨

  • 색상은 색상으로 매핑됨

  • 각도는 180으로 매핑됨 - (Photoshop 효과 각도)

Photoshop 라이브 효과 - 외부 광선

매핑은 다음과 같습니다.

  • 불투명도는 강도로 매핑됨

  • 색상은 색상으로 매핑됨

  • 크기는 blurX, blurY로 매핑됨

Photoshop 라이브 효과 - 내부 광선

매핑은 다음과 같습니다.

  • 불투명도는 강도로 매핑됨

  • 색상은 색상으로 매핑됨

  • 크기는 blurX, blurY로 매핑됨

  • 다른 Photoshop 레이어 효과가 있는 객체는 래스터화됩니다.

Flash에서 사용하기 위해 Fireworks 그래픽을 다른 형식으로 내보내기

Fireworks 그래픽을 JPEG, GIF, PNG 및 Adobe Illustrator 8(AI) 파일로 내보낸 다음 Flash로 가져올 수 있습니다.

PNG가 Fireworks의 기본 파일 형식이지만 Fireworks에서 내보낸 PNG 그래픽 파일과 Fireworks에서 저장한 PNG 소스 파일은 다릅니다. GIF 또는 JPEG와 마찬가지로, 내보내는 PNG 파일에는 슬라이스, 레이어, 상호 작용, 라이브 필터 또는 기타 편집 가능한 콘텐트에 대한 추가 정보 없이 이미지 데이터만 포함됩니다.

Fireworks 그래픽 및 애니메이션을 SWF 파일로 내보내기

Fireworks 그래픽과 애니메이션을 Flash SWF 파일로 내보낼 수 있습니다. 획 크기와 획 색상 형식을 유지하려면 [Flash SWF 내보내기 옵션] 대화 상자에서 [모양 유지]를 선택합니다.

SWF 형식으로 내보낼 때는 블렌드 모드, 레이어, 마스크(내보내기 전에 적용됨), 슬라이스 객체, 이미지 맵, 비헤이비어, 패턴 칠 및 윤곽선 그레이디언트 형식이 손실됩니다.

  1. [파일] > [다른 이름으로 저장]을 선택합니다.

  2. 파일 이름을 입력하고 대상 폴더를 선택합니다.

  3. 형식으로 [Adobe Flash SWF]를 선택합니다.

  4. [옵션]을 클릭합니다. 그런 다음 [객체] 옵션을 선택합니다.

    패스 유지

    패스의 편집성을 유지할 수 있습니다. 효과와 서식은 손실됩니다.

    모양 유지

    필요한 경우 벡터 객체를 비트맵 객체로 변환하고 적용된 획과 칠의 모양을 유지합니다. 편집성은 손실됩니다.

  5. [텍스트] 옵션 선택

    편집성 유지

    텍스트 편집성을 유지할 수 있습니다. 효과와 서식은 손실됩니다.

    패스로 변환

    텍스트를 패스로 변환하고 Fireworks에서 입력한 사용자 정의 자간 또는 간격을 유지합니다. 텍스트로서의 편집성은 손실됩니다.

  6. [JPEG 품질] 팝업 슬라이더를 사용하여 JPEG 이미지의 품질을 설정합니다.

  7. 내보낼 상태를 선택하고 상태 속도를 초 단위로 입력합니다.

  8. [확인]을 클릭한 다음 [내보내기] 대화 상자에서 [저장]을 클릭합니다.

투명 8비트 PNG 파일 내보내기

투명 32비트 PNG 파일을 내보내려면 Fireworks PNG 소스 파일을 직접 Flash로 가져오기만 하면 됩니다. 투명 8비트 PNG 파일을 내보내려면 다음 절차를 완료합니다.

  1. Fireworks에서 [윈도우] > [최적화]를 선택하여 [최적화] 패널을 엽니다.

  2. [내보내기 파일 형식]으로 [PNG 8]을 선택하고 [투명도] 팝업 메뉴에서 [알파 투명도]를 선택합니다.

  3. [파일] > [내보내기]를 선택합니다.

  4. [파일 형식] 팝업 메뉴에서 [이미지만]을 선택합니다.

  5. 파일 이름을 입력하고 파일을 저장합니다.

내보낸 Fireworks 그래픽 및 애니메이션을 Flash로 가져오기

  1. Flash에서 새 문서를 만듭니다.

    참고:

    Fireworks 그래픽을 기존 Flash 파일로 가져오는 경우에는 Flash에서 새 레이어를 만듭니다.

  2. [파일] > [가져오기]를 선택한 다음 그래픽이나 애니메이션 파일을 찾습니다.

  3. [열기]를 클릭하여 파일을 가져옵니다.

Fireworks를 사용하여 Flash에서 그래픽 편집

실행 및 편집 통합 기능을 사용하면 Fireworks에서 내보낸 그래픽이 아니더라도, 이전에 Flash로 가져온 그래픽을 Fireworks에서 변경할 수 있습니다.

참고:

Flash로 가져온 Fireworks 기본 PNG 파일의 경우에는 PNG를 병합된 비트맵 이미지로 가져와야만 변경할 수 있습니다.

그래픽을 Fireworks에서 내보냈으며 원본 PNG 파일을 저장한 경우에는 Flash 안에서 Fireworks로 PNG 파일을 편집할 수 있습니다. 편집을 마친 후 Flash로 돌아오면 PNG 파일과 Flash의 그래픽이 모두 업데이트됩니다.

  1. Flash의 [문서 라이브러리] 패널에서 그래픽 파일을 마우스 오른쪽 단추로 클릭(Windows) 또는 Control 키를 누른 상태에서 클릭(Mac OS)합니다.

  2. 팝업 메뉴에서 [Fireworks로 편집]을 선택합니다.

    참고:

    팝업 메뉴에 [Fireworks로 편집] 항목이 표시되지 않으면 [편집기 선택]을 선택한 다음 Fireworks 응용 프로그램을 찾습니다.

  3. Fireworks 그래픽의 원본 PNG 파일을 찾으려면 [소스 찾기] 상자에서 [예]를 클릭한 다음 [열기]를 클릭합니다.

  4. 이미지를 편집하고, 끝나면 [완료]를 클릭합니다.

    Fireworks에서 새 그래픽 파일을 Flash로 내보내고 원본 PNG 파일을 저장합니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책