Utilice el panel Historial en Dreamweaver para reproducir y automatizar los pasos. Cree, use y guarde los comandos de los pasos del historial.

Nota:

El panel Historial ya no existe en Dreamweaver CC 2017 ni en versiones posteriores. 

Automatización de tareas

El panel Historial graba los pasos que realiza al llevar a cabo una tarea. Automatice una tarea que realice con frecuencia reproduciendo de nuevo dichos pasos del panel Historial o creando un nuevo comando que lleve a cabo los pasos automáticamente.

Algunos movimientos del ratón, como seleccionar haciendo clic en la ventana de documento, no se pueden reproducir ni guardar. Al realizar un movimiento de ese tipo, aparece una línea negra en el panel Historial (dicha línea no es visible hasta que se realiza otra acción). Para evitar esto, utilice las teclas de flecha en lugar del ratón para mover el punto de inserción dentro de la ventana de documento.

Hay otros pasos que tampoco pueden repetirse, como arrastrar un elemento a otro lugar de la página. Al dar un paso de ese tipo, aparece un icono con una pequeña X roja en el panel Historial.

Los comandos guardados se conservan de manera permanente (a no ser que los elimine), mientras que los comandos grabados se eliminan al salir de Adobe Dreamweaver y las secuencias copiadas de los pasos se eliminan al copiar otro objeto.

Utilización del panel Historial

El panel Historial (Ventana > Historial) muestra una lista de todos los pasos realizados en el documento activo desde que éste se creó o se abrió (pero no los pasos dados en otros marcos, en otras ventanas de documento o en el panel Sitio). Utilice el panel Historial para deshacer varios pasos a la vez y para automatizar tareas.

Historial, panel
Historial, panel

A. Regulador (pulgar) B. Pasos C. Botón Reproducir D. Botón Copiar pasos E. Botón Guardar como comando 

El control deslizante, o el pulgar, del panel Historial señala inicialmente el último paso realizado.

Nota:

No se puede modificar el orden de los pasos en el panel Historial. El panel Historial no es un conjunto arbitrario de comandos, sino una forma de ver los pasos en el orden en que se han dado.

Anulación del último paso

  1. Siga uno de estos procedimientos:
    • Seleccione Edición > Deshacer.

    • Arrastre el control deslizante del panel Historial hasta el paso superior en la lista.

    Nota:

    Para desplazarse automáticamente a un determinado paso, deberá hacer clic a la izquierda del paso; si hace clic en el paso mismo, se seleccionará el paso. Seleccionar un paso no es lo mismo que volver a ese paso en el historial de deshacer.

Anulación de varios pasos a la vez

  1. Arrastre el control deslizante para que señale a cualquiera de los pasos o haga clic a la izquierda de un paso a lo largo del recorrido del control deslizante.

    El control deslizante se desplazará automáticamente a dicho paso y los pasos se desharán conforme se desplace.

    Nota:

    Como ocurre al deshacer un solo paso, si deshace una serie de pasos y, a continuación, realiza una nueva operación en el documento, no podrá rehacer los pasos deshechos, pues habrán desaparecido del panel Historial.

Definición del número de pasos que el panel Historial mantiene y muestra

El número de pasos predeterminado suele ser válido para la mayoría de las necesidades de los usuarios. Cuanto mayor sea el número, más memoria necesitará el panel Historial, lo que puede afectar al rendimiento y hacer que el equipo pierda velocidad de forma significativa.

  1. Seleccione Edición > Preferencias (Windows) o Dreamweaver > Preferencias (Macintosh).
  2. Seleccione General en la lista Categoría de la izquierda.
  3. Introduzca un número para Número máximo de pasos de historial.

    Cuando el panel Historial alcanza el número máximo de pasos, los pasos más antiguos se borran.

Borre la lista de historial para el documento actual:

  1. En el menú contextual del panel Historial, seleccione Borrar historial.

    Este comando también borra toda la información de deshacer del documento actual. Después de elegir Borrar historial, no podrá deshacer los pasos borrados. Borrar historial no deshace los pasos realizados, sino que simplemente quita el registro de esos pasos de la memoria.

Repetición de pasos

Utilice el panel Historial para repetir el último paso que ha realizado, repetir una serie de pasos consecutivos o repetir una serie de pasos no consecutivos. Reproduzca de nuevo los pasos directamente desde el panel Historial.

Repita un paso

  1. Siga uno de estos procedimientos:
    • Seleccione Edición > Rehacer.

    • En el panel Historial, seleccione el paso y haga clic en el botón Reproducir. El paso se reproducirá y aparecerá una copia suya en el panel Historial.

Repetición de una serie de pasos

  1. Seleccione los pasos del panel Historial:
    • Para seleccionar pasos adyacentes, arrastre de un paso a otro (no arrastre el control deslizante, sino tan sólo de la etiqueta de texto de un paso hasta la etiqueta de texto de otro paso) o seleccione el primer paso y luego presione Mayús mientras hace clic en el último paso.

    • Para seleccionar pasos no adyacentes, seleccione un paso y, a continuación, haga clic en otros pasos mientras presiona la tecla Control (Windows) o la tecla Comando (Macintosh) para seleccionarlos o anular su selección.

      Los pasos reproducidos son los pasos seleccionados (resaltados) y no necesariamente el paso al que señala el control deslizante.

    Nota:

    Aunque puede seleccionar una serie de pasos que incluyan una línea negra que indica un paso que no puede grabarse, dicho paso se omite al reproducir de nuevo los pasos.  

  2. Haga clic en Reproducir.

    Los pasos se reproducirán en orden y aparecerá un nuevo paso, Reproducir pasos, en el panel Historial.

Establecimiento o ampliación de una selección

  1. Mantenga presionada la tecla Mayús mientras presiona una tecla de flecha.

    Nota:

    Si aparece una línea negra que indica un movimiento del ratón mientras está realizando una tarea y desea repetirla más tarde, puede deshacer este paso e intentarlo de otra forma, quizá mediante la utilización de las teclas de flecha.

Aplicación de pasos del panel Historial a los objetos

Puede aplicar una serie de pasos del panel Historial a cualquier objeto de la ventana de documento.

Si selecciona varios objetos y, a continuación, les aplica pasos desde el panel Historial, los objetos se considerarán como una única selección a la que Dreamweaver intentará aplicar los pasos de forma combinada; no obstante, solo puede aplicar un conjunto de pasos a un único objeto cada vez.

Para aplicar los pasos a cada objeto de un conjunto de objetos, compruebe que el último paso de la serie selecciona el siguiente objeto del conjunto. El segundo procedimiento demuestra este principio en un escenario concreto: establecer el espaciado vertical y horizontal de una serie de imágenes.

Aplicación de pasos a otro objeto

  1. Seleccione el objeto.
  2. Seleccione los pasos pertinentes en el panel Historial y, a continuación, haga clic en Reproducir.

Aplicación de pasos a varios objetos

  1. Comience con un documento en el que cada línea contenga una pequeña imagen (por ejemplo, una viñeta gráfica o un icono) seguida de texto.

    El objetivo es separar las imágenes del texto y de otras imágenes situadas por encima y por debajo de ellas.

    Cada línea consta de una imagen pequeña
    Cada línea consta de una imagen pequeña

  2. Abra el inspector de propiedades (Ventana > Propiedades), si aún no está abierto.
  3. Seleccione la primera imagen.
  4. En el inspector de propiedades, introduzca números en los cuadros Espacio V y Espacio H para definir el espaciado de la imagen.
  5. Haga clic de nuevo en la imagen para activar la ventana de documento sin tener que mover el punto de inserción.
  6. Presione la tecla Flecha izquierda para mover el punto de inserción a la izquierda de la imagen.
  7. Presione la tecla Flecha abajo para mover el punto de inserción una línea hacia abajo, dejándolo justo a la izquierda de la segunda imagen de la serie.
  8. Presione Mayús+Flecha derecha para seleccionar la segunda imagen.

    Nota:

    No seleccione la imagen haciendo clic en ella. De lo contrario, no podrá reproducir todos los pasos.

  9. Seleccione en el panel Historial los pasos correspondientes al cambio de espaciado de la imagen y la selección de la imagen siguiente. Haga clic en Reproducir para reproducir esos pasos.
    Haga clic en Reproducir para reproducir los pasos.
    Haga clic en Reproducir para reproducir los pasos.

    El espaciado de la imagen actual cambiará y se seleccionará la imagen siguiente.

    Cambios en el espaciado de la imagen actual
    Cambios en el espaciado de la imagen actual

  10. Siga haciendo clic en Reproducir hasta que haya establecido correctamente el espaciado de todas las imágenes.

Copia y pegado de pasos entre documentos

Todos los documentos abiertos tienen su propio historial de pasos. Puede copiar los pasos de un documento y pegarlos en otro.

Al cerrar un documento se borra su historial. Si sabe que posteriormente va a utilizar pasos de un documento, copie o guarde los pasos antes de cerrar el documento.

  1. En el documento que contiene los pasos que desea reutilizar, seleccione los pasos en el panel Historial.
  2. Haga clic en Copiar pasos en el panel Historial .

    Nota:

    El botón Copiar pasos del panel Historial es diferente al comando Copiar del menú Edición. No puede utilizar Edición > Copiar para copiar pasos, aunque utilice Edición > Pegar para pegarlos.

    Hay que tener cuidado al copiar pasos que incluyan los comandos Copiar o Pegar:

    • No utilice Copiar pasos si uno de los pasos es un comando Copiar, ya que es posible que no pueda pegar dichos pasos de la manera deseada.

    • Si entre los pasos figura un comando Pegar, no podrá pegar dichos pasos a no ser que los pasos también incluyan un comando Copiar antes del comando Pegar.

  3. Abra el otro documento.
  4. Coloque el punto de inserción donde desee o seleccione un objeto para aplicarle los pasos.
  5. Seleccione Edición > Pegar.

    Los pasos se reproducirán a medida que se peguen en el panel Historial del documento. El panel Historial los muestra como un solo paso, denominado Pegar pasos.

    Si ha pegado pasos en un editor de texto o en la vista de Código o el inspector de código, aparecerán como código JavaScript. Esta opción puede resultar útil para aprender a escribir scripts.

Creación y utilización de comandos de pasos del historial

Guarde un conjunto de pasos de historial como un comando con nombre y podrá acceder a él desde el menú Comandos. Cree y guarde un comando si es posible que vaya a utilizar un conjunto determinado de pasos en el futuro, especialmente la próxima vez que inicie Dreamweaver.

Creación de un comando

  1. Seleccione un paso o un conjunto de pasos en el panel Historial.
  2. Haga clic en el botón Guardar como comando o seleccione Guardar como comando en el menú contextual del panel Historial.
  3. Introduzca un nombre para el comando y haga clic en Aceptar.

    El comando aparecerá en el menú Comandos.

    Nota:

    El comando se guardará como archivo JavaScript (o, en ocasiones, como un archivo HTML) en la carpeta Dreamweaver/Configuration/Commands. Si utiliza Dreamweaver en un sistema operativo multiusuario, el archivo se guardará en la carpeta Commands específica del usuario.

Utilización de un comando guardado

  1. Seleccione un objeto al que aplicar el comando o coloque el punto de inserción donde desee aplicar el comando.
  2. Seleccione el comando en el menú Comandos.

Edición del nombre de un comando

  1. Seleccione Comandos > Editar lista de comandos.
  2. Seleccione un comando para cambiar su nombre, introduzca un nombre nuevo y luego haga clic en Cerrar.

Eliminación de un nombre del menú Comandos

  1. Seleccione Comandos > Editar lista de comandos.
  2. Seleccione un comando.
  3. Haga clic en Eliminar y, seguidamente, en Cerrar.

Grabación y almacenamiento de comandos

Grabe un comando temporal para utilizarlo a corto plazo o grabe y guarde un comando para utilizarlo posteriormente. Dreamweaver solo conserva un comando grabado cada vez; en cuanto comience a grabar otro, se perderá el antiguo, a no ser que lo guarde antes de grabar el nuevo comando.

Grabación temporal de una serie de pasos

  1. Seleccione Comandos> Iniciar grabación o presione Control+Mayús+X (Windows) o Comando+Mayús+X (Macintosh).

    El puntero cambiará para indicar que se está grabando un comando.

  2. Cuando termine de grabar, seleccione Comandos> Detener grabación o presione Control+Mayús+X (Windows) o Comando+Mayús+X (Macintosh).

Reproducción de un comando grabado

  1. Seleccione Comandos > Reproducir comando grabado.

Almacenamiento de un comando grabado

  1. Seleccione Comandos > Reproducir comando grabado.
  2. Seleccione el paso Ejecutar comando que aparece en la lista de pasos del panel Historial y haga clic en el botón Guardar como comando.
  3. Introduzca un nombre para el comando y haga clic en Aceptar.

    El comando aparecerá en el menú Comandos.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea