The Develop module contains two sets of panels and a toolbar for viewing and editing a photo. On the left are the Navigator, Presets, Snapshots, History, and Collections panels for previewing, saving, and selecting changes you’ve made to a photo. On the right are the tools and panels for making global and local adjustments to a photo. The toolbar contains controls for tasks such as changing between Before and After views, playing an impromptu slide show, and zooming.

Video tutorial: Develop basics

Video tutorial: Develop basics

Lightroom Develop module
The Develop module

A. Presets, Snapshots, History, and Collections panels B. Toolbar C. Histogram D. Photo information E. Smart Preview Status F. Tool strip G. Adjustment panels 


  • The Histogram panel in the Develop module allows you to measure color tones as well as make tonal adjustments to the photo.
  • Additional information about the Smart Preview status of the photograph is displayed below the histogram/EXIF information/RGB values.


  • The tools in the tool strip let you fix red eye, remove dust and spots, crop and straighten photos, and apply adjustments to specific areas of a photo.

  • The Basic panel contains the main tools for adjusting the photo’s white balance, color saturation, and tonal scale.

  • The Tone Curve and HSL/Color/B&W panels contain tools for fine-tuning your color and tonal adjustments.

  • The Split Toning panel colors monochrome images or creates special effects with color images.

  • The Detail panel lets you adjust sharpness and reduce noise.

  • The Lens Corrections panel lets you correct chromatic aberration and lens vignetting caused by the camera lens.

  • The Effects panel lets you apply a vignette to a cropped photo, add a film-grain effect, or adjust the amount of haze or fog in a photograph.

  • The Camera Calibration panel makes adjustments to the default calibration settings for your camera.

Show or hide the Develop toolbar

Choose View > Show Toolbar or Hide Toolbar, or press the T key.

Tools in the tool strip

Tools for performing local edits to specific areas of a photo are located in the tool strip under the Histogram panel. Select any tool to display its options in the tool drawer. Deselect the tool to close the drawer and revert to the Hand or Zoom tool.

Crop Overlay

Includes the Crop Overlay tool, Crop Frame tool, Aspect Ratio Lock button and options, Straighten tool, and Straighten slider.

Spot Removal

Includes Clone or Heal options and the Size slider. Click Reset to clear the changes to the photo.

Red Eye Correction

Includes Pupil Size and Darken sliders. Click Reset to clear the changes to the photo.

Graduated Filter

Includes options for making tonal adjustments across a region of a photo.

Radial Filter  Includes options for creating multiple, off-center, vignetted areas to highlight specific portions of a photo.

Adjustment Brush

Includes options for brushing Exposure, Clarity, Brightness, and other tonal adjustments on specific areas of a photo.

Additional Develop module buttons and tools

Hand/Zoom tool

When you hold the pointer over the photo, R, G, and B color values display under the Histogram. The tool that appears changes depending on your view. The Zoom tool is selected if the magnification is Fit. The Hand tool is selected if the magnification is Fill, 1:1, or higher. Click the photo to toggle between Fit and 1:1.

White Balance Selector

Click this tool in the Basic panel, choose it from the View menu, or press W to select it. Options appear in the toolbar.

Targeted Adjustment

Lets you adjust certain color and tone sliders by dragging the tool in the photo. Select it in the Tone Curve or HSL/Color/B&W panels, or choose it from the View menu. Once the tool is selected, you can choose different targets from the Target Group pop-up menu in the toolbar.

Loupe View

Although this single-photo view is available in both the Develop and Library modules, the keyboard shortcut for Loupe view in the Develop module (the D key) is different from the keyboard shortcut in the Library module (the E key). The Loupe View button, located in the toolbar, lets you quickly switch to Loupe view in each module.

Copy and Paste

These buttons at the bottom of the left panels let you copy or paste the current settings to a selected photo.

Previous, Sync, and Auto Sync

These buttons at the bottom of the right panels toggle according to whether you have one or more photos selected in the Filmstrip. If only one photo is selected, the Previous button lets you copy and paste all of the settings of the previously selected photo to the currently selected photo on the Filmstrip. If multiple files are selected, the Sync button lets you choose which of the current settings to paste from the currently selected photo onto the other selected photos. Auto Sync adjusts other selected photos automatically after each slider is moved. Press Ctrl (Windows) or Command (Mac OS) to turn the Sync button into the Auto Sync button.

Before and After views

The Before And After Views button in the toolbar offers four choices. You can arrange two photo views side by side or top to bottom, display the whole photo in both views, or split the photo in two. Click the Loupe View button to turn off Before and After views.

Copy settings

These three buttons let you copy and paste the current settings from the After view to the Before view, from the Before view to the After view, or swap between the views. They appear in the toolbar when you have selected the Before and After view in the Develop module.

Select tools and options

Click the tool or choose it from the Tools menu. To deselect a tool, click it, click Done, or select or a different tool. 

Create and apply Develop presets

Presets provide a way to save a group of settings and apply them to other photos. Once you create and add a preset to the Presets panel in the Develop module, it remains there until you delete it. It also appears in the list of Develop settings that you can select it when you import photos.

Preview and apply a Develop preset

A set of default presets is listed in the Presets panel of the Develop module. Click the Lightroom Presets folder to display the default presets.

  • To preview the effects of a preset on your photo, move the pointer over it in the Presets panel and view the effects in the Navigator panel.
  • To apply a preset to the photo, click it in the Presets panel.

Create and organize Develop preset folders

  1. Right-click (Windows) or Control-click (Mac OS) the area where you want the folder to appear and choose New Folder.
  2. Type the name of the folder and click OK.
  3. Drag a template to a folder name to move the template to that folder.

If you drag a Lightroom preset template to a different folder, the template is copied to that folder.

Create a Develop preset

Presets you create are based on the current settings of the selected photo.

  1. In the Develop module, click the Create New Preset (+) button at the top of the Presets panel or choose Develop > New Preset.
  2. Click Check All to select everything or click Check None to deselect everything, and then click to select each of the settings to include in the preset.
  3. Type a name in the Preset Name box, specify which folder the preset should appear in, and click Create.

    The preset is added to the list in the Presets panel in the specified folder.

Update a Develop preset

  1. Select a user preset and modify settings as needed.
  2. Right-click (Windows) or Control-click (Mac OS) a preset in the Presets panel and choose Update With Current Settings.
  3. Specify the settings you want to include in the preset and click Update.

Delete a custom preset

You cannot delete built-in Lightroom presets. You can delete only custom presets.

  • In the Develop module, right-click (Windows) or Control-click (Mac OS) a preset in the Presets panel and choose Delete.


    Do not press the Delete key on your keyboard; this deletes the currently selected photo.

Determine where custom presets are stored

By default, custom (user) presets are stored in a folder in the Lightroom folder. For the specific locations on Mac OS and Windows, see Preference and other file locations in Lightroom 5.

  • To store user presets in a folder with the catalog, in the Presets panel of the Preferences dialog box, select Store Presets With Catalog.
  • To see where a user preset is located, right-click (Windows) or Control-click (Mac OS) it in the Presets panel of the Develop module and choose Show In Explorer (Windows) or Show In Finder (Mac OS).

Import and export a Develop preset

You can export presets you’ve created to share with colleagues or to use on a different computer. Preset templates are saved with an .lrtemplate extension.

  • To export a preset, right-click (Windows) or Control-click (Mac OS) a preset and choose Export. Type the name of the preset template file and click Save.
  • To import a preset, right-click (Windows) or Control-click (Mac OS) the area where you want the preset to appear and choose Import. Double-click the preset template file.

Undo image adjustments

Lightroom provides several ways to undo, or reset, adjustments you make to photos as you’re working in the Develop module.


Save a snapshot or preset of your settings before undoing them so that you don’t completely lose the settings.

To undo adjustments in the Develop module, do any of the following:

  • Click the Reset button to revert back to the Lightroom default settings.
  • Click the General - Zeroed preset in the Presets panel to remove all settings completely.
  • Select an earlier version in the History panel or Snapshots panel that occurred before you applied the settings.
  • Double-click individual slider controls to reset the sliders to zero.
  • Choose Undo from the Edit menu. Lightroom tracks each setting you make. You can undo all of them by choosing Undo multiple times.

View Before and After photos

You can compare two versions of a photo as you apply Develop settings to it. The Before view first displays the photo as it was originally imported, including any presets that were applied. The photo remains unchanged unless you copy settings to it. The After view shows changes as you make them. Zooming and panning are synchronized in the two views.

  • To switch the Before and After views one at a time in Loupe view, press the backslash (\ ) key or choose View > Before/After > Before Only. The word “Before” appears in the lower-right of the image.
  • To display the Before and After photos in two views together, click the Before And After Views button on the toolbar to toggle through the choices or choose an option from the pop-up menu.

    Before/After Left/Right:

    Displays two whole versions of the photo in two views, side-by-side on the screen.

    Before/After Left/Right Split :

    Displays two halves of the photo split into two views, side-by-side on the screen.

    Before/After Top/Bottom:

    Displays two whole versions of the photo in two views, one on top of the other.

    Before/After Top/Bottom Split:

    Displays two halves of the photo split into two views, one on top of the other.

Copy settings to the Before or After version of a photo

When you are working in a Before and After view of your photo, you can apply the settings of one version to the other, and vice versa.

  • In the toolbar, click the Copy Settings From The Before Photo To The After Photo button.
  • In the toolbar, click the Copy Settings From The After Photo To The Before Photo button.
  • Click Swap Before And After Settings.
  • Choose Settings > Copy After’s Settings To Before.
  • Choose Settings > Copy Before’s Settings To After.
  • Choose Settings > Swap Before And After Settings.


These menu commands are also available when you’re viewing Before and After versions of your photo in Loupe view.

All of the current settings for one version are copied to the other version. To copy a single history setting, right-click (Windows) or Control-click (Mac OS) a state in the History panel and choose Copy History Step Settings To Before.

Editing HDR images

In Lightroom 4.1 or later, you can import and work with 16-, 24-, and 32-bit floating point images—often referred to as HDR (high dynamic range images.) You can use the Develop module controls to edit HDR images, and then render the images for export or printing as 8-bit or 16-bit images. Lightroom imports TIFF and DNG format HDR images. Make sure the images are in process version 2012. See Process versions.

The Develop module Exposure control has an expanded range when working with HDR images (+10 to -10).

Lightroom imports HDR images, but does not assemble them. To assemble a 32-bit image, you can choose the images in the Library and then edit them in Photoshop. Make sure to save the HDR files as a 32-bit TIFF. See Merge photos to HDR in Photoshop.


Set your Lightroom preferences to save files edited in Photoshop as Tiff . Choose Lightroom > Preferences (Mac) or Edit > Preferences (Windows). In the External Editing section under Edit in Adobe Photoshop <version>, choose Tiff for File Format. The <version> of Photoshop may vary based on the version of Adobe Photoshop installed.

For more information about HDR images, see High dynamic range images in Photoshop help.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy