Find quick answers to frequently asked questions about catalogs in Lightroom Classic.

What is a catalog?

A catalog is a database that tracks the location of your photos and information about them. When you edit photos, rate them, add keywords to them, or do anything to photos in Lightroom Classic - all those changes are stored in the catalog. The files themselves are not touched. 

When you start Lightroom Classic for the first time, an empty catalog file (for example, Lightroom 5 Catalog.lrcat) is automatically created. To start working with this default and empty catalog, click the Import button.

Note:

Where are my images and catalog located?

See Open a file in Explorer or Finder to learn about where your images are saved. Do note that your images are not stored in the Lightroom Classic app.

Your Lightroom Classic catalogs are located in the following folders, by default:

  • Windows: \Users\[user name]\Pictures\Lightroom
  • macOS: /Users/[user name]/Pictures/Lightroom

To check your default catalog, choose Edit > Preferences > General and check Default Catalog.

For more information, see:

Note:

If you've moved your catalog and can't remember where it is, search for "lrcat" in the Explorer (Windows) or Finder (macOS).

How do I open my old catalog in my new version of Lightroom Classic?

You can easily upgrade your old catalog in the new version of Lightroom Classic. See Upgrade a catalog from an earlier version of Lightroom Classic.

Note:

If you are having trouble in upgrading a catalog, open the old catalog in your previous version of Lightroom Classic and export it as a new catalog. You can then import the exported catalog into the new version of Lightroom Classic. For more information, see Export a catalog or watch this video tutorial.

How do I merge two catalogs or import folders from another catalog?

  1. Choose File > Open Catalog and select the catalog that you want as the master (or primary) catalog. This is the catalog you want to add photos to.

  2. Choose File > Import From Another Catalog and navigate to the catalog that contains the photos you want to add from. Then, click Open (Windows) or Choose (macOS).

  3. In the Import From Catalog dialog box:

    1. Under Catalog Contents, select the folders that contain the photos you want to import.

    2. Specify how you want to handle new and existing photos. For more information on these options, see Import photos from a different Lightroom Classic catalog.

  4. Click Import.

    Repeat steps 1 – 4 for additional catalogs or photos that you want to add to the open one.

Note:

Looking for a video tutorial? We've got you covered. See Merging individual catalogs into a master catalog.

How can I use my catalog on two different computers?

The easiest way to use your Lightroom Classic catalog on more than one computer (such as a desktop and laptop) is to keep the catalog and photos together on an external drive. Then, you can set that catalog as the default catalog in Lightroom Classic Preferences.

Note:

Using multiple catalogs is not recommended. To know more, see Benefits of using a single catalog.

How do I move a catalog to a different drive or computer?

You can move your catalog to a different location on your computer's hard drive, to an external disk, or to another computer altogether. For details, see Move a catalog.

To move a catalog between a Windows computer and a Mac, copy your catalog, preview, and image files from the original computer onto an external drive. Then, attach the drive to the second computer and copy the files to the desired location on the second computer.

Note:

How do I open or switch between different catalogs?

To open a different catalog, choose File > Open Catalog, navigate to the location of the catalog you want to open, and click Open.

If you have multiple catalogs, you can tell Lightroom Classic which one to open when you start the program. To know more, see Change the default catalog.

Note:

It is not recommended to use multiple catalogs. To know more, see Benefits of using a single catalog.

Are catalogs in Lightroom Classic backward compatible?

No, the catalogs in Lightroom Classic aren't backward compatible. Catalogs from a new Lightroom Classic version cannot be opened in the older versions.

When you try to open a catalog from a new version into an older Lightroom Classic version, you get a dialog displaying: The Lightroom catalog named [Your Catalog Name] cannot be opened because it is too new to be used by this version of Lightroom.

To work in the older versions, import the required photos into Lightroom Classic and create another catalog from that version.

Check the table below to know your catalog compatibility:

Version Catalog compatibility
Lightroom Classic 9.x
  • Not compatible with Lightroom Classic 8.x, Lightroom Classic CC 7.x, Lightroom CC 2015.x, Lightroom 6.x, Lightroom 5.x, and earlier versions
Lightroom Classic 8.x
  • Compatible with Lightroom Classic CC 7.x
  • Not compatible with Lightroom CC 2015.x, Lightroom 6.x, Lightroom 5.x, and earlier versions
Lightroom Classic CC 7.x
  • Not compatible with Lightroom CC 2015.x, Lightroom 6.x, Lightroom 5.x, and earlier versions
Lightroom CC 2015.x
  • Compatible with Lightroom 6.x
  • Not compatible with Lightroom 5.x, Lightroom 4.x, and earlier versions
Lightroom 6.x
  • Compatible with Lightroom CC 2015.x
  • Not compatible with Lightroom 5.x, Lightroom 4.x, and earlier versions
Lightroom 5.x
  • Not compatible with Lightroom 4.x, and earlier versions

How do I rename a catalog?

You can rename a catalog in the Explorer (Windows) or Finder (macOS). If you rename a catalog, make sure you rename its corresponding Previews and Smart Previews files as well.

  1. Close Lightroom Classic.

  2. Navigate to your catalog and its preview files in the Explorer (Windows) or Finder (macOS). They should be in the same folder.

  3. Rename all three files. Make sure to retain 'Previews' in the preview cache files. For example, for 'Lightroom 5 Catalog Previews.lrdata' is renamed to 'My trip catalog Previews.lrdata'.

Note:

After you rename your catalog, you may need to help Lightroom Classic find it. See Lightroom Classic can't find my catalog. How do I find it?

How can I export a folder as a catalog?

To export a folder as a catalog, in the Folders panel of the Library module, right-click (Windows)/Control-click (macOS) the folder you want to export. From the context menu, select Export this Folder as a Catalog.

How do I back up a catalog and manage backup storage?

You can back up your catalog automatically when you quit Lightroom Classic or back up manually. To plan your backup strategy to manage storage and back up your catalog, see Plan your backup strategy.

Note:

Backing up your catalog does not back up the photos it references. To understand what a catalog is, see What is a catalog?

Are my images being backed-up on Cloud?

No, but you can sync smart previews of your photos from Lightroom Classic to the Lightroom ecosystem. To know more, see Sync Lightroom Classic with Lightroom ecosystem.

How do I delete a catalog?

To learn how to delete a catalog, see Delete a catalog.

Note:

When you delete a catalog, you're not deleting any photos nor are you removing the Lightroom Classic app itself. For more information, see Uninstall or remove Creative Cloud appsUninstall Lightroom manually, and Remove photos from catalogs.

Can I store or share a catalog on a network?

No, you can't store catalogs on a network but you can store or share your photos on a network. Smart Previews let you edit your photos in Lightroom Classic even when you are disconnected from the network or when your computer is disconnected from the drive that has your photos.

Lightroom Classic can't find my catalog. How do I find it?

If you move or rename your catalog and then try to open Lightroom Classic, you could encounter an error such as Lightroom catalog was not found.

  1. In the Lightroom catalog was not found error window, click Choose A Different Catalog.

    Choose a different catalog to open.
  2. If the catalog you want to open isn’t listed, click Choose A Different Catalog again to open the \Pictures\Lightroom (Windows) or /Pictures/Lightroom (macOS) folder.

  3. Navigate to the location of your renamed or moved catalog, select it, and click Choose.

  4. In the Select Catalog dialog box, your renamed catalog is probably the first catalog in the list. Select it and click Open.

My photos are missing in the catalog. How do I find them?

When you move images in Finder (macOS) or Explorer (Windows), your catalog could lose track of them. To avoid missing photos, always move them from within Lightroom Classic than in the operating system. To know more, see Move photos to a different folder and Locate missing photos.