Utilice los menús de salto para crear enlaces a documentos, correos electrónicos, gráficos, o a cualquier tipo de archivo que pueda abrirse en un navegador.

Acerca de los menús de salto

Un menú de salto es un menú emergente de un documento que pueden ver los visitantes del sitio y que ofrece vínculos con documentos o archivos. Puede crear vínculos con documentos del sitio Web, documentos de otros sitios, correo electrónico, gráficos o cualquier tipo de archivo que se pueda abrir en un navegador.

Cada opción de un menú de salto está asociada a un URL. Cuando los usuarios eligen una opción, se les remite (“saltan”) al URL asociado. Los menús de salto se insertan dentro del objeto de formulario Menú de salto.

Un menú de salto puede contener tres componentes:

  • Opcional: un mensaje de selección de menú, como la descripción de una categoría para los elementos del menú o instrucciones, como “Elija una opción”.

  • Obligatorio: una lista de elementos de menú vinculados: el usuario elige una opción y se abre un documento o un archivo vinculado.

  • Opcional: un botón Ir.

Inserción de un menú de salto

  1. Abra un documento y, a continuación, sitúe el punto de inserción en la ventana de documento.
  2. Siga uno de estos procedimientos:
    • Seleccione Insertar > Formulario > Menú de salto.

    • En la categoría Formulario del panel Insertar, haga clic en el botón Menú de salto.

  3. Rellene el cuadro de diálogo Insertar menú de salto y haga clic en Aceptar. A continuación se incluye una lista parcial de las opciones:

    Botones más (+) y menos (-)

    Haga clic en más para insertar un elemento; haga clic en más de nuevo para añadir otro elemento. Para eliminar un elemento, selecciónelo y haga clic en menos.

    Botones de flecha

    Seleccione un elemento y haga clic en las flechas para que suba o baje puestos en la lista.

    Texto

    Escriba el nombre de un elemento sin nombre. Si el menú incluye un mensaje de selección (por ejemplo “Elija una opción”), escríbalo aquí como primer elemento del menú (si lo hace, también deberá activar la opción Seleccionar primer elemento tras el cambio de URL en la parte inferior).

    Al seleccionarse, ir a URL

    Acceda al archivo de destino o escriba su ruta.

    Abrir URL en

    Especifique si el archivo debe abrirse en la misma ventana o en un marco. Si el marco deseado no aparece en el menú, cierre el cuadro de diálogo Insertar menú de salto y asigne un nombre al marco.

    Insertar botón Ir tras el menú

    Seleccione esta opción para insertar un botón Ir en lugar de un mensaje de selección de menú.

    Seleccionar primer elemento tras el cambio de URL

    Seleccione esta opción si ha insertado un mensaje de selección de menú (“Elija una opción”) como primer elemento del menú.

Edición de elementos del menú de salto

Puede cambiar el orden de los elementos del menú o el archivo con el que está vinculado un elemento. También puede añadir, eliminar o cambiar el nombre de un elemento.

Para cambiar la ubicación en la que se abre un archivo vinculado o para añadir o cambiar un mensaje de selección de menú, deberá aplicar el comportamiento Menú de salto del panel Comportamientos.

  1. Abra el inspector de propiedades (Ventana > Propiedades), si aún no está abierto.
  2. En la vista de Diseño de la ventana de documento, haga clic en el objeto Menú de salto para seleccionarlo.
  3. En el inspector de propiedades, haga clic en el botón Valores de lista.
  4. Utilice el cuadro de diálogo Valores de lista para realizar las modificaciones en los elementos del menú y haga clic en Aceptar.

Solución de problemas relacionados con los menús de salto

Una vez que el usuario selecciona un elemento del menú de salto no podrá volver a seleccionarlo si regresa a esa página o si el cuadro Abrir URL en especifica un marco. Hay dos formas de solucionar este problema:

  • Utilice un mensaje de selección de menú, como una categoría, o instrucciones para el usuario, como “Elija una opción”. Un mensaje de selección de menú vuelve a seleccionarse automáticamente después de cada selección del menú.

  • Utilice un botón Ir, que permite al usuario volver a visitar el vínculo seleccionado actualmente. Cuando utilice un botón Ir con un menú de salto, el botón Ir se convertirá en el único mecanismo que permite al usuario “saltar” al URL asociado a la selección del menú. La selección de un elemento de menú en el menú de salto ya no redirigirá al usuario automáticamente a otra página o marco.

Nota:

Seleccione sólo una de estas opciones por menú de salto en el cuadro de diálogo Insertar menú de salto, ya que se aplican a todo el menú de salto.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea