Importer SVG-filer

Sist oppdatert 29. sep. 2026

Lær hvordan du importerer SVG-filer som innebygde, redigerbare formlag som er klare til å animeres uten konvertering.

Dobbeltklikk inne i Prosjekt-panelet eller bruk Fil > Import > Fil for å bla gjennom og importere SVG-filen.

Notat

Den nyeste versjonen av After Effects lar deg importere filen som opptak eller en komposisjon.

Dra og slipp den importerte SVG-filen inn i Tidslinje-panelet.

Velg laget for å bruke Laginnhold-delen i Egenskaper-panelet for å vise SVG-strukturen.

Egenskaper-panelet er åpent og under Laginnhold er SVG-innholdet listet opp.
Bruk Egenskaper-panelet til å vise innholdet i SVG-filen og justere egenskapene.

Du kan også velge pilen ved siden av laget for å utvide det, og deretter utvide Innhold-delen.Du vil se alle de individuelle elementene og egenskapene deres, som Bane, Fyll og Transform.

Laget med SVG-filen er valgt, og Innhold-delen er utvidet for å vise egenskapene, inkludert Bane, Fyll og Transform.
Utvid Innhold-delen av SVG-laget for å få tilgang til og redigere egenskapene, inkludert Bane, Fyll og Transform.

Du kan bruke disse egenskapene til å animere akkurat som ethvert annet formlag.For eksempel:

  • Animer Banen for å lage morfende effekter
  • Endre fyllfarge over tid for dynamiske overganger
  • Bruk Transform-egenskaper for å skalere, rotere eller flytte elementer uavhengig

Hvis lagene har gradientfyll og strøk, kan du bruke Skaler- og Rotasjon-egenskapene til å animere gradienten.

Et av lagene med et gradientelement er valgt, og Gradientfyll 1 er uthevet.
Bruk Gradientfyll-egenskapene til å justere gradienten eller animere dem.

Importer SVG-fil som opptak eller som en komposisjon

SVG-import i After Effects tilbyr fleksibel og bedre kontroll over hvordan SVG-filer importeres i prosjektet ditt.Med den nyeste versjonen, når du importerer en SVG-fil, kan du velge å hente den inn som opptak eller som en komposisjon.

Importer som opptak

Importer som komposisjon

Importerer SVG som ett enkelt, kontinuerlig rasteriserbart vektorlag.

Importerer SVG som en komposisjon laget av redigerbare formlag.

Opprettholder en forbindelse til den eksterne SVG-filen.

Hvert element konverteres til sin egen redigerbare form.

Bra for enkeltlags vektorgrafikk når du ikke trenger å dele opp kunstverket i deler.

Bra for redigering av baner, former og lagdetaljer når du trenger å animere individuelle elementer.

Du kan kontrollere hvilken importmetode som brukes som standard ved import av SVG-filer ved å angi alternativet Dra flere filer som under Import-innstillingene.

  • macOS: After Effects > Innstillinger > Import > Dra flere filer som
  • Windows: Rediger > Innstillinger > Import > Dra flere filer som
Dialogboksen Innstillinger er åpen.I Import-fanen er rullegardinmenyen Dra flere filer som åpen og tilbyr alternativer for å velge importmetode.
Angi standardinnstillingen for import av en SVG-fil ved å velge om den importeres som opptak eller som komposisjon.

Dobbeltklikk inne i Prosjekt-panelet eller bruk Fil > Import > Fil for å bla gjennom og importere SVG-filen.

Bruk rullegardinmenyen Importer som i dialogboksen Importer fil for å velge ett av følgende:

  • Opptak
  • Komposisjon – Behold lagstørrelser

Ved å velge Opptak importeres filen som ett enkelt flatt lag uten tilgang til individuelle elementer, noe som gjør den egnet for statisk bruk eller når ingen animasjon er nødvendig.Ved å velge Komposisjon – behold lagstørrelser opprettes en ny komposisjon der hvert kildelag importeres separat, tilpasset det faktiske innholdet, noe som gjør ankerpunktene renere og transformasjoner enklere for animasjon.

macOS

Dialogboksen Importer fil er åpen og det er alternativer for å importere filen som opptak eller som komposisjon.

Windows

Dialogboksen Importer fil er åpen og det er alternativer for å importere filen som opptak eller som komposisjon.

Velg følgende alternativer hvis aktuelt:

  • Opprett komposisjon: Oppretter en ny komposisjon ved hjelp av standardinnstillinger og plasserer automatisk den importerte SVG, enten som opptak eller som komposisjon med formlag, i tidslinjen, noe som sparer deg for manuelt å opprette en komposisjon og dra SVG-filen inn i den.
  • Skalerbar vektorgrafikk-sekvens: Importerer flere nummererte SVG-filer og behandler dem som en bilde-for-bilde vektorbildesekvens.

Bruk delen Laginnhold i panelet Egenskaper eller delen Innhold av laget i tidslinjen for å vise og arbeide med individuelle elementer og egenskapene deres hvis du har importert SVG-filen som en komposisjon. Hvis importert som materiale, oppfører den seg som et vanlig lag og kan justeres ved hjelp av standard Transform-egenskaper.

Som med Illustrator-filer, hvis vektorfilen importeres som materiale, kan du velge laget i tidslinjen, høyreklikke og velge Opprett > Opprett former og tekst fra vektorlag for å konvertere den til redigerbare lag, slik at du kan animere individuelle baner, streker og fyllinger.I den nyeste After Effects beta konverteres tekst i kildefilen til redigerbare tekstlag som bevarer skrift, størrelse, fylling, posisjon, stiler, streker og innstillinger for variabel skrift. 

Når du importerer en SVG som materiale, beholder After Effects en direkte kobling til den opprinnelige filen, så eventuelle endringer du gjør i den SVG-en utenfor programmet oppdateres automatisk inne i prosjektet ditt.

Konverter Illustrator-tekst til redigerbare tekstlag

Bruk nye beta-funksjoner

Redigerbar tekst fra Illustrator-filer er nå tilgjengelig for testing og tilbakemelding. Prøv det nå i After Effects (beta).

I den nyeste After Effects-betaen, når et Illustrator-lag importeres som materiale, konverteres all tekst i kildefilen til sitt eget redigerbare tekstlag i stedet for å flates ut til formkonturer.Dette betyr at skrift, størrelse, fylling, posisjon, stiler (som fet og kursiv), streker og innstillinger for variabel skrift alle overføres, så du kan fortsette å redigere teksten direkte i After Effects i stedet for å gjenskape den fra bunnen av eller gå tilbake til Illustrator for å gjøre endringer.

Velg Fil > Import > Fil og deretter Illustrator-filen du vil importere.

I dialogboksen Importer fil, sørg for at Importer som er satt til Materiale når du velger filen som skal importeres.

I importdialogboksen, bekreft at Importtype er satt til Materiale og velg Lagalternativer basert på hva du vil importere fra Illustrator-filen.

Dra den importerte filen til panelet Tidslinje.

Høyreklikk Illustrator-laget og velg Opprett > Opprett former og tekst fra vektorlag, eller bruk Lag > Opprett > Opprett former og tekst fra vektorlag.

Lag > Opprett-undermeny med Opprett former og tekst fra vektorlag uthevet, som konverterer vektortekst til redigerbare tekstlag.
Velg Opprett former og tekst fra vektorlag for å konvertere Illustrator-tekst til redigerbare After Effects-tekstlag i stedet for former.

Teksten konverteres til et redigerbart tekstlag som ligger tett opp til skrift, størrelse, fylling og posisjon i den opprinnelige filen.Du kan deretter redigere og justere teksten direkte i After Effects.

Lysstyrke-tekstlag over en flammegrafikk, med Tegn-panelet som viser Adobe Clean Italic-skrift, 74 px størrelse og Fylling aktivert.
Etter konvertering forblir teksten fullt redigerbar — skrift, stil, størrelse og fylling kan fortsatt endres i Tegn-panelet.

Notat

Tekst med bare strek konverteres fortsatt som baner i stedet for et redigerbart tekstlag. 

Ikke-tekst vektorinnhold konverteres fortsatt til formlag som før, og hvis Illustrator-filen inneholder begge deler, vil du få en blanding av tekst- og formlag.

Delta i diskusjonen i After Effects (Beta)-fellesskapet vårt om støtte for redigerbar tekst fra Illustrator-filer.

Kopier og lim inn Illustrator- og SVG-innhold

SVG-innhold fra utklippstavlen kan nå limes inn i After Effects ved å bruke Rediger > Lim inn. Innehållet importeres som innfødte, redigerbare formlag som er klare for animering, uten at det kreves mellomliggende importtrinn.

Kopier innhold fra Illustrator

Åpne kunstverket ditt i Adobe Illustrator.

Bekreft at innstillingen Inkluder SVG-kode er valgt.

  • macOS: Velg Illustrator > Innstillinger > Utklippstavlehåndtering og velg Inkluder SVG-kode.
  • Windows: Velg Rediger > Innstillinger > Utklippstavlehåndtering og velg Inkluder SVG-kode.
Dialogboksen Innstillinger er åpen i Illustrator og alternativet Inkluder SVG-kode er valgt.
Aktiver Inkluder SVG-kode for å holde kunstverket ditt redigerbart og med høy kvalitet i andre Adobe-apper.

Velg kunstverket du vil kopiere.

Tips

Konverter eventuell SVG-tekst til kurver før kopiering, siden SVG-tekst ikke støttes ved innliming.

Velg Rediger > Kopier.

Bytt til After Effects og gjør ett av følgende avhengig av prosjektets tilstand:

  • Hvis ingen prosjekter er åpne, velg Rediger > Lim inn for å opprette et nytt prosjekt med en komposisjon som inneholder SVG-innholdet som et formlag.
  • Hvis et prosjekt er åpent, men ingen komposisjon er valgt, velg Rediger > Lim inn for å opprette en ny komposisjon i det gjeldende prosjektet som inneholder det innlimte innholdet.
Alternativet Rediger > Lim inn er valgt, og innholdet importeres som innfødte, redigerbare formlag som er klare for animering.
Rediger > Lim inn henter inn innhold som redigerbare formlag, klare for animering.

Hvis en komposisjon er valgt i After Effects, velg Rediger > Lim inn for å legge til SVG-innholdet som et nytt formlag i den komposisjonen.

Lim inn SVG fra andre apper

SVG-innhold kopiert fra et hvilket som helst program som skriver SVG til systemets utklippstavle, kan limes inn ved hjelp av samme Rediger > Lim inn-arbeidsflyt.Støtte avhenger av om kildeapplikasjonen plasserer gyldige SVG-data på utklippstavlen.