"Error compiling movie. Unknown error" when rendering or exporting

The error can be followed by this message:

"Sorry, a serious error has occurred that requires Adobe Premiere Elements to shut down. We will attempt to save your current project."

Note:

This document is about Adobe Premiere Elements. For a related document about Adobe Premiere Pro, see this page.

Important: Always restart the computer after a problem occurs to refresh its memory. Continuing to work without restarting the computer can compound the problem.

Render the project timeline

Prerendering the project timeline helps you to detect and eliminate problems with particular project media or effects. If an error or problem occurs when you render the timeline, then troubleshoot the media or effect in the timeline. To render, ensure that the work area selection encompasses the entire timeline and under the Timeline pop-up menu, select Render work area.

Convert your file to DV AVI (Windows only)

If you are working with a file that is different from the rest of your footage, convert the file to the DV AVI format.

  1. Create an Adobe Premiere Elements project with the same settings as your clip.
  2. Import only the clip and add it to the timeline/sceneline.
  3. Click Export & Share and select Devices >Computer >720 X 480 resolution.
  4. Select AVI format from the Format dropdown list., type in a filename, and choose a location to save the file. Click Save.
  5. Open your original Premiere Elements project. Under the Project tab, right-click the original file and choose Replace Footage. Select the file created in step 4.
NOTE: DV AVI is a standard and has certain settings for frame rate and size. If these settings do not match your project settings, skip this step.

Remove irregular clips

This type of error is commonly caused by a particular clip in your project. Using footage that is different from most of your clips (for example, from a different camera, different format, different codec, different frame size, different frame rate), could be the source of the issue.

If possible, try removing such clips from your timeline or sceneline and render or export your project again.

Troubleshoot footage or assets used in the project.

  1. Open the project with the issue in Adobe Premiere Elements.
  2. Save your original project, and create a copy of it called test by choosing File > Save As and renaming the project test
  3. In the test project, delete everything in the project from the halfway point to the end
  4. Click Export & Share tab and select Disc. Select the DVD or Blu-ray settings you want, select Disc from the Type dropdown list, and then click Burn:
    • If the error happens again, repeat Steps 2, 3 and 4, testing again with the other (first) half of the content from the timeline.
    • If the error no longer occurs, add back the clips that you removed in small groups and test after each addition. When the error happens again, one of the most recent clips added back to the timeline is the cause.
  5. Once you identify the problem clip, return to your original project and remove or replace the problem clip or file.
  6. Save the corrected version of the project and export it to DVD or Blu-ray disc.

Remove effects

Remove all of the following video effects from long clips:

  • Auto Levels
  • Auto Color
  • Auto Contrast
  • Shadow/Highlight

Auto Levels, Auto Color, Auto Contrast, and Shadow/Highlight are modified effects from Adobe Photoshop.

To remove a video effect, do the following:

1. Select the clip on the timeline/sceneline. Click Edit > Applied Effects panel to open it.

Click Edit

2. Click the Eye to disable the effect or right-click (Ctrl+click) the effect and choose Clear.

Click the Eye to disable the effect

Quit any applications that could be interfering with the render process

If you are using GPU (your video adapter) based effects and transitions (all 3D effects and transitions use the GPU), then make sure that you do not use other GPU intensive applications. (Don't use video games, screen savers, and so on.) Do not allow your system to be locked or hibernate while rendering the timeline or during export.

Use a different codec for your export

If you have customized your Share settings to use a third-party codec (changed by using the Advanced button of the Share settings), try exporting using one of Adobe Premiere Elements built-in presets.

Disable Auto Save

The Auto Save feature could interfere with the export process. Turn it off if you are experiencing problems when you export to your hard disk, DVD, or tape.

To disable Auto Save, do the following:

  1. Choose Edit > Preferences > Auto Save.
  2. Deselect Automatically Save Projects.

  3. Click OK.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy