Use the powerful Shape tools to quickly craft vector shapes. Most shapes are live, which means you can dynamically adjust them, without switching the tool, using the on-shape control widgets or the controls available in the Transform panel.

Live shapes

Create and modify live shapes

  1. Draw a live shape using one of the following tools:

    • Rectangle tool ()
    • Rounded Rectangle tool ()
    • Ellipse tool ()
    • Polygon tool ()
    • Shaper tool ()
    • Line Segment tool ()

    Notă:

    • To view the bounding box when you select an object, ensure that the setting is set to display the bounding box (View > Show Bounding Box).
    • To view the on-screen control widgets when you select any shape, select any live shape drawing tool and ensure that the setting is set to Show Shape Widgets () in the Control panel.

  2. Use the following on-shape control widgets to modify live shapes:

    Scale live shapes Rotate live shapes

    To scale a live shape, drag any of the eight bounding box handles.

    To rotate, move the cursor away from a corner until you see the Rotate icon (), and then drag.


    Move live shapes Create pie shapes

    To move the live shape, use the center point widget to drag it to the desired area.

    For an ellipse, drag one of the pie widgets to create a pie shape.


    Add or remove sides from polygons Change the corner radius of live shapes

    To change the number of the sides of a polygon, drag its side widget.

    Drag any corner widget to change the corner radius of the live shape.


    Notă:

    • When you drag the corners widgets to the maximum possible limit, the preview of the rounded corners is displayed in red.
    • To cycle through corner styles, such as Round, Inverted Round, and Chamfer, Alt-click (Windows) or Option-click (macOS) the corner widget or press Up and Down arrow keys while dragging the widget.
    • To access a Corners menu to customize the appearance and rounding attributes, double-click the widget using the Direct Selection tool. For details, see Work with Live Corners.
    • To edit a corner individually, use the Direct Selection tool and click the anchor point of the corner to modify.

  3. You can modify the shapes using the Control panel, the Properties panel, or the Transform panel (Window > Transform). For details, see Live shapes properties.

    Notă:

    • You can open the Transform panel by double-clicking any corner widget.
    • To specify if the Transform panel appears or not when you create a live shape, use the Show on Shape Creation option in the Transform panel menu.
    • Irrespective of which tool is selected, when shapes of the same type are selected, editing properties in the Transform panel will modify the selected artwork.

Specify live shape options

To view or edit the properties of live shapes, do one of the following:

  • Open the Transform panel by double-clicking any corner widget or choosing Window > Transform.
  • In the Transform section of the Properties panel (Window > Properties), click the More Options () button.

Specify live shape options
Specify live shape options

A. Transform panel B. Properties panel 

Rectangle/Rounded Rectangle

Live shape properties | Rectangle and Rounded Rectangle
  • Width/Height: Specifies the height or width of the rectangle. The corners are maintained, and the radii do not change.
  • Rectangle Angle: Rotate the rectangle, using the Scale/Rotate widget.
  • Corner Type: Specifies the Corner type of any of the corners of the rectangle.
  • Corner Radii: Use the stepper control or type in an absolute value in the Transform panel, for each of the corners of the rectangle.
  • Constrain Width And Height Proportions: Use the Scale Corner checkbox to ensure that corner radii increase or decrease in direct proportion to the object's transformation.

Ellipse

Live shape properties | Ellipse
  • Width/Height: Specifies the width and height of the ellipse. When equal, the ellipse is a circle.
  • Ellipse Angle: Specifies the angle at which the Ellipse is placed on the canvas.
  • Pie Start/Pie End Angle: Use the Pie widget (to the right of a newly-drawn Ellipse shape) to present the shape as a pie chart representation.
  • Constrain Pie Angle: Specifies if the difference in the Pie Start and Pie End Angles must be maintained when modifying their values using the Transform panel.
  • Invert Pie: Specifies when the Pie Start and Pie End Angles must be swapped. Use this to generate a 'slice' graphical representation.

Polygon

Live shape properties | Polygon
  • Polygon Side Count: Specifies the number of sides the polygon will have. 
    • Using the on-screen widget , you can change this to between 3 and 11. 
    • Use the slider to modify the value between 3 and 20. 
    • If you want a value between 3 and 1000, type the value manually.
  • Polygon Angle: Specifies the angle at which the polygon will be drawn or placed relative to the canvas.
  • Corner Type: Specifies the type of corner you want for the polygon (Round, Inverted Round, or Chamfer).
  • Polygon Radius: Specifies the exact radius of the polygon drawn. Use the on-screen widget  to modify the radius.
  • Polygon Side Length: Specifies the length of each side of the polygon.
  • Corner Radius: Specifies the radii of the corners of the polygon.
  • Make Sides Equal: While modifying a polygon, if the live shape becomes disproportionate or loses symmetry, use the Make Sides Equal button to balance the sides of the polygon.

Line

Live shape properties | Line
  • Line Length: Specifies the length of the line drawn.
  • Line Angle: Specifies the angle at which the line is drawn, relative to the canvas.

Hide bounding boxes and control widgets

While using the Shape tool, you may choose to hide or show the bounding box. Do one of the following:

  • To toggle between the two options, press (Windows) Shift+Ctrl+B, or (macOS) Shift+Cmd+B.
  • Choose View > Hide Bounding Box, or View > Show Bounding Box.

You may also choose to hide or show the on-screen control widgets by selecting any live shape drawing tool and clicking the Hide/Show Shape Widgets button () in the Control panel.

Select live shapes

Layers panel

Live shapes are displayed as a different object type in the Layers panel. For example, when you draw a Live Rectangle, the layer is named <Rectangle>, in the Layers panel. This helps in identifying the available live shapes, for purposes of selection and modification.

Live Rectangle and Ellipse appearing as <Rectangle> and <Ellipse> in the Layers panel
Example: Live Rectangles and Ellipses appear as <Rectangle> and <Ellipse> in the Layers panel. Similarly, other live shapes are marked in the Layers panel.

Select menu

To select all the available Live Shapes in your document, choose Select > Same > Shape.

Convert shapes

Convert paths to live shapes

  • When you open a document saved in an older version of Illustrator, the shapes in that document are not automatically editable as live shapes. To convert a path into a live shape, select it, and then click Object > Shape > Convert to Shape.

Convert live shapes to paths

  • To convert a live shape into a path, select the live shape, and then click Object > Shape > Expand Shape.

Această lucrare este oferită sub licență Atribuire-Necomercial-FărăModificări 3.0 Ne-adaptată Creative Commons  Postările pe Twitter™ şi Facebook nu sunt acoperite de condiţiile de licenţiere Creative Commons.

Prevederi legale   |   Politică de confidențialitate online