• Можно легко выполнить импорт, копирование и экспорт векторных и растровых графических объектов, анимации и изображений кнопок с несколькими состояниями Fireworks в Adobe Flash®.

  • Текст в формате TLF копируется из Flash в программу Fireworks, запущенную в ОС Windows, как пустое растровое изображение. Преобразуйте текст из формата TLF в формат ASCII и импортируйте в Fireworks.

  • Возможность запуска и редактирования упрощает редактирование графики Fireworks прямо во Flash. При работе во Flash всегда применяются параметры запуска и редактирования, заданные в Fireworks.

  • Стиль «Flash HTML» не поддерживает код всплывающих меню. Варианты поведения кнопок Fireworks и другие варианты интерактивного поведения во Flash не импортируются.

Помещение графики Fireworks во Flash

При импорте или копировании и последующей вставке PNG-файла Fireworks во Flash обеспечивается максимальный контроль над всеми аспектами импорта графики и анимации. Также можно импортировать файлы в форматах JPEG, GIF, PNG, и SWF, которые были экспортированы из Fireworks.

Примечание.

При импорте или копировании и последующей вставке графики Fireworks во Flash некоторые атрибуты, например, живые фильтры и текстуры, теряются. Эффект контурного градиента невозможно импортировать или скопировать и вставить в документ Flash из Fireworks. Кроме того, Flash поддерживает только сплошные заливки, градиентные заливки и основные варианты обводки.

Импорт PNG-файлов Fireworks во Flash

Исходные файлы Fireworks PNG можно непосредственно импортировать во Flash без необходимости использования промежуточного формата для экспорта. Все векторные и растровые графические объекты, анимация и кнопки со многими состояниями Fireworks могут быть импортированы во Flash.

Примечание.

Варианты поведения кнопок Fireworks и другие варианты интерактивного поведения не импортируются во Flash, поскольку варианты поведения Fireworks реализуются с помощью кода JavaScript, внешнего по отношению к файлам изображений. Flash использует собственный внутренний код ActionScript.

  1. Сохраните документ в программе Fireworks.

  2. Перейдите к открытому в программе Flash документу.

  3. (Необязательно) Щелкните ключевое состояние и слой, на который будет импортировано содержимое файла Fireworks.

  4. Выберите команду «Файл» > «Импорт».

  5. Найдите и выберите файл PNG.

  6. В диалоговом окне «Импорт документа Fireworks» выполните одно из следующих действий:

    • Выберите импорт в качестве единого, сведенного растрового изображения.

    • Выберите вариант импорта в двух всплывающих меню.

  7. Задайте параметры импорта текста.

  8. Нажмите кнопку «ОК».

    Примечание.

    Указанные вами в окне «Импорт документа Fireworks» параметры будут сохранены и использованы в качестве стандартных параметров.

Параметры импорта графики, векторных объектов и текста Fireworks

Параметры импорта графики

Импорт в виде единого, сведенного растрового изображения

Импортируется единое нередактируемое изображение.

Импорт всех страниц в новые состояния как фрагменты ролика

Все страницы из файла PNG импортируются в новый слой Flash, который получает имя PNG-файла. Ключевое состояние создается в новом слое в позиции текущего состояния, первая страница файла PNG помещается в это состояние как фрагмент ролика, остальные страницы помещаются как фрагменты ролика в последующие состояния. Иерархия слоев и состояний файла PNG сохраняется.

Импорт первой страницы в текущее состояние как фрагмента ролика

Содержимое выбранной страницы импортируется как фрагмент ролика, помещаемый в активное состояние и слой файла Flash. Иерархия слоев и состояний файла PNG сохраняется.

Импорт всех страниц в новые сцены как фрагменты ролика

Все страницы из файла PNG импортируются, каждая из них отображается на новую сцену как фрагменты ролика. Все слои и состояния в этих страницах сохраняются. Если в файле Flash уже существуют сцены, при импорте новые сцены добавляются после существующих.

Импорт первой страницы в новый слой

Выбранная страница импортируется как новый слой. Состояния исходного документа импортируются во временную шкалу в виде отдельных состояний.

Параметры импорта векторных объектов

Импорт в виде растровых изображений для сохранения внешнего вида

Сохраняет возможность редактирования векторных объектов, если они не содержат особых заливок, обводок или эффектов, не поддерживаемых во Flash. Для сохранения внешнего вида таких объектов Flash преобразует их в нередактируемые растровые изображения.

Импорт в виде редактируемых контуров

Сохраняет возможность редактирования всех векторных объектов. Если у объектов есть особые заливки, обводки или эффекты, которые не поддерживаются Flash, эти элементы могут выглядеть иначе после импорта.

Параметры импорта текста

Импорт в виде растровых изображений для сохранения внешнего вида

Сохраняет возможность редактирования текста, если в нем не используются особые заливки, обводки или эффекты, не поддерживаемые Flash. Для сохранения внешнего вида такого текста, Flash преобразует его в нередактируемые растровые изображения.

Примечание.

Текст в формате TLF копируется из Flash в программу Fireworks как пустое растровое изображение.

Сохранить возможность редактирования всего текста

Сохраняет возможность редактирования всего текста. Если у текстовых объектов есть особые заливки, обводки или эффекты, которые не поддерживаются Flash, эти элементы могут выглядеть иначе после импорта.

Копирование или перетягивание графики Fireworks во Flash

Для копирования графического объекта в версию программы Flash более раннюю, чем Flash 8, используйте пункт меню «Редактирование» > «Копировать как векторные объекты».

Примечание.

Возможно для этого придется разгруппировать объекты («Изменение» > «Разгруппировать») для того чтобы их можно было редактировать как отдельные векторные объекты во Flash.

  1. В Fireworks выделите один или более объектов для копирования.

  2. Выберите пункт меню «Редактирование» > «Копировать» и во всплывающем меню «Flash» выберите пункт «Копировать».

  3. В программе Flash создайте новый документ и выберите пункт меню «Редактирование» > «Вставить» или перетяните файл непосредственно из Fireworks во Flash.

  4. В диалоговом окне «Импорт документа Fireworks» выберите параметр «Вид»:

    Текущие состояния как фрагмент ролика

    Вставляемое содержимое импортируется как фрагмент ролика, который помещается в активное состояние и слой файла Flash. Иерархия слоев и состояний файла PNG сохраняется.

    Новый слой

    Вставляемое содержимое импортируется как новый слой. Состояния исходного документа импортируются во временную шкалу в виде отдельных состояний.

  5. Задайте параметры импорта векторных объектов.

  6. Задайте параметры импорта текста.

  7. Нажмите кнопку «ОК».

    Примечание.

    Указанные в окне «Импорт документа Fireworks» параметры будут сохранены и использованы в качестве стандартных параметров.

О структуре библиотеки Flash

Объекты Fireworks импортируются в папку Fireworks Objects Folder в библиотеке Flash. Эта папка имеет следующую структуру:

Папка «Файл 1» // Имя устанавливается соответственно имени файла Fireworks

  • Папка «Страница 1» // Имя устанавливается соответственно имени страницы (если страниц больше одной)

    — Страница 1 // Имя соответствует имени страницы

    — — Папка «Состояние 1» // Имя соответствует имени состояния (если состояний несколько)

    — — «Состояние 1» // Имя соответствует имени состояния

    — — — «Символ 1 в состоянии 1» // Имя соответствует имени символа

    — — — «Символ 2 в состоянии 1»

    ...

    — Папка «Общие слои» // Общие слои для всех состояний в папке «Страница 1»

    — — Папка «Общие слои» // Имя соответствует имени общего слоя

    — — Символ общего слоя

  • Папка «Страница 2»

    — Страница 2

    — Символ 1 на странице 2 (для страницы без состояний)

    ...

  • Папка «Страница-шаблон»

    — «Страница-шаблон»

     — Символ 1 в папке «Страница-шаблон»

    ...

    — Папка «Общие слои» // Общие слои для всех страниц

    — — Папка «Общие слои» // Имя соответствует имени общего слоя

    — — Символ общего слоя

Сведения об импорте символов Fireworks во Flash

При импорте символов Fireworks во Flash помните о следующих моментах:

  • Если символ использует 9-фрагментное масштабирование, при импорте во Flash сохраняются четыре направляющих фрагментов. Тем не менее, 9-фрагментное масштабирование не сохраняется для анимации. Импортированные символы сохраняются как символы в библиотеке Flash.

  • Результаты программных операций редактирования, примененных к расширенным символам, теряются. Импортируется шаблонная копия символа.

  • Расширенные графические символы сохраняются в виде файла PNG и файла JSF. Импортируется только файл PNG. Если символ состоит из ряда контуров, эти контуры объединяются в один символ.

  • Для получения полной функциональности расширенных символов во Flash замените эти символы соответствующими Flash-версиями.

О сохранении видимости и блокировки

Объекты и слои, скрытые в файле PNG, импортируются в документ Flash и остаются скрытыми. Однако невидимые части расширенных графических символов (например, состояния «Указатель над кнопкой» или «Нажатие») не импортируются.

Если слой заблокирован или скрыт, все объекты и вложенные слои в этом слое наследуют это свойство и сохраняют его при импорте в программу Flash.

При импорте новой страницы в виде нового слоя во Flash для целой страницы создается один слой, на котором присутствуют все объекты. Свойства видимости и блокировки не сохраняются.

Поддерживаемые эффекты слоев Photoshop

Живой эффект Photoshop – «Отбрасываемая тень».

Отображение происходит следующим образом:

  • размеры отображаются в значения blurX, blurY;

  • расстояние отображается в расстояние;

  • цвет отображается в цвет;

  • угол отображается в значение 180 – (угол, заданный в эффекте Photoshop).

Живой эффект Photoshop – «Внутренняя тень слоя».

Отображение происходит следующим образом:

  • размеры отображаются в значения blurX, blurY;

  • расстояние отображается в расстояние;

  • цвет отображается в цвет;

  • угол отображается в значение 180 – (угол, заданный в эффекте Photoshop).

Живой эффект Photoshop – «Внешнее свечение».

Отображение происходит следующим образом:

  • непрозрачность отображается в интенсивность;

  • цвет отображается в цвет;

  • размеры отображаются в значения blurX, blurY.

Живой эффект Photoshop – «Внутреннее свечение».

Отображение происходит следующим образом:

  • непрозрачность отображается в интенсивность;

  • цвет отображается в цвет;

  • размеры отображаются в значения blurX, blurY;

  • объекты, к которым применены любые прочие эффекты слоев Photoshop, растрируются.

Экспорт графических объектов Fireworks в другие форматы для использования во Flash

Графические объекты Fireworks можно экспортировать в файлы JPEG, GIF, PNG и AI (Adobe Illustrator 8), а затем импортировать созданные файлы в программу Flash.

Хотя PNG является стандартным форматом файлов Fireworks, экспортированные из Fireworks файлы PNG, отличаются от сохраненных в Fireworks исходных файлов PNG. Также как GIF и JPEG, экспортированные файлы PNG содержат только данные изображения, без дополнительной информации о фрагментах, слоях, интерактивности, живых фильтрах и другом редактируемом контенте.

Экспорт графики и анимации Fireworks в виде файлов SWF

Графику и анимацию Fireworks можно экспортировать в виде файлов Flash SWF. Для сохранения толщины и цветовых настроек обводки, в диалоговом окне «Параметры экспорта Flash SWF» выберите «Сохранять внешний вид».

При экспорте в SWF теряется следующее форматирование: режим смешения, слои, маски (применяются перед экспортом), объекты фрагментов, карты изображения, варианты поведения, узорные заливки и градиенты на обводках.

  1. Выберите команду «Файл» > «Сохранить как».

  2. Введите имя файла и выберите папку назначения.

  3. Выберите формат файла Adobe Flash SWF.

  4. Нажмите кнопку «Параметры». Затем отметьте параметр «Объекты»:

    Сохранить контуры

    Позволяет сохранить возможность редактирования контуров. Эффекты и форматирование теряются.

    Сохранить оформление

    Преобразует векторные объекты в растровые объекты по мере необходимости, сохраняя внешний вид примененных обводок и заливок. Возможность редактирования теряется.

  5. Выберите параметр «Текст»:

    Сохранять возможности редактирования

    Позволяет сохранить возможность редактирования текста. Эффекты и форматирование теряются.

    Преобразовать в контуры

    Преобразует текст в контуры, сохраняя любые пользовательские настройки кернинга или разрядки, введенные в Fireworks. Возможность редактирования объекта как текста теряется.

  6. Задайте качество изображений JPEG с помощью ползунка «Качество JPEG».

  7. Выберите диапазон экспортируемых состояний и количество состояний в секунду.

  8. Нажмите «ОК», затем в диалоговом окне экспорта нажмите «Сохранить».

Экспорт 8-битных PNG-файлов с сохранением прозрачности

Для экспорта 32-битных PNG-файлов с сохранением прозрачности достаточно импортировать исходные PNG-файлы Fireworks прямо во Flash. Для экспорта 8-битных PNG-файлов с сохранением прозрачности выполните следующие шаги:

  1. В Dreamweaver выберите пункт меню «Окно» > «Свойства» для открытия Инспектора свойств.

  2. Выберите формат файла экспорта «PNG 8» и тип прозрачности «Альфа-прозрачность» в соответствующих всплывающих меню.

  3. Выберите команду «Файл» > «Экспорт».

  4. Выберите вариант «Только изображения» во всплывающем меню «Экспорт».

  5. Укажите имя и сохраните файл.

Импорт экспортированной графики и анимации Fireworks в программу Flash

  1. Создайте новый документ в программе Flash.

    Примечание.

    Если изображение Fireworks импортируется в существующий файл Flash, создайте в программе Flash новый слой.

  2. Выберите пункт меню «Файл» > «Импорт», затем выберите файл анимации или изображения.

  3. Нажмите кнопку «Открыть», чтобы импортировать файл.

Использование Fireworks для редактирования графики во Flash

Благодаря интеграции типа «запуск и редактирование», вы можете использовать Fireworks для редактирования графики, которая ранее была импортирована во Flash, даже если графика не была экспортирована из Fireworks.

Примечание.

Импортированные во Flash оригинальные PNG-файлы Fireworks являются исключением; PNG-файл должен быть импортирован в виде сведенного растрового изображения.

Если изображение экспортировано из Fireworks и первоначальный файл PNG сохранен, этот файл можно редактировать в Fireworks из Flash. В этом случае при возврате во Flash обновляются и исходный файл PNG, и изображение во Flash.

  1. В программе Flash на панели «Библиотека документа» щелкните графический файл правой кнопкой (для Windows) или удерживая клавишу Control (для Mac OS).

  2. Выберите пункт «Редактировать в Fireworks» во всплывающем меню.

    Примечание.

    Если пункт «Редактировать в Fireworks» отсутствует во всплывающем меню, выберите пункт «Редактировать с помощью» и укажите путь к приложению Fireworks.

  3. Выберите «Да» в диалоговом окне «Найти источник», если нужно найти исходный файл PNG для изображения Fireworks, затем нажмите кнопку «Открыть».

  4. Отредактируйте изображение и затем нажмите кнопку «Готово».

    Fireworks экспортирует новый графический файл в приложение Flash и сохраняет исходный файл PNG.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет