Узнайте, как систематизировать и повторно использовать виджеты, шаблоны и другие элементы дизайна с помощью панели «Библиотека» в Adobe Muse CC.

Примечание.

Новые функции больше не добавляются в Adobe Muse. Поддержка этого приложения будет прекращена 26 марта 2020 г. Для получения подробной информации и поддержки посетите страницу прекращения обслуживания Adobe Muse.

Панель «Библиотека» в приложении Muse предоставляет удобный способ хранения общих элементов страниц и управления ими. После добавления элементов к библиотеки, вы сможете быстро получить доступ к ним для размещения на страницах сайта. Библиотека может содержать элементы различных типов, включая логотипы, изображения сайта, цветовые образцы цвета, настраиваемые виджеты, встроенные фрагменты кода HTML, стили абзацев, символов и графики. В этой статье приведены общие сведения об упрощении процесса разработки с помощью панели «Библиотека».

С помощью надстроек Creative Cloud можно создавать широкое разнообразие элементов оформления, которые позволят обогатить ваш дизайн. Чтобы перейти к загрузке, посетите веб-сайт, посвященный надстройкам Creative Cloud для Adobe Muse.

Доступ к панели «Библиотека»

Доступ к библиотеке возможен в представлении «Дизайн». Для активации панели выберите Окно > Библиотека или перейдите на вкладку «Библиотека» в наборе закрепленных панелей.

Откройте панель «Библиотека» в Adobe Muse.
Откройте панель «Библиотека» в Adobe Muse.

Примечание.

Для доступа к элементам библиотеки, которые можно загрузить и в дальнейшем применять при проектировании сайтов, воспользуйтесь ссылкой на Adobe Muse Exchange.

Управление папками на панели «Библиотека»

Создание новой папки

Для работы с панелью «Библиотека» следует создать новую папку. Выполните следующие действия.

  1. Нажмите кнопку Создать папку (значок папки) в нижней части панели «Библиотека».
Нажмите кнопку «Создать папку» для создания новой папки без содержимого.
Нажмите кнопку «Создать папку» для создания новой папки без содержимого.

  1. Введите информативное имя в поле рядом со значком папки.

Список имен папок на панели «Библиотека» упорядочен по алфавиту, что позволяет отображать родственные элементы рядом друг с другом, присваивая им сходные имена.

В любой момент можно переименовать папку в библиотеке, дважды щелкнув на ней.

Введите в поле информативное имя папки.
Введите в поле информативное имя папки.

После создания папки можно добавлять элементы к библиотеке.

Примечание.

Создавать папку перед добавлением элемента к библиотеке на панели «Библиотека» не обязательно, однако быстрее создать новую папку, присвоить ей имя и затем добавить элемент, чем сначала добавить новый элемент, а затем переименовать и его, и содержащую его папку. Независимо от выбранного способа рекомендуется всегда присваивать как папкам, так и элементам на панели «Библиотека» информативные имена.

Если планируется добавить к библиотеке несколько элементов, можно перед их добавлением создать набор пустых папок и присвоить им имена.

Добавьте папки для систематизации различных элементов сайта Adobe Muse и упрощения их поиска.
Добавьте папки для систематизации различных элементов сайта для упрощения их поиска.

Добавление элементов страницы в папки

Если требуется добавить элементы к библиотеке для быстрого доступа к ним и добавления их к другим страницам, выберите любой элемент на странице. Выбор нескольких элементов осуществляется при нажатой клавише Shift или путем нажатия и перетаскивания инструмента «Выделение» над элементами.

Выберите один из двух способов добавления элементов к библиотеке.

Способ 1.

  1. Нажмите выбранные элементы правой кнопкой мыши, выберите «Добавить в библиотеку», затем выберите папку для сохранения элемента из библиотеки.
В контекстном меню Adobe Muse выберите пункт «Добавить в библиотеку».
В контекстном меню выберите пункт «Добавить в библиотеку».

Выбранные элементы добавляются к папке и отображаются на панели «Библиотека» в области предварительного просмотра.

  1. Введите описательное имя элемента в соответствующем поле.
Введите информативное имя нового элемента, сохраненного в папке.
Введите информативное имя нового элемента, сохраненного в папке.

Можно также добавить выбранные элементы к библиотеке с помощью следующей процедуры.

Способ 2.

  1. При наличии выбранных элементов нажмите кнопку «Добавить выбранные элементы» в правом нижнем углу панели «Библиотека».
Нажмите кнопку «Добавить выбранные элементы».
Нажмите кнопку «Добавить выбранные элементы».

  1. Введите имя элемента в соответствующем поле.

Если папка содержит хотя бы один элемент, при щелчке на стрелке вниз, расположенной слева от имени папки, ее содержимое разворачивается или сворачивается.

В файлах крупных проектов можно свернуть все папки на панели «Библиотека», в результате чего список элементов сокращается и становится более удобным для поиска и управления. Для открытия или закрытия всех папок на панели «Библиотека» нажмите стрелку при нажатой клавише Option (в ОС Windows — при нажатой клавише Alt).

Переименование и систематизация папок

Как указано выше, в любой момент можно переименовать папку, дважды щелкнув на ней. При сохранении элементов для определенного клиента или раздела сайта рекомендуется присваивать всем папкам на панели «Библиотека» такие имена, чтобы данные папки отображались в списке рядом друг с другом.

Список имен папок на панели «Библиотека» в Adobe Muse упорядочен по алфавиту.
Список имен папок, упорядочен по алфавиту на панели «Библиотека».

Рекомендуется присваивать папкам и элементам в библиотеке информативные имена, изменяя имена, которые по умолчанию присваиваются в приложении Muse и начинаются с префикса untitled. Добавление информативных имен обеспечивает быстрый поиск элементов в списке папок. Это позволяет также выполнять поиск конкретных элементов в библиотеке согласно инструкциям в следующем разделе.

Управление ресурсами на панели «Библиотека»

Поиск на панели «Библиотека»

После добавления большого количества различных элементов на панели «Библиотека» может быть трудно вспомнить, в какой папке содержится требуемый элемент. В любой момент можно развернуть каждую папку для просмотра ее содержимого, однако при работе с большими библиотеками это потребует значительного времени.

Для поиска на панели «Библиотека» введите любой фрагмент имени элемента в поле «Фильтр по имени».

Все подходящие элементы отображаются в приведенном ниже списке в развернутых папках библиотеки.

Для поиска конкретного элемента введите его имя в поле поиска.
Для поиска конкретного элемента введите его имя в поле поиска.

По завершении поиска нажмите кнопку X для очистки поля и возврата к списку всех элементов на панели «Библиотека».

Импорт ресурсов

Возможность предоставления другим пользователям ресурсов пользовательской библиотеки упрощает сотрудничество разработчиков и стандартизацию параметров отображения и ввода при проектировании сайта. Файлы, экспортируемые из библиотеки Muse, сохраняются с расширением .mulib.

Для импорта файла из библиотеки Muse в текущий проект дважды нажмите файл .mulib. Запускается приложение Muse (если оно еще не открыто), и содержимое файла из библиотеки добавляется на панель «Библиотека».

Можно также выполнить следующие действия.

  1. Нажмите кнопку «Импорт библиотеки Muse» в левом нижнем углу панели «Библиотека».
  2. В появившемся диалоговом окне «Импорт элементов библиотеки» выберите файл .mulib, расположенный на компьютере, затем нажмите «Открыть».
Нажмите кнопку «Импорт библиотеки Muse» и откройте файл .mulib в Adobe Muse.
Нажмите кнопку «Импорт библиотеки Muse» и откройте файл .mulib.

На панели «Библиотека» отображаются импортированные папки, готовые к использованию в текущем файле.

Если требуется импортировать элементы из библиотеки во время работы не в представлении «Дизайн», можно также выбрать Файл > Открыть сайт и в появившемся диалоговом окне «Открыть» путем обзора файловой системы выбрать один или несколько файлов .mulib.

Использование элементов библиотеки в веб-дизайне

Можно сохранять различные ресурсы, в том числе графику, векторные изображения, формы, элементы колонтитулов и т. д., а также управлять ими. Эти элементы можно использовать в веб-дизайне одним из двух способов.

Размещение элементов библиотеки:

Выделите элемент, который необходимо использовать в проекте. Перетащите элемент библиотеки в представление «Дизайн».

Размещение элементов библиотеки с точками остановки:

Если элемент библиотеки содержит точки остановки, то его можно разместить в проекте вместе с точками остановки. Для использования элементов библиотеки с точками остановки, нажмите значок плюса рядом с элементом. Перетащите элемент в представление «Дизайн».

Добавление элементов библиотеки вместе с точками остановки в Adobe Muse
Добавление элементов библиотеки с точками остановки

Точки остановки из элемента библиотеки будут добавлены на страницу. С помощью этой функции можно добавлять набор точек остановки на страницы-шаблоны и дочерние страницы одним щелчком мыши. Можно также сохранить точки остановки в нескольких проектах Adobe Muse.

Если страница уже содержит точки остановки, то после добавления элемента библиотеки с точками остановки страница будет содержать все точки остановки.

Экспорт изображений и других ресурсов

После добавления содержимого на панель «Библиотека» можно экспортировать его как автономный файл для передачи другим разработчикам (или для ускорения процесса оформления сайта при работе на нескольких компьютерах).

Важно отметить, что в файл .mulib, создаваемый при экспорте элементов с панели «Библиотека», не включается содержимое, связанное с веб-сайтом (а не внедренное в него), такое как файлы OAM, созданные с помощью Adobe Edge Animate, видеоролики и другие связанные объекты.

Для экспорта файла из библиотеки Muse, содержащего файлы изображений, выполните следующие действия.

  1. В представлении «Дизайн» создайте элемент или набор элементов для добавления к библиотеке. Этот набор элементов может содержать прямоугольники, текст и файлы изображений.
  2. Перед добавлением элементов на панель «Библиотека» откройте панель «Ресурсы» (Окно > Ресурсы), нажмите изображения, которые требуется экспортировать, правой кнопкой мыши и выберите «Встроить ссылку».

Примечание. Если элементы библиотеки, которые требуется экспортировать, не содержат файлов изображений, можно пропустить шаг 2.

  1. Выберите требуемые элементы и добавьте их к библиотеке.
  2. Нажмите кнопку экспорта в нижней части панели «Библиотека».
Выберите папку или элементы для экспорта и нажмите кнопку «Экспорт».
Выберите папку или элементы для экспорта и нажмите кнопку «Экспорт».

Создается файл.mulib, который сохраняется на рабочем столе (или в местоположении, указанном пользователем). Передайте файл .mulib другому разработчику или участнику рабочей группы по электронной почте или с помощью службы передачи файлов.

Когда получатель открывает файл .mulib и затем добавляет элемент из библиотеки к странице, изображения отображаются на панели «Ресурсы» в качестве внедренных изображений.

Создание пользовательских цветовых образцов

Панель «Библиотека» позволяет сохранить элемент, который содержит все цвета, используемые при оформлении сайта. Можно также выбрать пользовательский набор направляющих и добавить их на панель «Библиотека». Эти приемы удобны для стандартизации параметров отображения и ввода при проектировании сайта.

Для импорта конкретного набора цветов в новый файл .muse с целью ускорения процесса оформления выполните следующие действия.

  1. Откройте файл .muse, содержащий цвета, которые требуется сохранить. Создайте одну прямоугольную фигуру с помощью инструмента «Прямоугольник», затем создайте несколько копий прямоугольника путем его перетаскивания при нажатой клавише Option/Alt. Задайте заливку каждого прямоугольника одним из основных цветов сайта с помощью инструмента «Пипетка» в меню «Заливка».
  2. Создайте на панели «Библиотека» новую папку для хранения цветовых образцов.
  3. Для выбора всего набора прямоугольников воспользуйтесь инструментом «Выделение». Можно щелкнуть на выбранной группе прямоугольников правой кнопкой мыши и выбрать «Добавить в библиотеку» или нажать кнопку «Добавить выбранные элементы» в нижней части панели «Библиотека». Введите в поле информативное имя, которое будет служить меткой набора цветовых образцов.
  4. Выберите папку, содержащую цветовые образцы, и нажмите кнопку «Экспорт» в нижней части панели «Библиотека» для экспорта файла библиотеки Muse с выбранным содержимым. Передайте файл .mulib другому участнику рабочей группы, отправив его в виде вложения в сообщение электронной почты или скопировав на накопитель USB.
  5. Получатель файла .mulib запускает приложение Muse, создает новый сайт, открывает библиотеку и нажимает кнопку «Импорт» для импорта в библиотеку файла, содержащего образцы (он может также выбрать Файл > Открыть сайт и открыть файл .mulib).
  6. Затем он перетаскивает элемент, содержащий цвета, с панели «Библиотека» на страницу для добавления цветовых образцов к палитре «Образцы».
  7. После этого получатель открывает палитру «Образцы» (Окно > Образцы), щелкает на палитре «Образцы» правой кнопкой мыши и в появившемся контекстном меню выбирает «Удалить все неиспользуемые».
После импорта удалите неиспользованные цветовые образцы на новом сайте Adobe Muse.
После импорта цветовых образцов в новый сайт можно выбрать удаление всех неиспользуемых цветов на палитре «Образцы».

После удаления неиспользуемых цветовых образцов на палитре «Образцы» при необходимости удалите со страницы элемент из библиотеки.

Примечание.

Этим же способом можно импортировать стили абзацев и символов, назначив их тексту и добавив текстовый фрейм на панели «Библиотека» в качестве элемента.

Создание пользовательских миниатюр

В области предварительного просмотра на панели «Библиотека» наглядно представлено выбранное содержимое, что упрощает выбор элементов в библиотеке и добавление их к страницам. Однако область предварительного просмотра рассчитана на вывод изображений, близких к квадратным. При добавлении к библиотеке элементов или наборов элементов, длина которых значительно отличается от ширины, в области предварительного просмотра соответствующие миниатюры могут отображаться в измененном масштабе.

Создание пользовательских миниатюр в Adobe Muse
Создание пользовательских миниатюр в Adobe Muse

При необходимости можно создать другую миниатюру для предварительного просмотра на панели «Библиотека». Выполните следующие действия.

  1. С помощью программы Finder на компьютере Mac или проводника Windows найдите на компьютере следующий каталог.
  • Mac: ~/Library/Preferences/Adobe/AdobeMuseLibrary/
  • Windows: %AppData%/AdobeMuseLibrary/

Примечание.

В Mac OSX для доступа к этому каталогу можно выбрать «Go» (Перейти) > «Go to Folder» (Перейти к папке). В Windows скопируйте указанный выше путь и вставьте его в строке адреса URL для поиска папки.

  1. Найдите имя, присвоенное папке библиотеки в Muse, которую требуется обновить. В этом примере папке библиотеки присвоено имя nav - background.
  2. Откройте папку для просмотра ее содержимого. Она содержит файл PNG.
  3. Откройте файл PNG в программе редактирования изображений, например Photoshop или Fireworks. Внесите требуемые изменения в файл PNG.
  4. Сохраните файл PNG в текущем местоположении и завершите работу программы редактирования изображений.
  5. Вернитесь в приложение Muse и выберите элемент в библиотеке. Отредактированный файл PNG отображается в области предварительного просмотра.
Пользовательский файл PNG содержит миниатюру, легче узнаваемую при беглом взгляде.
Пользовательский файл PNG содержит миниатюру, легче узнаваемую при беглом взгляде.

Для дальнейшего изучения приложения Adobe Muse перейдите на страницу справки и учебных пособий по Adobe Muse, а также ознакомьтесь с материалами, представленными на форуме технической поддержки пользователей Adobe Muse.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет