The various export options in Character Animator.

After you have assembled the scene, you can export it for use in other applications, such as After Effects or Premiere Pro. You can also export to a watch folder monitored by Adobe Media Encoder to automate the process of rendering your scene and export it to any format supported by Adobe Media Encoder. The default export format is H.264 with the Match Source – High bit rate preset. Read on to know more about importing an exported scene into other applications, exporting and sharing a puppet with other users, and lip sync export to After Effects.

Using Dynamic Link, you can open a scene directly in After Effects or Premiere Pro and keep a live connection to the original scene in Character Animator. Changes to the scene in Character Animator are automatically reflected when switching back to After Effects or Premiere Pro.

To import a scene in After Effects or Premiere Pro via Dynamic Link, do either of the following:

  • Drag the scene from the Project panel in Character Animator into the Project panel in After Effects or Premiere Pro. You can start dragging the scene in Character Animator, Alt/Command+Tab to After Effects or Premiere Pro, then drop the scene in the Project panel.
  • Import the scene from the .chproj file, as follows:
  1. Select a Character Animator project’s .chproj file to import by choosing File > Import > File in After Effects, choosing File > Import in Premiere Pro, or using the Media Browser in either application.

  2. Select the scene within the project to import.

    The scene appears in the Project panel as Dynamic Link video footage that you can add to a composition or sequence like any other video footage. Character Animator does not need to be running while you use the scene in After Effects or Premiere Pro.

Export with dynamic link

Export with dynamic link
Learn how to export Projects using dynamic link

Export to a file format for import into other applications

You can export directly to a movie format (H.264) via Adobe Media Encoder, or to a PNG sequence and WAV file. The exported movie file can be played back immediately or, like the PNG/WAV files, imported into other applications for further use. When used with After Effects and Premiere Pro, a single movie file is easier to import and manage than PNG image sequence and separate audio file. You can also choose to export a scene frame as PNG.

Export a scene as a movie file via Adobe Media Encoder

You can directly export a scene from Character Animator to a movie format via Adobe Media Encoder. The default movie format is H.264.

  1. Select or open the scene, then adjust the scene’s Duration (in the Properties panel) to restrict the frames to export.

    Scene duration is visualized as a lighter background in the Timeline panel.

  2. Choose File > Export > Video via Adobe Media Encoder and specify the location and filename for the file.

    Adobe Media Encoder launches and adds an entry for the scene into the queue. It can take several seconds for Adobe Media Encoder to launch the first time. Also, the Adobe Media Encoder window may not move to front, so you have to switch to it manually.

  3. In Adobe Media Encoder, adjust any settings for the queued item, then click the Start Queue (green play) button.

    The default export format is H.264 with the “Match Source – High bit rate” preset, but you can make changes as needed.

    The rendered movie file can be played immediately or imported into another application for further use.

Export a scene as PNG sequence and WAV file

  1. Select or open the scene.

  2. Choose File > Export > PNG Sequence and WAV (Cmd+Opt+M / Ctrl+Alt+M), then specify a location and base filename for the recorded scene. The base filename defaults to the scene’s name.

    On Mac, if you specify the name of an existing subfolder, you are asked to replace it. On Windows, specifying an existing subfolder name simply navigates to that subfolder. 

    The camera and microphone inputs are disabled during export.

    A subfolder based on the specified name is created for you, and the files — PNG sequence and a stereo 48-kHz WAV file — are placed in it. The subfolder is opened automatically. An .xml file is created next to the subfolder, and can be used to import the subfolder’s contents into applications that can import such files.

Export a scene frame

You can export the contents of the scene in the Scene panel at the current time to a PNG image file.
To export the current scene frame, choose File > Export > Frame (Command+Option+S / Ctrl+Alt+S). You can specify the location and name for the PNG file.

Opomba:

Note that the Scene panel’s background color is not saved and the PNG file would have a transparent background. Also, puppet meshes (if displayed) will not appear in the file.

Import an exported scene into other applications

Import a scene into After Effects

You need to manually import the PNG file and WAV file to After Effects from Character Animator. When you import the PNG sequence, interpret the footage to match the Character Animator scene’s frame rate.

Import a scene into Premiere Pro

Import the exported .xml file into the Project panel. A sequence containing the PNG sequence and WAV file is created.

Import a scene into Adobe Media Encoder

Add the exported .xml file to the Queue panel, then adjust the format settings and output file.

Opomba:

You can also set up a watch folder that automatically encodes the exported .xml file’s PNG sequence and WAV file to a movie or still-image format.

Export and share a puppet with other users

If you want to send a puppet to other Character Animator users or archive the structure of a puppet for reuse in other projects, create a shareable puppet, a self-contained file with all required artwork included.

To share a puppet:

  1. Select the puppet in the Project panel or open the puppet (from the Project panel) in the Puppet panel.
  2. Choose File > Export > Puppet, then name the .puppet file or right-click the puppet in the Project panel and choose Export Puppet.
  3. Send the .puppet file to the other user via shared link or other method.
  4. To open a shared puppet, import the .puppet file via File > Import or by dragging it into the Project panel.

Note: Shareable puppets are self-contained, including the artwork associated with them. If needed, you can relink the puppet to a shared instance of the artwork. Parameter changes to a puppet when selected in the timeline, or any recorded takes for a puppet track, are not included in a .puppet file. Also, behaviors that are on the imported puppet are updated to use the versions of the behaviors available in the current project. 

Stream a scene live to other devices or applications

Use the Live Streaming option to show your screen on an external monitor or a third-party video device. You can also send your scenes to other applications such as Facebook Live and YouTube to broadcast your live animations using live streaming. For information about streaming, see Stream a scene live. If you are looking for tips, tricks, and workarounds related to streaming, see Tips and tricks for streaming.

Lip Sync: Take export for After Effects

Take Character Animator visemes into After Effects for use on different characters by following these steps.

  1. In the Timeline panel, right-click a Lip Sync take > Copy Visemes for After Effects. All the visemes data is copied to the system clipboard as Time Remap keyframe data for use in After Effects.

  2. In After Effects, set up a composition that contains the different visemes at one-second intervals matching the order of visemes in Character Animator’s Visemes context menu. At time 0 seconds, it should be the Neutral mouth shape (that is, no viseme), at 1 second place the Aa viseme, at 2 seconds the D viseme, and so on.

  3. Now, nest the composition into another one containing your character’s face. Ensure that you set the composition for the same frame rate as the scene in your Character Animator project.

  4. To paste the Time Remap keyframes that you copied in step one onto the nested visemes composition, choose Edit > Paste.

  5. Now, select all Time Remap keyframes, then set their keyframe interpolation to Hold.

    Tip: You can also copy the data into a spreadsheet program, tweak the values as needed, then copy the data back to the system clipboard for pasting into After Effects.

Export a scene to a video format with alpha channel

If you want to export a scene to a movie file but include an alpha channel so that transparent or semitransparent areas of the scene can reveal the background when composited onto other footage in After Effects or other applications, you can use a separate menu command to send the scene to Adobe Media Encoder.

  • To export a scene to a video format with alpha channel, select the scene, then choose File > Export > Video with Alpha via Adobe Media Encoder.

The scene is added to the Adobe Media Encoder queue, and set to use QuickTime format with the GoPro CineForm RGB 12-bit with alpha preset.

Za ta izdelek je bila izdana neprenosljiva licenca za priznanje avtorstva, nekomercialno uporabo in skupno rabo pod enakimi pogoji 3.0  Objav v storitvah Twitter™ in Facebook ne urejajo pogoji pogodbe Creative Commons.

Pravna obvestila   |   Pravilnik o zasebnosti v spletu