Navodila za uporabo Prekliči

Dynamic PDF documents

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Customize your workspace in InDesign
      3. Toolbox
      4. Set preferences
      5. Properties panel
      6. Touch workspace
      7. Default keyboard shortcuts
      8. Document recovery and undo
    3. Generative AI
      1. Text to Image
      2. Generative AI FAQ
  3. Create and layout documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Convert PDFs to InDesign files in InDesign (Beta)
      7. Create book files
      8. Add basic page numbering
      9. Number pages, chapters, and sections
      10. Convert QuarkXPress and PageMaker documents
      11. Share content
      12. Understand a basic managed-file workflow
      13. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
      2. Align and distribute objects using rulers
      3. Measure objects using the Measure tool
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. South-East Asian Scripts
      4. Arabic and Hebrew features in InDesign
      5. Create type on a path
      6. Bullets and numbering
      7. Glyphs and special characters
      8. Text composition
      9. Text variables
      10. Generate QR codes
      11. Edit text
      12. Align text
      13. Wrap text around objects
      14. Anchored objects
      15. Linked content
      16. Format paragraphs
      17. Format characters
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Auto Style text
      3. Work with Style Packs
      4. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Spell check and language dictionaries
      1. Check spelling, autocorrect, and dynamic spelling
      2. Create, add, and manage dictionaries and words
      3. Change dictionary preferences
      4. Duden dictionary
    6. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    7. Styles
      1. Paragraph and character styles
      2. Map, export, and manage styles
      3. Object styles
      4. Drop caps and nested styles
      5. Work with styles
      6. Leading
    8. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    9. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
    10. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Frames and objects
      10. Align and distribute objects
      11. Linked and embedded graphics
      12. Integrate AEM assets
    11. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Understand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Find and replace
    1. Find and replace text
    2. Find and replace fonts
    3. Find and replace glyphs
    4. Find and replace using GREP expressions and queries
    5. Find and replace objects
    6. Find and replace colors
    7. Search options to find and replace
  6. Share
    1. Save and access cloud documents
    2. Organize, manage, and share cloud documents
    3. View and manage versions in cloud documents
    4. Common questions about InDesign cloud documents
    5. Share and collaborate        
    6. Share for Review
    7. Review a shared InDesign document
    8. Manage feedback 
  7. Publish
    1. Place, export, and publish
      1. Publish online
      2. Publish online dashboard
      3. Copy, insert graphics
      4. Export content for EPUB
      5. Adobe PDF options
      6. Export content to HTML
      7. Export to Adobe PDF
      8. Export to JPEG format
      9. Export HTML
      10. DPS and AEM Mobile overview
      11. Supported File Formats
      12. Export and import User Settings
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  8. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting
  9. Troubleshooting
    1. Fixed issues
    2. Known issues
    3. Crash on launch
    4. Preference folder read-only issue
    5. Troubleshoot file issues
    6. Unable to export PDF
    7. InDesign document recovery

Learn how to create, and export dynamic PDF documents in Adobe InDesign for interactive and engaging digital content.

You can create interactive slideshows with dynamic PDF documents using buttons, multimedia elements, hyperlinks, bookmarks, and page transitions in InDesign. You can also set up documents in InDesign that can be converted to forms in Acrobat.

Export to Interactive PDF documents

  1. Select File > Export.

  2. Specify a location and a File name.

  3. Select Use InDesign Document Name as the Output Filename if you want the exported PDF to have the same name as the name of the document from the next export.

  4. Select Adobe PDF (Interactive) in Save as type (Windows) or Format (macOS) and select Save.

  5. Specify options in the Export To Interactive PDF dialog box, and then click OK.

Create interactive documents for PDF

You can export Adobe PDF documents that include the following interactive features.

Bookmarks

You can create Bookmarks in the InDesign document that appears in the Bookmarks tab on the left side of the Adobe Acrobat or Adobe Reader window. Each bookmark jumps to a page, text, or graphic in the exported PDF file.

Movie and sound clips

You can add movies and sound clips to a document or link to streaming video files on the Internet. These movies and sound clips can be played back in the exported PDF file.

Hyperlinks

You can click on a hyperlink in an exported PDF document to jump to another location in the same or a different document or a website.

Cross-references

A cross-reference refers readers from one part of your document to another in the exported PDF file. Cross-references are especially useful in user guides and reference manuals. When a document with cross-references is exported to PDF, the cross-references act as interactive hyperlinks.

Page transitions

Page transitions apply a decorative effect, such as a dissolve or wipe, when you turn the page in the exported PDF while in Full Screen Mode.

Export to interactive PDF options

There are four tabs that appear in the Export To Interactive PDF dialog:

General, Compression, Advanced, and Security.

General Tab

Pages

Indicate whether all pages in the document or a page range is included. If you select Range, specify a page range, such as 1-7,9, to print pages 1 through 7 and 9.

Export As

Indicate whether you want to export the document as pages or spreads.

Create Separate PDF Files

Select this option to create separate PDFs for each page or spread.

Suffix

Add a file name suffix like Incremental Numbers (^#), Page Number (^P), Page Size (^S), or a customized name for identification.

Opomba:

To ensure that files can be shared smoothly between macOS and Windows, we recommend neither the use of illegal or reserved characters in file/folder names nor in dynamic strings. InDesign has taken a superset of these characters “ \ / : * ? " < > |  “ (Windows and macOS), and they will be skipped in PNG, JPEG, and PDF export.

View

Show the initial view settings of the PDF when it’s opened.

Layout

Show the initial layout of the PDF when it’s opened.

Presentation

  • Select Open In Full Screen Mode to display the PDF in Adobe Acrobat or Adobe Reader without menus or panels displayed. 
  • Select Flip Pages to advance the pages automatically, and specify the number of seconds between page turns.
  • Select View After Exporting to open the newly created PDF file in the default PDF viewing application.

Page Transitions

Specify one page transition to apply to all pages during export. If you use the Page Transitions panel to specify transitions, select the From Document option to use those settings.

Forms and Media

  • Select Include All to allow movies, sounds, and buttons to be interactive in the exported PDF file. 
  • Select Appearance Only to include the normal state of buttons and the video posters as static elements.

Embed Page Thumbnails

Select this to embed a thumbnail preview for each page in the PDF, increasing the file size. Deselect this setting when users of Acrobat 5.0 and later view and print the PDF; these versions generate thumbnails dynamically each time you select the Pages panel of a PDF.

Create Acrobat Layers

Select this to save each InDesign layer as an Acrobat layer within the PDF. The layers are fully navigable, which allows users of Acrobat 6.0 and later to generate multiple versions of the file from a single PDF.

Include Hidden Spreads

Select this option if you want to export the hidden spreads along with the other spreads of the documents.

Create Tagged PDF

Select this to automatically tag elements in the story based on a subset of the Acrobat tags that InDesign supports during export. This includes recognition of paragraphs, basic text formatting, lists, and tables. You can also insert and adjust tags in the document before exporting to PDF.

Use Structure for Tab Order

Use the Tab Order specified using Object > Interactive > Set Tab Order during export. This option is only available for tagged PDFs.

Compression Tab

Compression 

  • Select JPEG (Lossy) to remove image data and possibly reduce image quality. However, file size is reduced with a minimal loss of information. 
  • Select JPEG 2000 (Lossless) to export the file without lossy compression. 
  • Select Automatic to let InDesign determine the best quality for color and grayscale images.

JPEG Quality

Specifies the amount of detail in the exported image. The higher the quality, the larger the file size. If you select JPEG 2000 (Lossless) for Compression, this option is dimmed.

Resolution

Specify the resolution of bitmap images in the exported PDF.  When you select a high resolution it significantly increases the file size. High resolution is especially important to allow viewers to zoom in on pixel-based content within your exported PDF.

Advanced Tab

Display Title

Select what to display in the title bar of Acrobat when it opens your PDF. Available options are Document Title and File Name.

Language

Select the document language for the PDF. This determines the default language for the exported PDF. If the required language isn't in the list, you can also type the standard language ISO code.

Security Tab

Require a password to open the document

Select this option to require users to type the password you specify to open the document.

Document Open Password

Specify the password that users must type to open the PDF file.

Use a password to restrict printing, editing, and other tasks

Select this option to restrict access to the PDF file’s security settings. If the file is opened in Adobe Acrobat, the user can view the file but must enter the specified Permissions Password to change the file’s Security and Permissions settings. If the file is opened in Illustrator, Photoshop, or InDesign, the user must enter the Permissions Password since it isn't possible to open the file in a view-only mode.

Permissions Password

Specify a password that is required to change the permissions settings. This option is available only if the previous option is selected.

Printing Allowed

Specify the level of printing that users are allowed for the PDF document.

  • Select None to prevent users from printing the document.
  • Select Low Resolution (150 dpi) to let users print at no higher than 150 dpi resolution. Printing may be slower because each page is printed as a bitmap image.
  • Select High Resolution to let users print at any resolution, directing high-quality vector output to PostScript and other printers that support advanced high-quality printing features.

Changes Allowed

Defines which editing actions are allowed in the PDF document.

  • Select None to prevent users from making any changes to the document that are listed in the Changes Allowed menu, such as filling in form fields and adding comments.
  • Select Inserting, deleting and rotating pages to let users insert, delete, and rotate pages and create bookmarks and thumbnails.
  • Select Filling in form fields and signing to let users fill in forms and add digital signatures. This option doesn’t allow them to add comments or create form fields.
  • Select Commenting, filling in form fields, and signing to let users add comments and digital signatures and fill in forms. This option doesn’t allow users to move page objects or create form fields.
  • Select Any except extracting pages to let users edit the document, create and fill in form fields, and add comments and digital signatures.

Enable copying of text, images and other content

Lets users select and copy the contents of a PDF.

Enable text access for screen reader devices for the visually impaired

Lets visually impaired users read the document with screen readers, but doesn’t allow users to copy or extract the document’s contents.

Enable plaintext metadata

Lets users copy and extract content from the PDF. Select this option to allow storage/search systems and search engines to access metadata stored in the document. 

Create PDF forms (CS5.5 and CS5)

InDesign does not provide tools for adding form fields. You can use Adobe Acrobat for adding form fields. Design your form in InDesign with placeholders for radio buttons, check boxes, and text fields, then export to PDF and convert the placeholders into form fields using Acrobat.

  1. In InDesign, create the document you want to use for the form. Use tables and text boxes to create the placeholders for the fields.

    You can also add interactive buttons in InDesign.

  2. Export the document to Adobe PDF.

  3. Start the form wizard to convert the placeholders into form fields. Use the form tools to add and edit the form.

    • Select Tools > Forms > Create in Acrobat X to start the form wizard.
    • Select Forms > Start in Adobe Acrobat 9 to start the form wizard.

Preview interactive documents

Use the EPUB Interactivity Preview panel to preview the current selection, the current spread, or the entire document. You can resize, dock, or float the Preview panel, or move it to a second monitor.

  1. Select Window > Interactive > EPUB Interactivity Preview.

  2. To preview the interactivity and animation, do any of the following actions:

    • Select Set Preview Selection Mode   to preview the current selection.

    • Select Set Preview Spread Mode  to preview the current spread.

    • Select Set Preview Document Mode  to preview the current document.

  3. Select Play Preview  to preview the selection, spread, or document. Select interactive items such as buttons in the Preview panel to test them if necessary.

    While you preview the document, you can select the Go To Previous Page and Go To Next Page arrows at the bottom of the panel to move to different pages.

Opomba:

If you edit your document, you can refresh the preview by selecting the Play Preview button in the EPUB Interactivity Preview panel.

Use Presentation Mode

Presentation Mode (Shift + W) displays the active InDesign document as a presentation. The application menu, panels, guides, and frame edges are hidden in the Presentation mode. The background area has a dark color by default in case your document size is a different proportion from your current monitor dimensions.

Presentation Mode is a helpful companion feature to the Adobe Connect feature. You can start a web meeting by using the File > Share My Screen command. Once the screen sharing has started, you can put your InDesign document into Presentation Mode. You can also hide specific spreads in your InDesign document while in Presentation mode.

  1. Go to View > Screen Mode > Presentation.

  2. Use any of the following keystrokes.

    Key

    Action

    Mouse click, Right arrow, or Page Down

    Next Spread

    Shift-click, Right-click, Left Arrow, or Page Up

    Previous Spread

    Esc

    Exit Presentation Mode

    Home

    First Spread

    End

    Last Spread

    B

    Change background color to black

    W

    Change background color to white

    G

    Change background color to gray

Opomba:

You cannot edit the document in Presentation Mode. However with a dual screen monitor, you can have two windows open on the same document and put one of them into Presentation Mode. This approach lets you edit the document in the window set to Normal view and immediately see the results in the window set to Presentation Mode.

Have a question or an idea?

Ask the Community

We would love to hear from you. Share your thoughts with the Adobe InDesign Community

 Adobe

Pridobite pomoč hitreje in preprosteje

Ali ste nov uporabnik?