Troubleshoot common issues with Adobe Stock.

Troubleshoot Adobe Stock

Unable to download Adobe Stock assets

Unable to use vector graphics in Adobe Illustrator

A vector graphic is an image built from lines, curves, and shapes using a vector-editing software program such as Adobe Illustrator. Because of their construction, they can be resized up or downwithout any loss of quality, which makes them convenient and popular for web and mobile use, and for large-sized printed, works such as banners.

  • Try to open the vector graphic in Adobe Illustrator. If it does not work, download the file again via the Licensed History page.
  • If you are not able to download the file, follow the suggestions mentioned here.

Can't use Adobe stock with desktop apps that don't have Creative Cloud Libraries

  • Browse the Adobe Stock website, and when you find the image that you want, download it to your computer. 
  • After the image downloads, you can open it in your desktop application, even if it does not support the Creative Cloud Libraries.

Images look different in a browser than in Adobe Photoshop

The color is rendered differently in browser than in Photoshop. 

  • Make sure that you are working in RGB and not in CYMK or another color space. To check, go to Image > Mode and ensure that it's set to RGB.
  • Check what color profile Photoshop is using. It should be using sRGB IEC61966-2.1, which is considered a standard for most PC monitors. The easiest way to check is to go to Edit > Color Settings. If it's set to the "North America General Purpose 2" or "North America Web/Internet," it should work fine.
  • Set up a "proof setup" that sets a monitor color preview. Go to View > Proof Setup > Monitor RGB. Then, you can toggle the proof colors on or off by using the shortcut (depends on your operating system) for Proof Colors, which is under the View toolbar.
  • Adjust the brightness and contrast on your monitor, it displays color differently.
  • Images can look different in a browser when the browser is not color managed. Try using Firefox and turning on Color Management as described here http://www.gballard.net/photoshop/srgb_wide_gamut.html#.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy