Keyboard shortcuts

  1. Adobe XD User Guide
  2. Introduction
    1. What's new in Adobe XD
    2. Common questions
    3. Design, prototype, and share with Adobe XD
    4. System requirements
      1. Hardware and software requirements
      2. Adobe XD, Big Sur, and Apple silicon | macOS 11
    5. Workspace basics
    6. Change app language in Adobe XD
    7. Access UI design kits
    8. Accessibility in Adobe XD
    9. Keyboard shortcuts
    10. Tips and tricks
    11. Changes to XD Starter Plan
  3. Design
    1. Artboards, guides, and layers
      1. Get started with artboards
      2. Use guides and grids in XD
      3. Create scrollable artboards
      4. Work with layers
      5. Create scroll groups in XD
    2. Shapes, objects, and path
      1. Select, resize, and rotate objects
      2. Move, align, distribute, and arrange objects
      3. Group, lock, duplicate, copy, and flip objects
      4. Set stroke, fill, and drop shadow for objects
      5. Create repeating elements
      6. Create perspective designs with 3D transforms
      7. Edit objects using Boolean operations
    3. Text and fonts
      1. Work with drawing and text tools
      2. Fonts in Adobe XD
    4. Components and states
      1. Work with components
      2. Work with nested components in Adobe XD
      3. Add multiple states to components
    5. Masking and effects
      1. Create a mask with shapes
      2. Work with blur effects in XD
      3. Create and modify gradients
      4. Apply blend effects
    6. Layout
      1. Responsive resize and constraints
      2. Set fixed padding for components and groups
      3. Create dynamic designs with stacks
    7. Videos and Lotties
      1. Work with videos in XD
      2. Work with Lottie animations in XD
  4. Prototype
    1. Create interactive prototypes
    2. Animate prototypes
    3. Object properties supported for auto-animate
    4. Create prototypes with keyboard and gamepad
    5. Create prototypes using voice commands and playback
    6. Create timed transitions
    7. Add overlays
    8. Design voice prototypes
    9. Create anchor links in Adobe XD
    10. Preview designs and prototypes
    11. Create prototypes with videos in XD
  5. Share and export
    1. Share selected artboards
    2. Share designs and prototypes
    3. Work with prototypes in XD
    4. Coedit documents shared with you
    5. Create shareable links
    6. Review prototypes
    7. Work with design specs
    8. Share design specs
    9. Inspect design specs
    10. Navigate design specs
    11. Review and comment design specs
    12. Export design assets
    13. Export and download assets from design specs
  6. Design systems
    1. Design systems with Creative Cloud Libraries
    2. Work with document assets in Adobe XD
    3. Work with Creative Cloud Libraries in Adobe XD
    4. Migrate from linked assets to Creative Cloud Libraries
    5. Work with design tokens 
    6. Use assets from Creative Cloud Libraries
  7. Cloud documents
    1. Cloud documents in Adobe XD
    2. Collaborate and coedit designs
  8. Integrations and plugins
    1. Work with external assets
    2. Work with design assets from Photoshop
    3. Copy and paste assets from Photoshop
    4. Import or open Photoshop designs
    5. Work with Illustrator assets in Adobe XD
    6. Open or import Illustrator designs
    7. Copy vectors from Illustrator to XD
    8. Plugins for Adobe XD
    9. Create and manage plugins
    10. Jira integration for XD
    11. Slack plugin for XD
    12. Zoom plug-in for XD
    13. Share prototype from XD to Behance
  9. XD for iOS and Android
    1. Preview on mobile devices
    2. Adobe XD on mobile FAQ
  10. Troubleshooting
    1. Known and fixed issues
      1. Known issues
      2. Fixed issues
    2. Installation and updates
      1. XD appears as not compatible on Windows
      2. Error code 191
      3. Error code 183
      4. Issues installing XD plugins
      5.  Prompt to uninstall and reinstall XD on Windows 10
      6. Issues with preferences migration
    3. Launch and crash
      1.  XD crashes when launched on Windows 10
      2.  XD quits when you sign out of Creative Cloud
      3. Issue with subscription status on Windows
      4. Blocked-app warning when launching  XD on Windows
      5. Crash dump generation on Windows
      6. Crash log collection and sharing
    4. Cloud documents
      1. Issues with XD cloud documents
    5. Prototype, publish, and review
      1. Unable to record prototype interactions on macOS Catalina
      2. Issues with publish workflows
      3. Published  links do not appear in browsers
      4. Prototypes do not render correctly in browsers
      5. Commenting panel suddenly showing up on shared links
      6. Unable to publish libraries
    6. Import, export, and working with other apps
      1. Import and export in XD
      2. Photoshop files in XD
      3. Illustrator files in XD
      4. Export to After Effects from XD
      5. Sketch files in XD
      6. Third-party apps not visible in Export

List of all keyboard shortcuts that you can use in Adobe XD.

XD provides shortcuts to help you quickly work on documents. Many keyboard shortcuts appear next to the command names in menus.

Downloadable version of keyboard shortcuts

Download and print a print-friendly version of these keyboard shortcuts.

 Click to download.

XD has introduced a new plugin that lets you view all the keyboard shortcuts. To install the plugin, go to Plugins > Keyboard Shortcuts > Install. After installing the plugin, use the folllowing shortcuts to access the keyboard shortcuts:

  • Mac: Shift + Cmd + f
  • Windows: Shift + Ctrl + f

General shortcuts

Result

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Quit

Cmd + Q

Alt + F4

Keys for Edit menu

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
Undo Cmd + Z Ctrl + Z
Redo ⇧ + Cmd + Z Ctrl + Shift + Z
Cut Cmd + X Ctrl + X
Copy Cmd + C Ctrl + C
Paste Cmd + V Ctrl + V
Paste Appearance (in Design mode), and
Paste Interaction (in Prototype mode)
Cmd + Alt + V Ctrl + Alt +V
Duplicate Cmd + D Ctrl + D
Delete Delete
Select All
Cmd + A Ctrl + A
Deselect All ⇧+ Cmd + A Ctrl + Shift + A

Keys for File menu

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
New Cmd + N
Ctrl + N
Open... Cmd + Shift + O Ctrl + Shift + O
Close Cmd + W Alt + F4
Save... Cmd + S
Ctrl + S
Save As... ⇧+ Cmd + S Ctrl + Shift + S
Save As Local Document... Alt + Shift + Cmd + S     Shift + Ctrl + Alt + S
Export Batch Shift + Cmd + E Ctrl + Shift + E
Export Selected Cmd + E Ctrl + E
Export to an integrated third-party application (if an application integrated with XD is installed on your computer) Alt + Cmd + E Not available
Import Shift + Cmd + I Ctrl + Shift + I

Keys for Path/Pen

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
Switch to Pen tool P P
Convert Point Double-click Double-click
Asymmetric Control Point Alt Alt
Snap Control Point Angle Shift Shift
Snap Anchor Point Angle Shift Shift
Add Alt + Cmd + U Ctrl + Alt + U
Subtract Alt + Cmd + S Ctrl + Alt + S
Intersect Alt + Cmd + I Ctrl + Alt + I
Exclude Overlap Alt + Cmd + X Ctrl + Alt + X
Convert to Path Cmd + 8 Ctrl + 8

Keys for Layers (Objects), Groups, Scroll groups, and Artboards

Menu Keyboard shortcut on macOs Keyboard shortcut on Windows
Group layers Cmd + G Ctrl + G
Ungroup layers Shift + Cmd + G Ctrl + Shift +G
Make component Cmd + K Ctrl + K
Lock/Unlock layer Cmd + L Ctrl + L
Hide/Show layer Cmd + , Ctrl + ,
Mask with shape Shift + Cmd + M Ctrl + Shift + M
Make repeat grid
Cmd + R Ctrl + R
Directly select a layer in a group/component Cmd + Click layer in canvas Ctrl + click layer in canvas
Change layer opacity 1 to 9 (0 for 100%) 1 to 9 (or 0 for 100%)
Select artboard Cmd + Click on blank part of artboard Ctrl + click on blank part of artboard
Draw shape from center Alt + Drag Alt + Drag
Draw shape with 1:1 aspect ratio (perfects square/circle) Shift + Drag Shift + Drag
Draw equilateral triangle Shift + Drag Shift + Drag
Show/ Hide artboard guides Cmd + ; Ctrl + ;
Lock artbard guides Shift + Cmd + ; Shift + Ctrl + ;
Move element by 10px  Shift + Arrows Shift +  Arrows
Resize element by 1px increment Cmd + Arrows Alt + Arrows
Resize element by 10px increment Cmd + Shift + Arrows Alt + Shift + Arrows
Select through overlapping layers Cmd + Click Ctrl + Click
Edit padding Hover and drag on canvas + S Hover and drag on canvas + S
Mirror padding on opposing sides Alt + S Alt + S
Edit all sides Shift + S Shift + S
Horizontal scroll Shift + Cmd + H
                     Shift + Ctrl +H
Vertical scroll               Shift + Cmd + V
                     Shift + Ctrl +V
Horizontal and vertical scroll               Shift + Cmd + D
                    Shift + Ctrl +D

Keys for Align

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Left

Ctrl + Cmd + ←

Ctrl + Shift + ←

Center (horizontally)

Ctrl + Cmd + C

Shift + C

Right

Ctrl + Cmd + →

Ctrl + Shift + →

Top

Ctrl + Cmd + ↑

Ctrl +Shift + ↑

Middle (vertically)

Ctrl + Cmd + M

Shift + M

Bottom

Ctrl + Cmd + ↓

Ctrl + Shift + ↓

Keys for Arrange

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Bring to Front

Shift + Cmd +]

Shift + Ctrl + ]

Bring Forward

Cmd + ]

Ctrl + ]

Send Backward

Cmd + [

Ctrl + [

Send to Back

Shift + Cmd + [

Shift + Ctrl + [

Keys for Distribute

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Horizontal

Ctrl + Cmd + H

Ctrl + Shift + H

Vertical

Ctrl + Cmd + V

Ctrl + Shift + V

Keys for Text

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Bold

Cmd + B

Ctrl + B

Italic

Cmd + I

Ctrl + I

Underline

Cmd + U

Ctrl + U

Increase font size

Shift + Cmd + >

Ctrl + Shift + >

Decrease font size

Shift + Cmd + <

Ctrl + Shift + <

Keys for Operations menu

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

From Center

Alt

Alt

Copy Paste Object

Alt + Drag

Alt + Drag

Constrain

Shift

Shift

Edit Text

Enter

Enter

Constrain Rotate

Shift (15°)

Shift (15°)

Line Constrain Rotate

Shift (45°)

Shift (45°)

Constrain From Center

Shift + Alt

Shift + Alt

Direct Select

Cmd

Ctrl

Switch between Design and Prototype mode

Ctrl + Tab

Ctrl + Tab

Keys for Tools menu

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
Select V V
Rectangle R R
Ellipse E E
Polygon Y Y
Line L L
Pen P P
Text T T
Artboard A A
Zoom
Enter zoom mode: Z Enter zoom mode: Z
Zoom to Selection Cmd + 3 Ctrl + 3
Eyedropper  I I

Keys for Interface and Viewing Options

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
Switch to Design mode
Alt + 1
Alt + 1
Switch to Prototype mode Alt + 2
Alt + 2
Switch to Share mode Alt + 3
Alt + 3
Zoom In
  • Cmd + , 
  • Alt - Scrollwheel, 
  • Alt - swipe (Magic Mouse)
  • Pinch out (trackpad)
  • Ctrl + +
  • Ctrl - Scrollwheel
  • Pinch out (trackpad)
Zoom Out
  • Cmd + - 
  • Option-Scrollwheel
  • Option-swipe (Magic Mouse)
  • Pinch in (trackpad)
  • Ctrl + -
  • Ctrl-Scrollwheel
  • Pinch in (trackpad)
Zoom to Fit
Cmd + 0 Ctrl + 0
100% Cmd + 1 Ctrl + 1
200% Cmd + 2 Ctrl + 2
Pan Spacebar Spacebar
Assets Shift + Cmd + Y Ctrl + Shift + Y
Layers Cmd + Y Ctrl + Y
Show Layout Grid Shift + Cmd +  '
Shift + Ctrl + '
Show Square Grid Cmd + ' Ctrl + '
Fullscreen Mode Ctrl + Cmd + F  Not available
Switch between design and prototype mode Ctrl + Tab Ctrl + Tab
Switch between Windows (Files)

Cmd + Tilde (~)

Not available
Increase or decrease a value in a field by 1 ↑ or ↓ ↑ or ↓

Increase or Decrease a value in a field by 10

Hold Shift + hit ↑ or ↓

Hold Shift + hit ↑ or ↓

Keys for Window menu

Menu

Keyboard Shortcut on macOS

Keyboard shortcut on Windows

Maximize

 

WIN ↑

Minimize

Cmd + M

WIN ↓

Preview

Cmd + ⏎

Ctrl + Enter

Keys for operation modifiers

Menu

Keyboard Shortcut on macOS

Keyboard shortcut on Windows

Horizontal Pan

Shift + Scrollwheel

Shift + Scrollwheel

Vertical Pan

Scrollwheel

Scrollwheel

Keys for Selection and measuring distances between elements

Menu

Keyboard Shortcut on macOS

Keyboard shortcut on Windows

Enable measurements

Option (with an object selected)

Alt (with an object selected)

Distance from Selected Layer

Hold Alt and Hover over object/group/artboard

Hold Alt and Hover over object/group/artboard

Distance relative to Selected Group

Hold Alt + Cmd and Hover over an object in the group

Hold Ctrl + Alt  and Hover over an object in the group

Keys for Design Specs

Menu

Keyboard Shortcut on macOS

Keyboard shortcut on Windows

Zoom

Cmd + Mousewheel

Cmd + , Cmd - 

Ctrl + Mousewheel

Ctrl +, Ctrl -

Reset zoom

Cmd + 0

Ctrl + 0

Pan

↑, ↓, →, ←

Spacebar + Click-and-drag

↑, ↓, →, ←

Spacebar + Click-and-drag

Faster pan

Shift + ↑, ↓, →, ←

Shift + ↑, ↓, →, ←

Remove focus from artboard in Spec view

Esc

Esc

Navigate across linked artboards

Shift + Click

Shift + Click

Keys for Vector Editing

Menu

Keyboard Shortcuts on MacOS

Keyboard Shortcuts on Win

Start Editing Selected Vector Object

Enter

 Enter

Stop Editing Selected Vector Object

Esc

 Esc

Switch Between Straight and Mirrored Control Points

Double-Click

 Double-Click

Disconnect Control Point Handle

Alt + Drag

Alt + drag

Keys for Prototyping

Menu

Keyboard Shortcuts on MacOS

Keyboard Shortcuts on Win

See all connections in prototype mode

Cmd + A

Ctrl + A

Hide all wires 

Alt

Alt

Preview

Cmd + Enter

Ctrl + Enter

Start or stop recording the preview

Cmd + Ctrl + R

Not available

Stop recording

Esc

Not available

Navigate artboards in preview or shared prototype

Right or Left Arrow

 → or ←

Create a new line in the comment box of shared prototype link 

Enter or Shift + Enter

Enter or Shift + Enter

Submit comment entered in the comment box of shared prototype link

Cmd + Enter 

Ctrl + Enter 

More like this

Adobe logosu

Hesabınıza giriş yapın