User Guide Cancel

[Ps] Create a tutorial

1. Plan for limitations

Note:

triangular flag Important: Plan for the current limitations of Tutorial Builder

Plan for the current limitations by choosing images and workflows using features that are supported by the Tutorial Builder. 

  • Avoid Task spaces: These are windows that are separate from the main Photoshop interface.
    • check mark button Do example: Choose Select > All Layers
    • cross mark Don’t example: Select and Mask, Content Aware Fill, Sky Replacement, Camera Raw, Home screen
  • Avoid Filters above the bottom section of the main Filters menu as well as some filters in the bottom section of the main Filters menu 
  • direct hit Important Tip: Before you propose a tutorial that uses a filter, test that it works in the most recent build.
    • check mark button Do example: Gaussian Blur, Motion Blur, Radial Blur, Unsharp Mask, and some other filters in the bottom section of the main Filters menu. 
    • cross mark Don’t example: Neural filters, Filter Gallery, Camera Raw Filter, Lens Correction, Liquify, Vanishing Point
    • cross mark Don't example: Blur Gallery, Lens Blur 
  • Avoid Open, Create New, Save, Export, and opening multiple documents.
  • Avoid the Brush Settings panel and Brushes panel. Use the Brush Presets option instead.
  • Avoid the Layer > Create Clipping Mask and Layer > Release Clipping Mask commands for now. Use Option/Alt+click the border between layers instead.
  • Avoid transforming a Shape (the Free Transform, as well as Transform commands on a Shape layer) for now.
  • Avoid the Edit > Undo and Edit > Redo commands for now. Instead, for undo use Cmd+Z (MacOS) Ctrl+Z (Win), and for redo use Shift+Cmd+Z (MacOS) Shift+Ctrl+Z (Win).

2. Prepare to create a tutorial

Prepare

  • Follow the installation instructions provided by your Community Manager to install the version of Tutorial Builder and Photoshop stated in those instructions. Make sure you are using the correct version of Photoshop.
  • Plan your tutorial content.
  • Create your assets: Startup file, Hero image, and Thumbnail.

Open your Startup file

  • Open your Startup file locally in Photoshop

Launch the Tutorial Builder

  • In the Photoshop Menu bar, choose Plugins > Interactive Tutorial Builder > Interactive Tutorial Builder
  • The Interactive Tutorial Builder panel opens to your personal Dashboard, where you’ll see all your tutorials by status.   
    • In progress: In this tab you can Edit, Preview, or Delete a tutorial by clicking the three-dot menu
    • Submitted: Preview options available in this tab
    • Needs Review: Preview options and Editing is available
    • Published: Preview options available in this tab
  • Return to the Dashboard by clicking the Home icon

Create a new tutorial

  • Click the Create button to start a new tutorial.

3. Build the Start screen

This is the Start screen users will see in the Discover panel when they visit your tutorial. Follow the instructions below to build your Start screen. 

Enter the tutorial title

  • Prepare the tutorial title in advance, and review Writing titles in the Writing guidelines for Tutorial Builder article.
  • Enter your prepared title in the Title your tutorial field.
    • The title you enter here becomes both the user-facing title and the document identifier which is important for searches. 
    • Be thoughtful about what you enter, because you can’t return to this title screen or change the document identifier. 
      • You CAN change the user-facing title on the next screen if needed
  • Click Create to open the Create tab.

Complete the Intro View 

  • The Create tab opens to the Intro View section, which resembles the start screen a user will see when they visit your tutorial.
  • Click Edit to access fields for uploading the hero image, editing the tutorial title, and adding the tutorial description. 
  • Upload the Hero image: 
    • Click Select File and navigate to the Hero image you prepared (1200x600 px jpeg). The uploaded Hero image appears at the top of your Intro View
  • Edit the Tutorial title (optional): 
    • You can change the tutorial title you entered in the last screen. But this will change only the title the user sees; it won’t change the document identifier behind the scenes.
    • Enter the Tutorial description: 
Note:

triangular flag Important: Save your work!

  • Click both the  Done button below the details of each step and the Save button at the top of Tutorial Builder.

triangular flag Tip: To access this Tutorial Builder Guide in the Tutorial Builder, click the Question mark icon in the global footer to automatically launch the default browser to the TB Guide.

4. Create sections and steps

Create sections and steps to build out the tutorial. Aim for no more than 4 (four) sections and no more than 5 (five) steps in a section. See the Writing guidelines for Tutorial Builder article.

Create the first section

  •  Click the blue Add button below the Intro View section and choose Section.
  • Enter a Title for this section.
    • The section title usually starts with an action verb. It summarizes what users will accomplish by following the steps in this section. 
    • See more information for Writing titles in in the Writing guidelines for Tutorial Builder article.
  • Enter a Description for this section.
    • You have the option to enter additional information about the section here. Avoid using language that sounds like an instruction. 
    • See Writing descriptions in in the Writing guidelines for Tutorial Builder article.
  • Click the Done button below the Description field. 
    • Scroll down if you don’t see the Done button
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost. 

Add steps to the section

  • Click the blue Add button below the section description and choose Step.
  • Choose coach mark placement: 
    • Click Placement > Select to open the Placement menu.
    • Choose the type of Photoshop element on which to place this coach mark:
      • Canvas, Dialog, Layer, Menu Bar, Options Bar, Panel, or Tool Bar.
  • Your next steps depend on which Placement type you chose:

Placement > Tool Bar

  • To place a coach mark on a tool in the Toolbar, Choose Placement > Tool Bar
  • The Record button appears.
  • Click Record
    • Tutorial Builder guides you by displaying a Record button only if the Placement type you choose supports recording a coach mark.
  • In Photoshop, select the tool to which you want the coach mark to point. 
    • Tip: If the tool you want is already selected, click on another tool and then click back on the tool you want.
  • Click Stop recording.

Remove any extra actions

  • Tutorial Builder recorded your actions, each of which is displayed in a small box under the Record button. 
    • If multiple actions are displayed, identify the one you want to keep and click the X on the other actions to delete them. A step can have only one action.
    • Example: Click the X on the Object Selection tool action, so that that only the Quick Selection tool action remains.
    • Tip: If you recorded more than one of the same action (for example, if you clicked the same tool more than once by mistake), removing one of those actions will remove all instances of the same action on this step. 
      • If that isn’t the result you want, cancel or delete the step and record it again.

Edit the coach mark text

  • Scroll down to the Text field, where you’ll see auto-generated text for the coach mark, without a period at the end. 
  • Add a period. 
  • Enter any additional text. 
    • Example: Select the {quickSelectTool}. If this tool is already selected, click another tool and then back to this tool.
    •  Important Tip: Don’t change any auto-generated text that is inside of the curly brackets {...}.
  • The Play button to the right of the step will be on, so you can see a preview of this coach mark in Photoshop. 
  • Scroll down and click the Done button to close the editing area. The coach mark text appears in a blue box in the Tutorial Builder.
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.
  •  Important: Click the Save button at the top of Tutorial Builder.
  • Tip: To create a coach mark that points to an item below the three dot icon in the Toolbar (such as the Foreground or Background color box, the Default colors button, or the Color switcher), do not choose Placement > Tool Bar. 
    • Choose Placement > Panel and then choose Panel name > Tool

Placement > Panel

  • Choose Placement > Panel to point a coach mark to a panel in Photoshop. 
  • You will create this coach mark using the drop down menu and filling out the text box. The Record button does not appear for a Panel coach mark. 
  • Click the Panel name drop down menu and choose the name of the panel that contains the element you want to coach mark.
  • Click the Panel element drop down menu to choose where to place the coach mark.

triangular flag Tip: The Panel element menu does not contain all possible panel elements. If you don’t see the panel element you want, choose the panel name as the element 

  • Example: Panel element  > Properties panel
    • This creates a coach mark that points to the center of the vertical panel edge.

  •  Scroll to the Text field and enter the text that will appear on the coach mark. Include a period at the end of this text.
    • Tutorial Builder automatically adds at the end: Click Next to continue.
    • Tip: When you choose the panel name as the panel element, you often have to include all instructions related to that panel in one coach mark. 
      • Example: You want users to move multiple Hue/Saturation adjustment sliders in the Properties panel. Choose Placement > Panel and Panel name > Properties
        • In the Text field enter: Drag the Hue slider to about +8 to change the background color to yellow. Drag the saturation slider to about +20 to increase color intensity and the Lightness slider to about -10 to darken the color.
  • Click Done and click Save.
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.    

 Placement > Options bar

  • Choose Placement > Options bar to point a coach mark to the tool Options bar
  • You will create this coach mark by using the drop down menus and editing the text field. The Record button does not appear for an Options bar coach mark. 
    •  Tip: Skip over the Manual controls switch.
  •  Make sure a coach mark was created to record the tool selection first.
  • Click the Options bar element menu, which displays all the options for the selected tool in the order in which they appear in Photoshop’s tool Options bar. Choose an option 
    • Example: With the Brush tool selected, choose Options bar element > Click to open the Brush Preset picker.
  • In the Text field, enter the text for this coach mark, with a period at the end.
  • Tip: You’ll usually put all instructions for an Options bar step in one coach mark. 
    • Example: Click to open the Brush Preset picker. Set Size to 200 px and Hardness to 10% for a big soft brush.
  • Click Done and click Save.
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.

Placement > Menu Bar

  •  Choose Placement > Menu Bar to point a coach mark to an item on the Menu bar.
  • Click Record. Click the item in the Menu bar where you want the coach mark to point.
  • Click Stop Recording.
  • Remove any extra action tags 
    • The Tutorial Builder recorded your actions, each of which is displayed in a small box under the Record button. 
    • If multiple actions are displayed, identify the one you want to keep and click the X on the other actions to delete them. 
  • Edit the text: In the Text field, you’ll see auto-generated text for the coach mark, add a period at the end. 
    • You can change or add text, except do not change any auto-generated text that is inside of the curly brackets {...}.
  • Click Done and Save
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.
Note:
  • Important: Some coach marks for filters and other items in the Menu bar trigger a dialog box.
  • Create two coach marks:
    • One Menu Bar coach mark with the command for accessing the menu item 
    • One additional Dialog coach mark with instructions about what to do in the dialog box.

direct hit Example: You want to instruct users to apply a Gaussian Blur filter with certain settings. 

  • First create a coach mark that points to the Menu bar and instructs users to choose the Gaussian Blur filter: 
    • Choose Placement > Menu Bar
    • Click Record and choose Filter > Blur > Gaussian Blur. The Gaussian Blur dialog box opens. 
      • Don’t make changes to the filter settings yet. 
      • Instead, click OK to close the Gaussian Blur dialog box. (Until you do that you won’t be able to stop recording because you’ll be in a modal state.) 
    • Click Stop Recording
    • In the Text field, you’ll see auto-generated text Select Filter > Blur > Gaussian Blur [without a period].
    • Add a period at the end of that text and change the word Select to Choose. 
    • Click Done and Save. This creates a Menu Bar coach mark that reads Choose Filter > Blur > Gaussian Blur. 
      • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.
  • Secondly create another coach mark that points to the Gaussian Blur dialog box and tells users which filter settings to apply.
    • Choose Placement > Dialog. You won’t see a Record button. 
    • Choose Filter > Blur > Gaussian Blur to open the Gaussian Blur dialog box again. 
    • In the Text field in Tutorial Builder enter your coach mark text, including an instruction to click OK to close the Gaussian Blur dialog box. 
    • Click Stop Recording
    • Tutorial Builder automatically adds Click Next to continue.  This creates a Dialog coach mark that reads: Drag the Radius slider to +3 to blur the photo and click OK. Click Next to continue.
    • Click Done and Save.
      • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.
  • See the [Ps] Examples of common coach marks for additional examples.

 Placement > Layer

  • Placement > Layer records the following 4 actions:
    • Select a layer
    • Move a layer
    • Turn layer visibility off
    • Turn layer visibility on
  • Choose Placement > Layer
  • Click the Record button that appears.
  • In the Layers panel:
    • Select a layer or turn a layer’s visibility off or on.
    • To move a layer, first record selecting the layer to move, then record moving the layer.
  • Click Stop Recording.
  • Edit the coach mark text: 
    • Add a period and change the text to make it more user friendly.
    • Example: Change the auto-generated text Hide Layer → Background to Click to hide the Background layer
    • Example: Change the auto-generated text Select Layer → Girl to Select the Girl layer.
  •  Click Done and Save.
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.
  • triangular flag Important: The situations above are the only times you should choose Placement > Layer
    • For all other Layers panel-related coach marks, use the drop down menus to choose Placement > Panel, Panel > Layers, and a Panel Element. 
    • If you don’t find the specific Layers Panel Element you want, choose Panel Element > Layers panel to create a coach mark that points to the center of the vertical edge of the Layers panel.

Placement > Dialog

  • Choose Placement > Dialog to place a coach mark so it points to an open dialog box.
  •  In the Text field in Tutorial Builder enter your coach mark text, including an instruction to click OK to close the dialog box. 
    • The Record button doesn’t appear for a Dialog coach mark.
  • Click Done and Save.
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.
  •  Tutorial Builder automatically adds Click Next to continue.
  • A Dialog coach mark always points to the center of the vertical edge of the prior dialog box.

  • Tip: You usually have to put all instructions for a Dialog coach mark in one coach mark. Take this into account when planning your tutorial.
    • Example: Click the Foreground color box to open the Color Picker. Choose a purple color from the vertical bar. Then click in the large color box to choose a light purple. Click OK.

Placement > Canvas

  • Choose Placement > Canvas to place a coach mark on the canvas of the open document.
    • The Record button doesn’t appear for a Canvas coach mark. 
  • Drag the Horizontal position and Vertical position sliders to position the coach mark where you want it on the canvas.
  • Use the Arrow direction buttons to change the direction of the pointer on the coach mark. 
  • Click the double-arrow button to change the location of the pointer on the coach mark.
  • In the Text field, enter the text for this coach mark, with a period at the end.
    • Example: Drag across the object to select it.
  • Click the Play button below the step details to preview the coach mark on the canvas.
  • Click Done and click Save.
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.

Edit, move or delete a Section

  • To edit a section at any time, click the Edit button under the section.
  • To delete or move a Section and its steps, click the three dots under the section and choose Delete, Move Up, or Move Down.
  • Click the Done button, otherwise any edits made to an existing, or previously saved card, will be lost.
  • triangular flag Important Tip: You can’t create a new section between two existing sections or right after the Intro card
    • A workaround is to create a new section lower down in the stack of sections and include at least one step in that new section. 
    • Then click the three dots and choose Move Up.

Edit, move or delete a step

  • To edit a step, click the Edit button underneath.
  • To delete or move a step, click the three dots and choose Delete, Move Up, or Move Down.
  • Click the Done button, otherwise any edits made will be lost.

Edit, move or delete a note

  • To edit a note, click the Edit button underneath.
  • To delete or move a note, click the three dots and choose Delete, Move Up, or Move Down.
  • Click the Done button, otherwise any edits made will be lost.

Add a note to a step

  • To add a note to a step, click the blue Add button below that step and choose Note.
  • Enter the text of the note in the Text field.
  • Click Done and Save.
    • If you don't click the Done button, any content entered in a newly created card (or edits made to an existing, previously saved card) will be lost.
Note:

direct hit Important: Minimize the use of Notes

  • A note is a tip related to a coach mark that appears in the panel when that coach mark is activated. 
  • Notes can be distracting to users, so do not create a note unless you have a tip that is critical (like a “gotcha”) that does not fit in a coach mark.
  • Do not include instructions or words that sound like instructions. 
  • Do not include more than two (2) notes per section. 
  • If you’re thinking about adding a note, try to see if you can get the information into one of your other coach marks.
  • Note example: If you don’t get the result you expected, you may have the wrong layer selected. Check that the xyz layer is highlighted in Layers panel.

5. Preview your tutorial

When you’re finished creating a tutorial, preview how it will look to users from start to finish. You also can use this preview function while you’re creating the tutorial to preview everything you’ve created so far

  •  Click the Save button at the top of the Tutorial Builder.
  • Click the button Preview in the top right corner of the Tutorial Builder.
    • triangular flag Important Tip: You can’t Preview your tutorial until you’ve uploaded your Startup file. You can jump to the Finish screen at any time to upload the Startup file.
  • Click Start Tutorial to start the tutorial from its beginning.
  • Follow the instructions on the coach marks to walk through the tutorial from a users point of view. 
  • If you want to make changes to your tutorial, you will need to exit Preview mode. To exit the tutorial preview, click End
Note:

 direct hit Tip: In Preview mode, please make sure you can click through the entire tutorial. 

  • If you can’t advance to a next step and you don’t see a Click next button in the panel, try this:
    • Click End to exit Preview mode.
    • In the Tutorial Builder, delete the step on which you got stuck in Preview mode and re-create the step.
Finish tab in TB

6. Complete and submit your tutorial

Go to the Finish tab

  • Click Next at the bottom of Tutorial Builder or click the Finish tab at the top of Tutorial Builder to go to the Finish screen.

Upload your Startup file

  • Click Select a file to upload and navigate to the Startup file on your computer. This is the image file that begins the tutorial. 
  • The Startup file must be PSD or PSDT file under 20 MB. 
  • triangular flag Important Tip: You cannot Preview your tutorial until you’ve uploaded your Startup file. You can jump to the Finish screen at any time to upload the Startup file.
  • For startup file requirements, see [Ps] Asset guidelines and [Ps] Image specs.

Identify whether your Startup file contains any text

  • triangular flagImportant Tip: If your startup file contains any text, whether it’s on a Type layer or is rasterized text, check Yes in response to the question Does this file contain text? This will ensure that any text in your Startup file is localized.

Add image credits: 

  • If you are the image creator, select Include my name, which causes the system to enter your name in Image credits
  • Enter the names of any other image creators in the Image credits field.
  • If your Startup file is an Adobe Stock image list the contributors here, as follows: Adobe Stock: [contributor 1 name], [contributor 2 name], [contributor 2 name]

Enter a Completion message

  • Enter a Completion message that congratulates the user and summarizes what they learned in the tutorial. This is an important part of the learning experience for users!
Note:

If you are unsure of what tag to use for any of the fields below, go to our Tagging guidelines.

Enter Skill level

  • Skill level refers to the topic of the content, not you or the user.
  • Click in the field and select from the drop-down menu.
  • If you decide that a particular tag you choose does not fit the content, after all, you can always click the 'x' next to the tag to delete it. 
  • There are three (3) Skill level tags, and you can select only one (1). 

Enter Creative field

  • Click the Creative field menu and type the at symbol (@) and select one or more creative domains, or distinct areas of expertise that your content might be most associated with.
  • There is a short list of Creative field tags to choose from. Some tags don’t apply to some products, so you may see fewer.
  • Choose at least one Creative field, and as many as are necessary. 
  • If you decide that a particular tag you choose does not fit the content, after all, you can always click the 'x' next to the tag to delete it. 

Enter Topics covered

  • Topic tags reflect the content’s overall goal or subject matter.
  • In the Topics covered field, type the at symbol (@) and select one or more relevant topics from the menu.
  • Choose at least one Topic tag; you can add up to a total of 5 for your tutorial. 
  • If you decide that a particular tag you choose does not fit the content, after all, you can always click the x next to the tag to delete it.

Enter Tasks

  • These are the actions users take as they follow the content’s instructions.
  • You can select as many Task tags as you feel necessary, as long as they are outlined in the tutorial.
  • Type the at symbol (@) and select one or more tasks from the menu that appears. 
  • If you decide that a particular tag you choose does not fit the content, after all, you can always click the x next to the tag to delete it.

Enter Tools & features

  • This category contains the app-specific features used to accomplish tasks, such as tools, panels, and menu commands.
  • You can select an unlimited number of Tool tags, but be sure to select only the tools, panels, and menu commands mentioned in your tutorial.
  • Type the at symbol (@) and select one or more tools from the menu that appears. 
  • If you decide that a particular tag you choose does not fit the content, after all, you can always click the x next to the tag to delete it. 

Upload Thumbnail image

  •  Upload the 740px x 740px Thumbnail image you prepared. Must be a PNG, JPG, or JPEG file under 200KB. 
  • The square image appears next to your tutorial title in search results. It should show the final output, or "after" state, of your tutorial.
  • Specs and templates for Thumbnail images are here.

Save all your work again!

  • Click Save at the top of the Tutorial Builder. 
  • Click Preview again to give your tutorial a final once over.
  • If you want to make any changes to your tutorial, click Create at the top of the screen to return to your sections and steps.

Submit your tutorial

  • Click the Submit button at the bottom of the Finish screen when you’re sure the tutorial is complete. 
  • Submitting the tutorial moves it from the In progress queue in your Dashboard, you won’t be able to access it again until you receive a review notification.

7. Tutorial review

Step 1: Notification

  • After you submit your tutorial, a curator will review it, and you’ll receive an email notification from the system that your tutorial is approved or that further action is required.

Step 2: Editing

  • If you get an Action Required notification, go to your Topics for [author] Paper document. 
    • The requested changes will be listed in the Review Feedback section
    • Contact your Curator if you have questions or comments about changes.
  • Make the requested changes in the Tutorial Builder.
    •  In the TB Dashboard  go to the Needs review tab
    • Locate the tutorial that needs edits
    • Click the three-dot menu on the tutorial and choose Edit
    • Make the requested changes.
    • Click Submit

Step 3: Completion

  • After you make changes, you’ll receive another notification from the system approving or rejecting the tutorial.
    • If the tutorial is rejected at this stage, please repeat review Step 2: Editing.
    • Once your tutorial is approved, your work is complete. Thank you!

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online