Імпорт файлів SVG

Останнє оновлення: 29 вер. 2026 р.

Дізнайтеся, як імпортувати файли SVG як рідні шари форми, які можна редагувати та які готові до анімації без потреби в конвертації.

Двічі клацніть всередині панелі Проєкт або скористайтеся Файл > Імпорт > Файл, щоб знайти та імпортувати файл SVG.

Примітка

Найновіша версія After Effects дає змогу імпортувати файл як відеоматеріал або композицію.

Перетягніть імпортований файл SVG на панель Хронометраж.

Виберіть шар, щоб скористатися розділом Вміст шару на панелі Властивості для перегляду структури SVG.

Панель «Властивості» відкрита, а під розділом «Вміст шару» перелічено вміст SVG.
Скористайтеся панеллю «Властивості» для перегляду вмісту файлу SVG і налаштування його властивостей.

Також можна вибрати стрілку поруч зі шаром, щоб розгорнути його, а потім розширити розділ Вміст.Ви побачите всі окремі елементи та їхні властивості, як-от Контур, Заливка і Перетворення.

Вибрано шар з файлом SVG, а розділ «Вміст» розгорнуто, щоб відобразити його властивості, зокрема контур, заливку та перетворення.
Розгорніть розділ «Вміст» шару SVG, щоб отримати доступ до його властивостей і редагувати їх, зокрема контур, заливку та перетворення.

Ці властивості можна використовувати для анімації так само, як і будь-який інший шар форми.Наприклад:

  • Анімуйте Контур для створення ефектів морфінгу
  • Змінюйте колір заливки з часом для динамічних переходів
  • Використовуйте властивості Перетворення, щоб масштабувати, повертати або переміщувати елементи незалежно

Якщо шари мають градієнтні заливки та обведення, можна використовувати властивості Масштаб і Поворот для анімації градієнта.

Вибрано один зі шарів з елементом градієнта, і виділено «Градієнтна заливка 1».
Використовуйте властивості градієнтної заливки для налаштування градієнта або його анімації.

Імпорт файлу SVG як відеоматеріалу або як композиції

Імпорт SVG в After Effects забезпечує гнучке та розширене керування способом імпорту файлів SVG у проєкт.З найновішою версією під час імпорту файлу SVG можна вибрати, як його імпортувати: як відеоматеріал або як композицію.

Імпорт як відеоматеріал

Імпорт як композицію

Імпортує SVG як один неперервно растеризований векторний шар.

Імпортує SVG як композицію з шарів форми, які можна редагувати.

Зберігає з'єднання із зовнішнім файлом SVG.

Кожен елемент перетворюється на власну редаговану фігуру.

Підходить для однорівневої векторної графіки, коли не потрібно розбивати ілюстрацію на частини.

Підходить для редагування контурів, форм і деталей рівня шару, коли потрібно анімувати окремі елементи.

Можна керувати підходом до імпорту, що використовується за замовчуванням під час імпорту файлів SVG, встановивши параметр Перетягувати кілька елементів файлу як у налаштуваннях Імпорт.

  • macOS: After Effects > Параметри > Імпорт > Перетягувати кілька елементів файлу як
  • Windows: Редагування > Налаштування > Імпорт > Перетягувати кілька елементів файлу як
Діалогове вікно «Налаштування» відкрито.На вкладці «Імпорт» відкрито спадне меню «Перетягувати кілька елементів файлу як» з параметрами вибору способу імпорту.
Встановіть налаштування за замовчуванням для імпорту файлу SVG, вибравши, чи імпортувати його як відеоматеріал або як композицію.

Двічі клацніть на панелі Проєкт або скористайтеся командою Файл > Імпорт > Файл, щоб знайти та імпортувати файл SVG.

Скористайтеся спадним меню Імпорт як у діалоговому вікні Імпорт файлу, щоб вибрати один із наведених варіантів:

  • Відеоматеріал
  • Композиція — зберегти розміри шарів

Вибір Відеоматеріал імпортує файл як один сплощений шар без доступу до окремих елементів, що підходить для статичного використання або коли анімація не потрібна.Вибір параметра Композиція — зберегти розміри шарів створює нову композицію, де кожен вихідний шар імпортується окремо з розміром відповідно до фактичного вмісту, що робить точки прив'язки чистішими, а перетворення простішими для анімації.

macOS

Діалогове вікно «Імпорт файлу» відкрито, доступні параметри імпорту файлу як відеоматеріалу або як композиції.

Windows

Діалогове вікно «Імпорт файлу» відкрито, доступні параметри імпорту файлу як відеоматеріалу або як композиції.

Виберіть наведені параметри, якщо потрібно:

  • Створити композицію: створює нову композицію з налаштуваннями за замовчуванням і автоматично розміщує імпортований SVG на часовій шкалі як відеоматеріал або як композицію з шарами форм. Це дозволяє уникнути ручного створення композиції та перетягування файлу SVG.
  • Послідовність масштабованої векторної графіки: імпортує кілька пронумерованих файлів SVG і обробляє їх як покадрову послідовність векторних зображень.

Використовуйте розділ Вміст шару на панелі Властивості або розділ Вміст шару на часовій шкалі для перегляду та роботи з окремими елементами та їхніми властивостями, якщо ви імпортували файл SVG як композицію. Якщо імпортовано як відеоматеріал, він поводиться як звичайний шар і може коригуватися за допомогою стандартних властивостей Перетворити.

Як і з файлами Illustrator, якщо файл векторної графіки імпортовано як відеоматеріал, ви можете вибрати шар на часовій шкалі, потім клацнути правою кнопкою миші та обрати Створити > Створити форми та текст із векторного шару, щоб перетворити його в редаговані шари, що дозволить анімувати окремі контури, обведення та заливки. У найновішій бета-версії After Effects текст із вихідного файлу перетворюється на редаговані текстові шари, що зберігають шрифт, розмір, заливку, позицію, стилі, обведення та параметри змінного шрифту. 

Коли ви імпортуєте SVG як відеоматеріал, After Effects зберігає живе посилання на оригінальний файл, тому будь-які зміни, які ви робите в цьому SVG поза програмою, автоматично оновлюються всередині вашого проєкту.

Перетворення тексту Illustrator на редаговані текстові шари

Використання нових бета-функцій

Редагований текст із файлів Illustrator тепер доступний для тестування та відгуків. Спробуйте зараз в After Effects (beta).

У найновішій бета-версії After Effects, коли шар Illustrator імпортується як відеоматеріал, будь-який текст у вихідному файлі перетворюється на власний редагований текстовий шар замість того, щоб бути зведеним до контурів форм.Це означає, що шрифт, розмір, заливка, позиція, стилі (такі як жирний і курсив), обведення та параметри змінного шрифту зберігаються, тому ви можете продовжувати редагувати текст безпосередньо в After Effects замість його відтворення з нуля або повернення до Illustrator для внесення змін.

Виберіть Файл > Імпорт > Файл, а потім файл Illustrator, який потрібно імпортувати.

У діалоговому вікні Імпорт файлу переконайтеся, що Імпортувати як встановлено на Відеоматеріал під час вибору файлу для імпорту.

У діалоговому вікні імпорту підтвердьте, що Тип імпорту встановлено на Відеоматеріал, і виберіть Параметри шару залежно від того, що ви хочете імпортувати з файлу Illustrator.

Перетягніть імпортований файл на панель Часова шкала.

Клацніть правою кнопкою миші на шарі Illustrator і виберіть Створити > Створити форми та текст із векторного шару, або використовуйте Шар > Створити > Створити форми та текст із векторного шару.

Меню Шар > Створити з виділеною командою «Створити форми та текст із векторного шару», що перетворює векторний текст на редаговані текстові шари.
Виберіть «Створити форми та текст із векторного шару», щоб перетворити текст Illustrator на редаговані текстові шари After Effects замість форм.

Текст перетворюється на редагований текстовий шар, який точно відповідає шрифту, розміру, заливці та позиції оригінального файлу. Після цього можна редагувати та коригувати текст безпосередньо в After Effects.

Текстовий шар «Brightness» над графікою полум'я з панеллю «Символ», що показує шрифт Adobe Clean Italic, розмір 74 пікселі та увімкнену заливку.
Після перетворення текст залишається повністю редагованим — шрифт, стиль, розмір і заливка все ще можна змінювати на панелі «Символ».

Примітка

Текст лише з обведенням все ще перетворюється як контури, а не як редагований текстовий шар. 

Нетекстовий векторний вміст, як і раніше, перетворюється на шари форми, а якщо файл Illustrator містить обидва типи, ви отримаєте комбінацію текстових шарів і шарів форм.

Приєднайтеся до обговорення в нашій спільноті After Effects (Beta) про підтримку редагованого тексту з файлів Illustrator.

Копіювання та вставлення вмісту Illustrator і SVG

Вміст SVG з буфера обміну тепер можна вставляти в After Effects за допомогою Редагування > Вставити. Вміст імпортується як нативні редаговані шари форми, готові до анімації, без проміжного кроку імпорту.

Копіювання вмісту з Illustrator

Відкрийте свою ілюстрацію в Adobe Illustrator.

Переконайтеся, що вибрано параметр Увімкнути код SVG.

  • macOS: Виберіть Illustrator > Параметри > Обробка буфера обміну і виберіть Включити код SVG.
  • Windows: Виберіть Редагування > Параметри > Обробка буфера обміну і виберіть Включити код SVG.
Діалогове вікно «Установки» відкрито в Illustrator і вибрано опцію «Включити код SVG».
Увімкніть «Включити код SVG», щоб ваша ілюстрація залишалася редагованою та високоякісною в інших програмах Adobe.

Виберіть ілюстрацію, яку хочете скопіювати.

Підказка

Перетворіть будь-який текст SVG на криві перед копіюванням, оскільки текст SVG не підтримується під час вставлення.

Виберіть Редагування > Копіювати.

Перейдіть до After Effects і виконайте одну з наступних дій залежно від стану проєкту:

  • Якщо жодного проєкту не відкрито, виберіть Редагування > Вставити, щоб створити новий проєкт із композицією, яка містить вміст SVG як шар форми.
  • Якщо проєкт відкрито, але не вибрано жодної композиції, виберіть Редагування > Вставити, щоб створити нову композицію в поточному проєкті з вставленим вмістом.
Вибрано опцію «Редагування» > «Вставити», і вміст імпортується як нативні редаговані шари форми, готові до анімації.
«Редагування» > «Вставити» додає вміст як редаговані шари форми, готові для анімації.

Якщо в After Effects вибрано композицію, виберіть Редагування > Вставити, щоб додати вміст SVG як новий шар форми в цю композицію.

Вставлення SVG з інших програм

Вміст SVG, скопійований з будь-якої програми, що записує SVG до системного буфера обміну, можна вставляти, використовуючи той самий процес Редагування > Вставити. Підтримка залежить від того, чи розміщує джерельна програма дійсні дані SVG у буфері обміну.