Виберіть шари на панелі Timeline, а потім виберіть Шар > Прекомпонувати або натисніть Ctrl+Shift+C (Windows) чи Command+Shift+C (macOS).
Якщо потрібно групувати деякі шари, які вже є в композиції, можна виконати попередню композицію цих шарів. Попередня композиція шарів розміщує їх у новій композиції, яка замінює шари в оригінальній композиції. Нова вкладена композиція стає джерелом для одного шару в оригінальній композиції. Нова композиція з’являється на панелі Проєкт і доступна для рендерингу або використання в будь-якій іншій композиції. Можна вкладати композиції, додаючи наявну композицію до іншої композиції, так само як додається будь-який інший елемент відеоматеріалу до композиції. Попередня композиція одного шару корисна для додавання властивостей перетворення до шару та впливу на порядок рендерингу елементів композиції.
Вкладення — це включення однієї композиції в іншу. Вкладена композиція відображається як шар у композиції, що її містить.
Вкладену композицію іноді називають попередньою композицією, яку в розмовній мові іноді скорочують до precomp або pre-comp. Коли попередня композиція використовується як джерело відеоматеріалу для шару, цей шар називається шаром попередньої композиції.
Під час рендерингу можна сказати, що дані зображення та інша інформація перетікають з кожної вкладеної композиції в композицію, яка її містить. Тому вкладені композиції іноді називають такими, що розташовані вище за потоком відносно композицій, які їх містять, а композиції, що містять їх, вважаються розташованими нижче за потоком вкладених композицій.Набір композицій, з’єднаних через вкладення, називається мережею композицій. Можна переходити між композиціями в мережі композицій за допомогою панелі Composition Navigator та Mini-Flowchart. Докладніше про відкриття та навігацію у вкладених композиціях.
Попередні композиції в After Effects подібні до Smart Objects в Adobe Photoshop.
Попередня композиція та вкладення допомагають керувати складними композиціями та організовувати їх. За допомогою попередньої композиції та вкладення можна виконати такі дії:
- Застосування складних змін до всієї композиції: можна створити композицію, що містить кілька шарів, вкласти цю композицію в загальну композицію та анімувати й застосувати ефекти до вкладеної композиції, щоб усі шари змінювалися однаково протягом одного й того ж періоду.
- Використовуйте повторно все, що створите: Ви можете створити анімацію в окремій композиції, а потім перетягувати цю композицію в інші композиції стільки разів, скільки потрібно.
- Оновлюйте за один крок: Коли ви вносите зміни у вкладену композицію, вони впливають на кожну композицію, у якій її використано, так само як зміни в елементі вихідного відеоматеріалу впливають на кожну композицію, у якій його використано.
- Змінення стандартного порядку візуалізації шару: Можна вказати, щоб After Effects візуалізував перетворення (наприклад, обертання) перед візуалізацією ефектів, щоб ефект застосовувався до повернутого відеоматеріалу.
- Додайте до шару ще один набір властивостей перетворення: Шар, що представляє композицію, має власні властивості на додачу до властивостей шарів, які він містить. Це дає змогу застосувати до шару або набору шарів додатковий набір перетворень.
Оскільки прекомпозиція сама є шаром, ви можете керувати її поведінкою за допомогою перемикачів шарів і перемикачів композиції на панелі Timeline. Ви можете вибрати, чи поширюватимуться зміни перемикачів у батьківській композиції на вкладену композицію. Щоб перемикачі шарів не впливали на вкладені композиції, виберіть Редагування > Параметри > Композиція (Windows) або After Effects > Параметри > Композиція (macOS), а потім зніміть прапорець Перемикачі впливають на вкладені композиції.
На вкладці Додатково у діалоговому вікні Параметри композиції (Композиція > Параметри композиції) установіть Зберігати роздільну здатність у вкладеному режимі або Зберігати частоту кадрів у вкладеному режимі чи в черзі візуалізації, щоб композиція зберігала власну роздільну здатність або частоту кадрів і не успадковувала ці параметри від батьківської композиції.Наприклад, якщо ви навмисно використали в композиції низьку частоту кадрів, щоб створити ривчастий ефект ручної анімації, слід зберегти частоту кадрів для цієї композиції, коли її вкладено. Так само результати ротоскопії можуть виглядати некоректно після перетворення на іншу частоту кадрів або роздільну здатність. Використовуйте цей параметр замість ефекту Posterize Time, оскільки він менш ефективний.
Зміна поточного часу на одній панелі оновлює поточний час на інших панелях, пов’язаних із цією композицією. За замовчуванням поточний час також оновлюється для всіх композицій, пов’язаних із поточною композицією через вкладення. Щоб композиції, пов’язані через вкладення, не оновлювали свій поточний час, коли ви змінюєте поточний час в одній композиції, зніміть прапорець Синхронізувати час усіх пов’язаних елементів у параметрах (Редагування > Параметри > Композиція (Windows) або After Effects > Параметри > Композиція (macOS)).
Під час прекомпонування шари розміщуються в новій композиції, яку часто називають прекомпозицією або прекомпом. Ця дія замінює вибрані шари в початковій композиції одним шаром, який представляє нову прекомпозицію. Прекомпонування одного шару зручно використовувати, щоб додати до шару властивості перетворення та вплинути на порядок візуалізації елементів композиції.
Залишити всі атрибути всередині
Залишає властивості та ключові кадри прекомпонованого шару в початковій композиції, застосовуючи їх до нового шару, який представляє прекомпозицію. Розмір кадру нової композиції збігається з розміром вибраного шару. Цей параметр недоступний, якщо вибрано більше одного шару, текстовий шар або шар форми.
Перемістити всі атрибути в нову композицію
Переміщує властивості та ключові кадри попередньо скомпонованих шарів на один рівень далі від кореневої композиції в ієрархії композицій.Якщо використати цей параметр, зміни, застосовані до властивостей шарів, залишаються з окремими шарами в попередній композиції.Розмір кадру нової композиції збігається з розміром кадру вихідної композиції.
Ефекти, які використовують шари як вхідні дані, наприклад Set Matte і Displacement Map, націлені на маски та ефекти вхідного шару.Ці шари можна використовувати без попереднього компонування, щоб на них можна було посилатися за допомогою ефекту.
Цей елемент керування подібний до функції меню View у нижній частині панелі засобу перегляду Layer, яка дозволяє відтворювати шар з різних позицій у порядку рендерингу — з його джерела, масок або окремих ефектів.
Для ефектів із властивостями шару відкрийте меню Input Parameter праворуч від вибору шару і виберіть цільовий вхідний шар, наприклад:
- Source: Націлює лише на джерело шару.Маски та ефекти ігноруються.
- Masks: Націлює на шар після застосування його масок.Ефекти ігноруються.
- Effects & Masks: Націлює на шар після застосування його масок та ефектів.
Вкладені композиції іноді називають розташованими вище за потоком стосовно композицій, які їх містять, а композиції, що містять їх, називають розташованими нижче за потоком стосовно вкладених композицій, які вони містять.Коренева композиція розташована найнижче за потоком, а найглибше вкладена композиція розташована найвище за потоком.Шлях потоку композиції — це ланцюжок композицій, пов’язаних одна з одною через вкладення одна в одну.Мережа композицій — це повний набір композицій, пов’язаних одна з одною через вкладення.
After Effects пропонує кілька способів відкрити вкладену композицію (попередню композицію):
- Двічі клацніть запис композиції на панелі Project.
- Двічі клацніть шар попередньої композиції на панелі Timeline.Двічі клацніть, утримуючи клавішу Alt (Windows) або Option (macOS), щоб відкрити шар попередньої композиції як шар на панелі Layer.
Якщо двічі клацнути шар попередньої композиції, коли активним є інструмент малювання або інструмент Пензель для ротоскопії, шар відкриється на панелі Layer.
Щоб відкрити останню основну композицію в тій самій мережі композицій, що й поточна основна композиція, використовуйте Shift+Esc.
Скористайтеся панеллю Composition Navigator.
Скористайтеся панеллю Composition Mini-Flowchart.
Панель Composition Navigator розташована вздовж верхнього краю панелі Composition і показує композицію, яка є основною в цьому засобі перегляду, відносно інших композицій у тій самій мережі композицій.Показані композиції — це композиції, які були активними останнім часом на шляху потоку поточної активної композиції.
A. Стрілка для відкриття міні-блок-схеми Composition B. Кнопка меню панелі C. Активна (поточна) композиція
Стрілки між назвами композицій вказують напрямок передачі інформації про пікселі для цього шляху потоку.За умовчанням композиції відображаються на панелі Composition Navigator так, що похідні композиції розташовані зліва, а вихідні композиції – справа.Цей порядок за умовчанням позначається параметром Flow Right To Left у меню панелі Composition.Щоб показати композиції в іншому порядку, виберіть Flow Left To Right.Цей параметр є загальним – він застосовується до всіх композицій і до перегляду Composition Mini-Flowchart.
Назви похідних композицій відображаються тьмянішим кольором на позначення того, що їхній вміст не використовується та не показується в основній композиції.
Щоб показати або сховати панель Composition Navigator, виберіть Показати Composition Navigator у меню панелі Composition.
Щоб активувати будь-яку композицію, показану на панелі Composition Navigator, виберіть назву композиції.
Якщо шлях потоку занадто довгий для відображення на панелі Composition, кнопка з трьома крапками
з’являється на лівому або правому краю панелі Composition Navigator.Щоб тимчасово показати весь шлях потоку, виберіть кнопку з трьома крапками.
Щоб прокрутити довгий шлях потоку, розмістіть вказівник над кнопкою композиції на панелі Composition Navigator і прокрутіть колесо миші.
Composition Mini-Flowchart — це тимчасовий елемент керування, який можна використовувати для швидкої навігації в мережі композицій.Коли ви відкриваєте Composition Mini-Flowchart, він показує композиції, що безпосередньо передують і йдуть після вибраної композиції.
Кольори в Composition Mini-Flowchart базуються на кольорах позначок, призначених композиціям на панелі Project.Якщо композиція використовується кілька разів в одній композиції, кілька екземплярів вкладеної композиції відображаються як один запис із числом у круглих дужках, що вказує на кількість екземплярів.
Щоб відкрити Composition Mini-Flowchart, виконайте одну з таких дій:
A. Індикатор того, що композиція не переходить в інші композиції B. Напрямок потоку C. Активна (поточна) композиція
- Використовуйте клавішу Tab, коли основною є панель Composition, Layer або Timeline.
Виберіть стрілку праворуч від назви композиції на панелі Composition Navigator.
Виберіть Composition Mini-Flowchart у меню Composition, меню панелі Composition або меню панелі Timeline.
Виберіть кнопку Composition Mini-Flowchart у верхній частині панелі Timeline.
Як і в Composition Navigator, ви можете вибрати, чи показувати напрямок потоку зліва праворуч, чи справа наліво.Стрілки вказують напрямок потоку.Якщо композиція має
замість стрілки, це означає, що в неї не надходять інші композиції або вона сама не передається в інші композиції.
Композиції, що передують, у Composition Mini-Flowchart сортуються зверху вниз за алфавітом або за порядком шарів.Щоб перемикатися між цими порядками сортування, натисніть клавішу S, коли відкрито Composition Mini-Flowchart.При сортуванні за порядком шарів композиція, яка використовується кілька разів, сортується відповідно до її найвищого екземпляра в порядку стекування.Підпорядковані композиції завжди сортуються за алфавітом.
Щоб переміщатися між композиціями та вибирати їх у Composition Mini-Flowchart, використовуйте клавіші зі стрілками або натискайте кнопки зі стрілкою чи
з кожного боку композиції.Щоб активувати вибрану композицію, натисніть клавішу пробіл або Enter (Windows), або Return (macOS).Щоб закрити Composition Mini-Flowchart, не виконуючи ніяких дій, натисніть Esc, Shift або виберіть область за межами Composition Mini-Flowchart.
Візуалізація складної вкладеної композиції може тривати довго — як для перегляду, так і для остаточного виводу. Якщо у вас є вкладена композиція, над якою ви більше не плануєте працювати, можна заощаджувати час під час кожної операції візуалізації. Для цього попередньо візуалізуйте вкладену композицію у відеофайл і замініть композицію візуалізованим відео. Ви все одно можете змінювати вихідну вкладену композицію, оскільки вона залишається на панелі Проєкт. Якщо ви внесете суттєві зміни до вихідної вкладеної композиції, візуалізуйте її ще раз.
Попередня візуалізація вкладеної композиції особливо корисна, якщо ви використовуєте її в проєкті кілька разів.
Під час попередньої візуалізації вкладеної композиції застосуйте параметри остаточного виводу.
Виберіть композицію на панелі Проєкт або Композиція.
Виберіть Композиція > Попередня візуалізація.
Команда Попередня візуалізація додає композицію до черги візуалізації та встановлює для дії після візуалізації Імпорт і заміна використання значення, за якого композиція замінюється візуалізованим відео.
На панелі Черга візуалізації за потреби скоригуйте параметри й натисніть кнопку Візуалізувати, щоб візуалізувати композицію.
Замість того щоб замінювати композицію на відеофайл, можна використати візуалізоване відео як проксі для вкладеної композиції.
Композиція складається із шарів, розташованих один над одним на панелі Хронометраж. Коли композиція візуалізується — для перегляду чи для остаточного виводу — спочатку візуалізується нижній шар. У межах кожного растрового (не векторного) шару елементи застосовуються в такому порядку: маски, ефекти, перетворення та стилі шару. Для безперервно растеризованих векторних шарів типовий порядок візуалізації такий: маски, потім перетворення й ефекти.
Перетворення — це зміни властивостей, згрупованих у категорії Перетворення на панелі Хронологія, зокрема Точка прив'язки, Положення, Масштаб, Обертання і Непрозорість.Те, що ви бачите на панелі Шар, — це результат візуалізації до застосування перетворень.
Щоб точніше керувати моментом застосування перетворень, можна застосувати ефект Перетворити і змінити його порядок відносно інших ефектів.
У групі ефектів або масок елементи обробляються зверху вниз. Наприклад, якщо застосувати ефект Коло, а потім ефект Magnify, коло буде збільшено. Однак якщо перетягнути ефект Magnify вище (перед) ефектом Circle на панелі Effect Controls або Timeline, коло буде намальовано після збільшення і не збільшиться.
Після рендерингу шару починається рендеринг наступного шару. Відрендерений шар нижче може використовуватися як вхідні дані для рендерингу шару вище, наприклад, для визначення результату режиму змішування.
Якщо композиція містить інші вкладені композиції, вкладена композиція відтворюється перед іншими шарами в основній композиції.
Деякі ефекти ігнорують маски на шарі, до якого вони застосовані. Щоб такий ефект працював із замаскованим шаром, попередньо скомпонуйте шар із застосованою маскою, а потім застосуйте ефект до попередньо скомпонованого шару.
Згортання перетворень
Якщо для вкладеної композиції вибрано перемикач Collapse Transformations , перетворення для вкладеної композиції не виконуються, доки не буде відрендерено маски та ефекти для основної композиції. Такий порядок рендерингу дозволяє об’єднати — або згорнути — перетворення для вкладеної композиції та основної композиції та виконати їх разом. Те саме стосується векторних шарів, які не растеризуються безперервно.
Замість перемикача Collapse Transformations векторні шари мають перемикач Continuously Rasterize у тому самому місці. Векторні шари включають шари форми, текстові шари та шари, вихідним відеоматеріалом яких є файли векторної графіки. Текстові шари та шари форми завжди растеризуються безперервно.
Згортання перетворень може, наприклад, зберегти роздільну здатність, коли шар масштабується до половини розміру у вкладеній композиції, а вкладена композиція масштабується вдвічі в основній композиції. У такому випадку замість виконання обох перетворень і втрати даних зображення можна виконати одне перетворення, яке фактично нічого не змінює, оскільки окремі перетворення взаємно скасовують одне одного.
Якщо перетворення не згорнуто, вкладена композиція, що містить 3D-шари, рендериться як 2D-зображення 3D-композиції з використанням стандартної камери композиції.Такий рендеринг запобігає перетину вкладеної композиції з 3D-шарами, відкиданню тіней на 3D-шари та отриманню тіней від 3D-шарів в основній композиції. Вкладена композиція також не керується камерами та джерелами світла основної композиції.
Якщо перетворення згорнуто, властивості 3D для шарів у вкладеній композиції стають доступними в основній композиції. Таким чином, вкладена композиція може перетинатися з 3D-шарами, відкидати тіні на 3D-шари та отримувати тіні від 3D-шарів в основній композиції. Камера та джерела світла також можуть керувати вкладеною композицією.
Фактично, згортання перетворень для вкладеної композиції повідомляє After Effects, що шари в композиції не потрібно зводити в одне зображення та кадрувати. Оскільки коригуючий шар впливає на композицію всіх шарів під ним у тій самій композиції, коригуючий шар у вкладеній композиції зі згорнутими перетвореннями змушує виконати зведення та кадрування, яких згортання перетворень зазвичай запобігає.
Коли закрита маска (з режимом маски, відмінним від None), стиль шару або ефект застосовується до вкладеної композиції зі згорнутими перетвореннями, шари у вкладеній композиції спочатку рендеряться окремо, потім застосовуються маски та ефекти, а потім результат компонується в основну композицію. Такий порядок рендерингу означає, що режими змішування вкладених шарів не застосовуються до жодних шарів, розташованих нижче в основній композиції, а 3D-шари вище та нижче згорнутого шару не можуть перетинатися або відкидати тіні один на одного.
Створюйте вражаючі 3D-анімації в After Effects
Анімуйте персонажів та ілюстрації, додавайте рух до тексту й багато іншого.