Data merge using the Variables panel

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Create documents
      3. Tools Default keyboard shortcuts | Illustrator
      4. Tool galleries
      5. Customize keyboard shortcuts
      6. Artboards
      7. Customize the workspace
      8. Properties panel
      9. Set preferences
      10. Touch Workspace
      11. Microsoft Surface Dial support in Illustrator
      12. Recovery, undo, and automation
      13. Rotate view
      14. Rulers, grids, and guides
      15. Accessibility in Illustrator
      16. Safe Mode
      17. View artwork
      18. Use the Touch Bar with Illustrator
      19. Files and templates
      20. Synchronize settings using Adobe Creative Cloud
    3. Tools in Illustrator
      1. Selection
        1. Overview
        2. Selection
        3. Direct Selection
        4. Group Selection
        5. Lasso
        6. Magic Wand
      2. Navigation
        1. Overview
        2. Zoom
        3. Rotate View
      3. Paint
        1. Overview
        2. Gradient
        3. Shape Builder
      4. Type
        1. Overview
        2. Type
        3. Type on path
  3. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  4. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Upgrade cloud storage for Adobe Illustrator
      4. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  5. Add and edit content
    1. Drawing
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Image Trace
      7. Simplify a path
      8. Define perspective grids
      9. Symbolism tools and symbol sets
      10. Adjust path segments
      11. Design a flower in 5 easy steps
      12. Perspective drawing
      13. Symbols
      14. Draw pixel-aligned paths for web workflows
    2. 3D effects and Adobe Substance materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Create 3D objects
      4. Create 3D Text
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Duplicate objects
      8. Rotate and reflect objects
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Create text
      2. Fonts and typography
      3. Format type
      4. Import and export text
      5. Format paragraphs
      6. Special characters
      7. Create type on a path
      8. Character and paragraph styles
      9. Tabs
      10. Text and type
      11. Find missing fonts (Typekit workflow)
      12. Update text from Illustrator 10
      13. Arabic and Hebrew type
      14. Fonts | FAQ and troubleshooting tips
      15. Create 3D text effect
      16. Creative typography designs
      17. Scale and rotate type
      18. Line and character spacing
      19. Hyphenation and line breaks
      20. Text enhancements
      21. Spelling and language dictionaries
      22. Format Asian characters
      23. Composers for Asian scripts
      24. Create text designs with blend objects
      25. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Create a drop shadow
      4. Appearance attributes
      5. Create sketches and mosaics
      6. Drop shadows, glows, and feathering
      7. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Create animations
      5. Slices and image maps
  6. Import, export, and save
    1. Import
      1. Import artwork files
      2. Import bitmap images
      3. Import artwork from Photoshop
      4. Place multiple files | Illustrator CC
      5. Unembed images
      6. Import Adobe PDF files
      7. Import EPS, DCS, and AutoCAD files
      8. Links information
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Use Illustrator artwork in Photoshop
      2. Export artwork
      3. Collect assets and export in batches
      4. Package files
      5. Create Adobe PDF files
      6. Extract CSS | Illustrator CC
      7. Adobe PDF options
      8. File information and metadata
  7. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  8. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  9. Troubleshooting 
    1. Crash on launch issues
    2. Recover files after crash
    3. File issues
    4. GPU device driver issues
    5. Wacom device issues
    6. DLL file issues
    7. Memory issues
    8. Preferences file issues
    9. Font issues
    10. Printer issues
    11. Share crash report with Adobe

Using the Variables panel in Illustrator, you can easily create multiple variations of your artwork by merging a data source file (CSV or XML file) with an Illustrator document. For example, instead of manually modifying objects in a template, use the data merge functionality to produce hundreds of template variations for different output surfaces quickly and accurately. Similarly, you can change the names of participants on event badges, or vary images across web banners and postcards, without having to redo your artwork. Simply create one design and then quickly produce variations by importing the names or the images from a data source file.

Create custom variations of your design template for different projects, such as printable posters, web banners, and event badges, using the Variables panel.

Prerequisites

All you need for data merge is a data source file and a target document. 

  • The data source file contains the information that varies in each iteration of the target document, such as the names, photographs, and addresses of the recipients of a form letter. A data source file can be a comma-delimited file (.csv) or an extensible markup language file (.xml). 
  • The target document is an Illustrator document that contains the base artwork to use as the template. This document can contain the data-field placeholder and the items that remain the same in each iteration of the merged document.

Access the data merge functionality

Data merge is accessible from the Variables panel in Illustrator (Window > Variables). The type and name of each variable in the document are listed in the panel. If the variable is bound to an object, then the Objects column displays the name of the bound object as it appears in the Layers panel. You can sort the rows by clicking items in the header bar: by variable name, object name, or by variable type.

Variables panel

A. Data set B. Panel menu C. Switch between data sets D. Name of bound object E. Variable name F. Variable type G. Lock variables H. Make object dynamic I. Make visibility dynamic J. Unbind variables K. Create variables L. Delete variables 

Quick steps for merging data

  1. Create an Illustrator document to use as the template.

  2. Set up your source data file in CSV or XML format. For more information, see Prepare a data source file.

  3. Import a data source file in Illustrator using the Variables panel. For more information, see Import a data source file.

  4. Bind a variable to an object in your template. For more information, see Bind variables to objects.

  5. Preview the document with each data set before you export all the files. For more information, see Preview the document with each data set.

  6. Export a batch of files from the data using the Actions panel in Illustrator. For more information, see Export files using the Actions panel.

Prepare a data source file

Data source files should be saved in a comma-delimited (.csv) or Extensible Markup Language (.xml) format.

Set up your CSV source files

In a comma-delimited (.csv) file, records are separated by paragraph breaks; fields are separated by commas or tabs. The data source file can also include text or paths that see images on disk. Before importing a CSV file, do the following to let Illustrator identify the variable type.

  1. Open your spreadsheet.

  2. Specify your data field name in the first row of your spreadsheet. Then, do the following:

    • At the beginning of the data field name, type an “at” symbol (@) to insert text or paths that refer to image files. The @ symbol is required only in the first line; subsequent lines should include the image paths.
    • Similarly, at the beginning of the data field name, type a “percentage” symbol (%) for graphs and a "hashtag" symbol (#) for visibility.
    Бележка:
    • The data field names in your spreadsheet should not contain blank spaces. For example, you can specify the data field as Company_Name instead of Company Name
    • Similarly, the paths referring to image and graph files should not contain any blank spaces. For example, the path of an image file should be C:\Photos\BillTucker instead of C:\Photos\Bill Tucker.
    • All graph files linked from your data source file should be saved as comma-delimited (.csv) files.
    • If you get an error message when you type the @ symbol at the beginning of the field, type an apostrophe (') before the @ symbol (such as '@Photos) to validate the function. Some applications, such as Microsoft Excel, reserve the @ symbol for functions.

    (Windows) Example of image and graph references in the data source file

    Name

    Age

    @Photos

    %Graphs

    Bill Tucker

    36

    C:\Photos\BillTucker.jpg

    C:\Photos\BillTucker.csv

    Dat Nguyen

    53

    C:\MyDocuments\dat.jpg

    C:\MyDocuments\dat.csv

    Maria Ruiz

    26

    C:\Photos\Ruiz.jpg

    C:\Photos\Ruiz.csv

    (macOS) Example of image and graph references in the data source file

    Name

    Age

    @Photos

    %Graphs

    Bill Tucker

    36

    /Users/photos/BillTucker.jpg

    /Users/photos/BillTucker.csv

    Dat Nguyen

    53

    /Users/family/photos/dat.jpg

    /Users/family/photos/dat.csv

    Maria Ruiz

    26

    /Users/alpha/photos/Ruiz.jpg

    /Users/alpha/photos/Ruiz.csv

  3. Enter your data into the spreadsheet.

  4. Do one of the following:

    • Save spreadsheets created using the latest version of Microsoft Excel (2016 release) to the following file formats:
      • CSV (Comma delimited) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Save spreadsheets created using Apple Numbers to CSV format with Unicode (UTF-8) encoding.
    Бележка:

    Currently, CSV files exported in the formats mentioned above are supported in Illustrator. Other CSV file formats such as Macintosh Comma Separated (.csv) are not supported for data merge.

Prepare an XML file

  1. Define a variable in your document. For details, see Bind variables to objects.

  2. Click the Capture Data Set button () in the Variables panel. Alternatively, choose Capture Data Set from the Variables panel menu.

  3. After creating the desired number of data sets, choose Save Variable Library from the Variables panel menu to save the data sets as an XML file. Specify the filename and location, and click Save.

    Export the variables you've created in Illustrator as an XML file

  4. Now, edit the XML file in a text editing application such as Notepad++ (Windows) or TextWrangler (macOS) to include your data sets in this file.

    Example: editing an XML file using any text editing application

    A. Replace the path of the image B. Replace the string of text  

  5. To import your XML file in Illustrator, choose Load Variable Library from the Variables panel menu. Select the XML file and click Open.

    Import variables into Illustrator

Import a data source file

To bind variables to the desired data, import a data source in the Variables panel. You can have only one data source file selected per document.

  1. Choose Window > Variables.

  2. In the Variables panel, click Import.

    Import a data source file using the Variables panel

  3. In the Load Variable Library dialog box, select a data source file in CSV or XML format and click Open.

    Select a CSV or XML data source file

  4. (Optional) You can edit, rename, or delete the data set later by first choosing it from the Data Set drop‑down menu and editing its options.

    • To switch between data sets, select a data set from the Data Set list in the Variables panel. Alternatively, click the Previous Data Set button () or the Next Data Set button ().
    • To apply the data on the artboard to the current data set, choose Update Data Set  from the Variables panel menu.
    • To rename a data set, edit the text directly in the Data Set text box. Alternatively, double-click the words Data Set (to the left of the Data Set text box), enter a new name, and click OK.
    • To delete a data set, click the Delete icon. Alternatively, choose Delete Data Set from the Variables panel menu.

Bind variables to objects

Use variables to define the elements in a template that you want to change. You can define four types of variables: Visibility variable, Text String variable, Linked File variable, and Graph Data variable. A variable’s type indicates which object attributes are changeable (dynamic). The type and name of each variable in the document are listed in the panel. If the variable is bound to an object, then the Objects column displays the name of the bound object as it appears in the Layers panel.

Type of variable

Icon to indicate a variable’s type

Definition

Visibility variables

Show or hide artwork.

Text String variables

Replace a string of text.

Linked File variables

Replace the object in the artboard with an object from another file.

Graph Data variables

Replace the values in a graph.

No Type (unbound) variable

Not bound to any object.

To define variables in Illustrator, do the following:

  1. Select an object.

  2. In the Variables panel (Window > Variables), select the variable you want to bind it with.

  3.  To bind the object with the variable, do one of the following:

    • Click the Make Object Dynamic () button.
    • Choose Make Object Dynamic from the panel menu.

To create a variable without binding it to an object, do the following:

  1. Click the New Variable button () in the Variables panel or choose New Variable from the panel menu.

  2. To subsequently bind an object to the variable, select the object and the variable, and click the Make Visibility Dynamic button () or the Make Object Dynamic button (). Alternatively, choose one of these options from the panel menu.

Work with variables

You can edit a variable’s name or type, unbind a variable, and lock a variable using the Variables panel.

Unbinding a variable breaks the link between the variable and its object. Locking variables prevents you from creating variables, deleting variables, and editing variable options. However, you can bind and unbind objects to locked variables.

Change the name and type of a variable

  1. Double-click the variable in the Variables panel. Alternatively, select the variable in the Variables panel, and choose Variable Options from the Variables panel menu.

Unbind a variable

  1. Click the Unbind Variable button () in the Variables panel, or choose Unbind Variable from the Variables panel menu.

Lock or unlock all variables in a document

  1. Click the Lock/Unlock Variables button  or  in the Variables panel.

Delete variables

Deleting a variable removes it from the Variables panel. If you delete a variable that is bound to an object, the object becomes static (unless the object is also bound to a variable of a different type).

  1. Select a variable you want to delete.

  2. Do one of the following:

    • Click the Delete Variable button () in the Variables panel, or choose Delete Variable from the Variables panel menu.

    • To delete the variable without confirmation, drag it to the Delete Variable button ().

Edit dynamic objects

You can change the data associated with a variable by editing the object to which it is bound. For example, if you’re working with a Visibility variable, you change the object’s state of visibility in the Layers panel. Editing dynamic objects lets you create multiple data sets for use in the template.

  1. Select a dynamic object on the artboard, or do one of the following to automatically select a dynamic object:

    • Alt‑click (Windows) or Option‑click (Mac OS) a variable in the Variables panel.

    • Select a variable in the Variables panel, and choose Select Bound Object from the Variables panel menu.

    • To select all dynamic objects, choose Select All Bound Objects from the Variables panel menu.

  2. Edit the data associated with the object as follows:

    • For text, edit the text string on the artboard.

    • For linked files, replace the image using the Links panel or the File > Place command.

    • For graphs, edit the data in the Graph Data dialog box.

    • For all objects with dynamic visibility, change the state of visibility for the object in the Layers panel.

Identifying dynamic objects usingXML IDs

The Variables panel displays the names of dynamic objects as they appear in the Layers panel. If you save the template in SVG format for use with other Adobe products, these object names must conform to XML naming conventions. For example, XML names must begin with a letter, underscore, or colon, and cannot contain spaces.

Illustrator automatically assigns a valid XML ID to every dynamic object you create. To view, edit, and export object names using XML IDs, choose Edit > Preferences > Units (Windows) or Illustrator > Preferences > Units (Mac OS), and select XML ID.

Preview the document with each data set

To see how your final graphics will look, you can preview before you export all the files. Use the arrow keys next to Data Set in the Variables panel to navigate and preview the desired data set in your document.

Export files using the Actions panel

After you define variables and one or more data sets, you can output, in batch mode, artwork using the data set values. Do the following:

  1. Using the Actions panel (Window > Actions), record an action to save your document in the desired format. For details, see Automation with actions.

  2. Choose Batch from the Actions panel menu and select the action you’ve created in the previous step.

  3. For Source, select Data Sets to play the action on each dataset in the current file.

  4. For Destination, specify what you want to do with the processed files. You can leave the files open without saving the changes (None), save and close the file in their current location (Save And Close), or save the files to a different location (Folder).

    Depending on the Destination option you select, you can set additional options for saving the files. For more information, see Play an action on a batch of files.

  5. Click OK.

Save a template for data merge

When you define variables in an Illustrator document, you are creating a template for data merge. You can save the template in SVG format for use with other Adobe products, such as Adobe® Graphics Server. For example, a developer working with Adobe Graphics Server can bind the variables in the SVG file directly to a database or another data source.

  1. Choose File > Save As, enter a filename, select SVG as the file format, and click Save.

  2. Click More Options, and select Include Adobe Graphics Server Data. This option includes all information needed for variable substitution in the SVG file.

  3. Click OK.

Facing issues while importing your CSV file?

If you’re receiving the error: The incoming variable library is invalid while uploading a CSV data source file, check for the following:

  • Your CSV file is not blank.
  • The spreadsheets that you've created using the latest version of Microsoft Excel are saved as CSV (Comma delimited) (*.csv) or CSV (MS-DOS) (*.csv) and those created using Apple Numbers are saved as CSV format with Unicode (UTF-8) encoding. Data source files saved in any other file format such as Macintosh Comma Separated (*.csv) are not supported for data merge.
  • All columns have a data field name. For example, Illustrator displays the error message when a column in your data source file contains data but doesn't have a data field name.
  • The data source file doesn't have a blank column in between any filled columns. For example, Illustrator displays the error message when column B and D in your data source file contain data but column C is empty.
Example: errors while setting up a CSV source file for data merge

A. Data field name is missing for a column B. There's a blank column between filled columns 

  • The data field names in your spreadsheet don't contain any blank spaces.
  • The paths referring to image and graph files in your source file don't contain any blank spaces.
  • The graph files linked from your data source file are saved as comma-delimited (.csv) files.
Лого на Adobe

Влезте във вашия акаунт