Modelos do Dreamweaver
Quando uma página HTML for salva como um modelo, o Dreamweaver criará uma pasta de modelos no nível raiz da pasta raiz local e irá gerar um arquivo .dwt que se torna a origem para todas as páginas as o qual elas se aplicam. Cada vez que uma página HTML for aplicada em um modelo, (Arquivo > Nova a partir do modelo ou Modificar > Nodelo > Aplicar modelo à página) cria um link relativo à raiz do site no arquivo .dwt. O motivo pelo qual este link relativo ao site sempre vinculará corretamente é porque o arquivo .dwt sempre estará na pasta Modelos no nível raiz de uma estrutura de pastas do site. Se o arquivo .dwt for movido da pasta Modelos, ou se a pasta Modelos for movida ou renomeada, o link será quebrado. É muito importante manter o arquivo .dwt na pasta Modelos na qual o Dreamweaver o cria. Para evitar confusão, NÃO é uma boa prática salvar outros elementos do sue site (arquivos de origem da imagem ou documentos HTML) dentro da pasta Modelos.

Como as páginas são vinculadas aos arquivos de modelo?
Quando um arquivo for aplicado a uma página existente ou criado como novo a partir de um modelo, o seguinte código será inserido na origem:

<!-- #BeginTemplate "/Templates/templateName.dwt" -->

Para visualizar o código fonte HTML que O Dreamweaver gera, escolha Janela > HTML.

O caminho acima substitui a origem HTML normal que apareceria em uma nova página. Em vez de iniciar com as tags usuais que o novo arquivo iria gerar, ela está especificando que um nível dentro da pasta raiz local, em uma pasta chamada Modelos, existe um arquivo .dwt que contém todas as informações não dentro de regiões editáveis daquela página. Esse caminho envia o navegador para consultar o local correto para o arquivo que fornecerá as propriedades da página, layout e gráfico-todo o conteúdo que existe apenas no arquivo .dwt. É por isso que as alterações fora das regiões editáveis de uma página devem ser feitas diretamente no arquivo .dwt. Quando o próprio arquivo .dwt for aberto e todas as páginas aplicadas ao modelo forem revisada, elas serão vinculadas ao arquivo no mesmo local que antes. Todas as páginas aplicadas ao modelo são todas atualizadas automaticamente com as novas informações.

Relativo ao documento versus relativo à raiz do site
O caminho que vincula uma página HTML em um modelo é um caminho relativo à raiz do site. É chamado de relativo à raiz do site porque ela começa no nível superior da estrutura de diretórios (a pasta raiz local) e, então segue através da próxima pasta para baixo (Modelos) e, finalmente vincula o arquivo .dwt. O Dreamweaver gera automaticamente um caminho relativo à raiz do site para os modelos na pasta Modelos, pois ele não sabe exatamente onde o modelo será encontrado, não importando quais outras pastas de arquivos existem na estrutura do site.

Relativo ao documento cria um caminho específico de um arquivo para outro. Em vez da partir do nível superior (raiz do site) de sua estrutura da pasta de arquivos, ele gera um caminho que começa em um arquivo, passa através de quaisquer pastas (diretórios) de arquivos necessárias e para no local do outro arquivo. É imperativo ambos os arquivos sejam salvos dentro da pasta raiz local ANTES de criar um vínculo relativo ao documento de um para outro.

Se você desejar poder visualizar suas páginas em um navegador local, antes que de ter carregado os arquivos em um servidor remoto, elas devem ser relativas ao documento. Os navegadores Internet Explorer e Netscape não têm nenhum modo de entender que pasta raiz local foi definida (como o Dreamweaver faz), portanto ele somente pode seguir um caminho que seja relativo ao documento que estiver sendo exibido no momento. Como a maioria dos usuários preferem ver localmente suas páginas em um navegador antes de carregá-las, o Dreamweaver padroniza como sendo relativo ao documento sempre que um arquivo estiver vinculado ou uma imagem for inserida. Se o arquivo não tiver sido salvo ANTES de tentar inserir uma imagem ou um link para outra página HTML, o Dreamweaver não terá nenhuma referência para o local da página atual, portanto gerará um caminho que se parece algo com isso:

file:///HardDrive/Desktop Folder/localRootFolder/subfolder/subfolder/images/content.htm

ou

file:///C:/Desktop/localRootFolder/subfolder/subfolder/images/content.htm

Esses caminhos são específicos de sua estação de trabalho APENAS e não funcionarão quando você for carregar arquivos em um servidor remoto.

O gráfico a seguir fornece uma explicação gráfica da diferença entre relativo ao documento e relativo a raiz do site. No exemplo abaixo, a página bio.htm tem um gráfico denominado logo.jpg inserido nele usando as escolhas de caminho alternativo.

 

Caminhos relativos ao documento no modelo

Inserir imagens e links no diretamente no arquivo .dwt pode ser confuso. Lembre-se de que trabalhar no arquivo. dwt, qualquer link que você criar como relativo ao documento será exatamente aquele arquivo .dwt relativo. O caminho que é gerado é específico daquela página HTML ou origem de imagem para arquivo .dwt. O Dreamweaver mantém um registro de onde as páginas referenciadas aplicadas ao modelo ao vivo, e ajusta automaticamente o caminho para o arquivo HTML referenciado como sendo correto para a página atual. Se você observar o código fonte HTML do .dwt e de uma página aplicado ao modelo, os caminhos serão diferentes e isso é como deve ser. Se o Dreamweaver não ajustou automaticamente o caminho para o local específico de cada página, o caminho relativo será quebrado em todos os arquivos, exceto para o arquivo .dwt.

Aqui está um exemplo da forma pela qual o Dreamweaver poderia ajustar o caminho relativo ao documento:

O caminho original do modelo ao gráfico:
../graphics/images/banner.gif
O caminho ajustado na página aplicada ao modelo:
../../graphics/images/banner.gif

O Dreamweaver não ajusta os caminhos relativos ou absolutos à raiz do site (http://) do modelo às páginas aplicadas ao modelo, porque não é necessário revisá-las.

Caminhos relativos ao documento nas páginas aplicadas ao modelo

Inserir imagens e links dentro da região editável de uma página anexada a um modelo funciona exatamente da mesma forma que inserir imagens ou links em uma página que não esteja anexada a um modelo. Se você seguir o procedimento de selecionar Arquivo > Novo a partir do modelo e, a seguir, Arquivo > Salvar (escolha um local dentro da pasta raiz local) ANTES de criar quaisquer links para outras páginas ou imagens, e O Dreamweaver irá padronizar para Relativo ao documento nas caixas de diálogo Selecionar a página HTML ou Selecionar a origem da imagem. Se o menu suspenso “Relativo a” não for alterado manualmente para selecionar a Raiz do site, as imagens e os links estarão disponíveis quando você visualizar seu trabalho no navegador localmente.

Caminhos relativos à raiz do site no modelo

Ao trabalhar em um arquivo de modelo para criar links para outras páginas ou para fazer referência à origem da imagem de gráficos, o menu suspenso nas caixas de diálogo Selecionar arquivo HTML e Selecionar origem da imagem permite que você escolha entre relativo ao documento e relativo a raiz do site. Como mostrado no gráfico acima, selecionar Raiz do site cria um caminho da pasta raiz local diretamente para o arquivo que está sendo selecionado, independente do arquivo.dwt que estiver aberto no Dreamweaver. Usar links relativos à raiz do site pode ser benéfico quando o conteúdo na estrutura do diretório do site provavelmente se move dentro da pasta raiz local, pois o link permanecerá não quebrado, mesmo se os arquivos forem movidos de seu local original.

O caminho original do modelo ao gráfico:
/graphics/images/banner.gif
O caminho na página aplicada ao modelo:
/graphics/images/banner.gif

O Dreamweaver não ajusta os caminhos relativos ou absolutos à raiz do site (http://) do modelo às páginas aplicadas ao modelo, porque não é necessário revisá-las. O local do documento (se for o arquivo .dwt ou um arquivo HTML anexado ao modelo) é irrelevante para um caminho relativo à raiz do site.

Caminhos relativos à raiz do site nas páginas aplicadas ao modelo
Usar os links relativos à raiz do site pode ser útil se o site for complexo, envolve que uma equipe dos desenvolvedores trabalhem juntos, ou possui uma estrutura de diretório do site que seja revisada regularmente. Para criar um vínculo relativo ao site, basta selecionar o menu suspenso Raiz do site junto das palavras “Relativo a” nas caixas de diálogo Selecionar imagem de origem e Selecionar arquivo HTML.

Como caminho criado será a partir da pasta raiz local, através de qualquer número de subpastas, e no fim na página ou na imagem à qual está vinculada, os desenvolvedores têm permissão de usar a flexibilidade de mover as páginas ou os ativos para uma ou mais subpastas acima na estrutura de diretório do site sem quebrar os links. Por exemplo, no gráfico acima, se o arquivo logo.jpg fosse movido da pasta de imagens para a pasta de recursos e o link era um link relativo à raiz do site, o navegador ainda não teria nenhum problema para localizar o gráfico. Se o caminho for um link relativo ao documento, os arquivos logo.jpg e bio.htm DEVEM permanecer na estrutura de pastas onde se encontravam quando o caminho relativo foi criado. Mover um ou outro arquivo depois que o caminho for criado resultará em um caminho que estará quebrado.

Como mencionado acima, somente os links relativos aos documentos podem ser visualizados localmente no navegador. Se você optar por usar os links relativos à raiz do site, há somente duas maneiras para exibir suas páginas no navegador.

O primeiro é fazer upload (Put) os arquivos no servidor remoto e, a seguir, usar seu navegador para ir para a página digitando o caminho absoluto no campo Localizador do URL. Usando esse método, as páginas estão sendo exibidas assim como outros na Web as verão. Para efetuar revisões nas páginas, abra a cópia local dos arquivos, faça as alterações, salve as páginas HTML, conecte-se ao servidor FTP e “Coloque” os novos arquivos acima no servidor remoto. Os arquivos com o mesmo nome na mesma pasta substituirão as versões antgas do arquivo no servidor remoto.

A segunda maneira de visualizar os links relativos ao site no navegador é o de usar um servidor da Web pessoal. Somente no Windows, essa opção pode ser definida entrando no Dreamweaver usando Arquivo > Visualizar no navegador > Editar a lista no navegador e selecionando Visualizar usando o servidor local. Definir essa opção permitirá que o Dreamweaver possa visualizar os documentos usando um servidor da Web pessoal.

Observação: para o Macintosh, um servidor da Web pessoal é definido no nível do sistema. Consulte a documentação do sistema para obter ajuda adicional.

 

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online