• Você pode facilmente importar, copiar e colar ou exportar vetores, bitmaps, animações e gráficos de botão com vários estados do Fireworks para uso no Adobe Flash®.

  • O texto TLF do Flash é copiado como imagem de bitmap em branco no Fireworks em execução no Windows. Converta o texto TLF em texto ASCII e importe-o para o Fireworks.

  • A funcionalidade de inicialização e edição facilita a edição de gráficos do Fireworks a partir do Flash. Quando você trabalha no Flash, as preferências de inicialização e edição definidas no Fireworks sempre são aplicadas.

  • O estilo HTML do Flash não aceita código de menus pop-up. Comportamentos de botões e outros tipos de interatividade do Fireworks não são importados no Flash.

Inserir gráficos do Fireworks no Flash

Importar ou copiar um arquivo PNG do Fireworks oferece o máximo de controle sobre como gráficos e animações são adicionados ao Flash. Também é possível importar arquivos JPEG, GIF, PNG e SWF que foram exportados do Fireworks.

Observação:

Quando gráficos do Fireworks são importados ou copiados e colados no Flash, alguns atributos são perdidos, como texturas e Filtros em tempo real. Não é possível importar ou copiar e colar um efeito de gradiente de contorno do Fireworks em um documento do Flash. Além disso, o Flash apenas oferece suporte para preenchimentos sólidos, preenchimentos de gradiente e traçados básicos.

Importar arquivos PNG do Fireworks no Flash

Você pode importar arquivos de origem PNG do Fireworks diretamente no Flash, sem precisar exportar para nenhum outro formato de gráficos. Todos os vetores, bitmaps, animações e gráficos de botões com vários estados do Fireworks podem ser importados no Flash.

Observação:

Comportamentos de botões e outros tipos de interatividade do Fireworks não são importados no Flash, já que os comportamentos do Fireworks são ativados por um JavaScript que é externo ao formato do arquivo. O Flash usa o código ActionScript interno.

  1. Salve o documento no Fireworks.

  2. Alterne para um documento aberto no Flash.

  3. (Opcional) Clique no estado-chave e na camada para os quais deseja importar o conteúdo do Fireworks.

  4. Selecione Arquivo > Importar.

  5. Navegue até o arquivo PNG e selecione-o.

  6. Na caixa de diálogo Importar documento do Fireworks, siga um destes procedimentos:

    • Selecione a opção Importar como um único bitmap nivelado.

    • Selecione uma opção de importação nos dois menus pop-up.

  7. Selecione como importar o texto.

  8. Clique em OK.

    Observação:

    Suas seleções na caixa de diálogo Importar documento do Fireworks são salvas e usadas como configurações padrão.

Opções para importação de gráficos, objetos de vetor e texto do Fireworks

Opções para importação de gráficos

Importar como um único bitmap nivelado

Importa uma única imagem não editável.

Importar todas as páginas em novos estados como clipes de filme

Importa todas as páginas do arquivo PNG em uma nova camada do Flash que adquire o nome desse arquivo PNG. Um estado-chave é criado na nova camada, no local do estado atual, a primeira página do arquivo PNG é inserida como clipe de filme nesse estado e todas as outras páginas são inseridas em estados subsequentes como clipes de filme. A hierarquia de camadas e os estados no arquivo PNG são preservados.

Importar página 1 no estado atual como clipe de filme

O conteúdo da página selecionada é importado como clipe de filme, que é inserido no estado e camada ativos do arquivo do Flash. A hierarquia de camadas e os estados no arquivo PNG são preservados.

Importar todas as páginas em novas cenas como clipes de filme

Importa todas as páginas do arquivo PNG e mapeia cada uma para uma nova cena como clipes de filme. As camadas e os estados nas páginas são preservados. Se já houver cenas no arquivo do Flash, o processo de importação adicionará as novas cenas depois das existentes.

Importar página 1 em nova camada

A página selecionada é importada como uma nova camada. Os estados são importados na linha do tempo como estados separados.

Opções para importação de objetos de vetor

Importar como bitmaps para manter aparência

Preserva a capacidade de edição de objetos de vetor, a menos que eles tenham preenchimentos, traçados ou efeitos especiais não suportados pelo Flash. Para preservar a aparência desses objetos, o Flash os converte em imagens de bitmap não editáveis.

Importar como caminhos editáveis

Preserva a capacidade de edição de todos os objetos de vetor. Se os objetos tiverem preenchimentos, traçados ou efeitos especiais não suportados pelo Flash, essas propriedades poderão ter um aspecto diferente depois que forem importadas.

Opções para importação de texto

Importar como bitmaps para manter aparência

Preserva a capacidade de edição do texto, a menos que ele tenha preenchimentos, traçados ou efeitos especiais não suportados pelo Flash. Para preservar a aparência desse texto, o Flash o converte em uma imagem de bitmap não editável.

Observação:

O texto TLF do Flash é copiado como uma imagem bitmap em branco no Fireworks.

Manter todo o texto editável

Preserva a capacidade de edição de todo o texto. Se os objetos tiverem preenchimentos, traçados ou efeitos especiais não suportados pelo Flash, esses objetos poderão ter um aspecto diferente depois que forem importados.

Copiar ou arrastar gráficos do Fireworks para o Flash

Para copiar gráficos para versões do Flash anteriores ao Flash 8, escolha Editar > Copiar contornos de caminho.

Observação:

Talvez seja necessário desagrupar os objetos (Modificar > Desagrupar) para torná-los editáveis como objetos de vetor separados no Flash.

  1. No Fireworks, selecione um ou mais objetos para copiar.

  2. Selecione Editar > Copiar e escolha Copiar no menu pop-up do Flash.

  3. No Flash, crie um novo documento e escolha Editar > Colar ou arraste o arquivo diretamente do Fireworks até o Flash.

  4. Na caixa de diálogo Importar documento do Fireworks, selecione uma opção para Em:

    Estados atuais como clipe de filme

    O conteúdo que está sendo colado é importado como clipe de filme, que é inserido no estado e camada ativos do arquivo do Flash. A hierarquia de camadas e os estados no arquivo PNG são preservados.

    Nova camada

    O conteúdo colado é importado como uma nova camada. Os estados são importados na linha do tempo como estados separados.

  5. Selecione como importar objetos de vetor.

  6. Selecione como importar o texto.

  7. Clique em OK.

    Observação:

    As seleções na caixa de diálogo Importar documento do Fireworks são salvas e usadas como configurações padrão.

Sobre a estrutura de bibliotecas do Flash

Os objetos do Fireworks são importados em uma Pasta de objetos do Fireworks na biblioteca do Flash. A estrutura nessa pasta é a seguinte:

Pasta Arquivo 1 // Nomeada com o nome de arquivo do Fireworks

  • Pasta Página 1 // Nomeada com o nome da página (se houver mais de uma página)

    — Página 1 // Nomeada com o nome da página

    — — Pasta Estado 1 // Nomeada com o nome do estado (se houver mais de um estado)

    — — Estado 1 // Nomeado com o nome do estado

    — — — Símbolo 1 no Estado 1 // Nomeado com base no nome do símbolo

    — — — Símbolo 2 no Estado 1

    ...

    — Pasta Camadas compartilhadas // Camadas compartilhadas entre estados na Página 1

    — — Pasta Camada compartilhada // Nomeada com o nome da camada compartilhada

    — — Símbolo de Camada compartilhada

  • Pasta Página 2

    — Página 2

    — Símbolo 1 na Página 2 (para uma página sem estados)

    ...

  • Pasta Página mestre

    — Página mestre

    — Símbolo 1 na Página mestre

    ...

    — Pasta Camadas compartilhadas // Camadas compartilhadas entre páginas

    — — Pasta Camada compartilhada // Nomeada com o nome da camada compartilhada

    — — Símbolo de Camada compartilhada

Sobre a importação de símbolos do Fireworks no Flash

Ao importar símbolos do Fireworks no Flash, considere os seguintes fatores:

  • Se um símbolo utilizar escala com 9 fatias, as quatro guias de fatia serão importadas e preservadas no Flash. Entretanto, a escala com 9 fatias não é preservada para animações. Os símbolos importados são salvos como símbolos na biblioteca do Flash.

  • Edições temporárias aplicadas a símbolos elaborados são perdidas. A cópia mestre do símbolo é importada.

  • Símbolos de gráficos elaborados são armazenados como um arquivo PNG e um arquivo JSF. Apenas o arquivo PNG é importado. Se o símbolo for formado por vários caminhos, estes serão combinados em um símbolo.

  • Para obter a funcionalidade total de símbolos elaborados no Flash, substitua-os pela versão do Flash do símbolo.

Sobre preservação da visibilidade e bloqueio

Objetos e camadas ocultos no arquivo PNG são importados e permanecem ocultos no Flash. Entretanto, as partes não visíveis de um símbolo de gráfico elaborado não são importadas (por exemplo, os estados de botão Sobre ou Pressionado).

Se uma camada estiver bloqueada ou oculta, todos os objetos e subcamadas nessa camada herdarão a configuração bloqueada ou oculta e a manterão quando forem importados no Flash.

Se você importar uma única página em uma nova camada do Flash, uma camada será criada para a página inteira, e todos os objetos serão exibidos. Atributos de visibilidade e bloqueio não são preservados.

Efeitos de camadas do Photoshop suportados

Efeito em tempo real do Photoshop - Sombra projetada

O mapeamento é o seguinte:

  • tamanho é mapeado para desfoqueX, desfoqueY

  • distância é mapeada para distância

  • cor é mapeada para cor

  • ângulo é mapeado para 180 - (ângulo de Efeito do Photoshop)

Efeito em tempo real do Photoshop - Sombra interna

O mapeamento é o seguinte:

  • tamanho é mapeado para desfoqueX, desfoqueY

  • distância é mapeada para distância

  • cor é mapeada para cor

  • ângulo é mapeado para 180 - (ângulo de Efeito do Photoshop)

Efeito em tempo real do Photoshop - Brilho externo

O mapeamento é o seguinte:

  • opacidade é mapeada para intensidade

  • cor é mapeada para cor

  • tamanho é mapeado para desfoqueX, desfoqueY

Efeito em tempo real do Photoshop - Brilho interno

O mapeamento é o seguinte:

  • opacidade é mapeada para intensidade

  • cor é mapeada para cor

  • tamanho é mapeado para desfoqueX, desfoqueY

  • Objetos com outros efeitos de camada do Photoshop são rasterizados.

Exportação de gráficos do Fireworks para outros formatos para uso no Flash

Você pode exportar gráficos do Fireworks como arquivos JPEG, GIF, PNG e Adobe Illustrator 8 (AI) e, em seguida, importá-los no Flash.

Embora o PNG seja o formato de arquivo nativo para o Fireworks, arquivos gráficos PNG exportados do Fireworks são diferentes dos arquivos PNG de origem salvos no Fireworks. Como GIFs ou JPEGs, os arquivos PNG exportados contêm apenas dados de imagem, sem informações adicionais sobre fatias, camadas, interatividade, Filtros em tempo real ou outro conteúdo editável.

Exportar gráficos e animações do Fireworks como arquivos SWF

Gráficos e animações do Fireworks podem ser exportados como arquivos Flash SWF. Para manter a formatação de tamanho e cor do traçado, escolha Manter aparência na caixa de diálogo Opções de exportação para Flash SWF.

A formatação a seguir é perdida durante a exportação para o formato SWF: modo de mesclagem, camadas, máscaras (aplicadas antes da exportação), objetos de fatia, mapas de imagem, comportamentos, preenchimentos de padrão e gradientes de contorno.

  1. Selecione Arquivo > Salvar como.

  2. Insira um nome de arquivo e escolha uma pasta de destino.

  3. Para o formato, selecione Adobe Flash SWF.

  4. Clique em Opções. Em seguida, selecione uma opção de Objetos:

    Manter caminhos

    Permite manter a capacidade de edição de caminhos. Os efeitos e a formatação são perdidos.

    Manter aparência

    Converte objetos de vetor em objetos de bitmap, conforme necessário, e preserva a aparência de traçados e preenchimentos aplicados. A capacidade de edição é perdida.

  5. Selecione uma opção de Texto:

    Manter capacidade de edição

    Permite manter a capacidade de edição do texto. Os efeitos e a formatação são perdidos.

    Converter em caminhos

    Converte o texto em caminhos, preservando qualquer kerning ou espaçamento personalizado inserido no Fireworks. A capacidade de edição do texto é perdida.

  6. Defina a qualidade de imagens JPEG, usando o seletor pop-up de Qualidade JPEG.

  7. Selecione os estados a serem exportados e a taxa de estados, em segundos.

  8. Clique em OK e, na caixa de diálogo Exportar, clique em Salvar.

Exportar arquivos PNG de 8 bits com transparência

Para exportar arquivos PNG de 32 bits com transparência, basta importar arquivos de origem PNG do Fireworks diretamente no Flash. Para exportar arquivos PNG de 8 bits com transparência, complete o procedimento a seguir:

  1. No Fireworks, escolha Janela > Otimizar, para abrir o painel Otimizar.

  2. Selecione PNG 8 como formato de arquivo de exportação e Transparência alfa no menu pop-up Transparência.

  3. Selecione Arquivo > Exportar.

  4. Selecione Apenas imagens no menu pop-up Salvar como tipo.

  5. Dê um nome e salve o arquivo.

Importar gráficos e animações exportados do Fireworks no Flash

  1. Crie um novo documento no Flash.

    Observação:

    Se estiver importando um gráfico do Fireworks em um arquivo do Flash existente, crie uma nova camada no Flash.

  2. Selecione Arquivo > Importar e localize o arquivo de gráfico ou animação.

  3. Clique em Abrir para importar o arquivo.

Usar o Fireworks para editar gráficos no Flash

Com a integração de inicialização e edição, você pode usar o Fireworks para alterar um gráfico anteriormente importado no Flash, mesmo que esse gráfico não tenha sido exportado do Fireworks.

Observação:

Arquivos PNG nativos do Fireworks importados no Flash são uma exceção; o arquivo PNG deve ter sido importado como imagem de bitmap nivelada.

Se o gráfico tiver sido exportado do Fireworks e você tiver salvado o arquivo PNG original, poderá editar o arquivo PNG no Fireworks a partir do Flash. Quando retornar ao Flash, tanto o arquivo PNG quanto o gráfico no Flash serão atualizados.

  1. No Flash, clique com o botão direito (Windows), ou com a tecla Control (Mac OS) pressionada, no arquivo gráfico do painel Biblioteca de documentos.

  2. Selecione Editar com o Fireworks no menu pop-up.

    Observação:

    Se a opção Editar com o Fireworks não aparecer no menu pop-up, escolha Editar com e localize o aplicativo Fireworks.

  3. Clique em Sim na caixa Localizar origem, para localizar o arquivo PNG original referente ao seu gráfico do Fireworks, e clique em Abrir.

  4. Edite a imagem e clique em Concluído quando terminar.

    O Fireworks exporta um novo arquivo gráfico para o Flash e salva o arquivo PNG original.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online