Vyjmutí vlastností objektu CSS

Můžete extrahovat vlastnosti objektu CSS, například oblé rohy, přechody, vržené stíny a transformace.

  1. Vyberte objekt.
  2. Zvolte příkaz Okno > Vlastnosti CSS.
  3. Kliknutím na možnost Kopírovat vše zkopírujete vlastnosti CSS vybraného objektu. Kliknutím na příkaz Kopírovat vybrané můžete zkopírovat jednotlivé vlastnosti.
    Další informace viz Extrahování vlastností CSS z navrhovaných objektů pomocí aplikace Fireworks CS6.

Export řezů jako spritu CSS

Můžete vytvářet řezy objektů v dokumentu a exportovat je jako jeden sprite CSS. Použití jednoho spritu CSS místo více obrázků zlepšuje čas načtení webových stránek, protože snižuje počet požadavků na server.

Při exportu řezů jako obrazu CSS sprite je s obrazovým souborem zároveň generován soubor CSS, který obsahuje hodnoty posunutí.

  1. Klikněte pravým tlačítkem myši na řez nebo skupinu řezů.
  2. Zvolte možnost Exportovat CSS sprity.
  3. V dialogovém okně Exportovat klikněte na tlačítko Exportovat.

Další informace viz Práce s CSS sprity v aplikaci Fireworks CS6.

Vytváření mobilních témat jQuery

Mobilní témata jQuery můžete vytvářet na základě výchozích spritů a vzorků barev. Můžete také zobrazit náhled mobilního tématu jQuery a exportovat jej jako CSS a sprity.

  • Chcete-li vytvořit mobilní téma, zvolte možnost Příkazy > Téma jQuery Mobile Theme > Vytvořit nové téma.
  • Chcete-li zobrazit mobilní témata v prohlížeči, zvolte možnost Příkazy > Téma jQuery Mobile Theme > Náhled tématu.
  • Chcete-li exportovat mobilní téma jako sprity a CSS, zvolte možnost Příkazy> Téma jQuery Mobile Theme > Exportovat téma.
  • Chcete-li zobrazit náhled tématu, zvolte možnost Okno > Doplňky > Náhled mobilního tématu jQuery v aplikaci.
  • Chcete-li přidat vyhrazené místo pro ikonu, vyberte možnosti Motiv jQuery Mobile > Vložit vyhrazené místo pro ikonu.

Další informace viz Vytvoření motivů jQuery Mobile pomocí aplikace Fireworks CS6.

Vylepšení výkonu

  • Aby byly vyřešeny problémy s nedostatkem volného místa v paměti, používání objektů GDI aplikací Fireworks bylo omezeno.
  • Byl zvýšen limit využití paměti u počítačů s 64bitovým systémem Windows za účelem vyšší stability při otevírání a ukládání velkých souborů.
  • U systému Mac OS byla vylepšena rychlost aktualizace Inspektora vlastností při přepínání mezi objekty.

Nastavení krytí nezávisle pro výplň a tah

  1. Vyberte objekt a poté vyberte možnost Výběr barvy pro výplň a tah. Možnost Výběr barvy pro výplň a tah můžete vybrat také na liště Nástroje.
  2. Klikněte na posuvník Krytí.
  3. Přetáhněte posuvník na požadovanou hodnotu.
    U systému Mac OS zadejte hodnotu do textového rámečku.

Video

Podpora alfy u výplně a tahu (00:02:50)

Získejte přehled o podpoře alfy pro výplň a tah – tato nová funkce přináší úsporu času a tvůrčí všestrannost.

Autor: Patrick Foster

Vylepšení výběru barev

  • Pomocí tlačítek můžete v Inspektoru vlastností nebo v pruhu Nástroje určit volby typu výplně, například bez výplně, plný, přechod a vzorky. Dříve byly tyto volby ovládány pomocí rozbalovacích nabídek.
  • Nyní můžete pomocí dialogu Vytáhnout určit polohu vytažení (uvnitř, na střed, vně).

Video

Rychlejší přístup k barvě (00:03:02)

Objevte výhody nového a vylepšeného panelu Barva. Zjistěte, co je nového ohledně krytí výplně/tahu, přechodů a vyjmutí a vkládání informací šestnáctkových a RGB barev.

Autor: Patrick Foster

Nastavení úhlu pro přechod nebo výplně vzorkem

  1. Vyberte objekt.
  2. V poli Inspektor vlastností vyberte přechod nebo výplň vzorkem.
  3. V dialogovém okně Upravit přechod nebo Upravit vzorek zadejte hodnotu úhlu.

Nová přípona souboru fw.png

Pokud soubor uložíte, ve výchozím nastavení se uloží s příponou fw.png.

Chcete-li změnit výchozí chování aplikace, zvolte možnost Úpravy > Předvolby. Na kartě Všeobecné dialogového okna Předvolby odznačte možnost Přidat .fw.png a klikněte na možnost OK.

Tuto příponu můžete také odstranit v dialogu Uložit jako.

Různá vylepšení

  • Vylepšení panelu Styly.
  • Je zvýrazněn uzel umístění pro zarážku barvy v nástroji přechod.
  • Pomocí nástroje kapátko můžete kopírovat, zvolit výplň nebo obarvit tah.
    Vyberte nástroj kapátko, klikněte pravým tlačítkem myši na objekt a vyberte požadovanou volbu.
  • Výchozí předlohu Fireworks a symboly ze společné knihovny můžete nyní vyhledat ve složce Uživatelé.
    Pokud je symbol ze společné knihovny odstraněn, po restartování aplikace Fireworks se vytvoří nová kopie symbolu.
  • Název vybraného objektu a úroveň zvětšení se nyní nezobrazují v titulním pruhu dokumentu. Tyto informace jsou dostupné na panelu Vrstvy a na panelu aplikací.
  • Aktualizace panelu cesty a vzorků barev.
  • V systému Mac OS nyní můžete zobrazit náhled souborů obrázku v aplikaci Google Chrome.
  • Volba Cesta, nabízející rychlý přístup k mnoha příkazům týkajícím se cest, se nachází v nabídce Okno.
  • Volba Seskupit jako masku obsahuje kontextovou nabídku po kliknutí pravým tlačítkem.
  • Výchozí nastavení optimalizace pro nový soubor je PNG32.
  • Odebrané funkce:
    • Export AIR
    • Vytváření prezentace
    • Změna vzhledů aplikace Flex
    • Device Central
    • Sdílní obrazovky
  • Nyní můžete zamknout omezení pro nástroj Oříznutí pomocí Inspektora vlastností.
  • Ikony miniatur pro objekty na panelu Vrstvy.
  • Následující datové zdroje jsou nyní dostupné ve společné knihovně: gesto, ikony, iPhone, jQuery Bootstrap, drátový model, drátový model – reklamy, drátový model – iPad, drátový model – iPhone a drátový model Windows Phone 7.
  • Knihovna stylů byla rozšířena o následující kategorie: styly symbolů tlačítek, vzorky výplně, barevné tečky tahu a styly webových tlačítek.
  • Nyní jsou k dispozici tipy nástrojů pro operaci Import souboru.
  • Při ukládání symbolu do společné knihovny je symbol uchován na plátně.
  • Nyní je k dispozici více voleb pro vzorky a textury.
  • K navigaci mezi zarážkami barvy a krytí v dialogovém okně Výplň přechodem použijte kombinaci kláves CTRL+šipka vlevo nebo CTRL+šipka vpravo. V systému Mac použijte kombinaci kláves Command+šipka vlevo nebo Command+šipka vpravo.
  • Knihovny byly rozšířeny o další vzorky a textury.

Vylepšení API

Nové metody

  • fw.appTemplatesDir: Vrací cestu k adresáři předloh.
  • fw.commonLibraryDir: Vrací cestu k adresáři společné knihovny.
  • fw.activeTool: Určuje, zda je aktivním nástrojem určený nástroj.
    Například možnost if(fw.activeTool==Tools.pen) použijte ke zjištění, zda je aktivním nástrojem nástroj pero. Tato metoda nezávisí na názvu nástroje v lokalizovaném jazyku.
  • fw.appPatternsDir: Vrací cestu k adresáři Vzorky.
  • fw.appTexturesDir: Vrací cestu k adresáři Textury.
  • fw.reloadPatterns: Znovu načte vzorky z adresáře Vzorky.
  • fw.reloadTextures: Znovu načte texturu z adresáře Textury.
  • dom.updateSymbol: Aktualizuje symbol importovaný ze společné knihovny.

Aktualizované metody

  • fw.browseForFileURL(browseType, title, previewArea, startFolder): Nový volitelný parametr startFolder určuje kořenový adresář pro dialogové okno Procházet.
  • fw.setDocumentImageSize(boundingRectangle, resolution, currentPageOnly, interpolationMethod): Nový volitelný parametr interpolationMethod načítá hodnoty v celých číslech z 1 až 4 určujících bikubických, bilineárních, měkkých a nejbližších sousedů, a to v tomto pořadí.
  • fw.saveAs(doc, url, defaultFromOptions): Výchozí hodnota parametru defaultFromOptions byla změněna na false. Pokud je nastavena na true, bude soubor uložen s aktuálními nastaveními optimalizace.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online