Los trazados de máscara y forma se animan del mismo modo que otras propiedades: establezca fotogramas clave para la propiedad Trazado de máscara o Trazado, defina trazados en cada fotograma clave y After Effects interpolará entre estos valores específicos.

Recursos e introducción a la rotoscopia

La rotoscopia (o simplemente roto en su uso informal) es el dibujo o pintura en los fotogramas de una película, utilizando elementos visuales en la película como referencia. Un tipo común de rotoscopia consiste en la utilización de un trazo alrededor de un objeto en una película, usando ese trazo como máscara para separar el objeto de su fondo. Esto permite trabajar con el objeto y el fondo por separado, de modo que se pueden realizar operaciones como aplicar diferentes efectos al objeto que en su fondo o sustituir el fondo.

Nota:

After Effects incluye las herramientas Pincel tipo rotoscopia y Perfeccionar borde, que pueden utilizarse para realizar muchas de las mismas tareas que la rotoscopia convencional, pero en mucho menos tiempo. Para obtener más información sobre la herramienta Pincel tipo rotoscopia, consulte Pincel rotoscopia, Perfeccionar borde y Perfeccionar mate.

Nota:

Si un objeto de fondo o primer plano presenta un color definido y uniforme, se puede utilizar la incrustación por croma en lugar de la rotoscopia para eliminar el fondo o el objeto. Si el material de archivo se tomó teniendo en cuenta la incrustación de color, esta técnica resulta mucho más sencilla que la rotoscopia. (Consulte Introducción a la incrustación y flujo de trabajo).

La rotoscopia en After Effects consiste principalmente en dibujar máscaras, animar el trazado de máscara y en el uso de estas máscaras para definir un mate. Muchas técnicas y tareas adicionales facilitan esta operación como, por ejemplo, el uso del seguimiento de movimiento en el objeto antes de comenzar a dibujar máscaras y posteriormente los datos de seguimiento de movimiento para que una máscara o mate sigan automáticamente al objeto.

Sugerencias sobre rotoscopia

  • Inmediatamente tras comenzar a dibujar una máscara, presione Alt+Mayús+M (Windows) u Opción+Mayús+M (Mac OS) para activar los fotogramas clave de esa máscara y establecer un fotograma clave. De este modo, no se editará ninguna máscara fotograma a fotograma durante varios minutos (o más tiempo) ni se perderá todo el trabajo en los fotogramas anteriores porque se olvidó hacer clic en el cronómetro para animar la forma de la máscara.
  • Dibuje las máscaras en una capa blanca y sólida con su vídeo desconectado, sobre la capa de material de archivo (bloqueada). De este modo, no se corren riesgos de mover por error la capa de material de archivo cuando la máscara se manipule y se pueden aplicar mucho más fácilmente los datos de seguimiento a la máscara. (Los datos de seguimiento se aplican a la capa sólida invisible que alberga la máscara). Esto también implica que no se pierden los fotogramas con previsualización almacenados en caché cada vez que se manipule la máscara. (Consulte Activación y desactivación de la visibilidad o influencia de un grupo de propiedades o capas y Bloqueo o desbloqueo de una capa).
  • Active la preferencia Conservar el recuento de vértices constante. (Consulte Designar el primer vértice de un trazado Bézier).
  • Si es posible, transforme (rotando, aplicando escala, moviendo) toda la máscara o un subconjunto de los vértices de la máscara en lugar de mover los vértices individualmente. Esta operación se lleva a cabo por eficacia y para evitar la inestabilidad que se deriva del movimiento irregular entre los fotogramas. (Consulte Mover los vértices en modo de transformación libre).
  • El seguimiento de movimiento manual requiere menos tiempo que la rotoscopia manual. Cuantos más esfuerzos se dediquen a obtener buenos datos de seguimiento en distintas partes de la escena y el objeto, menos tiempo se empleará en dibujar y ajustar las máscaras. (Consulte Seguimiento y estabilización del movimiento).
  • Utilice la función Calado de máscara de anchura variable para controlar mejor el calado de objetos.

Recursos en línea sobre rotoscopia

Este vídeo de la serie After Effects CS5: Learn by Video (After Effects CS5: aprendizaje por vídeo) muestra cómo combinar el seguimiento del movimiento y la rotoscopia para aislar y corregir el color de la cara de un actor de forma selectiva.

Scott Squires proporciona un par de películas en su sitio web Effects Corner para mostrar cómo utilizar el rotoscopio, tanto en pintura como en máscara:

Mathias Möhl incluye la secuencia de comandos KeyTweak en su sitio web, con la que se podrán modificar diversos fotogramas clave en una propiedad de forma simultánea. Con KeyTweak, es posible modificar algunos fotogramas clave manualmente y el script modifica los fotogramas clave restantes de forma correspondiente. KeyTweak resulta especialmente útil para los fotogramas clave Mask Path en un flujo de trabajo de rotoscopia.

Rich Young incluye varios recursos para rotoscopia en su sitio web After Effects Portal (en inglés).

Visualización de trazados de máscara y formas

  • Para visualizar trazados de máscara en las capas seleccionadas en el panel Línea de tiempo, presione M.
  • Para ver las máscaras o formas seleccionadas en el panel Línea de tiempo, presione SS (presione la tecla S dos veces).
  • Para visualizar trazados de máscara y de formas en el panel Composición, haga clic en el botón Mostrar u ocultar máscaras y visibilidad de trazado de formas situado en la parte inferior del panel Composición.
  • Para visualizar trazados de máscara en el panel Capa, elija Máscaras del panel Capa en el menú Ver.
  • Para ocultar un trazado de máscara mientras otros se muestran, bloquee la máscara (seleccione el definidor Bloquear del panel Línea de tiempo) y, a continuación, elija Capa > Máscara > Ocultar máscaras bloqueadas.
  • Para aislar las máscaras seleccionadas y ocultar otras, seleccione Capa > Máscara > Bloquear otras máscaras y, a continuación, elija Capa > Ocultar máscaras bloqueadas.

Selección de trazados de formas, formas y grupos de formas

Se pueden seleccionar capas de formas y sus componentes en cualquiera de los cuatro niveles de selección, conocidos como modos de selección:

Modo de selección de capas

Se selecciona toda la capa de formas. Las transformaciones se aplican a las propiedades de transformación de la capa, en el grupo de propiedades de transformación que se encuentra en el mismo nivel que el grupo de propiedades de contenidos.

Modo de selección de grupos

Se selecciona un grupo de formas completo. Las transformaciones se aplican a las propiedades de transformación del grupo, en el grupo de propiedades de transformación dentro del grupo de formas, en el panel Línea de tiempo.

Modo de transformación libre

Se seleccionan varios vértices de uno o más trazados Bézier En el panel Composición, aparece un cuadro delimitador de transformación libre alrededor de los vértices. Actuando sobre este cuadro se pueden mover varios vértices con una sola transformación. Las transformaciones se aplican a los vértices propiamente dichos, los cuales se encuentran en la propiedad Trazados, en el panel Línea de tiempo.

Modo de edición de trazados

Solo se seleccionan los vértices. En este modo, se pueden realizar operaciones de edición de trazados, como agregar vértices a un trazado y mover vértices individualmente.

Nota:

Cuando alguna herramienta de pluma está activa, el modo de edición de trazados también lo está. Para permanecer en modo de edición de trazados, seleccione la herramienta Pluma; presione V o Ctrl (Windows) o Comando (Mac OS) para activar temporalmente la herramienta Selección, según sus necesidades.

Modos de selección de formas en las capas de formas
Modos de selección de formas en las capas de formas

A. Selección de capas B. Selección de grupos C. Transformación libre D. Modificación de trazados 

Para obtener más información acerca de la selección de máscaras, consulte Selección de máscaras, segmentos y vértices.

Nota:

Teniendo seleccionado un vértice de forma, presione Ctrl+A (Windows) o Comando+A (Mac OS) para seleccionar todos los vértices de ese trazado. Vuelva a pulsar las teclas para seleccionar todas las formas. Púlselas una vez más para seleccionar todas las capas.

Seleccionar una capa de formas

  • En el panel Línea de tiempo, haga clic en el nombre o la barra de duración de la capa.
  • Con la herramienta Selección, haga clic dentro de los límites de la capa en el panel Composición.
  • Para cancelar la selección de todas las formas de una capa, pero dejar seleccionada la capa de formas, haga clic dentro de los límites de la capa, pero fuera de los trazados de todas las formas.

Seleccionar un grupo de formas en el modo de selección de grupos

  • Utilizando la herramienta Selección, haga doble clic en un elemento del grupo del panel Composición. Cada vez que se hace doble clic, se desciende un nivel en la jerarquía del grupo.
  • Para activar la herramienta Selección directa , mantenga presionada la tecla Ctrl (Windows) o Comando (Mac OS) teniendo seleccionada la herramienta Selección. Haga clic en una forma del panel Composición con la herramienta Selección directa para seleccionar directamente el grupo de esa forma, independientemente de la profundidad a la que se encuentre la forma en la jerarquía del grupo.
  • Para seleccionar un grupo contenido en el mismo grupo que el grupo que ya ha seleccionado, haga clic en el grupo que desea seleccionar.
  • Para agregar un grupo a una selección, haga clic en él teniendo presionada la tecla Mayús. Se puede combinar la tecla Mayús con un doble clic y con la herramienta Selección directa para agregar a la selección más grupos anidados a gran profundidad.

Seleccionar trazados y vértices en el modo de edición de trazados

Nota:

Para especificar el tamaño de los controles de dirección de curva Bézier y los vértices para las máscaras y formas, seleccione Editar > Preferencias > General (Windows), o bien, After Effects > Preferencias > General (Mac OS) y edite el valor Tamaño del punto de trazado.

  • Para seleccionar un vértice, haga clic en él con la herramienta Selección. Para agregar vértices a la selección, haga clic en ellos mientras presiona la tecla Mayús.
  • Para seleccionar un segmento de trazado, haga clic en él con la herramienta Selección. Para agregar segmentos a la selección, haga clic en ellos mientras presiona la tecla Mayús.
  • Para seleccionar un trazado completo, teniendo presionada la tecla Alt (Windows) u Opción (Mac OS), haga clic en un segmento o vértice del trazado con la herramienta Selección. También puede seleccionar cualquier parte del trazado y pulsar Ctrl+A (Windows) o Comando+A (Mac OS).
  • Para seleccionar vértices arrastrando, seleccione un trazado o una parte del mismo para entrar en modo de edición de trazados y, entonces, arrastre con la herramienta recuadro de selección para arrastrar un recuadro de selección alrededor de los vértices que desea seleccionar. Para agregar vértices a la selección, mantenga presionada la tecla Mayús mientras dibuja otros recuadros de selección.

Seleccionar todos los puntos de un trazado y entrar en modo de transformación libre

  • Haga doble clic en un segmento del trazado estando en modo de edición de trazados o en modo de selección de grupos para una sola forma.
  • Seleccione la propiedad de Trazado en el panel Línea de tiempo y presione Ctrl+T (Windows) o Comando+T (Mac OS).

Selección de máscaras, segmentos y vértices

A diferencia de las capas, las máscaras pueden tener más de un nivel de selección. Se puede seleccionar una máscara como un trazado completo cuando se desea mover o redimensionar. Sin embargo, si se desea cambiar el trazado de una máscara, deben seleccionarse uno o más puntos de la misma. Los puntos seleccionados se muestran sólidos, mientras que los no seleccionados se muestran huecos.

Nota:

Para especificar el tamaño de los controles de dirección de curva Bézier y los vértices para las máscaras y formas, seleccione Editar > Preferencias > General (Windows), o bien, After Effects > Preferencias > General (Mac OS) y edite el valor Tamaño del punto de trazado.

Seleccionar o deseleccionar máscaras en el panel Capa o Composición

  • Para seleccionar un vértice de una máscara, haga clic en el vértice con la herramienta Selección . Para agregar vértices a la selección, haga clic en ellos mientras presiona la tecla Mayús.
  • Para seleccionar un segmento de máscara, haga clic en el segmento con la herramienta Selección. Para agregar segmentos a la selección, haga clic en ellos mientras presiona la tecla Mayús.
  • Para seleccionar toda una máscara, presione la tecla Alt (Windows) u Opción (Mac OS) mientras hace clic en un segmento, vértice o control de una máscara con la herramienta Selección, o seleccione cualquier parte de la máscara y seleccione Editar > Seleccionar todo o presione Ctrl+A (Windows) o Comando+A (Mac OS). Para agregar máscaras a la selección haga clic en ellas mientras presiona la combinación de teclas Alt+Mayús (Windows) u Opción+Mayús (Mac OS).
  • Para seleccionar máscaras arrastrándolas, seleccione una máscara o una parte de ella para entrar en el modo de edición de máscaras, y después arrástrela con la herramienta Selección para trazar un recuadro de selección completamente alrededor de los vértices o las máscaras que desee seleccionar. Para agregar máscaras o vértices a la selección, mantenga presionada la tecla Mayús mientras dibuja los demás rectángulos de selección.
  • Para seleccionar todas las máscaras de una capa, seleccione una máscara de la capa y elija Editar > Seleccionar todo o presione Ctrl+A (Windows) o Comando+A (Mac OS).
  • Para anular la sección de todas las máscaras, presione Ctrl+Mayús+A (Windows) o Comando+Mayús+A (Mac OS).
  • Para seleccionar una máscara adyacente en una capa, presione Alt+acento grave (`) (Windows) u Opción+acento grave (`) (Mac OS) para seleccionar la siguiente máscara, o bien Mayús+Alt+acento grave (`) (Windows) o Mayús+Opción+acento grave (`) (Mac OS) para seleccionar la máscara anterior.
  • Para deseleccionar una máscara, haga clic en un lugar fuera de la máscara.
  • Para quitar un vértice o segmento de una selección, haga clic en el vértice o segmento mientras presiona la tecla Mayús.

Nota:

Para utilizar la herramienta Selección cuando está seleccionada la herramienta Pluma, mantenga presionada la tecla Ctrl (Windows) o Comando (Mac OS).

Seleccionar máscaras en el panel Línea de tiempo

  1. Haga clic en la flecha hacia la derecha situada junto a un nombre de capa para expandirla.
  2. Haga clic en la flecha hacia la derecha situada junto al encabezado Máscaras para expandirlo y mostrar todas las máscaras de esa capa.
  3. Realice cualquiera de las acciones siguientes:
    • Para seleccionar una máscara, haga clic en su nombre.
    • Para seleccionar un intervalo de máscaras contiguas, haga clic en los nombres de la primera y última máscara del intervalo mientras presiona la tecla Mayús.
    • Para seleccionar varias máscaras que no son contiguas, haga clic en sus nombres mientras presiona la tecla Ctrl (Windows) o Comando (Mac OS).

Nota:

En el panel Línea de tiempo sólo se pueden seleccionar máscaras completas. Para seleccionar vértices individuales de una máscara, utilice el panel Composición o Capa.

Bloquear o desbloquear máscaras

El bloqueo de una máscara evita que se seleccione en los paneles Línea de tiempo, Composición y Capa o que se defina como destino en el panel Capa. Use esta característica si no desea que se modifique una máscara.

  1. En el panel Línea de tiempo, expanda el grupo de propiedades de Máscara.
  2. En la columna Características A/V, haga clic en el cuadro situado debajo del icono del cerrojo  al lado de la máscara que desea bloquear o desbloquear. Una máscara se bloquea y no puede ser seleccionada cuando se elige Bloquear, es decir, cuando el icono del cerrojo aparece en el cuadro.

Nota:

Para desbloquear varias máscaras al mismo tiempo, seleccione una o más capas y elija Capa > Máscara > Desbloquear todas las máscaras.

Nota:

Para aislar las máscaras seleccionadas y ocultar otras, seleccione Capa > Máscara > Bloquear otras máscaras y, a continuación, elija Capa > Ocultar máscaras bloqueadas.

Mover los vértices en modo de transformación libre

Se puede ajustar la escala y girar un trazado completo de máscaras o formas (o los vértices seleccionados de uno o varios trazados) mediante el comando Transformación libre de puntos. Cuando se utiliza este comando, un cuadro delimitador de transformación libre rodea los vértices seleccionados y un punto de anclaje aparece en el centro del cuadro delimitador para marcar el punto de anclaje de la transformación actual. Es posible ajustar la escala de los vértices seleccionados y girarlos, arrastrando el cuadro delimitador o sus controles. También se puede cambiar el punto de referencia desde el cual se giran los vértices o se les cambia la escala desplazando el punto de anclaje del cuadro delimitador. Los controles y el punto de anclaje del cuadro delimitador Transformación libre son independientes de los controles y el punto de anclaje de la capa.

Nota:

Cuando se aplican animaciones al giro mediante Transformación libre de puntos, los vértices de la máscara se interpolan en línea recta entre los fotogramas clave. Por esta razón, los resultados pueden ser diferentes de lo que se espera.

  1. Muestre la capa que contiene los trazados que desea transformar en el panel Composición o Capa.
  2. Con la herramienta Selección, realice uno de los siguientes procedimientos:
    • Para transformar un número determinado de vértices, seleccione los vértices que desea transformar y elija Capa > Trazado de máscaras y formas > Transformación libre de puntos.
    • Para transformar un trazado completo de máscaras o formas, selecciónelo en el panel Línea de tiempo y elija Capa > Trazado de máscaras y formas > Transformación libre de puntos.
  3. Para mover el punto de anclaje del cuadro delimitador, sitúe la herramienta Selección encima del mismo  hasta que dicha herramienta se convierta en un icono para mover punto de anclaje . Arrastre para colocar el punto de anclaje.
  4. Realice cualquier combinación de las operaciones siguientes:
    • Para mover el trazado o los vértices seleccionados, coloque el puntero dentro del cuadro delimitador y arrastre.
    • Para escalar el trazado o los vértices seleccionados, coloque el puntero en un control del cuadro delimitador y, cuando el puntero se convierta en una flecha recta de dos puntas , arrastre para definir el nuevo tamaño. Mantenga presionada la tecla Mayús mientras arrastra para restringir la escala. Mantenga presionada Ctrl (Windows) o Comando (Mac OS) y arrastre para escalar alrededor del punto de anclaje del cuadro delimitador.
    • Para girar el trazado o los vértices seleccionados, coloque el puntero justo fuera del cuadro delimitador de transformación libre y, cuando el puntero se convierta en una flecha curva de dos puntas , arrastre para realizar el giro.
  5. Para salir del modo de transformación libre, presione Esc, Intro (Windows) o Retorno (Mac OS).

Convertir un trazado de Bézier manual a RotoBézier

Se puede convertir cualquier trazado de máscara Bézier manual o trazado de forma Bézier manual a un trazado RotoBézier. Si el trazado Bézier manual tiene controles de dirección que han sido ajustados, esta conversión alterará la forma del trazado porque After Effects calcula automáticamente la curvatura de los segmentos RotoBézier.

La conversión de un trazado RotoBézier a un trazado Bézier manual no modifica la forma del trazado.

  1. Seleccione una máscara en el panel Capa, Composición o Línea de tiempo o seleccione un trazado de forma en el panel Composición o Línea de tiempo.
  2. Seleccione Capa > Trazado de máscaras o capas > RotoBézier.

Modificar un trazado de máscara o de forma Bézier

Se puede modificar un trazado de máscara Bézier utilizando la herramienta Selección y las herramientas de pluma en el panel Capa o Composición. Se puede modificar un trazado de forma Bézier utilizando la herramienta Selección y las herramientas de pluma en el panel Composición.

Las herramientas de pluma (Agregar vértices, Eliminar vértices y Convertir vértices) se agrupan con la herramienta Pluma en el panel Herramientas. Para ver estas herramientas en el panel Herramientas, haga clic en la herramienta Pluma del panel Herramientas y manténgala presionada.

Nota:

En la mayoría de los casos, se activa la herramienta adecuada cuando se coloca el puntero de la herramienta Pluma en un contexto concreto. Por ejemplo, la herramienta Eliminar vértices se activa cuando se coloca el puntero de la pluma sobre un vértice y se activa Agregar vértices cuando se coloca el puntero de la pluma sobre un segmento de trazado. Para activar manualmente estas herramientas y pasar de una a otra, presione G.

Cuando modifique un trazado, asegúrese de que hace clic sólo en vértices o segmentos existentes; de lo contrario, creará un trazado nuevo.

Desplazar, agregar o eliminar un vértice

  • Realice una de las acciones siguientes:
    • Para mover un vértice, arrastre el vértice con la herramienta Selección .

    Nota:

    Para pasar temporalmente de la herramienta Pluma a la herramienta Selección, presione V o Ctrl (Windows) o Comando (Mac OS).

    • Para agregar un vértice a una máscara, utilice la herramienta Agregar vértice (MS Windows) o Añadir vértice (Mac OS)  para hacer clic en el segmento entre dos vértices existentes.
    • Para eliminar un vértice de una máscara, haga clic en el vértice con la herramienta Eliminar vértices (MS Windows) o Suprimir vértices (Mac OS) .

Ajuste de un segmento del trazado

  • Realice una de las acciones siguientes con la herramienta Selección:
    • Arrastre un vértice.
    • Arrastre los controles de dirección que se extienden desde un vértice suave colindante.
    • Arrastre un segmento curvo.

    Nota:

    Al arrastrar un segmento curvo en una máscara RotoBézier también se mueven los vértices.

Conmutar un vértice entre punto suave y punto de borde

  • Haga clic en el vértice con la herramienta Convertir vértices .

    Nota:

    Para activar la herramienta Convertir vértices, estando seleccionada la herramienta Pluma, mantenga presionada la tecla Alt (MS Windows) u Opción (Mac OS).

Ajuste de la tensión de una máscara RotoBézier

  1. Si desea ajustar la tensión de varios vértices al mismo tiempo, selecciónelos.
  2. Arrastre un vértice con la herramienta Convertir vértices .

    Nota:

    Para activar la herramienta Convertir vértices, estando seleccionada la herramienta Pluma, mantenga presionada la tecla Alt (Windows) u Opción (Mac OS).

    El puntero Ajustar tensión aparece cuando se arrastra un vértice en la máscara RotoBézier.

    Si se hace clic en un vértice en lugar de arrastrar, el vértice se define como punto de borde (tensión del 100%); si se vuelve a hacer clic, el vértice se define como un punto suave (tensión del 33%). Al arrastrar hacia arriba o hacia la derecha disminuye la tensión de la selección, aumentando la curva de los segmentos de trazado adyacentes; al arrastrar hacia abajo o hacia la izquierda, aumenta la tensión de la selección, disminuyendo la curva de los segmentos de trazado adyacentes.

    Nota:

    Para ver el valor de tensión de un vértice, consulte el panel Información a medida que la ajusta.

Cambiar un trazado de máscara numéricamente

  1. Seleccione la máscara.
  2. En el panel Línea de tiempo, expanda las propiedades de Máscara.
  3. Junto a la propiedad Trazado de máscara, haga clic en la palabra subrayada y especifique los cambios en el cuadro de diálogo Forma de la máscara.

Designar el primer vértice de un trazado Bézier

Para animar un trazado, After Effects designa el vértice superior del fotograma clave inicial como el primer vértice y numera los vértices posteriores en orden ascendente a partir del primero. A continuación, After Effects asigna los mismos números a los vértices correspondientes de todos los fotogramas clave posteriores. After Effects interpola el desplazamiento de cada vértice desde su posición inicial en un fotograma clave en la posición del vértice numerado correspondiente en el siguiente fotograma clave. En cualquier momento de la animación se puede designar otro vértice como primer vértice. En ese caso, After Effects vuelve a numerar los vértices del trazado. Al volver a numerar los vértices, la animación del trazado cambia porque After Effects asigna los nuevos números de vértices a los números antiguos que todavía están guardados en fotogramas clave sucesivos.

Al copiar un trazado cerrado en un trazado de movimiento, el vértice designado como primer vértice del trazado cerrado se utiliza como el principio del trazado de movimiento. Todos los trazados de movimiento son trazados abiertos.

Algunas operaciones de trazado de formas, como Recortar trazados, también se basan en el primer vértice para determinar cómo deben modificar el trazado.

Nota:

De manera predeterminada, al agregar un vértice a un trazado, el nuevo vértice aparece en el trazado en toda su duración, pero la forma del trazado sólo cambia en el punto en que se ha agregado. Al eliminar un vértice de un trazado en un punto específico, el vértice se elimina del trazado en toda su duración. Para evitar que After Effects agregue y elimine vértices en toda la duración del trazado, elija Editar > Preferencias > General (Windows) o After Effects > Preferencias > General (Mac OS), y anule la selección de Conservar el recuento de vértices constante al editar máscaras.

Nota: Conservar el recuento de vértices constante al editar máscaras se denomina “Conservar el recuento de puntos de calado y de vértices constante al editar máscaras” en After Effects CC y CS6.

  1. Crear un trazado animado.
  2. En el panel Línea de tiempo, mueva el indicador de la hora actual allí donde desea designar un nuevo primer vértice.
  3. Seleccione el vértice que desea designar como primer vértice.
  4. Seleccione Capa > Trazado de máscaras y formas > Definir primer vértice.

    Nota:

    El vértice designado como el primer vértice aparece un poco más grande que los demás vértices del panel Composición.

Animación de un trazado de máscara con interpolación de máscara inteligente

La interpolación de máscara inteligente proporciona un nivel alto de control para la creación de fotogramas clave de trazado de máscara y animación suave y realista. Una vez seleccionados los fotogramas clave de trazado de máscara que se van a interpolar, la opción Interpolación de máscara inteligente crea fotogramas clave intermedios basados en los ajustes proporcionados. El panel Información muestra el progreso de la interpolación y el número de fotogramas clave creados.

  1. Elija Ventana > Interpolación de máscara.
  2. Seleccione al menos dos fotogramas clave de trazado de máscara adyacentes.
  3. Defina las opciones en el panel Interpolación de máscara y, a continuación, haga clic en Aplicar.

    Nota:

    Para interrumpir el proceso de interpolación, presione Esc. El panel Información indica que el proceso se ha interrumpido e informa del número de fotogramas clave creados.

    Velocidad de fotogramas clave

    Especifica el número de fotogramas clave que Interpolación de máscara inteligente crea por segundo entre los fotogramas clave seleccionados. Por ejemplo, el valor 10 crea un nuevo fotograma clave cada décima de segundo. Elija Automático para que la velocidad de fotogramas se ajuste a la velocidad de fotogramas de la composición, que aparece entre paréntesis. Si se crean más fotogramas clave, la animación será más suave; si se crean menos fotogramas, se reducirá el tiempo de procesamiento.

    Nota:

    Independientemente de la velocidad de fotogramas que elija, Interpolación de máscara inteligente siempre agrega fotogramas clave en el fotograma inmediatamente posterior al primer fotograma clave de trazado de máscara y en el fotograma inmediatamente anterior al segundo fotograma clave de trazado de máscara. Por ejemplo, si define una interpolación entre fotogramas clave a 0 y 1 segundos en una composición de 30 fps y una velocidad de fotogramas clave de 10 por segundo, se agregarán fotogramas clave de trazado de máscara en los números de fotograma 1, 3, 6, 9, 12, 15, 18, 21, 24, 27 y 29.

    Campos de fotograma clave

    Duplica la velocidad de fotogramas clave. Cuando se selecciona esta opción y Velocidad de fotogramas clave se define como la velocidad de fotogramas de la composición, se agrega un fotograma clave en cada campo de vídeo. Seleccione esta opción si desea animar máscaras de vídeo entrelazado. Si no se selecciona esta opción, puede que la máscara se desplace fuera del objeto que se intenta eliminar. Para obtener más información sobre los campos en vídeo entrelazado, consulte Vídeo entrelazado y separación de campos.

    Utilizar trazados de vértices lineales

    Especifica que los vértices del primer fotograma clave se desplacen en línea recta hasta sus vértices correspondientes en el segundo fotograma clave. No seleccione esta opción si desea interpolar algunos vértices en trazados curvos; por ejemplo, cuando es necesario girar partes para obtener la interpolación deseada. Si no selecciona esta opción, Interpolación de máscara inteligente crea un trazado natural para la máscara.

    Resistencia de curvatura

    Especifica la susceptibilidad del trazado de máscara interpolada a la curvatura en lugar del estiramiento. El valor 0 especifica que, a medida que se anima el trazado de máscara, se dobla más de lo que se estira; el valor 100 especifica que el trazado de máscara se estira más de lo que se dobla.

    Calidad

    Especifica la precisión con la cual Interpolación de máscara inteligente hace coincidir los vértices de un fotograma clave con los de otro. El valor 0 especifica que un vértice determinado del primer fotograma clave se corresponde sólo con el vértice que tenga el mismo número en el segundo fotograma clave. Por ejemplo, el décimo vértice del primer fotograma clave debe coincidir con el décimo vértice del segundo fotograma clave. El valor 100 significa que un vértice del primer fotograma clave puede corresponderse con cualquier vértice del segundo fotograma clave. Cuanto mayor sea el valor, mejor será la interpolación resultante, aunque el tiempo de procesamiento también será mayor.

    Añadir vértices de trazado de máscara

    Especifica que Interpolación de máscara inteligente agregue vértices para facilitar las interpolaciones de calidad. Por lo general, Interpolación de máscara inteligente funciona mejor cuando los trazados de máscara tienen conjuntos densos de vértices. Asimismo, para obtener el resultado deseado, a veces se deben agregar vértices antes de que se efectúe la correspondencia, ya que un vértice del primer trazado de máscara no puede coincidir con la mitad de un segmento curvo o de línea recta del segundo trazado de máscara. Interpolación de máscara inteligente no modifica los fotogramas clave originales. Sólo los fotogramas clave de trazado de máscara nuevos calculados con Interpolación de máscara inteligente tienen vértices adicionales.

    El valor que se define especifica con qué grado de perfección se subdividen los trazados de máscara de entrada. Píxeles entre vértices especifica la distancia, en píxeles, entre los vértices del trazado de máscara de mayor perímetro después de la subdivisión. Total de vértices especifica el número de vértices de los trazados de máscara interpolados. Porcentaje de contornos especifica que se agregue un vértice en cada porcentaje indicado de la longitud del contorno del trazado de máscara. Por ejemplo, el valor 5 significa que se agrega un vértice en cada segmento sucesivo del contorno que represente el 5% del perímetro total. Para utilizar únicamente los vértices que había en el trazado del primer fotograma, no seleccione esta opción.

    Nota:

    Con la Interpolación de máscara inteligente se pueden añadir vértices en posiciones de vértice existentes aunque no se seleccione la opción Añadir vértices de trazado de máscara. Si dos vértices de un trazado de máscara coinciden con un solo vértice de la otra, este único vértice se duplica en el mismo lugar de manera que el segmento entre los dos vértices se reduzca hasta esa posición.

    Método de coincidencia

    Especifica el algoritmo que utiliza Interpolación de máscara inteligente para hacer coincidir los vértices de un trazado de máscara con los vértices de la otra. Automático aplica el algoritmo de coincidencia de curvas si alguno de los dos fotogramas clave seleccionados tiene un segmento curvo; en caso contrario, aplica el algoritmo de polilíneas. Curva aplica el algoritmo para trazados de máscara con segmentos curvos. Polilínea aplica el algoritmo para trazados de máscara que sólo tienen segmentos rectos.

    Nota:

    Los fotogramas clave de trazado de máscara agregados con Interpolación de máscara inteligente son polilíneas cuando se selecciona el método de coincidencia Polilínea, independientemente de si los trazados de máscara de entrada contenían segmentos curvos.

    Utilizar coincidencia de vértices 1:1

    Especifica que Interpolación de máscara inteligente cree un vértice en un trazado de máscara que coincida con el mismo número de vértice en la otro trazado de máscara. En cada una de los trazados de máscara de entrada, Interpolación de máscara inteligente hace coincidir los primeros vértices, los segundos vértices, los terceros vértices, etc. Si los dos trazados no tienen los mismos números de vértices, esta acción puede generar resultados no deseados.

    Primera coincidencia de vértices

    Especifica que Interpolación de máscara inteligente haga coincidir los primeros vértices de los fotogramas clave de los dos trazados de máscara. Si no se selecciona, Interpolación de máscara inteligente busca la mejor coincidencia de primer vértice entre los dos trazados de máscara de entrada.

    Nota:

    Para obtener resultados correctos, asegúrese de que los primeros vértices de los trazados de máscara de entrada coinciden y, después, seleccione Primera coincidencia de vértices.

Mover una máscara o desplazar una capa detrás de una máscara

Se puede ajustar el área visible a través de una máscara desplazando la máscara en el panel Capa o Composición, o panoramizando (desplazando) la capa que se encuentra detrás de la máscara en el panel Composición. Cuando se desplaza una máscara, los valores de posición de la capa de la máscara se mantienen constantes, y la máscara se desplaza en relación con los otros objetos del panel Composición.

Cuando se utiliza la herramienta Panorámica trasera (Punto de anclaje) para panoramizar una capa situada detrás de una máscara, la posición de la máscara se mantiene constante en el panel Composición, pero cambia en el panel Capa. Los valores de Posición de la capa con máscara cambian en relación con la composición. Cuando la panorámica excede los bordes del fotograma de la capa, cambian los valores del trazado de máscara de la capa. La herramienta Panorámica trasera (Punto de anclaje) reduce el número de pasos del procedimiento; sin ella, tendría que cambiar manualmente las propiedades de posición y trazado de máscara de la capa de la máscara. Se puede animar una capa panoramizada detrás de otra capa definiendo los fotogramas clave de las propiedades de posición y trazado de máscara de la capa de la máscara.

Mover una máscara o desplazar una capa detrás de una máscara
Cuando se utiliza la herramienta Panorámica trasera (Punto de anclaje) del panel Composición, After Effects realiza dos ajustes automáticamente. En el panel Capa, la máscara se desplaza con relación a su capa (superior), mientras que, en el panel Composición, la capa se desplaza con relación a la composición (inferior).

Mover una máscara

  1. Seleccione la máscara o las máscaras que desea desplazar.
  2. En el panel Composición, arrastre la máscara o máscaras a la nueva posición. Para limitar el movimiento de la máscara o máscaras en horizontal o vertical, mantenga presionada la tecla Mayús después de empezar a arrastrar.

Para panoramizar una capa detrás de su máscara

  1. Seleccione la herramienta Panorámica trasera (Punto de anclaje) en el panel Herramientas.

  2. Haga clic dentro del área de la máscara en el panel Composición y arrastre la capa hasta una nueva posición.

Seguimiento de caras y seguimiento de máscaras

Puede utilizar el rastreador de máscara para transformar una máscara de modo que siga el movimiento de uno o más objetos en la película. Para obtener más información, consulte Seguimiento de máscara.

También puede utilizar el rastreador de máscara para detectar y seguir caras con precisión. Para obtener más información, consulte Seguimiento de máscara.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea