Acerca de archivos importados y elementos de material de archivo

Los archivos de origen se importan en un proyecto como base de los elementos de material de archivo y se utilizan como orígenes para las capas. El mismo archivo puede ser el origen para varios elementos de material de archivo, cada uno con sus propios ajustes de interpretación. Cada elemento de material de archivo se puede usar como el origen de una o más capas. En una composición se trabaja con colecciones de capas.

Con los elementos de material de archivo se trabaja principalmente en el panel Proyecto. Se puede utilizar el panel Material de archivo para evaluar el material de archivo y realizar tareas simples de edición, como recortar la duración de un elemento de material de archivo.

Se pueden importar muchos tipos de archivos diferentes, colecciones de archivos o componentes de archivos como las fuentes para los elementos de material de archivo individuales, incluyendo archivos de imagen en movimiento, archivos de imágenes fijas, secuencias de imágenes fijas y archivos de audio. El usuario puede crear por sí mismo elementos de material de archivo en After Effects, como sólidos y precomposiciones. En un proyecto se pueden importar elementos de material de archivo en cualquier momento.

Al importar archivos, After Effects no copia en el proyecto los datos de imagen propiamente dichos, sino que crea un enlace de referencia al origen del elemento de material de archivo, lo que mantiene el tamaño relativamente reducido de los archivos de proyecto.

Si se elimina, cambia de nombre o mueve un archivo de origen importado, se rompe el enlace de referencia a ese archivo. Cuando un enlace se rompe, el nombre del archivo de origen aparece en cursiva en el panel Proyecto, y como no disponible en la columna Ruta de archivo. Si el elemento de material de archivo está disponible, se puede restablecer el enlace (normalmente, basta con hacer doble clic en el elemento y volver a seleccionar el archivo).

Nota:

Puede buscar elementos de material de archivo a los que le faltan elementos de origen escribiendo no existe en el campo de búsqueda del panel Proyecto. Consulte Búsqueda y filtro en los paneles Línea de tiempo, Proyecto y Efectos y ajustes preestablecidos.

Para reducir el tiempo de procesamiento y aumentar el rendimiento, a menudo es mejor preparar el material de archivo antes de importarlo a After Effects. Por ejemplo, suele ser mejor aumentar la escala o recortar una imagen fija en Photoshop antes de incluirla en After Effects que aumentar su escala o recortarla en After Effects. Es mejor realizar una operación una vez en Photoshop que forzar a After Effects a que realice la misma acción muchas veces por segundo, es decir, una vez para cada fotograma en el que aparece la imagen.

Para ahorrar tiempo y reducir el tamaño y la complejidad de un proyecto, importe un elemento de origen como un solo elemento de material de archivo y, a continuación, utilícelo varias veces en una composición. No obstante, de vez en cuando resulta útil duplicar un elemento de material de archivo e interpretar cada uno de forma diferente. Por ejemplo, puede utilizar el mismo material de archivo en dos velocidades de fotogramas diferentes.

Si se utiliza otra aplicación para modificar un elemento de material de archivo que se utilice en un proyecto, los cambios aparecerán en After Effects la próxima vez que abra el proyecto o seleccione el elemento de material de archivo y elija Archivo > Volver a cargar material de archivo.

Nota:

Para reemplazar un elemento de material de archivo de origen de una capa por otro elemento sin que los cambios realizados en las propiedades de la capa se vean afectados, seleccione la capa y, a continuación, presione Alt (Windows) u Opción (Mac OS) y arrastre el nuevo elemento de material de archivo a la capa en el panel Línea de tiempo.

Nota:

Para reemplazar todos los usos de los elementos de material de archivo seleccionados por otro elemento de material de archivo, seleccione los elementos de material de archivo en el panel Proyecto y, a continuación, presione Alt-arrastrar (Windows) u Opción-arrastrar (Mac OS) en el nuevo elemento de material de archivo del panel Proyecto.

Cuando After Effects importa vídeo y audio en algunos formatos, procesa y almacena en caché versiones de estos elementos a los que se puede acceder con facilidad al generar previsualizaciones. Este almacenamiento en caché mejora enormemente el rendimiento de las previsualizaciones, dado que no es necesario volver a procesar los elementos de vídeo y audio en cada previsualización. 

Para obtener más información sobre la importación de recursos, consulte este tutorial de vídeo de Andrew Devis en el sitio Web de Creative COW.

Codificación y descodificación nativos de archivos QuickTime

After Effects puede codificar y descodificar de forma nativa los archivos de QuickTime (.mov) con los códecs de GoPro CineForm de Mac OS y Windows. Esto significa que no es necesario que instale códecs adicionales para utilizar y crear estos archivos.

En MOV, After Effects tiene compatibilidad de importación nativa con los siguientes formatos no comprimidos:

  • DV, IMX, MPEG2, XDCAM, h264, JPEG, Avid DNxHD, Avid DNxHR, Apple ProRes, AVCI y GoPro CineForm

La compatibilidad nativa con la exportación está disponible para los siguientes formatos no comprimidos:

  • Avid DNxHD, Avid DNxHR, DV y GoPro CineForm

Nota:

Como After Effects puede importar y exportar de forma nativa muchos códecs (mencionados anteriormente), no se requiere QuickTime en Windows. Para obtener más información sobre los problemas de compatibilidad, consulte la entrada de blog QuickTime en Windows

Formatos de importación compatibles

Algunas extensiones de nombres de archivo, como MOV, AVI, MXF, FLV y F4V, identifican formatos de archivos contenedores en lugar de un formato de datos de imagen, vídeo o audio determinado. Los archivos contenedores pueden tener datos codificados mediante varios esquemas de compresión y codificación. After Effects puede importar estos archivos contenedores, pero la capacidad de importar los datos del archivo dependerá de los códecs (especialmente los descodificadores) instalados.

Para que After Effects pueda importar más tipos de archivos, deberá instalar códecs adicionales. Muchos códecs deben instalarse en el sistema operativo (Windows o Mac OS) y funcionan como uno de los componentes de los formatos QuickTime o Vídeo para Windows. Póngase en contacto con el fabricante del hardware o software para obtener más información sobre los códecs que funcionan con los archivos creados específicamente por sus aplicaciones o dispositivos.

La importación y el uso de algunos archivos requiere la instalación de plugins de importación adicionales. (Consulte Plugins).

Adobe Premiere Pro puede capturar e importar muchos formatos que After Effects no puede importar de forma nativa. Puede transferir datos de Adobe Premiere Pro a After Effects de muchas formas. (Consulte Uso de Adobe Premiere Pro y After Effects).

Formatos de audio

  • Adobe Sound Document (ASND; archivos multipista importados como una única pista fusionada)

  • Advanced Audio Coding (AAC, M4A)

  • Formato de archivo de intercambio de audio (AIF, AIFF)

  • MP3 (MP3, MPEG, MPG, MPA, MPE)

  • Vídeo para Windows (AVI; se requiere QuickTime en Mac OS)

  • Forma de onda (WAV)

Formatos de imagen fija

  • Adobe Illustrator (AI, AI4, AI5, EPS, PS; rasterización continua)
  • Adobe PDF (PDF; solo la primera página; rasterización continua)
  • Adobe Photoshop (PSD)
  • Mapa de bits (BMP, RLE, DIB)
  • Raw de cámara (TIF, CRW, NEF, RAF, ORF, MRW, DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF)
  • Cineon/DPX (CIN, DPX con archivos DPX de 8, 10, 12 y 16-bpc, incluidos los que tienen código de tiempo y canal alfa)
  • Discreet RLA/RPF (RLA, RPF; 16bpc; importa datos de cámara)
  • EPS
  • GIF
  • JPEG (JPG, JPE)
  • Datos de cámara Maya (MA)
  • Maya IFF (IFF, TDI; 16bpc)
  • OpenEXR (EXR, SXR, MXR; 32bpc)
  • PICT (PCT)
  • Gráficos de red portátiles (PNG; 16 bpc)
  • Radiance (HDR, RGBE, XYZE; 32 bpc)
  • SGI (SGI, BW, RGB; 16 bpc)
  • Softimage (PIC)

Nota:

Los plugins del efecto Canal 3D de fnord software se incluyen en After Effects para ofrecer acceso a varias capas y canales de archivos OpenEXR. (Consulte Uso de canales en archivos OpenEXR).

Nota:

After Effects también puede leer archivos ZPIC correspondientes a archivos PIC importados. Consulte (Importación y uso de archivos 3D de otras aplicaciones).

  • Targa (TGA, VDA, ICB, VST)

  • TIFF (TIF)

Nota:

Puede importar archivos con cualquier formato de imagen fija como una secuencia. Consulte Preparación e importación de imágenes fijas.

Formatos de vídeo y animación

  • GIF animado (GIF)
  • Avid DNxHR
  • HEVC (H.265) MPEG-4
  • Compatibilidad con archivos ARRIRAW de cámaras ARRI ALEXA o ARRIFLEX D-21
    Para obtener más información sobre los archivos ARRIRAW, consulte las preguntas frecuentes de ARRIRAW en el sitio web del grupo ARRI.
  • CinemaDNG

Nota: CinemaDNG es un subconjunto de Camera RAW. Se puede acceder a un conjunto de ajustes de Camera RAW a través de Más opciones en el cuadro de diálogo Interpretar material de archivo. La administración de color para CinemaDNG incluye los mismos espacios de color que Camera RAW existente de After Effects: Adobe RGB, sRGB IEC619662.1, ColorMatch RGB y ProPhoto RGB.

  • DV (en contenedor MOV o AVI o como flujo DV sin contenedor)
  • ElectricImage (IMG, EI)
  • FLV, F4V
  • QuickTime (MOV; 16bpc, solo para los códecs que no tienen descodificadores nativos)
  • Vídeo para Windows (AVI, WAV; requiere QuickTime en MAC OS)

  • Archivo de Windows Media (WMV, WMA, ASF; solo Windows)

  • XDCAM HD y XDCAM EX

  • RED (R3D)
  • Media eXchange Format (Formato de intercambio de medios, MXF)

MXF es un formato contenedor. After Effects solo puede importar algunos tipos de datos incluidos en archivos MXF. After Effects puede importar la variedad Op-Atom de archivos MXF utilizados por las cámaras de vídeo Panasonic para grabar medios de Panasonic P2. After Effects puede importar vídeo de estos archivos MXF utilizando los códecs AVC-Intra 50, AVC-Intra 100, DV, DVCPRO, DVCPRO50 y DVCPRO HD. After Effects también puede importar archivos XDCAM HD en formato MXF (el formato MXF OP1, que contiene el vídeo MPEG-2 que cumple con el formato XDCAM HD).

  • Formatos MPEG-1, MPEG-2 y MPEG-4: MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, M2TS (AVCHD), MP4, M4V, M4A
  • SWF (rasterización continua)

Formatos de proyecto

  • Adobe Premiere Pro 1.0, 1.5, 2.0, CS3, CS4, CS5, CS6 y CC (PRPROJ; 1.0, 1.5 y 2.0 Windows solamente) y proyectos posteriores

  • Proyectos binarios de Adobe After Effects 6.0 y posterior en After Effects CS5 (AEP, AET)

  • After Effects 7 puede abrir proyectos de After Effects 3.0 hasta After Effects 7.

  • Proyectos XML de Adobe After Effects CS4 y superior (AEPX)

El plugin Automatic Duck Pro Import AE está integrado en la aplicación y se denomina Pro Import After Effects. Con este plugin, puede importar archivos AAF y OMF desde un sistema Avid, archivos XML desde Final Cut Pro 7 o una versión anterior y archivos de proyecto de Motion 4 o versiones anteriores. Para obtener más información sobre el uso de Pro Import After Effects, consulte su Guía del usuario, a la que puede acceder si selecciona Archivo > Importar > Pro Import After Effects, y, a continuación, hace clic en el botón Ayuda.

También puede importar proyectos de Final Cut Pro en Premiere Pro y posteriormente incorporar los componentes del proyecto en After Effects.


Nota:

 

  • After Effects también puede leer archivos EIZ correspondientes a archivos EI importados. Consulte (Importación y uso de archivos 3D de otras aplicaciones).
  • Algunos formatos de datos MPEG se guardan en formatos contenedores con extensiones de nombre de archivo que After Effects no reconoce, como .vob y .mod. En ciertos casos, puede cambiar la extensión de nombre de archivo por otra que After Effects reconozca para poder importar el archivo. Debido a las variaciones en la implementación de estos formatos contenedores, no se puede garantizar que sean compatibles.
  • Para obtener más información sobre formatos MPEG, consulte el sitio web sobre MPEG y la página sobre MPEG en el sitio web de Wikipedia.
  • Antes de empezar a trabajar con QuickTime, lea la alerta publicada por el equipo de la disposición de emergencia informática de Estados Unidos de abril de 2016, que recomienda a los usuarios de Windows desinstalar Apple QuickTime de sus equipos.
  • Los archivos R3D se interpretan como archivos que contienen colores de 32 bpc en un espacio de color no lineal HDTV (Rec. 709). La configuración de color de los ajustes de origen RED R3D no conservan los valores de brillo excesivo. Los ajustes de color realizados en After Effects conservan los colores de brillo excesivo cuando se trabaja con color de 32 bpc (bits por canal). Para evitar el recorte, manipule la exposición en After Effects, en lugar de en el escenario de interpretación de material de archivo en el cuadro de diálogo Ajustes de origen RED R3D.
  • After Effects puede importar recursos Sony XDCAM HD si estuvieran registrados en archivos MXF. After Effects no puede importar recursos XDCAM HD en formato IMX. After Effects puede importar recursos Sony XDCAM EX almacenados como archivos de esencia con la extensión de nombre de archivo .mp4 en un directorio BPAV. Para obtener más información sobre el formato XDCAM, consulte este documento PDF en el sitio Web de Sony.
  • Los archivos SWF se importan con un canal alfa. El audio no se conserva. No se conserva el contenido interactivo ni la animación con secuencias de comandos, La animación definida mediante fotogramas clave en la película principal de nivel superior se mantiene.

Importación de elementos de material de archivo

Puede importar archivos de medios en su proyecto utilizando el cuadro de diálogo Importar o arrastrándolos. Los elementos de material de archivo importado aparecen en el panel Proyecto.

Si el cuadro de diálogo Interpretar material de archivo aparece después de haber importado un elemento de material de archivo, incluirá un canal alfa sin etiquetar. Tendrá que seleccionar un método de interpretación del canal alfa o hacer clic en Deducir para que After Effects determine cómo interpretarlo. (Consulte Interpretación de canal alfa: premultiplicado o recto).

Importación de elementos de material de archivo mediante el cuadro de diálogo Importar

  1. Seleccione Archivo > Importar > Archivo o seleccione Archivo > Importar > Varios archivos, o haga doble clic en un área vacía del panel Proyecto.

    Si selecciona Importar archivos múltiples, podrá realizar el siguiente paso más de una vez sin tener que seleccionar el comando Importar varias veces.

    Nota:

    Para mostrar únicamente los archivos compatibles con el material de archivo (excluyendo los archivos de proyecto), seleccione Todos los archivos de material de archivo en el menú Archivos de tipo (Windows) o Activar (Mac OS).

  2. Realice una de las acciones siguientes:
    • Seleccione un archivo y, a continuación, haga clic en Abrir.

    • Mantenga presionada la tecla Ctrl (Windows) o Comando (Mac OS) mientras hace clic en varios archivos para seleccionarlos y, a continuación, haga clic en Abrir.

    • Haga clic en un archivo y, a continuación, mantenga presionada la tecla Mayús y haga clic en otro archivo para seleccionar un rango de archivos y, a continuación, haga clic en Abrir.

    • (Solo Windows) Seleccione una carpeta entera y haga clic en Importar carpeta.

    Nota:

    Si se selecciona la opción Secuencia, varios archivos de la carpeta se importarán como una secuencia de imágenes fijas.  

Importación de elementos de material de archivo arrastrándolos

Nota:

Si siempre desea que los archivos de imágenes fijas en capas se arrastren a After Effects para importarse como una composición, seleccione Edición > Preferencias > Importar (Windows) o After Effects > Preferencias > Importar (Mac OS) y seleccione Composición o Composición: Conservar tamaños de capa en el menú Arrastrar varios elementos de importación como. (Consulte Importación de una secuencia de imágenes fijas como una composición).

  • Para importar un solo archivo, arrástrelo desde el Explorador de Windows (Windows) o Finder (Mac OS) al panel Proyecto.
  • Para importar el contenido de una carpeta como una secuencia de imágenes fijas que aparecen en el panel Proyecto como un único elemento de material de archivo, arrastre una carpeta desde el Explorador de Windows (Windows) o el Finder (Mac OS) al panel Proyecto.
  • Para importar el contenido de la carpeta como elementos de material de archivo individuales que aparecen en el panel Proyecto de una carpeta, arrastre una carpeta desde el Explorador de Windows (Windows) mientras pulsa la tecla Alt o arrastre una carpeta desde el Buscador (Mac OS) mientras pulsa la tecla Opción al panel Proyecto.
  • Para importar un archivo de salida procesado del panel Cola de procesamiento, arrastre el módulo de salida correspondiente desde el panel Cola de procesamiento al panel Proyecto.

Nota:

Si arrastra un módulo de salida desde el panel Cola de procesamiento al panel Proyecto antes de realizar el procesamiento, After Effects crea un elemento de material de archivo de marcador de posición. Las referencias al elemento de material de archivo del marcador de posición se sustituyen automáticamente cuando se procesa el módulo de salida; el propio elemento de material de archivo del marcador de posición no se reemplaza.

Interpretación de elementos de material de archivo

After Effects utiliza un conjunto de reglas internas para interpretar cada elemento de material de archivo que importe de acuerdo a lo más parecido para la proporción de aspecto de píxeles, la velocidad de fotogramas, perfil de color y tipo de canal alfa del archivo de origen. Si After Effects realiza un deducción errónea o si quiere utilizar el material de archivo de forma diferente, puede modificar estas reglas para todos los elementos de material de archivo de un tipo determinado mediante la edición del archivo de reglas de interpretación (interpretation.rules.txt), o puede modificar la interpretación de un elemento de material de archivo específico con el cuadro de diálogo Interpretar material de archivo.

Los ajustes de interpretación le indican a After Effects la siguiente información sobre cada elemento de material de archivo:

Nota:

En todos estos casos, la información se utiliza para adoptar decisiones sobre cómo interpretar los datos en el elemento de material de archivo importado: para informar a After Effects sobre el material de archivo de entrada. Los ajustes de interpretación del cuadro de diálogo Interpretar material de archivo deben coincidir con los ajustes utilizados para crear el archivo del material de archivo de origen. No utilice los ajustes de interpretación para intentar especificar la configuración de la salida final procesada.

Por lo general, no será necesario modificar los ajustes de interpretación. Sin embargo, si un elemento de material de archivo no es de un tipo común, After Effects puede necesitar información adicional para interpretarlo correctamente.

Puede utilizar los controles de la sección Administración de color del cuadro de diálogo Interpretar material de archivo para indicarle a After Effects cómo interpretar la información de color de un elemento de material de archivo. Este paso solo suele ser necesario cuando el elemento de material de archivo no contiene un perfil de color incrustado.

Cuando se realiza una previsualización en el panel Material de archivo, se ven los resultados de las operaciones de interpretación del material de archivo.

Jeff Almasol proporciona una secuencia de comandos en su sitio web redefinery que puede utilizar para que la deducción de la disminución 3:2, telecine 24Pa o la interpretación del canal alfa sean más apropiadas.

Nota:

Seleccione Previsualización en el cuadro de diálogo Interpretar material de archivo para previsualizar los resultados de los ajustes realizados en este cuadro de diálogo antes de aceptar los cambios.

Interpretación de un solo elemento de material de archivo mediante el cuadro de diálogo Interpretar material de archivo

  1. Seleccione un elemento de material de archivo en el panel Proyecto y siga uno de los procedimientos siguientes:
    • Haga clic en el botón Interpretar material de archivo de la parte inferior del panel Proyecto.

    • Arrastre el elemento de material de archivo al botón Interpretar material de archivo.

    • Elija Archivo > Interpretar material de archivo > Principal.

    • Presione Ctrl+Alt+G (Windows) o Comando+Opción+G (Mac OS).

Interpretación de un proxy mediante el cuadro de diálogo Interpretar material de archivo

  1. Seleccione el elemento de material de archivo original en el panel Proyecto y siga uno de los procedimientos siguientes:
    • Presione Alt (Windows) u Opción (Mac OS) y haga clic en el botón Interpretar material de archivo de la parte inferior del panel Proyecto.

    • Presione Alt (Windows) u Opción (Mac OS) y arrastre el elemento de material de archivo al botón Interpretar material de archivo.

    • Elija Archivo > Interpretar material de archivo > Proxy.

Aplicación de los ajustes de Interpretar material de archivo a varios elementos de material de archivo

Para estar seguro de que los distintos elementos de material de archivo utilizan los mismos ajustes, copie los ajustes de interpretación de un elemento y aplíquelos a los demás.

  1. En el panel Proyecto, seleccione el elemento cuyos ajustes de interpretación desea aplicar.
  2. Elija Archivo > Interpretar material de archivo > Recordar interpretación.
  3. En el panel Proyecto, seleccione uno o más elementos del material de archivo.
  4. Elija Archivo > Interpretar material de archivo > Aplicar interpretación.

Edición de las reglas de interpretación para todos los elementos de un determinado tipo

El archivo de reglas de interpretación contiene las reglas que especifican cómo After Effects interpreta los elementos de material de archivo. En la mayoría de los casos, no es necesario personalizar el archivo de reglas de interpretación. Cuando se importa un elemento de material de archivo, After Effects busca una coincidencia en el archivo de reglas de interpretación y, a continuación, determina los ajustes de interpretación del elemento de material de archivo. Mediante el cuadro de diálogo Interpretar material de archivo se pueden omitir estos ajustes después de realizar la importación.

En la mayoría de los casos, el nombre del archivo de reglas de interpretación es interpretation rules.txt; no obstante, algunas actualizaciones de After Effects instalan un nuevo archivo de reglas de interpretación con un nombre que indica el número de versión actualizado y la aplicación actualizada utiliza este nuevo archivo. Si ha realizado cambios en el archivo de reglas de interpretación antiguo, puede que también necesite aplicar esos cambios al archivo nuevo.

Ubicaciones del archivo de reglas de interpretación en After Effects CC:

  • (Windows) <unidad>\Users\<nombre_usuario>\AppData\Roaming\Adobe\After Effects <15.1>
  • (Mac OS) <unidad>/Users/<nombre_usuario>/Library/Preferences/Adobe/After Effects <15.1>

Ubicaciones del archivo de reglas de interpretación en versiones anteriores de After Effects CC:

  • (Windows) <unidad>\Users\<nombre_usuario>\AppData\Roaming\Adobe\After Effects <14.x>
  • (Mac OS) <unidad>/Users/<nombre_usuario>/Library/Preferences/Adobe/After Effects <14.x>
  1. Salga de After Effects
  2. Como precaución, haga una copia de seguridad del archivo de reglas de interpretación. De forma predeterminada, este archivo se encuentra en la misma ubicación que la aplicación After Effects.
  3. Abra el archivo de reglas de interpretación en un editor de texto.
  4. Modifique los ajustes según las instrucciones del archivo.

    Nota:

    Debe facilitar un código de cuatro caracteres para identificar al tipo de archivo, por cada tipo de material de archivo o códec. Si no conoce el código de un archivo o códec de un proyecto, presione Alt (Windows) u Opción (Mac OS), al seleccionar el archivo en el panel Proyecto. El código de tipo de archivo y el código de códec (si el archivo está comprimido) aparecen en la última línea de la descripción del archivo, en la parte superior del panel Proyecto.

  5. Guarde el archivo interpretation rules.txt.

Interpretación de canal alfa: premultiplicado o recto

Los archivos de imagen con canales alfa almacenan información de transparencia de una de dos formas: rectos o premultiplicados. Aunque los canales alfa son iguales, los canales de color son diferentes.

En los canales rectos (o sin mate), la información de transparencia solo se almacena en el canal alfa y no en ninguno de los canales de color visibles. En los canales rectos, los resultados de la transparencia no son visibles hasta que la imagen se visualiza en una aplicación que admite canales rectos.

En los canales premultiplicados (o con mate), la información de transparencia se almacena en el canal alfa y también en los canales RGB visibles, que se multiplican con un color de fondo. A veces se dice que los canales premultiplicados se han convertido en mate con color. Los colores de las áreas semitransparentes, como los bordes calados, se desplazan hacia el color de fondo de acuerdo con su grado de transparencia.

Algunos tipos de software permiten especificar el color de fondo con el cual se premultiplican los canales; de lo contrario, el color de fondo suele ser negro o blanco.

Los canales rectos conservan información de color más precisa que los canales premultiplicados. Los canales premultiplicados son compatibles con una gama más amplia de programas, como Apple QuickTime Player. A menudo, la opción de si utilizar o no imágenes con canales rectos o premultiplicados se ha realizado antes de recibir los recursos para editar y componer. Adobe Premiere Pro y After Effects reconocen los canales rectos y premultiplicados pero solo el primer canal alfa que encuentran en un archivo que contiene varios canales alfa.

El ajuste correcto de la interpretación del canal alfa puede evitar problemas al importar un archivo, tales como colores no deseados en el borde de una imagen o la pérdida de calidad de imagen en los bordes del canal alfa. Por ejemplo, si los canales se interpretan como canales rectos cuando en realidad se trata de canales premultiplicados, las áreas semitransparentes conservarán parte del color de fondo. Si aparece una inexactitud del color, como un halo, a lo largo de los bordes semitransparentes de una composición, pruebe a cambiar el método de interpretación.

Canales premultiplicados
Cuando se interpreta como Recto (sin mate) (parte inferior izquierda), aparece un elemento de material de archivo con canales premultiplicados (parte superior) con una aureola de color negro. La aureola no aparece (parte inferior derecha) cuando el elemento de material de archivo se interpreta como Premultiplicado (mate con color) y el color de fondo especificado es el negro.

Puede utilizar el efecto Eliminar los halos de color para eliminar la multiplicación de una capa y quitar los flequillos de áreas semitransparentes de la misma.

Ajuste de la interpretación del canal alfa para un elemento de material de archivo

  1. En el panel Proyecto, seleccione un elemento del material de archivo.
  2. Elija Archivo > Interpretar material de archivo > Principal.
  3. Si desea cambiar las áreas opacas y transparentes de la imagen, seleccione Invertir Alfa.
  4. En la sección Alfa, seleccione un método de interpretación:

    Deducir

    Intenta determinar el tipo de los canales alfa utilizados en la imagen. Si After Effects no puede deducir con seguridad, emite un sonido.

    Ignorar

    No tiene en cuenta los datos de transparencia del canal alfa.

    Recto (sin mate)

    Interpreta los canales como rectos.

    Premultiplicado (mate con color)

    Interpreta los canales como premultiplicados. Utilice el cuentagotas o el selector de color para especificar el color de fondo con los canales que se premultiplicaron.

Ajuste de las preferencias de canales alfa predeterminados

  1. Elija Edición > Preferencias > Importar (Windows) o After Effects > Preferencias > Importar (Mac OS)
  2. Elija las opciones del menú Interpretar alfa no etiquetado como. Las opciones de este menú son similares a las opciones del cuadro de diálogo Interpretar material de archivo. Preguntar al usuario especifica que el cuadro de diálogo Interpretar material de archivo se abre cada vez que se importa un elemento de material de archivo con un canal alfa sin etiquetar.

Velocidad de fotogramas

La velocidad de fotogramas de la composición determina el número de fotogramas que se muestran por segundo y cómo se divide el tiempo por fotogramas en la regla de tiempo y en el visualizador de tiempo. Es decir, la velocidad de fotogramas de la composición especifica cuántas veces por segundo se muestrean las imágenes desde los elementos de material de archivo de origen, así como las divisiones de tiempo en las que se pueden establecer los fotogramas clave.

Nota:

After Effects contiene un menú desplegable para código de tiempo de fotogramas eliminados o sin eliminar en el cuadro de diálogo Ajustes de composición. En versiones anteriores, esta opción era un ajuste global por proyecto.

La velocidad de fotogramas de la composición suele venir determinada por el tipo de resultado deseado. Los vídeos NTSC tienen una velocidad de fotogramas de 29,97 fotogramas por segundo (fps), los vídeos PAL tienen una velocidad de fotogramas de 25 fps y las películas con imágenes en movimiento suelen tener una velocidad de fotogramas de 24 fps. Según el sistema de emisión, los vídeos DVD pueden tener la misma velocidad de fotogramas que los vídeos NTSC o PAL, o bien, una velocidad de 23,976. Los dibujos animados y vídeos diseñados para Web o CD-ROM suelen ser de 10 a 15 fps.

Nota:

Si se define la velocidad de fotogramas de la composición como dos veces la frecuencia del formato de salida, After Effects mostrará cada uno de los campos del material de archivo de origen entrelazado como un fotograma solo separado en el panel Composición. Este proceso permite definir los fotogramas clave de los campos individuales y mejorar la precisión al animar máscaras.

Cuando se procesa una película para obtener el resultado final, puede elegir entre utilizar la velocidad de fotogramas de la composición u otra velocidad de fotogramas. La capacidad de establecer la velocidad de fotogramas para cada módulo de salida resulta útil cuando se utiliza la misma composición para crear una salida para varios medios.

Compatibilidad de material de archivo de alta velocidad de fotogramas

En la versión de abril de 2017 de After Effects CC, se puede fijar un campo de velocidad de fotogramas de hasta un máximo de 999 fps. A diferencia de las versiones anteriores, en las que se podía fijar una velocidad máxima de fotogramas de 99 fps, esta actualización permite establecer velocidades de fotogramas mayores para su procesado.

Todos los elementos de material de archivo de movimiento de una composición también pueden tener su propia velocidad de fotogramas. La relación entre la velocidad de fotogramas del elemento de material de archivo y la velocidad de fotogramas de la composición determina la suavidad con la que se reproduce la capa. Por ejemplo, si la velocidad de fotogramas del elemento de material de archivo es de 30 fps y la velocidad de fotogramas de la composición es de 30 fps, siempre que la composición avance un fotograma, aparecerá el siguiente fotograma del elemento de material de archivo. Si la velocidad de fotogramas del elemento de material de archivo es de 15 fps y la velocidad de fotogramas de la composición es de 30 fps, cada fotograma del elemento de material de archivo aparece en dos fotogramas sucesivos de la composición. (Por supuesto, esto asume el caso simple en el que no se ha aplicado la expansión de tiempo o la fusión de fotogramas a la capa).

Lo mejor es utilizar material de archivo de origen que coincida con la velocidad de fotogramas de la salida final. De esta forma, After Effects procesa todos los fotogramas y en la salida final no se omiten, duplican ni interpolan fotogramas. Si, aun así, la velocidad de fotograma del material de archivo de origen es algo distinta a lo que desea (por ejemplo, material de archivo de 30 fps y salida final de 29,97 fps), puede hacer que coincida con la velocidad de fotograma de la composición ajustándola.

El hecho de ajustar la velocidad de fotogramas de un elemento de material de archivo no varía el archivo original, solamente la referencia que utiliza After Effects. Al ajustar, After Effects cambia la duración interna de los fotogramas pero no el contenido de estos. Después, el material de archivo se reproduce a una velocidad distinta. Por ejemplo, si se ajusta la velocidad de fotogramas de 15 fps a 30 fps, el material de archivo se reproduce el doble de rápido. En la mayoría de casos, ajuste la velocidad de fotogramas solamente cuando la diferencia entre la velocidad de fotogramas del material de archivo y la de la salida sea pequeña.

Nota:

El hecho de ajustar puede cambiar la sincronización de material de archivo visual que tenga una pista de audio, puesto que al cambiar la velocidad de fotogramas se cambia la duración del vídeo, pero el audio no varía. Si desea estirar el audio y el vídeo, utilice el comando de ampliación de tiempo. (Consulte Ampliar el tiempo de una capa). Los fotogramas clave aplicados al material de archivo de origen permanecen en las ubicaciones originales (que retiene su sincronización en la composición pero no el contenido visual de la capa.) Es posible que haya que ajustar las ubicaciones de los fotogramas clave después de ajustar un elemento de material de archivo.

Puede cambiar la velocidad de fotogramas de cualquier película o secuencia de imágenes fijas. Por ejemplo, puede importar una secuencia de diez imágenes fijas y especificar una velocidad de fotogramas para cada elemento de material de archivo de 5 fotogramas por segundo (fps); esta secuencia tendría una duración de dos segundos cuando se utilizase en una composición.

Nota:

Al importar una secuencia de imágenes fijas, se asume la velocidad de fotogramas especificada en la preferencia Material de archivo de secuencias de la categoría Importar. La frecuencia predeterminada es de 30 fotogramas por segundo (fps). Al volver a interpretar el elemento de material de archivo después de la importación, se puede cambiar la velocidad de fotogramas. (Consulte Interpretación de elementos de material de archivo).

Las velocidades de fotograma más bajas tienden a dar la impresión de irrealidad, por lo que muchos usuarios prefieren trabajar con una velocidad más baja como, por ejemplo, 24 fotogramas por segundo cuando realizan un trabajo creativo en lugar de trabajar a 29,97 fotogramas por segundo, que es el valor estándar para vídeo NTSC.

Nota:

Si elimina el telecine 3:2 del material de archivo de vídeo entrelazado, After Effects definirá de manera automática la velocidad de fotogramas del material de archivo resultante a cuatro quintos de la velocidad original de fotogramas. Cuando se elimina el telecine 3:2 del vídeo NTSC, la velocidad de fotogramas resultante es de 24 fps.

La velocidad de fotogramas de la composición debe coincidir con la del formato de salida final. En la mayoría de los casos, simplemente se debe seleccionar un ajuste de composición preestablecido. En cambio, establezca la velocidad de fotogramas para cada elemento de material de archivo en la velocidad del material de archivo de origen inicial.

Trish y Chris Meyer ofrecen sugerencias y trucos sobre el ajuste de elementos de material de archivo a una velocidad de fotogramas específica en un artículo (PDF) del sitio web Artbeats.

Cambio de la velocidad de fotogramas para un elemento de material de archivo

  1. Seleccione un elemento de material de archivo en el panel Proyecto.
  2. Elija Archivo > Interpretar material de archivo > Principal.
  3. Seleccione Ajustar a la velocidad de fotogramas, escriba una nueva velocidad de fotogramas para Fotogramas por segundo y, a continuación, haga clic en Aceptar.

Nota:

En lugar de utilizar Interpretar material de archivo para cambiar la velocidad de fotogramas de un elemento de material de archivo, puede ampliar el tiempo de una capa en función del elemento. Por ejemplo, amplíe el tiempo de una capa un 100,1% para convertir entre 30 fps y 29,97 fps. Con la ampliación de tiempo se modifica la velocidad del audio, así como la de vídeo. (Consulte Ampliación del tiempo de una capa).

Cambio de la velocidad de fotogramas para una composición

  1. Elija Composición > Ajustes de composición.
  2. Realice una de las acciones siguientes:
    • Elija un ajuste preestablecido de los ajustes de composición en el menú Ajuste preestablecido.

    • Ajuste el valor Velocidad de fotogramas.

Nota:

Jeff Almasol proporciona una secuencia de comandos en su sitio web redefinery para establecer la velocidad de fotogramas y la duración de la composición actual y de todas las composiciones anidadas en ella.

Proporción de aspecto de píxeles y fotogramas

La Proporción de aspecto de píxeles (PAR) indica la proporción de anchura respecto a la altura de un píxel en una imagen. La Proporción de aspecto de fotogramas (a veces denominada proporción de aspecto de imagen o IAR) indica la proporción de anchura respecto a la altura del fotograma de la imagen.

Proporción de aspecto de fotogramas
Proporción de aspecto de fotogramas de 4:3 (izquierda) y de 16:9 más ancha (derecha)

La mayoría de pantallas de ordenador utilizan píxeles cuadrados, pero muchos formatos de vídeo, incluidos ITU-R 601 (D1) y DV, utilizan píxeles rectangulares no cuadrados.

Algunos formatos de vídeo tienen como resultado la misma proporción de fotogramas aunque utilizan una proporción de píxeles diferente. Por ejemplo, algunos digitalizadores NTSC crean una proporción de aspecto de fotogramas 4:3, con píxeles cuadrados (proporción de aspecto de píxeles de 1,0) y un fotograma con unas dimensiones de píxeles de 640 x 480. D1 NTSC crea la misma proporción de aspecto de fotogramas 4:3, pero utiliza píxeles no cuadrados (proporción de aspecto de píxeles de 0,91) y un fotograma con unas dimensiones de píxeles de 720 x 486. Los píxeles D1, que siempre son rectangulares, se orientan verticalmente en sistemas que producen vídeo NTSC y horizontalmente en sistemas que producen vídeo PAL.

Si se muestran píxeles rectangulares en un monitor de píxeles cuadrados sin alteración, las imágenes aparecerán distorsionadas; por ejemplo, los círculos aparecerán como elipses. No obstante, cuando aparecen en un monitor de vídeo, las imágenes son correctas. Cuando se importa material de archivo de origen D1 NTSC o DV a After Effects, la imagen parece ligeramente más ancha que en un sistema D1 o DV (el material de archivo D1 PAL parece ligeramente más estrecho). El efecto contrario tiene lugar cuando se importa material de archivo anamórfico utilizando D1/DV NTSC pantalla panorámica o D1/DV PAL pantalla panorámica. Los formatos de vídeo de pantalla panorámica tienen una proporción de fotogramas de 16:9.

Nota:

Para previsualizar píxeles no cuadrados en la pantalla de un ordenador, haga clic en el botón Conmutar corrección de la proporción de aspecto de píxeles que se encuentra al final del panel Composición. La calidad de la corrección de la proporción de aspecto de píxeles para las previsualizaciones se ve afectada por la preferencia Calidad de zoom de la categoría Previsualizaciones. (Consulte Preferencias de la calidad del visor).

Píxeles cuadrados y rectangulares
Píxeles cuadrados y rectangulares

A. Píxeles cuadrados y proporción de aspecto de fotogramas de 4:3 B. Píxeles no cuadrados y proporción de aspecto de fotogramas de 4:3 C. Píxeles rectangulares mostrados en un monitor de píxeles cuadrados 

Si un elemento de material de archivo utiliza píxeles rectangulares, After Effects muestra la proporción de aspecto de píxeles junto a la imagen en miniatura del elemento de material de archivo en el panel Proyecto. Puede cambiar la interpretación de la proporción de aspecto de píxeles para elementos de material de archivo individuales en el cuadro de diálogo Interpretar material de archivo. Al garantizar que todos los elementos de material de archivo son interpretados correctamente, se pueden combinar los elementos de material de archivo con diferentes proporciones de aspecto de píxeles en la misma composición.

After Effects lee y escribe proporciones de píxeles directamente desde películas QuickTime. Si, por ejemplo, importa una película capturada como pantalla panorámica (16:9 DV), After Effects le asigna automáticamente la etiqueta correcta. De manera parecida, los archivos AVI y PSD contienen información que indica explícitamente la proporción de aspecto de píxeles de las imágenes.

Si un elemento de material de archivo no contiene información que indique explícitamente la proporción de aspecto de píxeles de la imagen, After Effects utiliza las dimensiones de píxel del fotograma del elemento de material de archivo para deducirla. Al importar un elemento de material de archivo con dimensiones de píxeles D1 de 720x486 o con dimensiones de píxeles DV de 720x480, After Effects interpreta de manera automática ese elemento de material de archivo como D1/DV NTSC. Al importar un elemento de material de archivo con dimensiones de píxeles D1 o DV de 720x576, After Effects interpreta de manera automática ese elemento de material de archivo como D1/DV PAL. No obstante, siempre puede asegurarse de que todos los archivos se interpretan correctamente en el panel Proyecto o en el cuadro de diálogo Interpretar material de archivo.

Nota:

Asegúrese de restablecer la proporción de aspecto de píxeles como píxeles cuadrados cuando importe un archivo de píxeles cuadrados que tenga unas dimensiones de píxeles D1 o DV (por ejemplo, una imagen que no sea DV con unas dimensiones de píxeles de 720x480).

Los ajustes de la proporción de aspecto de píxeles de la composición deben coincidir con la proporción de aspecto de píxeles del formato de salida final. En la mayoría de los casos, simplemente se debe seleccionar un ajuste de composición preestablecido. En cambio, ajuste la proporción de aspecto de los píxeles para cada elemento de material de archivo a la del material de archivo de origen inicial.

Trish y Chris Meyer ofrecen sugerencias y trucos acerca de la proporción de aspecto de píxeles en dos documentos PDF en el sitio web de Artbeats:

Chris Pirazzi proporciona información técnica sobre proporciones de aspecto en su sitio web Lurker's Guide to Video.

Actualización de proporciones de aspecto de píxeles para corregir valores

After Effects CS3 y versiones anteriores utilizaban proporciones de aspecto de píxeles para formatos de vídeo de definición estándar que ignoran el concepto de apertura limpia. No teniendo en cuenta el hecho de que la apertura limpia difiere de la apertura de producción en el vídeo de definición estándar, las proporciones de aspecto de píxeles utilizadas en After Effects CS3 y versiones anteriores eran ligeramente inexactas. Las proporciones de aspecto de píxeles incorrectas hacen que algunas imágenes se muestren ligeramente distorsionadas.

Nota:

La apertura limpia es la porción de la imagen que está libre de los artefactos y las distorsiones que aparecen en los bordes de una imagen. La apertura de producción es toda la imagen.

Todd Kopriva proporciona información (en inglés) sobre las proporciones de aspecto de píxeles corregidas en una entrada del sitio web de Adobe.

En la tabla siguiente encontrará información sobre los valores de proporción de píxeles en After Effects:

formato

Valor en After Effects CS4 y posterior

Valor anterior

D1/DV NTSC

0,91

0,9

D1/DV NTSC Pantalla ancha

1,21

1,2

D1/DV PAL

1,09

1,07

D1/DV PAL Pantalla ancha

1,46

1,42

Esta discrepancia se limita a estos formatos más antiguos de definición estándar para los cuales la apertura limpia es diferente de la apertura de producción. Esta discrepancia no existe en los formatos más recientes.

Los nuevos proyectos creados en After Effects CS4 y posterior utilizan los valores correctos de proporción de aspecto de píxeles de forma predeterminada.

Los proyectos y las composiciones creados en After Effects CS3 o versiones anteriores se actualizan para utilizar las proporciones de aspecto de píxeles correctas cuando estos proyectos se abran en After Effects CS4 y posterior.

Nota:

Si dispone de archivos de reglas de interpretación personalizados, debe actualizarlos con los valores correctos.

Si utiliza elementos de material de archivo de píxeles cuadrados diseñados para rellenar el fotograma en una composición sin píxeles cuadrados, es posible que note que el cambio en la proporción de aspecto de píxeles cause una diferencia de comportamiento. Por ejemplo, si previamente ha creado elementos de material de archivo de píxeles cuadrados de 768x576 para su uso en una composición PAL D1/DV, ahora debería crear esos elementos con dimensiones de píxeles cuadrados de 788x576.

Los ajustes preestablecidos de configuración de composición para los equivalentes en píxeles cuadrados de los formatos de definición estándar han cambiado de la forma siguiente:

formato

dimensiones de píxeles en After Effects CS4 y posteriores

dimensiones de píxeles anteriores

equivalente en píxeles cuadrados de NTSC D1

720 x 534

720 x 540

equivalente en píxeles cuadrados de pantalla ancha NTSC D1

872 x 486

864 x 486

equivalente en píxeles cuadrados de PAL D1/DV

788 x 576

768 x 576

equivalente en píxeles cuadrados de pantalla ancha PAL D1/DV

1050 x 576

1024 x 576

Cambio de interpretación de la proporción de aspecto de píxeles para un elemento de material de archivo

  1. Seleccione el elemento de material de archivo en el panel Proyecto.
  2. Elija Archivo > Interpretar material de archivo > Principal.
  3. Elija una proporción de entre las del menú Proporción de aspecto píxeles y haga clic en Aceptar (MS Windows) u OK (Mac OS).

Cambio de la proporción de aspecto de los píxeles para una composición

  1. Elija Composición > Ajustes de composición.
  2. Realice una de las acciones siguientes:
    • Elija un ajuste preestablecido de los ajustes de composición en el menú Ajuste preestablecido.

    • Elija un valor del menú Proporción de aspecto de píxeles.

Proporciones de aspecto de píxeles comunes

Proporción de aspecto de píxeles

Cuándo se utiliza

Píxeles cuadrados

1,0

El material de archivo tiene un tamaño de fotograma de 640x480 o 648x486, es 1920x1080 HD (no HDV o DVCPRO HD), es 1280x720 HD o HDV, o se ha exportado de una aplicación que no es compatible con píxeles no cuadrados. Este ajuste también puede ser apropiado para material de archivo que se haya transferido desde películas o para proyectos personalizados.

D1/DV NTSC

0,91

El material de archivo tiene un tamaño de fotograma de 720x486 o 720x480 y desea que el resultado tenga una proporción de aspecto de fotogramas de 4:3. Este ajuste también puede ser adecuado para el material de archivo que se ha exportado de una aplicación que funciona con píxeles no cuadrados como una aplicación de animación 3D.

D1/DV NTSC Pantalla ancha

1,21

El material de archivo tiene un tamaño de fotograma de 720x486 o 720x480 y desea que el resultado tenga una proporción de aspecto de fotogramas de 16:9.

D1/DV PAL

1,09

El material de archivo tiene un tamaño de fotograma de 720x576 y desea que el resultado tenga una proporción de aspecto de fotogramas de 4:3.

D1/DV PAL Pantalla ancha

1,46

El material de archivo tiene un tamaño de fotograma de 720x576 y desea que el resultado tenga una proporción de aspecto de fotogramas de 16:9.

Anamórfico 2:1

2,0

El material de archivo se tomó con lentes de película anamórfica o se ha transferido de forma anamórfica desde un fotograma de película con una proporción de aspecto de 2:1.

HDV 1080/DVCPRO HD 720, HD Anamorphic 1080

1,33

El material de archivo tiene un tamaño de fotograma de 1440x1080 o 960x720 y desea que el resultado tenga una proporción de aspecto de fotogramas de 16:9.

DVCPRO HD 1080

1,5

El material de archivo tiene un tamaño de fotograma de 1280x1080 y desea que el resultado tenga una proporción de aspecto de fotogramas de 16:9.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea