Wersje programu Dreamweaver CC 2015
Podsumowanie nowych funkcji

W wersjach Adobe Dreamweaver CC 2015.1, 2015.2 i 2015.3 wprowadzono przełomowe zmiany w procesie projektowania i budowania serwisów WWW. Biblioteki Creative Cloud i usługa Adobe Stock są teraz dostępne bezpośrednio w programie Dreamweaver, co pozwala na integrację elementów projektu i stylów z innych aplikacji komputerowych i mobilnych Adobe oraz wstawianie obrazów i filmów w dużej rozdzielczości. Funkcje współpracy oferowane przez usługę Creative Cloud umożliwiają płynny obieg pracy między projektantami i programistami.

W tej wersji wprowadzono również kilka rozszerzeń panelu DOM, usługi Extract, narzędzi do projektowania reagujących serwisów WWW i funkcji edycji w widoku aktywnym, a także inne ulepszenia oparte na prośbach użytkowników. Poniższy artykuł zawiera omówienie tych nowych funkcji i udoskonaleń, a także odsyłacze do zasobów pozwalających zdobyć dodatkowe informacje.

Adobe Dreamweaver CC 2015.3

W tej wersji programu Dreamweaver wprowadzono poprawkę błędu występującego na komputerach z systemem Windows, który uniemożliwiał wprowadzenie komputera w stan uśpienia przy uruchomionym programie Dreamweaver (błąd licznika czasu wybudzania). 

Więcej informacji: Nie można uśpić komputera, gdy jest uruchomiony program Dreamweaver | Windows.

Adobe Dreamweaver CC 2015.2 (wydanie: marzec 2016)

Rozszerzenia panelu DOM

Wprowadzono obsługę zaznaczania wielu elementów, edytowania znaczników, klas i identyfikatorów oraz wstawiania nowych elementów, dzięki czemu panel DOM stał się narzędziem umożliwiającym tworzenie układu i projektu niemal wszystkich części strony WWW.

Poniżej można znaleźć więcej informacji o tych rozszerzeniach panelu DOM:

Obsługa zaznaczania wielu elementów w panelu DOM

W panelu DOM dokumentu można teraz zaznaczyć wiele znaczników naraz, aby je jednocześnie edytować lub wykonywać na nich inne działania.

  • Aby zaznaczyć elementy leżące obok siebie, przytrzymaj klawisz Shift i klikaj kolejne znaczniki w panelu DOM.
  • Aby zaznaczyć elementy nieleżące obok siebie, przytrzymaj klawisz Ctrl i klikaj odpowiednie znaczniki w panelu DOM.
Zaznaczenie leżących obok siebie elementów w panelu DOM
Zaznaczenie leżących obok siebie elementów w panelu DOM

Zaznaczenie nieleżących obok siebie elementów w panelu DOM
Zaznaczenie nieleżących obok siebie elementów w panelu DOM


Po zaznaczeniu wielu elementów w panelu DOM:

  • Panele Inspektor właściwości i Projektant CSS są nieaktywne.
  • Hierarchia znaczników widoczna na dole strony jest usuwana.
  • Punkt wstawiania w widoku Kod staje się nieaktywny.

Edytowanie znaczników, klas i identyfikatorów w panelu DOM

Możesz teraz zmienić znaczniki, klasy i identyfikatory poprzez dwukrotne kliknięcie w panelu DOM. Można również dodać dodatkowe klasy lub identyfikatory, oddzielając je spacją. Dla znaczników niepowiązanych z klasą lub identyfikatorem można wpisać nazwę klasy lub identyfikatora po dwukrotnym kliknięciu znacznika.

Podpowiedzi do kodu pojawiają się podczas wpisywania znacznika, klasy lub nazwy identyfikatora. Aby zawęzić podpowiedzi do klas, rozpocznij pisanie od kropki. Aby widzieć tylko identyfikatory w podpowiedziach, rozpocznij pisanie od symbolu „#”.

Edytowanie znaczników w panelu DOM
Edytowanie znaczników w panelu DOM

Edytowanie i dodawanie klas w panelu DOM
Edytowanie i dodawanie klas w panelu DOM

Edytowanie i dodawanie identyfikatorów w panelu DOM
Edytowanie i dodawanie identyfikatorów w panelu DOM

Aby usunąć znacznik, kliknij go prawym przyciskiem myszy w panelu DOM i wybierz opcję Usuń znacznik.

Wstawianie elementów w panelu DOM

Panel DOM umożliwia teraz wstawianie nowych elementów na strony WWW. Można to zrobić na kilka sposobów:

  • Naciśnij klawisz spacji lub kliknij ikonę wstawiania obok odpowiedniego elementu w panelu DOM. W wyświetlonym okienku kliknij jedną z opcji. Aby otoczyć wiele elementów znacznikiem, zaznacz odpowiednie elementy, a następnie wybierz opcję wstawiania Otocz znacznikiem.
Spowoduje to wstawienie znacznika zastępczego DIV, który zostanie wyświetlony w trybie edycji. Zamiast znacznika DIV można wpisać inną nazwę znacznika.
Opcje wstawiania w panelu DOM
Opcje wstawiania w panelu DOM

  • Kliknij odpowiedni element w panelu Wstaw i przeciągnij go do panelu DOM. Podpowiedzi w czasie rzeczywistym będą pokazywać, w którym miejscu element zostanie wstawiony. Upuść element w odpowiedniej lokalizacji.

Podczas wstawiania znaczników za pomocą panelu DOM do dokumentu jest wstawiany także domyślny (zastępczy) tekst i atrybuty znaczników:

  • Po wstawieniu jednego z następujących znaczników i zatwierdzeniu zmian w widokach Kod, Aktywny i Projekt jest wstawiany tekst zastępczy:
    div, header, nav, aside, article, section, footer, h1-h6, hgroup
  • Po wstawieniu znacznika table i zatwierdzeniu zmian jest wstawiana tabela 3X3.
  • Po wstawieniu znacznika embed lub img i zatwierdzeniu zmian jest wyświetlane okno dialogowe Wybierz plik, w którym należy wybrać odpowiedni plik.
  • Po wstawieniu znacznika meta i zatwierdzeniu zmian w widoku Kod jest wstawiany następujący kod: <meta name="" content="">
  • Po wstawieniu znacznika figure i zatwierdzeniu zmian jest wstawiany znacznik figure z zagnieżdżonym podpisem.
  • W przypadku wstawiania znacznika ul lub ol po zatwierdzeniu zmian jest wstawiany znacznik ol/ul z zagnieżdżonym znacznikiem li.

Pomoce wizualne w przypadku węzłów potomnych

Gdy dany węzeł w panelu DOM jest zaznaczony, jego węzły potomne są oznaczane kolorem jasnoniebieskim.

Jeśli węzły potomne zostaną zaznaczone bezpośrednio, jasnoniebieskie wyróżnienie nie jest wyświetlane.

Węzły potomne podświetlone po zaznaczeniu węzła nadrzędnego
Węzły potomne podświetlone po zaznaczeniu węzła nadrzędnego

Węzeł potomny podświetlony podobnie do węzła nadrzędnego
Węzeł potomny podświetlony podobnie do węzła nadrzędnego


Rozszerzenia zabezpieczeń zapobiegające potencjalnemu obejściu funkcji Gatekeeper

Gatekeeper jest wbudowaną funkcją do wykrywania złośliwego oprogramowania w systemie Mac OS X 10.7 i jego późniejszych wersjach. Służy ona do sprawdzania prawidłowości podpisów Developer ID (identyfikatora programisty) w aplikacjach przed zainstalowaniem ich na komputerze. Jednak Gatekeeper nie wykrywa ani nie blokuje aplikacji ładowanych dynamicznie przez inne aplikacje, mające prawidłowe podpisy. Jeśli program Dreamweaver został nabyty z nieautoryzowanych źródeł, ta luka zabezpieczeń Gatekeeper może zostać wykorzystana w celu zainstalowania szkodliwych wtyczek dodanych do pakietu instalacyjnego programu. 

Aby zapobiec potencjalnemu naruszeniu zabezpieczeń, Dreamweaver prosi teraz użytkownika o potwierdzenie, czy załadować wtyczki innych firm zainstalowane w lokalizacji innej niż folder /Applications.

Komunikat potwierdzenia załadowania bibliotek innych firm
Komunikat potwierdzenia załadowania bibliotek innych firm

Integracja ze strukturą CEF

Program Dreamweaver jest teraz zintegrowany ze strukturą CEF3 2357. Widok aktywny umożliwia obecnie renderowanie przejść, animacji i transformacji 3D w standardzie CSS3.

Więcej informacji: Integracja ze strukturą CEF.

Rozszerzenia wizualnych zapytań o media

Dodając zapytania za pomocą paska wizualnych zapytań o media można teraz wybrać jednostkę (px, em lub rem). Jeśli poda się wartość w określonej jednostce, a następnie zmieni tę jednostkę na inną, wprowadzona wartość zostanie automatycznie przekonwertowana na nowo wybraną jednostkę.

Określanie jednostek podczas dodawania zapytania o media.
Określanie jednostek podczas dodawania zapytania o media.

Więcej informacji: Wizualne zapytania o media.

Rozszerzenia dotyczące funkcji Bibliotek CC

Zmiany w oknie dialogowym ponownego próbkowania

Element interfejsu „Rozmiar” w oknie dialogowym optymalizacji obrazu zmienił nazwę na „Próbkuj do”.

Do czasu pełnego przepróbkowania obrazu z panelu Biblioteki CC na obrazie tym jest wyświetlana ikona oczekiwania na zakończenie pracy.

Okno dialogowe ponownego próbkowania w programie Dreamweaver CC 2015.2
Okno dialogowe ponownego próbkowania w programie Dreamweaver CC 2015.2

Wydzielanie przygotowanych do wyświetlania w Internecie plików SVG z Bibliotek CC

Jeśli licencjonowane obrazy Adobe Stock zapisano w bibliotekach Creative Cloud, to można je wydzielić jako dostosowane do wyświetlania w Internecie pliki SVG przeznaczone na strony WWW programu Dreamweaver. Obrazy przeciągnięte z panelu Biblioteki CC na strony WWW są domyślnie wstawiane jako pliki SVG.

Właściwości plików SVG można dostosować, edytując preferencje w pliku options.json.

Więcej informacji: Wydzielanie przygotowanych do wyświetlenia w Internecie plików SVG z Bibliotek CC.

Nowe szablony początkowe

W tej wersji dodano trzy nowe szablony wiadomości e-mail: Email-Fluid (elastyczny), Email-Hybrid (hybrydowy) oraz Email-Responsive (reagujący).

Aby skorzystać z tych szablonów, wybierz polecenie Plik > Nowy > Szablony początkowe > Szablony e-mail.

Nowe szablony początkowe wiadomości e-mail w programie Dreamweaver CC 2015.2
Nowe szablony początkowe wiadomości e-mail w programie Dreamweaver CC 2015.2

Rozszerzone możliwości edycji tabel w widoku aktywnym

Nowe opcje edycji wierszy i kolumn

W widoku aktywnym są teraz dostępne następujące opcje edycji tabel:

  • Usuwanie za pomocą klawisza Delete/Backspace.
  • Wycinanie za pomocą menu kontekstowego, menu Edytuj lub skrótu klawiszowego.
  • Kopiowanie za pomocą menu kontekstowego, menu Edytuj lub skrótu klawiszowego.
  • Wklejanie za pomocą menu kontekstowego, menu Edytuj lub skrótu klawiszowego.
  • Kopiowanie i zastępowanie innych wierszy lub kolumn za pomocą opcji Zastąp zaznaczone komórki, dostępnej w menu kontekstowym.

Aby wyświetlić te opcje, uruchom tryb formatowania tabeli, zaznaczając ją i klikając ikonę menu w polu Monitor elementu. Następnie zaznacz odpowiednie komórki i kliknij prawym przyciskiem myszy.

Opcje edycji komórek tabeli w widoku aktywnym
Opcje edycji komórek tabeli w widoku aktywnym

Nawigacja między wierszami i kolumnami

Klawisze strzałki w lewo i w prawo umożliwiają teraz przechodzenie między komórkami tabeli w widoku aktywnym. Kliknij komórkę w tabeli i naciśnij klawisz strzałki w lewo, aby przejść do poprzedniej komórki. Naciśnij klawisz strzałki w prawo, aby przejść do następnej komórki tabeli.

Zmiany ekranu powitalnego

W tej wersji programu Dreamweaver wprowadzono następujące zmiany ekranu Witamy:

Ekran Witamy w wersji Dreamweaver CC 2015.2
Ekran Witamy w wersji Dreamweaver CC 2015.2

Adobe Dreamweaver CC 2015.1 (wersja z listopada 2015 r.)

Integracja z Bibliotekami Creative Cloud

Nowe funkcje obsługi Bibliotek Creative Cloud umożliwiają współpracę z innymi użytkownikami oraz współużytkowanie zasobów graficznych i motywów kolorów utworzonych w innych programach, takich jak Photoshop, Illustrator i aplikacje mobilne. Zasoby kreatywne można przeglądać, zarządzać nimi i wykorzystywać je w dowolnym momencie we wszystkich projektach programu Dreamweaver.  

Panel Biblioteki CC w programie Dreamweaver
Panel Biblioteki CC w programie Dreamweaver

Wstawiając grafikę z Bibliotek Creative Cloud, można zachować połączenie między wstawianym zasobem a jego źródłem, co pozwoli na nieustanną aktualizację tego zasobu.

Nowy panel Biblioteki CC w programie Dreamweaver ułatwia przeglądanie zasobów znajdujących się w bibliotekach Creative Cloud i wstawianie ich na strony WWW. Zasoby te można wstawiać w widoku aktywnym albo w widoku Kod, posługując się podpowiedziami do kodu.

Szczegółowe informacje: Biblioteki Creative Cloud w programie Dreamweaver.

Integracja z usługą Adobe Stock

Integracja z usługą Adobe Stock umożliwia pobieranie dostępnych bez tantiem zdjęć, obrazów, grafiki wektorowej i filmów do Bibliotek Creative Cloud. Po zapisaniu tej zawartości w bibliotece można nią łatwo zarządzać bezpośrednio w programie Dreamweaver.

Nie opuszczając programu Dreamweaver, można wyszukać w usłudze Adobe Stock odpowiednie obrazy, ilustracje i filmy, aby nadać tworzonemu serwisowi WWW odpowiednią oprawę, przykuwającą uwagę odbiorców.

Wyszukiwanie i kupowanie obrazów z usługi Adobe Stock
Wyszukiwanie i kupowanie obrazów z usługi Adobe Stock

Rozszerzenia związane z projektami reagującymi

Udoskonalenia związane ze strukturą Bootstrap

Obsługa Bootstrap 3.3.5

Strukturę Bootstrap używaną w programie Dreamweaver zaktualizowano do wersji 3.3.5. W związku z tym składniki, urywki i szablony początkowe Bootstrap mają teraz wersję 3.3.5. 

Również funkcje jQuery zostały zaktualizowane do wersji 1.11.3.

Powielanie wierszy i kolumn

Obok funkcji dodawania kolumn i wierszy w dokumentach Bootstrap w widoku aktywnym, program Dreamweaver udostępnia teraz także możliwość powielania wierszy i kolumn.

Wybrany wiersz lub kolumnę można powielić, klikając ikonę powielania () widoczną w prawym dolnym rogu. Zostanie powielona cała zaznaczona kolumna lub cały zaznaczony wiersz wraz z zawartością.

Uwaga:

Opcja Dodaj wiersz lub Dodaj kolumnę powoduje powielenie danego wiersza lub kolumny z zachowaniem klas, ale bez zawartości.

Opcja powielania wierszy i kolumn w dokumentach Bootstrap
Opcja powielania wierszy i kolumn w dokumentach Bootstrap

Rozszerzenia obiegu pracy związanego z tworzeniem dokumentów Bootstrap

Obieg pracy został uproszczony i przebiega teraz płynnie zarówno przy tworzeniu dokumentu Bootstrap w oknie dialogowym Nowy dokument, jak i na podstawie szablonów startowych. Nie są już wyświetlane okna Kopiuj pliki zależne oraz Nadpisz istniejące pliki, tak jak we wcześniejszych wersjach programu Dreamweaver.

Gdy dokument Bootstrap jest tworzony i zapisywany w konkretnej lokalizacji, pliki zależne będą automatycznie zapisywane w tym samym miejscu.

Rozszerzenia wizualnych zapytań o media

Podświetlanie bieżących wartości punktów przerwań

Program Dreamweaver wyróżnia teraz zapytania o media powiązane z bieżącym rozmiarem okna ekranowego, co pozwala je szybko zidentyfikować. Wyróżnienie to ma postać ciemniejszych strzałek i ciemnego tła wartości przerwań w zapytaniach o media.

Aktywne zapytania o media oraz nieaktywne (podświetlone powyżej) zapytania o media
Aktywne zapytania o media oraz nieaktywne (podświetlone powyżej) zapytania o media

Udoskonalony obieg pracy dodawania zapytania o media

Po kliknięciu ikony + na pasku wizualnych zapytań o media program Dreamweaver nie wymaga już wybrania opcji maksymalnej szerokości lub minimalnej szerokości. Okienko umożliwiające dodanie zapytania o media jest teraz wyświetlane od razu.

W okienku tym jest domyślnie wybrana opcja maksymalnej szerokości (max-width). Dostępna jest również rozwijana lista umożliwiająca zmianę tego ustawienia na opcję minimalnej szerokości (min-width) lub minimalnej i maksymalnej szerokości (min-max).  

Zmiany związane z dodawaniem zapytań o media
Zmiany związane z dodawaniem zapytań o media

Rozszerzone możliwości edycji punktów przerwań

Dwukrotne kliknięcie wartości punktów przerwań na pasku wizualnych zapytań o media umożliwia rozpoczęcie edycji zapytania. Możliwość edycji jest sygnalizowana przez wyświetlenie pomarańczowego obramowania, w którym znajduje się punkt wstawiania.

Po wprowadzeniu nowych wartości (w pikselach) można nacisnąć klawisz Enter/Return, aby zatwierdzić zmiany, albo klawisz Escape, aby je anulować.

Punkt przerwania o wartości 768px w trybie edycji z pomarańczowym obramowaniem
Punkt przerwania o wartości 768px w trybie edycji z pomarańczowym obramowaniem

Wyświetlanie numerów wierszy za pomocą opcji Przejdź do kodu.

Opcja Przejdź do kodu w menu kontekstowym otwieranym za pomocą prawego przycisku myszy na pasku Wizualne zapytania o media podaje teraz numer wiersza, ułatwiając odnalezienie odpowiedniego miejsca w kodzie.

Numery wierszy kodu odpowiadającego wizualnemu zapytaniu o media
Numery wierszy kodu odpowiadającego wizualnemu zapytaniu o media

Rozszerzenia usługi Extract

Obsługa wielu obszarów roboczych

Panel Extract w programie Dreamweaver umożliwia teraz otwieranie plików PSD z wieloma obszarami roboczymi w celu wydzielania z nich zasobów. Każdy obszar roboczy jest wyświetlany jako folder w okienku warstw. Foldery takie można rozwijać lub zwijać, aby wyświetlać lub ukrywać ich zawartość.

Aby powiększyć konkretny obszar roboczy, po prostu kliknij jego nazwę.

Dwukrotnie kliknij opcję ZMIEŚĆ w nagłówku panelu, aby zmniejszyć skalę wyświetlania obszaru roboczego i wyświetlić w bieżącym widoku cały plik PSD.

Możliwość wydzielania cieni za pomocą usługi Extract

Jeśli plik PSD przetwarzany za pomocą usługi Extract zawiera element Cień, to będzie on teraz wydzielany jako właściwość CSS box-shadow.

Porady dotyczące postępowania z nieobsługiwanymi stylami warstw

Plik PSD zawiera często wiele stylów warstw, które funkcjonują prawidłowo jako autonomiczne elementy, ale nie dają się połączyć w kombinację. Usługa Extract sprawdza, czy zachodzi jedna z takich sytuacji, i proponuje metody postępowania ze stylami warstw tego typu.

Extract wykrywa następujące sytuacje:

  • Scenariusz 1: Wiele wystąpień dowolnej właściwości, która jest interpretowana jako kolory tła. Plik PSD może na przykład zawierać definicje dwóch nakładek koloru lub gradientu.
  • Scenariusz 2: Nakładka koloru o kryciu mniejszym niż 100% jest nałożona na nakładkę gradientu lub warstwa ma przypisany kolor tła. W takim przypadku określenie koloru powstającego w wyniku mieszania będzie trudne.
  • Scenariusz 3: Nakładka gradientu ma poziom krycia mniejszy niż 100%, a do warstwy jest przypisany kolor tła. Również w tym przypadku określenie koloru powstającego w wyniku mieszania będzie trudne.

Jeśli usługa Extract wykryje takie przypadki, wyświetli ikonę ostrzeżenia na miniaturce warstwy w panelu Extract. W wyskakującym okienku miniaturki warstwy oraz w kodzie CSS tej warstwy jest wyświetlany następujący komunikat z ostrzeżeniem:

„Ta warstwa zawiera wiele stylów warstw, których nie można odwzorować za pomocą stylów CSS. Użyj próbnika kolorów lub wydziel tę warstwę jako obraz”.

Ponadto w przypadku nałożenia półprzezroczystego koloru tła na inny kolor tła (scenariusze 2 i 3) w kodzie CSS są wyświetlane wartości wszystkich kolorów tła. Pozwala to wydzielić odpowiednią wartość.

Rozszerzone możliwości edycji w widoku aktywnym

Rozszerzenia funkcji edycji tabel

Zaznaczanie wierszy lub kolumn jednym kliknięciem

Wiersze i kolumny tabeli w widoku aktywnym można teraz zaznaczać jednym kliknięciem. Została dodana nowa ikona (podobna do tej, która jest dostępna w widoku Projekt), umożliwiająca zaznaczenie wiersza lub kolumny.

  1. Zaznacz tabelę, aby wyświetlić pole Monitor elementu z ikoną menu (≡).

  2. Kliknij ikonę menu (≡), aby uaktywnić tryb formatowania tabeli.

  3. Zatrzymaj wskaźnik myszy nad wierszem lub kolumną do zaznaczenia. Wskaż myszą zewnętrzną krawędź wiersza lub kolumny, aby wyświetlić strzałkę, którą można kliknąć w celu zaznaczenia.

  4. Kliknij, aby zaznaczyć dany wiersz lub kolumnę.

    Zaznaczanie wiersza tabeli w widoku aktywnym
    Zaznaczanie wiersza tabeli w widoku aktywnym

    Zaznaczanie kolumny tabeli
    Zaznaczanie kolumny tabeli w widoku aktywnym

  5. Kontynuuj edycję wiersza lub kolumny, korzystając z menu kontekstowego wyświetlanego prawym przyciskiem myszy.

Zaznaczanie wielu komórek przez przeciągnięcie

Przeciągając kursor, można teraz zaznaczać wiele komórek, wierszy lub kolumn. Kliknij komórkę i przeciągnij nad wieloma innymi komórkami, wierszami lub kolumnami, aby je zaznaczyć.

  1. Zaznacz tabelę, aby wyświetlić pole Monitor elementu z ikoną menu (≡).

  2. Kliknij ikonę menu (≡), aby uaktywnić tryb formatowania tabeli.

  3. Przeciągnij i zaznacz odpowiednie wiersze i kolumny.

    Zaznaczanie wielu komórek przez przeciągnięcie
    Zaznaczanie wielu komórek przez przeciągnięcie

  4. Kontynuuj edycję wiersza lub kolumny, korzystając z menu kontekstowego wyświetlanego prawym przyciskiem myszy.

Usuwanie wierszy lub kolumn klawiszem Delete

Zaznaczone kolumny i wiersze można teraz usuwać, naciskając klawisz Delete/Backspace.

Szybki inspektor właściwości dla tekstu

Szybki inspektor właściwości tekstu w widoku aktywnym umożliwia teraz formatowanie tekstu, dodawanie wcięć i wstawianie hiperłączy w tekście. Szybki inspektor właściwości tekstu jest wyświetlany po kliknięciu ikony menu (≡) elementów tekstowych: h1–h6, pre, p.

Szybki inspektor właściwości dla tekstu
Szybki inspektor właściwości dla tekstu

  • Opcja formatu pozwala szybko zmienić znacznik elementu w jeden z następujących znaczników: h1–h6, p, pre. 
  • Opcja odsyłacza umożliwia przekształcenie elementu tekstowego w hiperłącze. 
  • Ikony Pogrubienie i Kursywa umożliwiają wstawienie znaczników <strong> oraz <em> w elemencie tekstowym.
  • Ikony BLOCKQUOTE ułatwiają wstawianie lub usuwanie wcięć w tekście. Powoduje to odpowiednio dodanie lub usunięcie znacznika w kodzie.

W dokumentach Bootstrap panel Szybki inspektor właściwości tekstu umożliwia również wyrównywanie i przekształcanie elementów tekstowych.

Szybki inspektor właściwości tekstu w dokumentach Bootstrap
Szybki inspektor właściwości tekstu w dokumentach Bootstrap

  • Wyrównywanie: elementy tekstowe Bootstrap można wyrównywać do prawej lub do lewej, środkować lub justować, stosując do nich odpowiednie klasy.
  • Przekształcanie: wielkość liter elementu można zmienić na małe litery, wielkie litery albo pierwszą wielką literę (jak w zdaniu), stosując odpowiednie klasy.

Zmiany w panelu Szybki inspektor właściwości obrazów

Szybki inspektor właściwości obrazów zawiera teraz opcje umożliwiające dostosowywanie obrazów w dokumentach Bootstrap.

Szybki inspektor właściwości tekstu w dokumentach Bootstrap
Szybki inspektor właściwości tekstu w dokumentach Bootstrap

  • Przycinanie do kształtu: umożliwia dostosowywanie obrazów przez przycięcie ich do kształtu koła, zaokrąglenie rogów lub przekształcenie w miniaturki.
  • Przekształcanie obrazu w reagujący: umożliwia nadanie obrazowi charakteru reagującego, tak aby dostosowywał się do różnych wymiarów ekranu.

Aktualizacje w aplikacji

Adobe udostępnia aktualizacje w trybie ciągłym, aby program Dreamweaver zawsze obsługiwał najnowsze technologie. Są to np. aktualizacje bibliotek Bootstrap i szablonów początkowych.

Aktualizacje w aplikacji można pobierać i instalować automatycznie lub ręcznie. Można je również wyłączyć albo odinstalować, aby przywrócić program Dreamweaver do stanu, w jakim się znajdował po instalacji lub aktualizacji za pomocą aplikacji Adobe Creative Cloud Desktop. W oknie dialogowym preferencji programu Dreamweaver można określić tryb aktualizacji w aplikacji, wyłączyć je albo wycofać.

Więcej informacji: Aktualizacje w aplikacji.

Preferencje aktualizacji w aplikacji
Preferencje aktualizacji w aplikacji

Serwer testowy — udoskonalony obieg pracy

W poprzedniej wersji (Dreamweaver CC 2015) wprowadzono funkcję automatycznego publikowania plików na serwerze testowym, aby ułatwić płynne edytowanie dynamicznych dokumentów w widoku aktywnym. Zgodnie z życzeniem użytkowników, którzy prosili o możliwość wyłączenia tej funkcji, dodano nową opcję preferencji w oknie dialogowym Konfiguracja serwisu.

Szczegółowe informacje: Wyłączanie automatycznego publikowania plików dynamicznych.

Wyłączanie opcji automatycznego publikowania plików dynamicznych
Wyłączanie opcji automatycznego publikowania plików dynamicznych

Zwijanie kodu na podstawie zaznaczenia

Przywrócona została możliwość zwijania zaznaczonego bloku kodu. Można teraz wykonywać następujące działania:

  • zwijać kod na poziomie znaczników (tak jak w poprzedniej wersji programu Dreamweaver);
  • zwijać fragment kodu, zaznaczając go.
Po zaznaczeniu bloku kodu zostanie wyświetlona opcja, która umożliwia jego zwinięcie:
Zwijanie kodu na podstawie zaznaczenia
Kliknij ikonę „–”, aby zwinąć kod.

Zwijanie kodu na podstawie zaznaczenia
Kliknij ikonę „+”, aby rozwinąć kod.


Kliknij ikonę „–”, aby zwinąć kod. Aby rozwinąć zwinięty fragment kodu, kliknij ikonę „+”.

Kliknij ikonę „–”, aby zwinąć kod. Aby rozwinąć zwinięty fragment kodu, kliknij ikonę „+”. 
Kliknij ikonę „–”, aby zwinąć kod. Aby rozwinąć zwinięty fragment kodu, kliknij ikonę „+”. 
Kliknij ikonę „–”, aby zwinąć kod. Aby rozwinąć zwinięty fragment kodu, kliknij ikonę „+”. 

Więcej informacji: Zwijanie kodu.

Rozszerzenia panelu Projektant CSS

Zmiana kolejności selektorów

Kolejność selektorów w okienku Selektory można teraz zmieniać, przeciągając je na odpowiednie miejsce.

Zmiana kolejności selektorów w panelu Projektant CSS
Zmiana kolejności selektorów w panelu Projektant CSS

Okienka w panelu Projektant CSS zachowują niestandardowe rozmiary

Rozmiary okienek ustawione w danej sesji są zapamiętywane także po zwinięciu lub rozwinięciu poszczególnych części panelu Projektant CSS. Okienka Źródła i Media zachowują niestandardowy rozmiar do czasu kolejnej zmiany tego rozmiaru.

Panel Właściwości jest wyłączony w plikach Bootstrap

W plikach Bootstrap, w których style są definiowane w plikach Bootstrap CSS (tylko do odczytu), okienko Właściwości w panelu Projektant CSS będzie wyłączone.

Uwaga:

Jeśli chcesz zmodyfikować style w dokumencie Bootstrap, utwórz nowy plik CSS, aby przesłonić istniejące style, a następnie dołącz ten plik do dokumentu.

Cofanie i ponawianie zmian aktywnego dokumentu

Zakres operacji cofania i ponawiania można teraz ograniczyć tylko do aktywnych dokumentów.

Operacje cofania i ponawiania wpływają domyślnie zarówno na aktywny w danym momencie dokument, jak i na wszystkie pliki powiązane, np. pliki CSS. Jeśli zakres cofania zostanie ograniczony do aktywnego dokumentu, operacje cofania i ponawiania będą wykonywane tylko w odniesieniu do zmian wprowadzonych w pliku, który jest obecnie aktywny. Na przykład jeśli pracuje się w pliku HTML, cofanie i ponawianie obejmie tylko zmiany wprowadzone w tym pliku HTML, ale nie zmiany w powiązanym pliku CSS. Aby cofnąć lub ponowić zmiany wprowadzone w powiązanym pliku CSS, konieczne będzie przejście do tego pliku i wybranie odpowiedniej opcji cofania lub ponawiania.

Jeśli aktywny dokument jest wyświetlony w widoku aktywnym lub widoku Projekt, operacje cofania i ponawiania będą obejmować tylko zmiany, które spowodowały modyfikację kodu HTML. Załóżmy na przykład, że użytkownik pracuje nad stroną Bootstrap w widoku aktywnym, edytując tekst, a następnie zmieniając rozmiar zapytania o media za pomocą paska Wizualne zapytania o media. Cofnąć będzie można tylko edycję tekstu, a nie zmiany zapytania o media, ponieważ zmiany te nie zachodzą w pliku HTML, lecz w pliku powiązanym. Aby cofnąć takie zmiany, można przejść do tego powiązanego pliku CSS.

Aby ograniczyć zakres operacji cofania i ponawiania do bieżącego dokumentu, wykonaj następujące czynności:

  1. Kliknij polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Mac).

  2. Przejdź do kategorii Ogólne. W sekcji Opcje edycji zaznacz opcję Ogranicz cofanie działań do aktywnego dokumentu.

    Ograniczanie cofania i ponawiania działań do aktywnego dokumentu
    Ograniczanie cofania i ponawiania działań do aktywnego dokumentu

  3. Kliknij kolejno przyciski Zastosuj i Zamknij, aby zamknąć okno dialogowe Preferencje.

  4. Aby zmiany zostały uwzględnione, należy ponownie uruchomić program Dreamweaver.

Udoskonalenia panelu DOM

Korzystając z menu kontekstowego (otwieranego prawym przyciskiem myszy) w panelu DOM można teraz kopiować znaczniki z panelu DOM jednego dokumentu i wklejać je do panelu DOM w innym dokumencie.

Uwaga:

W panelu DOM można wkleić wyłącznie znaczniki skopiowane wcześniej z innego panelu DOM. Znacznik skopiowany z widoku aktywnego może zostać wklejony tylko w widoku aktywnym. Nie można go wkleić w panelu DOM.

Opcja resetowania przewodników po nowych funkcjach

Przewodniki po nowych funkcjach w postaci ruchomych opisów oraz kontekstowych podpowiedzi są automatycznie wyświetlane po pierwszym uruchomieniu zaktualizowanego programu Dreamweaver. Okienka opisu funkcji umożliwiają poznawanie nowych funkcji w najnowszej aktualizacji. Kontekstowe podpowiedzi ułatwiają odkrywanie nowych obiegów pracy i rozszerzeń funkcjonalnych.

Przy kolejnych uruchomieniach programu Dreamweaver te przewodniki po nowych funkcjach zostają domyślnie wyłączone i nie będą już wyświetlane. Jeśli chcesz je obejrzeć ponownie, skorzystaj z opcji Resetuj w preferencjach programu Dreamweaver.

 

  1. Wybierz polecenie Pomoc > Resetuj przewodniki po nowych funkcjach. Zostanie wyświetlone okno dialogowe Preferencje.

  2. Stosownie do potrzeb możesz zresetować tylko opisy funkcji, tylko kontekstowe podpowiedzi, albo oba rodzaje pomocy.

  3. Zamknij okno Preferencje i program Dreamweaver.

  4. Uruchom ponownie program Dreamweaver. Przewodniki po nowych funkcjach zostaną wyświetlone ponownie.

Aktualizacja funkcji walidacji W3C

W programie Dreamweaver wprowadzono obsługę nowej usługi walidacji kodu HTML5, opublikowaną przez organizację W3C: https://validator.w3.org/nu/ Stara usługa walidacji, validator.w3.org, jest już nieaktualna.

Nowa usługa walidacji obsługuje tylko następujące parsery:

Wartość Opis
brak Wybór parsera HTML lub XML jest oparty na wartości Content-Type.
xml Parser XML, nie będzie ładować encji zewnętrznych
xmldtd Parser XML, będzie ładować encje zewnętrzne
html Parser HTML, konfiguracja oparta na wartości DOCTYPE.
html5 Parser HTML w trybie HTML5.
html4 Parser HTML w trybie HTML4 Strict.
html4tr Parser HTML w trybie HTML4 Transitional.

Tak jak we wcześniejszych wersjach programu Dreamweaver, nadal można przesłonić parser domyślny. Jest to parser, którego program Dreamweaver używa w przypadku, gdy nie można wybrać odpowiedniego parsera na podstawie typu zawartości (Content Type) lub wartości DTD. Wraz z nowym walidatorem zmieniła się tylko lista dostępnych parserów.

Preferencje walidatora W3C
Preferencje walidatora W3C

Więcej informacji zawiera sekcja Walidacja dokumentów za pomocą walidatora W3C.

Obsługa plików SVG w panelu Zasoby

Panel Zasoby wyświetla teraz listę wszystkich zasobów SVG w serwisie programu Dreamweaver powiązanym z aktywnym dokumentem. Podobnie jak w przypadku innych elementów w panelu Zasoby, na zasobach SVG można wykonywać różne operacje, takie jak edytowanie, przypisywanie adresów URL oraz wielokrotne używanie danego zasobu w różnych dokumentach i serwisach.

Zasoby SVG przedstawione w panelu Zasoby
Zasoby SVG przedstawione w panelu Zasoby

Zmiany opcji powiększania

W programie Dreamweaver nie są już dostępne następujące metody powiększania i zmniejszania skali wyświetlania w widoku aktywnym i widoku Projekt:

Windows:

  • Użycie kółka myszy z przytrzymaniem klawisza Ctrl
  • Użycie przewijania na gładziku z przytrzymaniem klawisza Ctrl

Mac:

  • Użycie kółka myszy z przytrzymaniem klawisza Cmd
  • Użycie przewijania na gładziku z przytrzymaniem klawisza Cmd

Nie wprowadzono zmian w innych metodach powiększania i zmniejszania skali wyświetlania dokumentu: Cmd/Ctrl + „+” lub Cmd/Ctrl + „-” oraz menu Widok > Powiększenie.

Zmiany w menu Widok

Opcja widoku Kod i Aktywny / Kod i Projekt w menu Widok zmieniła nazwę na „Podziel” i ma takie samo działanie, jak w przypadku wybrania jej z paska narzędziowego Dokument.

Menu Widok w wersjach wcześniejszych niż Dreamweaver CC 2015.1
Menu Widok w wersjach wcześniejszych niż Dreamweaver CC 2015.1

Menu Widok w wersji Dreamweaver CC 2015.1
Menu Widok w wersji Dreamweaver CC 2015.1


Szybsza synchronizacja ustawień programu Dreamweaver z chmurą Creative Cloud

Wprowadzono kilka udoskonaleń podnoszących wydajność synchronizacji ustawień, dzięki czemu synchronizacja między instancjami programu Dreamweaver i chmurą Creative Cloud przebiega teraz znacznie szybciej.  

Wycofanie panelu Style CSS oraz powiązanych interfejsów API

Z programu Dreamweaver usunięto starszy panel Style CSS. W wyniku tej zmiany usunięte zostały również powiązane z nim funkcje API.

Nadal są dostępne następujące podstawowe funkcje API:

  • dreamweaver.cssRuleTracker.newRule()
  • dreamweaver.cssStylePalette.getStyles()
  • dreamweaver.cssStylePalette.editStyleSheet()
  • dreamweaver.cssStylePalette.attachStyleSheet()
  • dreamweaver.cssStylePalette.getMediaType()
  • dreamweaver.cssStylePalette.setMediaType()
  • dreamweaver.cssStylePalette.getDisplayStyles()
  • dreamweaver.cssStylePalette.setDisplayStyles()
  • dreamweaver.cssStylePalette.newStyle()

Następujące funkcje API nie będą już obsługiwane w kolejnych wersjach:

  • dreamweaver.cssRuleTracker.editSelectedRule()
  • dreamweaver.cssRuleTracker.canEditSelectedRule()
  • dreamweaver.cssStylePalette.getSelectedStyle()
  • dreamweaver.cssStylePalette.editSelectedStyle()
  • dreamweaver.cssStylePalette.editSelectedStyleInCodeview()
  • dreamweaver.cssStylePalette.renameSelectedStyle()
  • dreamweaver.cssStylePalette.applySelectedStyle()
  • dreamweaver.cssStylePalette.duplicateSelectedStyle()
  • dreamweaver.cssStylePalette.deleteSelectedStyle()
  • dreamweaver.cssStylePalette.canEditSelectedStyle()
  • dreamweaver.cssStylePalette.canEditSelectedStyleInCodeview()
  • dreamweaver.cssStylePalette.canRenameSelectedStyle()
  • dreamweaver.cssStylePalette.canDuplicateSelectedStyle()
  • dreamweaver.cssStylePalette.canDeleteSelectedStyle()
  • dreamweaver.cssStylePalette.canApplySelectedStyle()
  • dreamweaver.canDisableSelectedStyle()
  • dreamweaver.canEnableAllDisabled()
  • dreamweaver.canDeleteAllDisabled()
  • dreamweaver.getSelectedStyleIsDisabled()
  • dreamweaver.setSelectedStyleIsDisabled()
  • dreamweaver.enableAllDisabled()
  • dreamweaver.deleteAllDisabled()

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online