Podręcznik użytkownika Anuluj

Optymalizacja kodu

  1. Podręcznik użytkownika programu Dreamweaver
  2. Wprowadzenie
    1. Podstawy projektowania serwisów WWW o elastycznym układzie
    2. Dreamweaver — co nowego
    3. Programowanie zawartości WWW za pomocą programu Dreamweaver — przegląd
    4. Dreamweaver / Popularne pytania
    5. Skróty klawiszowe
    6. Wymagania systemowe programu Dreamweaver
    7. Podsumowanie funkcji
  3. Program Dreamweaver a platforma Creative Cloud
    1. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    2. Biblioteki Creative Cloud w programie Dreamweaver
    3. Używanie plików programu Photoshop w programie Dreamweaver
    4. Praca z programami Adobe Animate oraz Dreamweaver
    5. Wydzielanie przygotowanych do wyświetlania w Internecie plików SVG z bibliotek
  4. Przestrzenie robocze i widoki w programie Dreamweaver
    1. Przestrzeń robocza programu Dreamweaver
    2. Optymalizacja przestrzeni roboczej programu Dreamweaver do programowania wizualnego
    3. Wyszukiwanie plików według nazwy lub zawartości | Mac OS
  5. Konfigurowanie serwisów
    1. Informacje o serwisach programu Dreamweaver
    2. Konfigurowanie lokalnej wersji serwisu
    3. Nawiązywanie połączenia z serwerem publikacji
    4. Konfigurowanie serwera testowego
    5. Importowanie i eksportowanie ustawień serwisu programu Dreamweaver
    6. Przenoszenie istniejących serwisów z serwera zdalnego do lokalnego katalogu głównego serwisu
    7. Funkcje ułatwień dostępu w programie Dreamweaver
    8. Ustawienia zaawansowane
    9. Ustawianie preferencji serwisu dotyczących transferu plików
    10. Określanie ustawień serwera proxy w programie Dreamweaver
    11. Synchronizowanie ustawień programu Dreamweaver z chmurą Creative Cloud
    12. Korzystanie z systemu Git w programie Dreamweaver
  6. Zarządzanie plikami
    1. Tworzenie i otwieranie plików
    2. Zarządzanie plikami i folderami
    3. Odbieranie plików i wysyłanie ich na serwer
    4. Pobieranie plików do edycji i odkładanie ich na serwer
    5. Synchronizacja plików
    6. Porównywanie plików w poszukiwaniu różnic
    7. Maskowanie plików i folderów w serwisie programu Dreamweaver
    8. Włączanie funkcji Uwagi do projektu w serwisach programu Dreamweaver
    9. Zapobieganie potencjalnemu obejściu funkcji Gatekeeper
  7. Układ i projekt
    1. Korzystanie z wizualnych pomocy do układu
    2. Informacje o tworzeniu układu strony za pomocą stylów CSS
    3. Projektowanie elastycznych serwisów WWW z użyciem struktury Bootstrap
    4. Tworzenie i używanie zapytań o media w programie Dreamweaver
    5. Prezentacja zawartości za pomocą tabel
    6. Kolory
    7. Tworzenie reagujących projektów za pomocą układów elastycznej siatki
    8. Narzędzie Extract w programie Dreamweaver
  8. CSS
    1. Podstawowe informacje o stylach CSS
    2. Tworzenie układu strony za pomocą panelu Projektant CSS
    3. Korzystanie z preprocesorów CSS w programie Dreamweaver
    4. Ustawianie preferencji stylów CSS w programie Dreamweaver
    5. Przenoszenie reguł CSS w programie Dreamweaver
    6. Konwertowanie stylu CSS wewnątrz znacznika na regułę CSS w programie Dreamweaver
    7. Posługiwanie się znacznikami DIV
    8. Stosowanie gradientów na tło
    9. Tworzenie i edytowanie efektów przejść CSS3 w programie Dreamweaver
    10. Formatowanie kodu
  9. Zawartość strony i zasoby
    1. Ustawianie właściwości strony
    2. Ustawianie właściwości CSS dla nagłówków i łączy
    3. Praca z tekstem
    4. Znajdowanie i zastępowanie tekstu, znaczników i atrybutów
    5. Panel DOM
    6. Edytowanie w widoku aktywnym
    7. Kodowanie znaków dokumentu w programie Dreamweaver
    8. Zaznaczanie i wyświetlanie elementów w oknie Dokument
    9. Ustawianie właściwości tekstu na panelu Inspektor właściwości
    10. Sprawdzanie pisowni na stronie internetowej
    11. Używanie linii poziomych w programie Dreamweaver
    12. Dodawanie i modyfikowanie kombinacji czcionek w programie Dreamweaver
    13. Praca z zasobami
    14. Wstawianie i aktualizowanie dat w programie Dreamweaver
    15. Tworzenie list ulubionych zasobów w programie Dreamweaver i zarządzanie nimi
    16. Wstawianie i edytowanie obrazów w programie Dreamweaver
    17. Dodawanie obiektów multimedialnych
    18. Dodawanie zawartości wideo w programie Dreamweaver
    19. Wstawianie wideo HTML5
    20. Wstawianie plików SWF
    21. Dodawanie efektów dźwiękowych
    22. Wstawianie obiektów audio HTML5 w programie Dreamweaver
    23. Praca z elementami bibliotek
    24. Stosowanie pisma arabskiego i hebrajskiego w programie Dreamweaver
  10. Łączenie i przeglądanie
    1. Informacje o łączeniu i przeglądaniu stron
    2. Tworzenie łączy
    3. Mapy obrazu
    4. Rozwiązywanie problemów dotyczących łączy
  11. Efekty i widgety jQuery
    1. Używanie widgetów jQuery interfejsu użytkownika i elementów mobilnych w programie Dreamweaver
    2. Używanie efektów jQuery w programie Dreamweaver
  12. Tworzenie kodu serwisów WWW
    1. Informacje o tworzeniu kodu w programie Dreamweaver
    2. Środowisko programistyczne w programie Dreamweaver
    3. Ustawianie preferencji kodowania
    4. Dostosowywanie ustawień kolorowania kodu
    5. Pisanie i edytowanie kodu
    6. Podpowiedzi i uzupełnianie kodu
    7. Zwijanie i rozwijanie kodu
    8. Ponowne wykorzystywanie fragmentów kodu za pomocą funkcji Urywki
    9. Linting: oczyszczanie kodu z błędów
    10. Optymalizacja kodu
    11. Edytowanie kodu w widoku Projekt
    12. Praca z zawartością znacznika HEAD strony
    13. Wstawianie dołączeń po stronie serwera w programie Dreamweaver
    14. Korzystanie z bibliotek znaczników w programie Dreamweaver
    15. Importowanie własnych znaczników do programu Dreamweaver
    16. Używanie zachowań JavaScript (instrukcje ogólne)
    17. Stosowanie wbudowanych zachowań JavaScript
    18. Omówienie języków XML i XSLT
    19. Wykonywanie transformacji XSL po stronie serwera w programie Dreamweaver
    20. Wykonywanie przekształceń XSL po stronie klienta w programie Dreamweaver
    21. Dodawanie encji znaków w kodzie XSLT w programie Dreamweaver
    22. Formatowanie kodu
  13. Obiegi pracy związane z wieloma produktami
    1. Instalowanie i używanie rozszerzeń programu Dreamweaver
    2. Aktualizacje w aplikacji w programie Dreamweaver
    3. Wstawianie dokumentów Microsoft Office w programie Dreamweaver (tylko Windows)
    4. Praca z programami Fireworks i Dreamweaver
    5. Edycja zawartości w stronach programu Dreamweaver za pomocą aplikacji Contribute
    6. Integracja programu Dreamweaver z aplikacją Business Catalyst
    7. Tworzenie spersonalizowanych kampanii rozsyłanych pocztą elektroniczną
  14. Szablony
    1. Informacje o szablonach programu Dreamweaver
    2. Rozpoznawanie szablonów oraz dokumentów opartych na szablonach
    3. Tworzenie szablonu programu Dreamweaver
    4. Tworzenie edytowalnych regionów w szablonach
    5. Tworzenie powtarzalnych regionów i tabel w programie Dreamweaver
    6. Używanie regionów opcjonalnych w szablonach
    7. Definiowanie edytowalnych atrybutów znacznika w programie Dreamweaver
    8. Tworzenie zagnieżdżonych szablonów w programie Dreamweaver
    9. Edytowanie, aktualizowanie i usuwanie szablonów
    10. Eksportowanie i importowanie zawartości XML w programie Dreamweaver
    11. Stosowanie szablonu lub usuwanie go z istniejącego dokumentu
    12. Edycja zawartości w szablonach programu Dreamweaver
    13. Reguły składni dla znaczników szablonu w programie Dreamweaver
    14. Ustawianie preferencji podświetlenia dla regionów szablonów
    15. Korzyści wynikające z używania szablonów w programie Dreamweaver
  15. Urządzenia mobilne i obsługa wielu ekranów
    1. Tworzenie zapytań o media
    2. Zmiana orientacji strony na urządzeniach mobilnych
    3. Tworzenie aplikacji internetowych przeznaczonych na urządzenia mobilne za pomocą programu Dreamweaver
  16. Dynamiczne serwisy, strony i formularze WWW
    1. Podstawowe informacje o aplikacjach internetowych
    2. Konfigurowanie komputera do programowania aplikacji
    3. Rozwiązywanie problemów z połączeniami z bazą danych
    4. Usuwanie skryptów połączenia w programie Dreamweaver
    5. Projektowanie stron dynamicznych
    6. Omówienie źródeł zawartości dynamicznej
    7. Definiowanie źródeł zawartości dynamicznej
    8. Dodawanie dynamicznej zawartości do stron
    9. Modyfikowanie dynamicznej zawartości w programie Dreamweaver
    10. Wyświetlanie rekordów z bazy danych
    11. Udostępnianie aktywnych danych w programie Dreamweaver oraz rozwiązywanie problemów z takimi danymi
    12. Dodawanie własnych zachowań serwerowych w programie Dreamweaver
    13. Tworzenie formularzy w programie Dreamweaver
    14. Zbieranie informacji od użytkowników za pomocą formularzy
    15. Tworzenie oraz włączanie formularzy ColdFusion w programie Dreamweaver
    16. Tworzenie formularzy WWW
    17. Rozszerzona obsługa elementów formularza w języku HTML5
    18. Tworzenie formularzy za pomocą programu Dreamweaver
  17. Tworzenie aplikacji metodą graficzną
    1. Tworzenie stron wzorca i szczegółów w programie Dreamweaver
    2. Tworzenie stron wyszukiwania i wyników
    3. Tworzenie strony wstawiania rekordów
    4. Tworzenie strony uaktualniania rekordów w programie Dreamweaver
    5. Tworzenie stron usuwania rekordów w programie Dreamweaver
    6. Używanie poleceń ASP do modyfikacji bazy danych w programie Dreamweaver
    7. Tworzenie strony rejestracji
    8. Tworzenie strony logowania
    9. Tworzenie strony, do której dostęp będą mieli tylko uwierzytelnieni użytkownicy
    10. Zabezpieczanie folderów w aplikacji ColdFusion za pomocą programu Dreamweaver
    11. Korzystanie ze składników ColdFusion w programie Dreamweaver
  18. Testowanie, podgląd i publikacja serwisów WWW
    1. Podgląd stron
    2. Podgląd stron WWW programu Dreamweaver na wielu urządzeniach
    3. Testowanie serwisu programu Dreamweaver

 

Informacje o czyszczeniu kodu w programie Dreamweaver, sprawdzaniu zgodności przeglądarek, walidacji dokumentów XML oraz zapewnianiu zgodności stron ze specyfikacją XHTML.

Czyszczenie kodu

Można automatycznie usuwać puste znaczniki, łączyć zagnieżdżone znaczniki font oraz w inny sposób poprawiać zawiły lub nieczytelny kod HTML lub XHTML.

Informacje na temat czyszczenia kodu HTML generowanego z dokumentu Microsoft Word podano w artykule Otwieranie i edytowanie istniejących dokumentów.

  1. W otwartym dokumencie wybierz polecenie Narzędzia > Oczyść HTML.

  2. W oknie dialogowym, które się pojawi, ustaw dowolne z poniższych opcji i kliknij przycisk OK.
    Uwaga:

    W zależności od wielkości dokumentu oraz liczby wybranych opcji, czyszczenie może zająć kilka sekund.

    Usuwanie pustych znaczników kontenerowych

    Usuwa wszystkie znaczniki, między którymi nie ma zawartości. Na przykład <b></b> i <font color="#FF0000"></font> są pustymi znacznikami, ale znacznik <b> w łańcuchu <b>jakiś tekst</b> nie jest pusty.

    Usuwanie nadmiarowych znaczników zagnieżdżonych

    Usuwa wszystkie nadmiarowe instancje znacznika. Na przykład w kodzie <b>To <b>właśnie</b> próbuję powiedzieć</b>, znaczniki b otaczające słowo właśnie są nadmiarowe i mogą zostać usunięte.

    Usuwanie elementów kodu HTML spoza programu Dreamweaver

    Usuwa wszystkie komentarze, które nie zostały wstawione przez program Dreamweaver. Na przykład komentarz <!‑‑begin body text‑‑> zostanie usunięty, natomiast komentarz <!‑‑TemplateBeginEditable name="doctitle"‑‑&#62; nie zostanie usunięty, ponieważ jest to komentarz programu Dreamweaver, który oznacza początek edytowalnego regionu w szablonie.

    Usuwanie specjalnych znaczników programu Dreamweaver

    Usuwa komentarze, które program Dreamweaver dodaje do kodu, aby umożliwić automatyczną aktualizację dokumentów w przypadku modyfikacji szablonów i pozycji bibliotek. Jeżeli podczas czyszczenia kodu w dokumencie opartym na szablonie opcja ta jest zaznaczona, dokument zostanie odłączony od szablonu. Więcej informacji na ten temat podano w artykule Odłączanie dokumentu od szablonu.

    Usuwanie konkretnych znaczników

    Usuwa znaczniki określone w sąsiednim polu tekstowym. Opcja ta służy do usuwania niestandardowych znaczników wstawionych przez inne edytory wizualne oraz innych znaczników, które są niepożądane w danym serwisie (na przykład blink). Jeśli wpisujesz wiele znaczników, rozdziel je przecinkami (na przykład font,blink).

    Połącz zagnieżdżone znaczniki <font>, gdy to możliwe

    Łączy wiele znaczników font, które sterują tym samym zakresem tekstu. Na przykład kod <font size="7"><font color="#FF0000">duży czerwony</font></font> zostanie przekształcony w kod <font size="7" color="#FF0000">duży czerwony</font>.

    Po zakończeniu pokaż dziennik

    Natychmiast po zakończeniu czyszczenia wyświetlane jest okno ostrzeżenia ze szczegółami zmian wprowadzonych w dokumencie.

Sprawdzanie domknięcia znaczników, nawiasów i klamer

Za pomocą tej funkcji można sprawdzić, czy nawiasy (( )), nawiasy klamrowe ({ }) oraz nawiasy kwadratowe ([ ]) na stronie są domknięte. Domknięcie oznacza, że każdy otwierający znacznik, nawias, nawias klamrowy i kwadratowy ma pasujący do niego element zamykający i vice versa.

Sprawdzanie domknięcia znaczników

  1. Otwórz dokument w widoku Kod
  2. Umieść punkt wstawiania w miejscu, w którym chcesz sprawdzić kod zagnieżdżony.
  3. Wybierz polecenie Edycja > Zaznacz znacznik macierzysty.

    Pasujące do siebie znaczniki otaczające (i ich zawartość) zostaną zaznaczone w kodzie. Jeżeli wybierzesz polecenie Edycja &#62; Zaznacz znacznik macierzysty wiele razy, a wszystkie znaczniki są domknięte, to program Dreamweaver zaznaczy ostatecznie zewnętrzne znaczniki html i /html dokumentu.

Sprawdzanie domknięcia nawiasów zwykłych, klamrowych oraz kwadratowych

  1. Otwórz dokument w widoku Kod
  2. Umieść punkt wstawiania w miejscu, w którym chcesz sprawdzić kod.
  3. Wybierz poleceń Edycja > Kod > Zrównoważ klamry.

    Cały kod otoczony nawiasami, klamrami oraz nawiasami kwadratowymi zostanie zaznaczony. Wybierając ponownie polecenie Edycja > Kod > Zrównoważ klamry, zaznaczysz cały kod między nawiasami, klamrami oraz nawiasami kwadratowymi, które otaczają nowe zaznaczenie.

Sprawdzanie zgodności przeglądarek

Funkcja Kontrola zgodności przeglądarki ułatwia wykrywanie takich kombinacji kodu HTML i CSS, które mogą powodować błędy interpretacji stylów w przeglądarkach. Funkcja ta testuje także kod w dokumencie pod względem właściwości CSS lub wartości, które nie są obsługiwane w docelowych przeglądarkach.

Przeprowadzanie walidacji dokumentów XML

Korzystając z tej funkcji, można określać preferencje walidatora, problemy do sprawdzenia,, a także typy błędów, które mają być zgłaszane.

  1. Wykonaj jedną z następujących czynności:
    • W przypadku pliku XML lub XHTML wybierz polecenie Plik > Waliduj > Jako XML.

    • Karta Walidacja na panelu Wyniki wyświetla komunikat „Nie znaleziono błędów ani ostrzeżeń” lub listę znalezionych błędów składni.

  2. Dwukrotnie kliknij komunikat o błędzie, aby podświetlić dany błąd w dokumencie.
  3. Aby zapisać raport jako plik XML, kliknij przycisk Zapisz raport.
  4. Aby wyświetlić raport w domyślnej przeglądarce (co pozwoli również wydrukować ten raport), kliknij przycisk Przeglądaj raport.

Sprawdzanie poprawności dokumentów za pomocą walidatora W3C

Program Dreamweaver udostępnia wbudowaną obsługę walidacji W3C, umożliwiając tworzenie stron internetowych zgodnych ze standardami tej organizacji. Walidator W3C sprawdza, czy dokumenty HTML i XML są zgodne ze standardami HTML, XHTML lub XML. Walidować można zarówno otwarte dokumenty, jak i pliki opublikowane na aktywnym serwerze.

W wyniku walidacji generowany jest raport, który ułatwia poprawienie błędów w pliku.

Uwaga:

W preferencjach programu Dreamweaver można określić parser, według którego będą sprawdzane dokumenty. Jest to ustawienie używane jako opcja domyślna w sytuacji, gdy nie można automatycznie wykryć wartości DOCTYPE.

Sprawdzanie poprawności otwartego dokumentu

  1. Wybierz polecenie Okno > Wyniki > Walidacja, aby otworzyć panel Walidacja. Panel ten służy do wyświetlania wyników sprawdzania poprawności.

  2. Wybierz polecenie Plik > Waliduj > Bieżący dokument (W3C).

Walidacja aktywnego dokumentu

W przypadku aktywnych dokumentów program Dreamweaver przeprowadza walidację kodu odebranego przez przeglądarkę. Kod ten jest widoczny po kliknięciu w przeglądarce prawym przyciskiem myszy i wybraniu opcji wyświetlania kodu źródłowego. Walidacja aktywnych dokumentów to funkcja szczególnie przydatna w przypadku aktywnych stron, wykorzystujących takie technologie, jak PHP czy JSP.

Opcja Przeprowadź walidację aktywnego dokumentu jest dostępna tylko wtedy, gdy adres URL sprawdzanej strony rozpoczyna się od frazy http.

  1. Wybierz polecenie Okno &#62; Wyniki &#62; Walidacja, aby otworzyć panel Walidacja. Panel ten służy do wyświetlania wyników sprawdzania poprawności.

  2. Kliknij opcję Widok aktywny.

  3. Wybierz polecenie Plik > Waliduj > Aktywny dokument (W3C).

W przypadku aktywnych dokumentów po dwukrotnym kliknięciu błędu na panelu walidacji W3C wyświetlane jest osobne okno. Okno to zawiera kod wygenerowany przez przeglądarkę z wyróżnionym wierszem, w którym wystąpił błąd.

Dostosowywanie ustawień walidacji

  1. Wybierz polecenie Okno &#62; Wyniki &#62; Walidacja, aby otworzyć panel Walidacja.

  2. Na panelu Walidacja W3C kliknij ikonę Walidacja W3C (Odtwórz). Wybierz opcję Ustawienia.

  3. Wybierz ustawienie DOCTYPE na potrzeby walidacji, jeśli w dokumencie nie ma jawnej deklaracji DOCTYPE.

  4. Jeśli nie chcesz, aby były wyświetlane błędy i ostrzeżenia, wyłącz odpowiednie opcje.

  5. Kliknij przycisk Zarządzaj, jeśli chcesz usunąć ostrzeżenia lub błędy ukryte za pomocą panelu Walidacja W3C. Usunięte ostrzeżenia lub błędy nie będą wyświetlane na panelu Walidacja W3C po wybraniu opcji Pokaż wszystko.

  6. Jeśli nie chcesz, aby po rozpoczęciu walidacji było wyświetlane okno Powiadomienia walidatora W3C, zaznacz opcję Nie pokazuj okna powiadomienia walidatora W3C.

Praca z raportami z walidacji

Po zakończeniu walidacji na panelu W3C wyświetlane są stosowne raporty.

  • Aby uzyskać więcej informacji na temat błędu lub ostrzeżenia, zaznacz ten błąd lub ostrzeżenie na panelu Walidacja W3C. Kliknij przycisk Więcej informacji.

  • Aby zapisać raport jako plik XML, kliknij przycisk Zapisz raport.

  • Aby wyświetlić cały raport w formacie HTML, kliknij przycisk Przeglądaj raport. Raport w formacie HTML zawiera pełną listę błędów i ostrzeżeń oraz ich podsumowanie.

  • Aby przejść do miejsca w kodzie, w którym znajduje się błąd, zaznacz ten błąd na panelu Walidacja W3C. Kliknij przycisk Opcje i wybierz polecenie Przejdź do wiersza.

  • Aby ukryć błędy lub ostrzeżenia, zaznacz odpowiedni błąd lub ostrzeżenie. Kliknij przycisk Opcje i wybierz polecenie Ukryj błąd.

  • Aby wyświetlić wszystkie błędy i ostrzeżenia, w tym również te ukryte, kliknij przycisk Opcje. Wybierz polecenie Pokaż wszystko. Ukryte błędy i ostrzeżenia usunięte w oknie dialogowym Preferencje nie będą wyświetlane.

  • Aby wyczyścić wszystkie wyniki na panelu Walidacja W3C, kliknij przycisk Opcje. Wybierz polecenie Wyczyść wyniki.

Ustawianie preferencji walidatora

Obok standardowego walidatora W3C program Dreamweaver obsługuje zewnętrzne walidatory kodu, instalowane jako rozszerzenia. Po zainstalowaniu zewnętrznego rozszerzenia do walidacji program Dreamweaver wyświetla jego preferencje w kategorii Walidator W3C w oknie dialogowym Preferencje.

  1. Wybierz polecenie Edycja > Preferencje (Windows) lub Dreamweaver > Preferencje (Macintosh).
  2. Z listy Kategoria po lewej stronie wybierz pozycję Walidator W3C.

  3. Wybierz bibliotekę znaczników, względem której będzie prowadzona walidacja.

    Nie można zaznaczyć wielu wersji tej samej biblioteki znaczników lub języka. Na przykład jeśli zostanie wybrana opcja HTML 4.01, to nie będzie można wybrać również opcji HTML 5. Wybierz najwcześniejszą wersję, według której chcesz przeprowadzać walidację. Na przykład jeśli dokument zawiera poprawny kod HTML 4.01, to będzie to również kod poprawny w wersji HTML 5.

  4. Wybierz opcje wyświetlania dotyczące typów błędów oraz ostrzeżeń, które mają się znaleźć w raporcie z walidacji.
  5. Kliknij przycisk Zastosuj, aby zastosować zmiany, a następnie kliknij przycisk Zamknij, aby zamknąć okno dialogowe Preferencje.

Zapewnianie zgodności dokumentu ze specyfikacją XHTML

Tworząc stronę, można zapewnić jej zgodność ze specyfikacją XHTML. Można także przekształcić istniejący dokument HTML do postaci zgodnej ze standardem XHTML.

Tworzenie dokumentów zgodnych ze standardem XHTML

  1. Wybierz polecenie Plik > Nowy.
  2. Wybierz kategorię i typ strony, którą chcesz utworzyć.
  3. Wybierz jedną z definicji dokumentów XHTML (DTD) z menu DocType znajdującego się po prawej stronie okna dialogowego, a następnie kliknij przycisk Utwórz.

    Na przykład jeśli chcesz, aby dokument HTML był zgodny ze specyfikacją XHTML, wybierz opcję XHTML 1.0 Transitional albo XHTML 1.0 Strict.

    Uwaga:

    Nie wszystkie dokumenty mogą uzyskać zgodność ze standardem XHTML.

Domyślne tworzenie dokumentów zgodnych ze specyfikacją XHTML

  1. Wybierz polecenie Edycja > Preferencje lub Dreamweaver > Preferencje (Mac OS X). Następnie wybierz kategorię Nowy dokument.
  2. Zaznacz dokument domyślny i wybierz jedną z definicji typów dokumentu XHTML z menu Domyślny typ dokumentu (DTD), a następnie kliknij przycisk OK.

    Na przykład jeśli chcesz, aby dokument HTML był zgodny ze specyfikacją XHTML, wybierz opcję XHTML 1.0 Transitional albo XHTML 1.0 Strict.

Przekształcanie istniejącego dokumentu HTML do postaci zgodnej ze specyfikacją XHTML

  1. Otwórz dokument i wykonaj jedną z następujących czynności:

    • W przypadku dokumentu bez elementów FRAME wybierz polecenie Plik > Konwertuj, a następnie wybierz jedną z definicji typu dokumentu XHTML.

      Na przykład jeśli chcesz, aby dokument HTML był zgodny ze specyfikacją XHTML, wybierz opcję XHTML 1.0 Transitional albo XHTML 1.0 Strict.

    • W przypadku dokumentu, który zawiera elementy FRAME, zaznacz odpowiednią ramkę, a następnie wybierz polecenie Plik > Konwertuj. Wybierz jedną z definicji typu dokumentu XHTML.

  2. Aby przekonwertować cały dokument, powtórz ten krok w odniesieniu do każdej ramki oraz układu ramek.

Uwaga:

Dokumentu opartego na szablonie nie można przekonwertować, ponieważ taki dokument musi być zakodowany w tym samym języku, co szablon, na którym jest oparty. Na przykład dokument oparty na szablonie XHTML będzie zawsze zakodowany w formacie XHTML, a dokument oparty na szablonie HTML niezgodnym ze specyfikacją XHTML zachowa kod HTML i nie może zostać przekonwertowany na XHTML ani na żaden inny język.

Adobe

Pomoc dostępna szybciej i łatwiej

Nowy użytkownik?