Omówienie panelu Przekształć

Panel Przekształć służy do wyświetlania lub zmiany informacji geometrycznych o zaznaczonym obiekcie, w tym wartości jego położenia, rozmiaru, obrotu i pochylenia. Polecenia z menu panelu Przekształć oferują dodatkowe opcje i możliwość szybkiego obracania i odbijania obiektów.

Uwaga:

Przyciski i oraz polecenia menu panelu Przekształć są dostępne również w panelu Sterowanie.

Panel Przekształć
Panel Przekształć

A. Wskaźnik punktu odniesienia B. Ikona Zachowaj proporcje C. Menu panelu 

Wyświetlanie panelu Przekształć

  1. Wybierz polecenie Okno > Obiekt i układ > Przekształć.

Wyświetlanie informacji geometrycznych o obiektach

Po zaznaczeniu obiektu, w panelach Przekształć i Sterowanie pojawiają się informacje o jego geometrii. Jeżeli zaznaczy się kilka obiektów, to informacje odnoszą się do wszystkich zaznaczonych obiektów, tak jakby stanowiły one jedną całość.

  1. Zaznacz jeden lub więcej obiektów i wyświetl panel Przekształć (Okno > Obiekt i układ > Przekształć).

    Informacje o położeniu zależą od początku miarki i punktu odniesienia obiektu. Informacje o kącie podawane są względem obszaru roboczego, przy założeniu, że linia pozioma ma kąt 0 stopni.

Zmiana ustawień przekształcania

Panel Przekształć zawiera różne opcje, które decydują o sposobie przekształcania obiektów oraz ich wyświetlania w panelach Przekształć i Sterowanie.

Ustawianie punktu odniesienia dla obiektów zagnieżdżonych

Wszystkie przekształcenia rozpoczynają się w wyznaczonym punkcie na lub obok obiektu, nazywanym punktem odniesienia. Jeśli narzędzie przekształcenia, takie jak Skalowanie, jest włączone, przy punkcie odniesienia jest widoczna ikona .

Punkt odniesienia jest przeniesiony na środek (po lewej), a obiekt – przeskalowany (po prawej)
Punkt odniesienia jest przeniesiony na środek (po lewej), a obiekt – przeskalowany (po prawej)

  1. Wykonaj jedną z następujących czynności:
    • Aby określić różne punkty odniesienia dla wybranego obiektu, kliknij dowolny z dziewięciu punktów na wskaźniku punktu odniesienia  w panelu Przekształć lub panelu Sterowanie.


      Klikając różne punkty odniesienia w panelu Przekształć lub w panelu Sterowanie (na górze po lewej i po prawej) można zmienić punkt odniesienia dla zaznaczonych obiektów (na dole po lewej i po prawej).

       

    • Aby przemieścić punkt odniesienia dla zaznaczonego obiektu w ściśle określone miejsce, zaznacz narzędzie Obróć , narzędzie Skaluj , lub narzędzie Pochyl , umieść narzędzie nad ikoną punktu odniesienia, a następnie przeciągnij w nowe miejsce. Można też, po zaznaczeniu jednego z tych narzędzi, kliknąć gdziekolwiek obiekt lub stronę. Punkt odniesienia przemieszcza się wtedy w wybrane miejsce.

Uwaga:

Kiedy narzędzie służące do przekształcania jest zaznaczone, kliknięcie poza obiektem nie usunie jego zaznaczenia. Przemieszcza się wtedy punkt odniesienia. Wybierz polecenie Edytuj > Odznacz wszystko, aby usunąć zaznaczenie obiektu.

Punkt odniesienia wybrany ostatnio na wskaźniku punktu odniesienia staje się nowym domyślnym punktem odniesienia dla wszystkich narzędzi i obiektów. Jeżeli przeciągnie się ikonę punktu odniesienia obiektu na zazwyczaj wybierane położenie (z wyjątkiem przeciągania go na punkt kontrolny), to po odznaczeniu bieżącego obiektu, punkt odniesienia panelu powróci na swoje domyślne położenie. Program InDesign zachowuje domyślny punkt odniesienia w nowych dokumentach. Nie trzeba go więc przywracać.

Zmiana informacji wyświetlanych dla obiektów zagnieżdżonych

Panel Przekształć używa obszaru roboczego rozkładówki jako punktu odniesienia dla obiektu; linia pozioma ma kąt obrotu równy 0°. Domyślnie odniesienie to obowiązuje także wtedy, gdy obiekt jest zagnieżdżony w przekształconym obiekcie-kontenerze (czyli obiekcie wchodzącym w skład przekształconej grupy lub wklejonym do przekształconej ramki). Na przykład, jeżeli wklei się nieobróconą grafikę do ramki, obróci ramkę o 10° z grafiką w środku, a następnie zaznaczy grafikę za pomocą narzędzia Zaznaczanie bezpośrednie, panel Przekształć wyświetli kąt obrotu tej grafiki jako 10°.

Kąt obrotu obiektu wyświetlany w odniesieniu do obszaru roboczego
Kąt obrotu obiektu wyświetlany w odniesieniu do obszaru roboczego

Aby wyświetlić te same informacje w odniesieniu do zagnieżdżonego kontenera obiektu, można usunąć zaznaczenie w poleceniu Transformacje są sumaryczne. W powyższym przykładzie, po usunięciu zaznaczenia z opcji Transformacje są sumaryczne, panel Przekształć wyświetli kąt obrotu grafiki jako zero stopni (kąt, jaki grafika ma względem jej obróconego kontenera).

Kąt obrotu obiektu wyświetlany w odniesieniu do obiektu-kontenera.
Kąt obrotu obiektu wyświetlany w odniesieniu do obiektu-kontenera.

  1. Otwórz panel Przekształć lub panel Sterowanie.
  2. Wykonaj jedną z następujących czynności w menu panelu Przekształć lub panelu Sterowanie:
    • Pozostaw zaznaczenie polecenia Transformacje są sumaryczne (ustawienie domyślne), aby wyświetlić wartości przekształcenia dla obiektów zagnieżdżonych w odniesieniu do obszaru roboczego.

    • Wyłącz opcję Transformacje są sumaryczne, aby wyświetlić wartości obrotu, skalowania i ścinania dla obiektów zagnieżdżonych względem obiektu-kontenera.

Pomiar położenia zaznaczonych obiektów

Polecenie Pokaż przesunięcie zawartości oblicza współrzędne X i Y panelu Przekształć dla obiektów zagnieżdżonych zaznaczonych narzędziem Zaznaczenie bezpośrednie . Punkt odniesienia zaznaczony na wskaźniku punktu odniesienia w panelach Przekształć i Sterowanie określa, który z dziewięciu punktów odniesienia zaznaczonego obiektu jest porównywany z punktem zerowym dokumentu lub z punktem zerowym ramki-kontenera. Punkt zerowy w ramce-kontenerze znajduje się zawsze w lewym górnym rogu ramki.

Położenie zaznaczonych obiektów mierzone jest w trzech aspektach:

  • Położenie ramki-kontenera w stosunku do punktu zerowego dokumentu. Niezależnie od ustawienia opcji Pokaż przesunięcie zawartości, zaznacz ramkę-kontener narzędziem Zaznaczanie.

  • Położenie obiektu zagnieżdżonego względem punktu zerowego dokumentu. Wyłącz opcję Pokaż przesunięcie zawartości i zaznacz zagnieżdżony obiekt narzędziem Zaznaczenie bezpośrednie.

  • Położenie zagnieżdżonego obiektu w stosunku do punktu zerowego (lewego górnego rogu) ramki-kontenera. Włącz opcję Pokaż przesunięcie zawartości i zaznacz zagnieżdżony obiekt narzędziem Zaznaczanie bezpośrednie.

Położenie ramki macierzystej wyświetlone względem punktu zerowego dokumentu.
Położenie ramki macierzystej wyświetlone względem punktu zerowego dokumentu.

Położenie zagnieżdżonego obiektu wyświetlone względem punktu zerowego dokumentu
Położenie zagnieżdżonego obiektu wyświetlone względem punktu zerowego dokumentu

Położenie zagnieżdżonego obiektu wyświetlone względem ramki-kontenera
Położenie zagnieżdżonego obiektu wyświetlone względem ramki-kontenera

Gdy opcja Pokaż przesunięcie zawartości jest włączona, to wartości współrzędnych X i Y osadzonego obiektu wyświetlane są w odniesieniu do obiektu-kontenera. Ikony X/Y w panelu Przekształć zmieniają się wtedy w ikony X+/Y+. Gdy opcja ta jest wyłączona, współrzędne zagnieżdżonych obiektów wyświetlane są względem miarek.

  1. Włącz lub wyłącz opcję Pokaż przesunięcie zawartości w menu panelu Przekształć lub panelu Sterowanie.

Uwzględnij lub nie uwzględniaj grubości obrysu w pomiarze

Grubość obrysu może wpływać na rozmiar i położenie obiektu. Można dokonać zmiany wyrównania obrysu, a następnie określić, czy panel Przekształć ma mierzyć rozmiar i położenie obiektu od środka, czy od krawędzi jego obrysu. Informacje na temat zmiany wyrównania obrysu można znaleźć w części Opcje obrysu panelu.

Uwaga:

Opcja ta nie zmienia wpływu skalowania ramki na grubość obrysu, a jedynie jego wpływ na pomiary.

  1. Wykonaj jedną z następujących czynności w menu panelu Przekształć lub panelu Sterowanie:
    • Zaznacz polecenie Wymiary obejmują grubość obrysu, jeżeli pomiary panelu mają odpowiadać zewnętrznej krawędzi obrysu obiektu. Na przykład: jeżeli jedna ramka jest o dwa punkty krótsza od drugiej, ale obrys krótszej ramki jest o dwa punkty grubszy, to takie ustawienie spowoduje, że obie ramki będą miały na panelach Przekształcenia i Sterowanie taką samą wysokość.

    • Usuń zaznaczenie z opcji Wymiary obejmują grubość obrysu, jeżeli pomiary panelu mają odpowiadać ścieżce lub ramce obiektu, niezależnie od grubości obrysu. Na przykład, dwie ramki o tej samej wysokości będą miały w panelach Przekształć i Sterowanie jednakową wysokość, niezależnie od różnic w grubości ich obrysów.

Przekształcanie obiektów

Program InDesign umożliwia modyfikowanie rozmiarów i kształtów obiektów, a także ich orientacji w obszarze roboczym, udostępniając różne narzędzia i polecenia służące do tych celów. Przybornik zawiera cztery narzędzia do przekształceń — narzędzia Obracanie, Skalowanie, Pochylenie oraz Przekształcanie swobodne. Ponadto narzędzia Zaznaczanie można użyć do przekształcania obiektów. Wszystkie te przekształcenia, a dodatkowo także odbicie, dostępne są w panelach Przekształć i Sterowanie, w których można precyzyjnie określać przekształcenia.

Narzędzia do przekształcania (na górze) w porównaniu z panelem Przekształć (na dole)
Narzędzia do przekształcania (na górze) w porównaniu z panelem Przekształć (na dole)

A. Opcje obrotu B. Opcje pochylania C. Opcje skalowania 

W trakcie przekształcania obiektów, zwróć uwagę na następujące rzeczy:

  • Wyniki przekształcania mogą znacząco się różnić w zależności od tego, co zostało zaznaczone. Na przykład, gdy obracasz obraz, to co się obraca zależy od tego, czy zaznaczyłeś obraz, ramkę, czy obraz i ramkę. Narzędzia Zaznaczanie należy używać do przekształcania (obracania, skalowania, ścinania) całej ścieżki oraz jej zawartości (kliknij poza uchwytem zawartości), natomiast narzędzia Zaznaczanie bezpośrednie należy używać tylko do przekształcania ścieżki bez przekształcania jej zawartości lub do przekształcania tylko zawartości bez przekształcania samej ścieżki. Aby przekształcić zawartość bez przekształcania ścieżki, należy się upewnić, że wszystkie punkty kontrolne są zaznaczone.

Uwaga:

Aby zmienić rozmiar ramki i zawartości, zamiast z pól W i H skorzystaj z pól Wartość procentowa skali X i Wartość procentowa skali Y. Pola W i H zmieniają tylko zaznaczoną ramkę lub zawartość, a nie oba te elementy naraz. Należy pamiętać, że w polach Skala nie trzeba koniecznie określać wartości procentowych. Równie dobrze można ręcznie wpisać wymiary, dodając odpowiednią jednostkę, np. „6p”.

  • Przekształcanie modyfikuje wszystkie zaznaczone obiekty tak, jak pojedynczy obiekt. Na przykład, jeżeli zaznaczy się kilka obiektów i obróci je o 30°, to wszystkie zostaną obrócone wokół jednego punktu odniesienia. Aby obrócić każdy zaznaczony obiekt o 30° stopni wokół jego własnego punktu odniesienia, zaznacz je i obróć pojedynczo.

  • Przy przekształcaniu tekstu można posłużyć się jedną z dwóch metod zaznaczania. Całą ramkę tekstową lub tekst przekształcony na krzywe można zaznaczyć za pomocą narzędzia Zaznaczanie lub Zaznaczanie bezpośrednie, a następnie użyć narzędzi do przekształcania. Można też zaznaczyć tekst lub umieścić punkt wstawiania w ramce tekstowej, używając narzędzia Tekst, następnie określić przekształcenia w panelu Przekształć, w panelu Sterowanie albo w oknach dialogowych otwieranych po dwukrotnym kliknięciu narzędzia. W obu przypadkach przekształcenie obejmuje całą ramkę tekstową.

  • W przypadku obracania, pochylania lub skalowania grupy, ustawienia te nadawane są całej grupie, a także poszczególnym obiektom w grupie. Na przykład, jeżeli obróci się grupę o 30°, to wartość kąta obrotu w panelu Przekształć lub Sterowanie wynosi 30°, niezależnie od tego, czy zaznaczy się samą grupę, czy też zaznaczy bezpośrednio jeden z obiektów w tej grupie.

Przekształcanie obiektów za pomocą panelu Przekształcenia

Użyj narzędzi do zaznaczania, aby określić, czy zawartość i ramka mają być przekształcane razem czy oddzielnie.

  1. Zaznacz obiekt do przekształcenia.
    • Aby zaznaczyć ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki.

    • Aby przekształcić zawartość bez przekształcania ramki, użyj narzędzia Zaznaczanie bezpośrednie , aby bezpośrednio zaznaczyć obiekt, lub użyj narzędzia Zaznaczenie, aby klikną uchwyt zawartości obrazu.

    • Aby przekształcić ramkę bez przekształcania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.

  2. Wyznacz punkt odniesienia dla przekształcenia w panelu Przekształć lub panelu Sterowanie.

    Wszystkie wartości w panelu odnoszą się do obwiedni obiektów. Wartości współrzędnych X i Y odnoszą się do wskazanego punktu odniesienia na obwiedni względem punktu początkowego miarki.

  3. Wykonaj dowolną z następujących czynności.
    • Wprowadź nowe wartości w pola tekstowe.
    • Wybierz dostępne wartości z rozwijanych menu.
    • Wybierz polecenia z menu panelu

    Uwaga:

    Aby zachować proporcje obiektu podczas przekształcania za pomocą opcji Procent skali X i Procent skali Y, kliknij ikonę Stałe proporcje  w panelu. Gdy opcja ta nie jest włączona, po obu stronach ikony widoczne są kropki (jak w przerywanym łańcuchu). Można także zamiast wartości procentowych określić wymiary, podając odpowiednią jednostkę, np. 6p.

  4. Naciśnij klawisz Tab, Enter (w systemie Windows) lub Return (w systemie Mac OS), aby wprowadzić zmiany.

Przekształcanie obiektów za pomocą narzędzia Zaznaczanie

Aby przemieszczać, zmieniać rozmiar i obracać obiekty, użyj narzędzia Zaznaczenie.

  1. Zaznacz obiekt, korzystając z narzędzia Zaznaczanie . Aby przekształcić obraz w ramce, kliknij uchwyt zawartości, który pojawi się, gdy przytrzymasz wskaźnik nad obrazem.
  2. Wykonaj dowolną z następujących czynności:
    • Aby przesunąć obiekty, kliknij dowolne miejsce na obwiedni, a następnie przeciągnij.

    • Aby skalować obiekty, przytrzymaj wciśnięty klawisz Ctrl (Windows) lub Command (Mac OS) i przeciągaj uchwyt dowolnej obwiedni aż dany obiekt nie osiągnie pożądanego rozmiaru. Dodaj klawisz Shift, aby zachować proporcje zaznaczenia. Dodaj klawisz Alt (Windows) lub Option (Mac OS), by przeskalować obiekty poczynając od środka.

    • Aby obrócić obiekty, umieść kursor w dowolnym miejscu poza uchwytem obwiedni. Gdy wskaźnik przyjmie postać , przeciągaj, aż zaznaczenie obróci się pod pożądanym kątem.

    • Aby utworzyć odbicie obiektów, przeciągnij uchwyt obwiedni poza przeciwległą krawędź lub uchwyt, aż obiekt osiągnie żądany poziom odbicia.

Przekształcanie obiektów przy pomocy narzędzia Przekształcanie swobodne

Narzędzie Przekształcanie swobodne działa w taki sam sposób, jak w programach Adobe Photoshop i Adobe Illustrator, zapewniając możliwość dokonywania wszystkich przekształceń za pomocą jednego narzędzia. Gdy aktywne jest narzędzie Przekształcanie swobodne, przekształcenia można łączyć, np. obracając i skalując jednocześnie.

Uwaga:

Skróty klawiaturowe pozwalają błyskawicznie przełączać między narzędziem Przekształcanie swobodne (klawisz E), narzędziem Zaznaczanie (V) oraz narzędziem Zaznaczanie bezpośrednie (A).

  1. Zaznacz obiekt lub obiekty do przekształcania, używając odpowiedniego narzędzia do zaznaczania.
  2. Wybierz narzędzie Przekształcanie swobodne .
    • Aby przesunąć obiekty, kliknij dowolne miejsce na obwiedni, a następnie przeciągnij.

    • Aby przeskalować obiekty, przeciągnij jeden z uchwytów obwiedni, aż obiekt uzyska pożądaną wielkość. Przytrzymaj klawisz Shift podczas przeciągania uchwytu, aby zachować proporcje zaznaczenia.

    • Przytrzymaj klawisz Alt (w systemie Windows) lub Option (w systemie Mac OS) podczas przeciągania, aby skalować obiekty od środka obwiedni.

    • Aby obrócić obiekty, umieść kursor w dowolnym miejscu poza obwiednią. Gdy wskaźnik przyjmie postać , przeciągaj, aż zaznaczenie obróci się pod pożądanym kątem.

    • Aby utworzyć odbicie obiektów, przeciągnij uchwyt obwiedni poza przeciwległą krawędź lub uchwyt, aż obiekt osiągnie żądany poziom odbicia.

    • W celu pochylenia obiektów, rozpocznij przeciąganie uchwytu, a następnie przytrzymaj klawisz Ctrl (Windows) lub Command (Mac OS). Aby pochylić obiekt z obydwu stron, przytrzymaj klawisz Alt+Ctrl (Windows) lub Command+Option.

Obracanie obiektów

Obiekty można obracać przy pomocy różnych metod.

Obracanie obiektu przy pomocy narzędzia Obracanie

  1. Zaznacz obiekt do obrócenia. Aby obrócić ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby obrócić zawartość bez obracania jej ramki, kliknij Uchwyt zawartości lub użyj narzędzia Zaznaczanie bezpośrednie, aby zaznaczyć dany obiekt. Aby obrócić ramkę bez obracania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wybierz narzędzie Obracanie .
  3. Jeśli chcesz użyć innego punktu odniesienia dla obrotu, kliknij tam, gdzie ma być punkt odniesienia.
  4. Umieść narzędzie z dala od punktu odniesienia i przeciągnij wokół niego. Aby ograniczyć działanie narzędzia do wielokrotności 45°, przytrzymać Shift podczas przeciągania. Dla zwiększenia precyzji przeciągaj kursor dalej od punktu odniesienia.

Obiekty można również obracać za pomocą narzędzia Przekształcanie swobodne.

Jeśli włączono opcję Inteligentne linie pomocnicze (i Inteligentne wymiary), wyświetlona zostanie wskazówka, jeśli obiekt obrócono pod takim samym kątem, co inny pobliski obiekt. Na przykład jeśli jeden obiekt na stronie został obrócony o 24 stopnie, to podczas obracania innego obiektu do wartości zbliżonej do 24 stopni pojawi się ikona obrotu.

Obracanie obiektu przy pomocy narzędzia Zaznaczanie

  1. Korzystając z narzędzia Zaznaczanie, umieść wskaźnik w dowolnym miejscu poza uchwytem zaznaczenia. Gdy wskaźnik przyjmie postać , przeciągaj, aż zaznaczenie obróci się pod pożądanym kątem.

Obracanie obiektu przy pomocy panelu Przekształć lub Sterowanie

  1. Zaznacz obiekt do obrócenia. Aby obrócić ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby obrócić zawartość bez obracania jej ramki, kliknij Uchwyt zawartości lub użyj narzędzia Zaznaczanie bezpośrednie, aby zaznaczyć dany obiekt. Aby obrócić ramkę bez obracania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wykonaj dowolną z następujących czynności:
    • Aby obrócić zgodnie z ruchem wskazówek zegara lub przeciwnie z przyrostami o 90°, kliknij odpowiednie przyciski Obróć w panelu Sterowanie.

    • Aby obrócić element pod jednym z ustalonych wcześniej kątów, wybierz daną wartość kąta z wyskakującego menu Kąt obrotu  w panelu Przekształć lub Sterowanie.

    • Wpisz wartość w polu Kąt obrotu  w panelu Przekształć lub Sterowanie. Wartości dodatnie obracają zaznaczone obiekty w kierunku przeciwnym do ruchu wskazówek zegara, a wartości ujemne w kierunku zgodnym z ruchem wskazówek zegara. Następnie naciśnij klawisz Enter (Windows) lub Return (Mac OS).

    • Aby utworzyć kopię obiektu z zastosowaniem do niej nowego obrotu, wpisz wartość w polu Kąt obrotu w panelu Przekształć, a następnie przytrzymaj klawisz Alt (Windows) lub Option (Mac OS) i naciśnij klawisz Enter.

Jeśli obracasz pojedynczy obiekt, określona wartość nadal jest wyświetlana w panelu Przekształć lub Sterowanie. Jeśli obracasz wiele obiektów, Kąt obrotu jest ustawiany na 0 stopni, mimo wykonania obrotu obiektów.

Obracanie obiektu przy pomocy polecenia Obróć

Za pomocą polecenia Obrót można obrócić obiekt o zadany kąt. Polecenie to umożliwia również obrócenie kopii zaznaczonego obiektu podczas, gdy oryginał pozostaje na miejscu.

  1. Zaznacz obiekt do obrócenia. Aby obrócić ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby obrócić zawartość bez obracania jej ramki, zaznacz bezpośrednio obiekt. Aby obrócić ramkę bez obracania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wykonaj jedną z następujących czynności, aby otworzyć okno dialogowe Obrót:
    • Wybierz polecenie Obiekt > Przekształć > Obróć.

    • Dwukrotnie kliknij narzędzie Obracanie .

    • Zaznacz narzędzie Obracanie i przytrzymując klawisz Alt (Windows) lub Option (Mac OS), kliknij obiekt lub przestrzeń obok niego, aby zaznaczyć nowy punkt odniesienia.

  3. Wprowadź kąt obrotu w stopniach w pole Kąt. Wartości dodatnie obracają zaznaczone obiekty w kierunku przeciwnym do ruchu wskazówek zegara, a wartości ujemne w kierunku zgodnym z ruchem wskazówek zegara.
  4. Wykonaj jedną z następujących czynności:
    • Aby obejrzeć efekt przed zastosowaniem go, zaznacz opcję Podgląd.

    • Aby obrócić obiekt, kliknij OK.

    • Aby obrócić kopię obiektu, kliknij Kopiuj.

Przesuwanie obiektów

Obiekty można przenosić na inne miejsce, wycinając je z jednego punktu i wklejając w innym, wprowadzając odpowiednie współrzędne w pionie i w poziomie, albo przeciągając je. Przeciąganie umożliwia ponadto przesunięcie kopii i pozostawienie oryginalnego obiektu na miejscu, a także kopiowanie obiektów między różnymi aplikacjami.

Funkcja Inteligentnych linii pomocniczych ułatwia dokładne przenoszenie obiektów w obrębie układu. Podczas przeciągania obiektu pojawiają się tymczasowe linie pomocnicze wskazujące, czy dany obiekt jest wyrównywany do krawędzi lub środka strony lub do innego elementu na stronie.

Przesuwanie obiektów

Aby uzyskać lepsze rezultaty, użyj narzędzia zaznaczanie do przesuwania wielu obiektów. Jeśli użyjesz narzędzia Zaznaczanie bezpośrednie do zaznaczenia wielu obiektów lub ścieżek, przeciąganie przesunie tylko zaznaczoną grafikę, ścieżkę lub punkt kontrolny.

  1. Zaznacz obiekt do przesunięcia. Aby przesunąć ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby przesunąć zawartość bez przesuwania ramki, zaznacz bezpośrednio obiekt lub kliknij uchwyt zawartości, gdy nad obraz przesuniesz kursor myszy. Aby przesunąć ramkę bez przesuwania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wykonaj jedną z następujących czynności:
    • Aby wkleić obiekt (lub jego kopię) na nowe miejsce, wybierz polecenie Edycja > Wytnij lub Edycja > Kopiuj. Uaktywnij docelowe strony widzące i wybierz polecenie Edycja > Wklej. Obiekty pojawią się na środku aktywnej rozkładówki.
    • Aby wkleić kopię obiektu w to samo miejsce, co oryginał, wybierz polecenie Edycja > Kopiuj. Następnie wybierz polecenie Edycja > Wklej w miejscu. (Aby nieco odsunąć jedną kopię od drugiej, można użyć klawiszy strzałek).

    Uwaga:

    Jeżeli obiekt ma się pojawiać w tym samym miejscu na wielu stronach, warto utworzyć stronę wzorcową i umieścić na niej ten obiekt.

    • Aby przenieść obiekt na konkretne miejsce opisane numerycznie, wpisz wartość położenia w poziomie (X) i w pionie (Y) w panelu Przekształć lub Sterowanie. Następnie naciśnij klawisz Enter (Windows) lub Return (Mac OS).

    • Aby nieco przesunąć obiekt w jednym kierunku, naciśnij lub przytrzymaj klawisz strzałki; natomiast aby przenieść go na odległość dziesięć razy większą, przytrzymaj klawisz Shift podczas naciskania klawisza strzałki.

    • Aby przenieść obiekt przez przeciąganie, przeciągnij obiekt na nowe miejsce. Przytrzymanie podczas przeciągania klawisza Shift ogranicza ruch obiektu do ruchu w poziomie, w pionie albo pod kątem o wielokrotności 45°.

    Uwaga:

    Przeciągnij uchwyt zawartości, aby przesunąć obraz w jego ramce.

Przesuwanie obiektów na precyzyjnie podaną odległość

Za pomocą polecenia Przesunięcie można przenieść obiekt na zadaną odległość. Polecenie to umożliwia również przesunięcie kopii zaznaczonego obiektu podczas, gdy oryginał pozostaje na miejscu.

  1. Zaznacz obiekt do przesunięcia. Aby przesunąć ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby przesunąć zawartość bez przesuwania jej ramki, zaznacz bezpośrednio obiekt. Aby przesunąć ramkę bez przesuwania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wybierz polecenie Obiekt > Przekształć > Przesuń lub dwukrotnie kliknij ikonę narzędzia Zaznaczenie lub Zaznaczenie bezpośrednie.
  3. W oknie dialogowym Przesunięcie wykonaj jedną z następujących czynności:
    • Wpisz odległość przesunięcia w pionie i w poziomie. Wartości dodatnie przenoszą obiekt w dół i w prawo od osi x; wartości ujemne przenoszą obiekt w górę i w lewo.

    • Aby przesunąć obiekt z precyzyjnie zadaną odległością i kątem, wpisz odległość i kąt przesunięcia. Wprowadzony kąt jest liczony w stopniach względem osi x. Wartości dodatnie kąta określają ruch w kierunku przeciwnym do ruchu wskazówek zegara, natomiast wartości ujemne kąta określają ruch w kierunku zgodnym z ruchem wskazówek zegara. Można również wpisywać wartości od 180° do 360°; wartości te konwertowane są na odpowiadające im wartości ujemne (np. wartość 270° jest konwertowana na –90°).

  4. Wykonaj dowolną z następujących czynności.
    • Aby obejrzeć efekt przed zastosowaniem go, zaznacz opcję Podgląd.

    • Aby przesunąć obiekt, kliknij OK.

    • Aby przesunąć kopię obiektu, kliknij Kopiuj.

Przesuwanie obiektów do precyzyjnie podanego położenia

  1. Zaznacz obiekt do przesunięcia.
  2. Jeśli chcesz użyć innego punktu odniesienia dla przesunięcia, kliknij tam, gdzie ma być punkt odniesienia.

    Na przykład, jeśli chcesz przesunąć obiekt do górnego lewego rogu strony, wybierz górny lewy punkt odniesienia.

  3. W polach X i Y panelu Przekształcenia, wprowadź współrzędne miejsca, do którego ma być przesunięte zaznaczenie.

Określanie odległości skoku obiektów podczas przemieszczania

  1. Wybierz polecenie Edycja > Preferencje > Jednostki i skoki (Windows) lub InDesign > Preferencje > Jednostki i skoki (Mac OS).
  2. W polu Klawisze kursora wpisz odległość, na jaką każde naciśnięcie klawisza strzałki ma przenosić zaznaczenie, a następnie kliknij OK.

Uwaga:

Jeżeli podczas przenoszenia zaznaczenia przytrzyma się klawisz Shift, to będzie się ono przesuwało na odległość dziesięć razy większą od podanej w tym polu.

Skalowanie a zmiana rozmiaru obiektów

W programie InDesign zmiana rozmiaru i skalowanie to dwie osobne operacje. Zmiana rozmiaru to po prostu zmiana wartości Szerokości i Wysokości obiektu. Skalowanie polega na wprowadzeniu wartości procentowej w stosunku do oryginalnej skali (100%) ramki.

Różnica pomiędzy zmianą rozmiaru a skalowaniem nie zawsze jest jednak widoczna. Łatwiej zauważyć różnicę zmieniając rozmiary i skalując ramkę tekstową z obrysem. Jeśli zwiększysz dwukrotnie rozmiar ramki tekstowej, rozmiar tekstu i grubość obrysu pozostaną niezmienione. Jeśli przeskalujesz dwukrotnie ramkę tekstową, rozmiar tekstu i grubość obrysu również się podwoją.

Zmiana rozmiaru ramki

Według domyślnych ustawień, gdy zaznaczona jest ramka (bez zawartości), to zmiana wartości w polach Szerokość i Wysokość odnosi się wyłącznie do ramki, a nie do zawartości, bez względu na to które narzędzie zaznaczania jest aktywne.

Skalowanie ramki i jej zawartości

Gdy ramka jest zaznaczona narzędziem Zaznaczanie, to zmiana w polach Wartość procentowa skali x i Wartość procentowa skali Y odnosi się do ramki i jej zawartości. Jeśli wybrana jest funkcja Automatyczne dopasowanie, ramka i jej zawartość zmieniają rozmiar razem.

Zmiana rozmiaru i skalowanie zawartości ramki

Jeśli chcesz zmienić jedynie zawartość (zmienić rozmiar lub przeskalować) ramki, kliknij Uchwyt zawartości lub użyj narzędzia Zaznaczanie bezpośrednie, aby zaznaczyć daną zawartość. Następnie możesz skorzystać albo z pól Szerokość i Wysokość, albo z pól Skala.

Omijanie ustawień domyślnych

Aby przeskalować ramkę lub jej zawartość o wartość procentową i uzyskać wynik wyrażony w aktualnie wybranym systemie miar, możesz wpisać numer ze znakiem procentu, aby ominąć domyślny system miar. Przykładowo, jeśli aktualna szerokość wynosi 12p, a nowa ma wynosić 75% obecnej wartości, to w polu Szerokość można wpisać 75%. Po wciśnięciu klawisza Enter nowa wartość Szerokości wynosić będzie 9p.

W podobny sposób można też używać innych systemów miar w celu przeskalowania o określoną wartość, uzyskując wynik podany jako wartość procentową oryginału. Przykładowo, można zastąpić 100 % wartością 9p, a InDesign rozpozna jaka wartość procentowa musi być użyta dla uzyskania takiego wymiaru.

Zmiana rozmiaru obiektów

Przeciągnięcie uchwytu ramki, zawierającej zawartość, na przykład zaimportowaną grafikę, domyślnie nie powoduje zmiany rozmiaru zawartości. Należy pamiętać, że zawartość i ramka kontenera stanowią dwa odrębne elementy. Każdy z nich ma własną obwiednię. Zwyczajne przeciąganie ramki importowanej grafiki albo ją wykadruje albo pozostawi pustą przestrzeń poza grafiką, w zależności od kierunku przeciągania. Możliwość modyfikowania ramki odrębnie od jej zawartości zapewnia większą elastyczność, ale wymaga przyzwyczajenia.

Funkcja Inteligentnych linii pomocniczych ułatwia zmianę rozmiaru obiektów w odniesieniu do innych elementów układu. Podczas zmiany rozmiaru obiektu pojawiają się tymczasowe linie pomocnicze, wskazujące czy obiekt jest wyrównywany do krawędzi lub środka strony lub czy ma taką samą wysokość lub szerokość co inny element na stronie.

Zmiana rozmiaru importowanej grafiki
Zmiana rozmiaru importowanej grafiki

A. Ramka zaznaczona za pomocą narzędzia Zaznaczanie B. Ramka o zmienionych rozmiarach C. Przeskalowana ramka i zawartość 
  • Aby przeskalować ramkę, przeciągnij dowolny uchwyt za pomocą narzędzia Zaznaczanie. Jeśli podczas przeciągania przytrzymasz klawisz Ctrl (Windows) lub Command (Mac OS), ramka i zawartość zostaną przeskalowane. Dodatkowe naciśnięcie klawisza Shift powoduje skalowanie proporcjonalne.

Uwaga:

Jeśli wybrana jest funkcja Automatyczne dopasowanie, zmiana rozmiaru ramki powoduje zmianę rozmiaru obrazu w tej ramce.

  • Aby zmienić rozmiar zawartości ramki graficznej, użyj narzędzia Zaznaczanie, aby kliknąć uchwyt zawartości lub bezpośrednio zaznacz grafikę, a następnie przeciągnij którykolwiek z uchwytów ramki graficznej.
  • Aby precyzyjnie zmienić rozmiar ramki lub jej zawartości, zaznacz obiekt i wprowadź rozmiar w polach szerokość (Sz) lub wysokość (W) panelu Sterowanie.

Uwaga:

Aby zachować oryginalne proporcje obiektu, w trakcie stosowania panelu Sterowanie, zaznacz ikonę Zachowaj proporcje .

  • Aby zmienić rozmiar ramki i zawartości, zamiast z pól W i H skorzystaj z pól Wartość procentowa skali X i Wartość procentowa skali Y. Pola W i H zmieniają tylko zaznaczoną ramkę lub zawartość, a nie oba te elementy naraz. Zamiast określania wartości procentowych, można wpisać wymiary dodając odpowiednią jednostkę miary, jak np. „6p”.
  • Aby procentowo w stosunku do obecnego rozmiaru zmienić rozmiar ramki lub jej zawartości, zaznacz obiekt i wprowadź procenty w polach szerokość lub wysokość panelu Przekształcenia.
  • Aby utworzyć kopię obiektu z zastosowaniem do niej nowego rozmiaru, wpisz wartość w pole szerokość lub długość w panelu Przekształć, a następnie przytrzymaj klawisz Alt (Windows) lub Option (Mac OS) i naciśnij klawisz Enter.

Uwaga:

Po zamianie rozmiaru ramki lub obiektu, możesz użyć opcji dopasowywania (Obiekt > Dopasowanie), aby dopasować zawartość do ramki lub ramkę do zawartości.

Skalowanie obiektów

Skalowanie obiektu zwiększa lub zmniejsza go w poziomie (wzdłuż osi x), w pionie (wzdłuż osi y) albo w poziomie i w pionie, względem wybranego punktu odniesienia.

Domyślnie, program InDesign skaluje obrysy. Na przykład, jeśli przeskalujesz zaznaczony obiekt z 4-punktowym obrysem o 200%, panel Obrys pokaże 8-punktowy obrys a obrys wizualnie dwukrotnie powiększy swój rozmiar. Możesz zmienić domyślne zachowanie obrysu przez wyłączenie zaznaczenia opcji Podczas skalowania dopasuj grubość obrysu w menu panelu Przekształć lub Sterowanie.

Skalowanie obiektu przy pomocy narzędzia Zaznaczanie

  1. Aby przeskalować ramkę i zawartość jednocześnie, wybierz narzędzie Zaznaczenie, aby zaznaczyć dany obiekt i przytrzymaj klawisz Ctrl (Windows) lub Command (Mac OS). Przytrzymanie dodatkowo klawisza Shift umożliwi proporcjonalną zmianę rozmiaru obiektu.

Skalowanie obiektu przy pomocy narzędzia Skalowanie

  1. Zaznacz obiekt do przeskalowania. Aby przeskalować ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby przeskalować zawartość bez skalowania ramki, kliknij Uchwyt zawartości, aby bezpośrednio zaznaczyć dany obiekt. Aby przeskalować ramkę bez skalowania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wybierz narzędzie Skalowanie .
  3. Umieść narzędzie Skalowanie z dala od punktu odniesienia i przeciągnij. Aby przeskalować tylko oś x lub y, rozpocznij przeciąganie narzędziem Skalowanie tylko wzdłuż jednej osi. Aby przeskalować proporcjonalnie, przytrzymaj klawisz Shift w trakcie przeciągania narzędzia Skalowanie. Dla zwiększenia precyzji rozpocznij przeciąganie dalej od punktu odniesienia obiektu.

    Uwaga:

    Obiekty można również skalować za pomocą narzędzia Przekształcanie swobodne.

Skalowanie obiektu przy pomocy panelu Przekształć

Aby zachować oryginalne proporcje obiektu, w trakcie korzystania z panelu Przekształć zaznacz ikonę Zachowaj proporcje .

  1. Zaznacz obiekt do przeskalowania. Aby przeskalować ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby przeskalować zawartość bez zaznaczania jej ramki, zaznacz bezpośrednio obiekt. Aby przeskalować ramkę bez skalowania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wykonaj jedną z następujących czynności w panelu Przekształć lub Sterowanie:
    • Wybierz jedną z predefiniowanych wartości z wyskakującego menu Wartość procentowa skali X  lub Wartość procentowa skali Y .

    • Wprowadź wartość procentową (np. 120%) lub określoną odległość (np. 10p) w polu Wartość procentowa skali X lub Wartość procentowa skali Y, a następnie naciśnij klawisz Enter lub Return.

Skalowanie obiektu klawiszami strzałek

  1. Zaznacz lub zaznacz bezpośrednio obiekt lub ramkę.
  2. W panelu Przekształć należy wybrać opcję Wartość procentowa skali X lub Wartość procentowa skali Y .
  3. Naciśnięcie strzałki w górę lub w dół powoduje przeskalowanie obiektu odpowiednio o 1%. Przytrzymanie klawisza Shift oraz jednoczesne naciśnięcie klawisza strzałki powoduje przeskalowanie obiektu o 10%.

Podczas korzystania z tej metody skalowania w górę i w dół o taki sam procent obiekt powraca do oryginalnej wartości skali, jeśli w ogólnych preferencjach została wybrana opcja Dopasuj procent skalowania. Na przykład, jeśli koło o średnicy 20 mm zostanie przeskalowane w górę o 10%, a następnie w dół również o 10%, będzie miało ponownie 20 mm (nie 1,98 mm).

Skalowanie obiektu przy pomocy polecenia Skaluj

  1. Zaznacz obiekt do przeskalowania. Aby przeskalować ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby przeskalować zawartość bez zaznaczania jej ramki, zaznacz bezpośrednio obiekt. Aby przeskalować ramkę bez skalowania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wykonaj jedną z następujących czynności, aby otworzyć okno dialogowe Skalowanie:
    • Wybierz polecenie Obiekt > Skaluj.

    • Dwukrotnie kliknij narzędzie Skalowanie .

    • Zaznacz narzędzie Skalowanie i przytrzymując klawisz Alt (Windows) lub Option (Mac OS), kliknij obiekt lub kliknij obok obiektu, aby zaznaczyć nowy punkt odniesienia.

  3. Wpisz wartość procentową w polu Skala X lub Skala Y.

    Uwaga:

    Aby zachować oryginalne proporcje obiektu, w trakcie korzystania z panelu Przekształć zaznacz ikonę Zachowaj proporcje .

  4. Wykonaj dowolną z następujących czynności:
    • Aby obejrzeć efekt przed zastosowaniem go, zaznacz opcję Podgląd.

    • Aby przeskalować obiekt, kliknij OK.

    • Aby przeskalować kopię obiektu, kliknij Kopiuj.

Określanie sposobu śledzenia skalowania

Możesz określić sposób śledzenia skalowania w interfejsie. Jeśli w preferencjach ogólnych zaznaczona jest opcja Zastosuj do zawartości, wartości skalowania przyjmują wartość 100% w panelu Przekształć po przeskalowaniu obiektu. Jeśli zaznaczona jest opcja Dopasuj procent skalowania, wartości skalowania pozostają bez zmian (np. 125%).

Jeśli zaznaczonych jest wiele obiektów, wartość skalowania zawsze pokaże 100 %. Jednakże możesz zaznaczać obiekty indywidualnie i zobaczyć zastosowany efekt przekształcenia (np. 125 %) jeśli zaznaczona jest opcja Dopasuj procent skalowania.

  1. Wybierz polecenie Edycja > Preferencje > Ogólne (Windows) lub InDesign > Preferencje > Ogólne (Mac OS).
  2. Pod opcją Podczas skalowania zaznacz Zastosuj do zawartości lub Dopasuj procent skalowania, a następnie kliknij OK.

Uwaga:

Jeśli wybrana jest opcja Dopasuj procent skalowania, to podczas skalowania obiektu możesz wybrać polecenie Przedefiniuj skalę na 100 % z menu panelu Przekształcanie lub panelu Sterowanie, aby ustawić procent skalowania na 100 %.

Dostosowywanie grubości obrysu, kiedy obiekty są skalowane

  1. Zaznacz opcję Podczas skalowania dopasuj grubość obrysu w panelu Przekształć lub Sterowanie.

Na przykład, jeśli skalujesz 4-punktowy obrys o 200 % gdy ta opcja jest włączona, grubość obrysu osiągnie 8 punktów. Jeśli wyłączysz tę opcję, obiekt podwoi swój rozmiar, lecz obrys pozostanie 4-punktowy.

Jeśli ta opcja jest zaznaczona i skalujesz obiekt nieproporcjonalnie, program InDesign stosuje zmniejszą grubość obrysu do wszystkich stron. Na przykład, przypuśćmy, że skalujesz zaznaczony obiekt z 4-punktowym obrysem tylko w kierunku X o 200%. Zamiast zastosować 8-punktowy obrys w kierunku X i 4-punktowy w kierunku Y, program InDesign stosuje mniejszą wartość (4 punkty) do wszystkich boków.

Skalowanie efektów

Po utworzeniu obiektu i zastosowaniu do niego efektu skalowanie tego efektu przebiega proporcjonalnie do skalowanego obiektu. Skalowany efekt przejmuje tę samą proporcję, jaką zastosowano wobec skalowanego obiektu.

W menu Preferencje wybierz Ogólne > Zastosuj do zawartości > Dołącz efekty. Aby przeskalować obiekt bez skalowania efektu, należy cofnąć zaznaczenie tej opcji.

Preferencje – Dołącz efekty
Preferencje – Dołącz efekty

Lub

Okno > Obiekt i układ > Przekształć. Z menu wysuwanego wybierz polecenie Dopasuj efekty w trakcie skalowania, aby włączyć lub wyłączyć skalowanie efektów.

Dopasuj skalowanie
Dopasuj skalowanie

Opcja ta działa podobnie do efektów obrysu. Można więc skalować efekty w taki sam sposób, w jaki odbywa się skalowanie obrysów.

Zerowanie skalowania na 100%

W niektórych przypadkach, jeśli zajdzie potrzeba wyzerowania wartości Skala X i Skala Y do 100% bez zmian rozmiaru obiektu. Na przykład: jeśli został otwarty dokument z poprzedniej wersji programu InDesign, w którym wartości skalowania są różne od 100%, lub został przeskalowany obiekt z zaznaczoną preferencją Dopasuj procent skalowania. Gdy wybierzesz to polecenie, wartości skalowania dla wszystkich zaznaczonych ramek zostaną wyzerowane do 100%. Wybranie tego polecenia nie zmienia rozmiaru ani wyglądu obiektów.

  1. Zaznacz co najmniej jeden obiekt z wartością skalowania różną od 100%.

    Polecenie to nie jest aktywne jeśli zaznaczyłeś bezpośrednio importowany obraz lub ma wartości skalowania równe 100%.

  2. Wybierz Przedefiniuj skalę na 100% z menu panelu Przekształć lub Sterowanie.

Uwaga:

Wybranie tego polecenia może spowodować nieoczekiwane zachowanie obiektów w przekształcanej grupie.

Odbijanie (odwracanie) obiektów

Odbijanie obiektu odwraca go wzdłuż niewidocznej osi w podanym punkcie odniesienia. (Zobacz Zmiana ustawień przekształcania).

Oryginalny obiekt (na górze) odbity za pomocą polecenia Odbij poziomo (w środku) i Odbij pionowo (na dole)
Oryginalny obiekt (na górze) odbity za pomocą polecenia Odbij poziomo (w środku) i Odbij pionowo (na dole)

Znacznik odwrócenia/odbicia (P) w środku panelu Sterowanie pojawia się jako biały z czarnym konturem jeśli obiekt jest odwrócony. Jeśli obiekt nie jest odwrócony, znacznik jest cały czarny.

  1. Zaznacz obiekt do odwrócenia. Aby odwrócić ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby odwrócić zawartość bez odwracania jej ramki, zaznacz bezpośrednio obiekt. Aby odwrócić ramkę bez odwracania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wykonaj jedną z następujących czynności:
    • Aby odbić obiekty używając punktu odniesienia jako osi poziomej, kliknij przycisk Odbij poziomo z menu panelu Sterowanie.

    • Aby odbić obiekty, używając punktu odniesienia jako osi pionowej, kliknij przycisk Odbij pionowo z menu panelu Sterowanie.

    Uwaga:

    Obiekty możesz odbijać za pomocą narzędzia do zaznaczania lub narzędzia Przekształcanie swobodne, przeciągając jeden z boków obwiedni na drugą stronę, lub wpisując wartości ujemne w pola Procent skali X lub Procent skali Y w panelu Przekształć.

Ścinanie (pochylanie) obiektów

Ścinanie obiektu przekrzywia go wzdłuż osi poziomej lub pionowej, a także obraca obie osi obiektu. Ścinanie jest przydatne do:

  • Symulowania niektórych typów perspektywy, np. rzutu izometrycznego.

  • Pochylania ramki tekstowej.

  • Tworzenia perspektywicznych cieni, jeżeli pochyli się kopię obiektu.

Ścinanie obiektu

  1. Zaznacz obiekt do ścięcia. Aby ściąć ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby ściąć zawartość bez jej ramki, kliknij Uchwyt zawartości, aby bezpośrednio zaznaczyć dany obiekt. Aby ściąć ramkę bez skalowania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wykonaj jedną z następujących czynności:
    • Aby ściąć zaznaczone obiekty przez przeciąganie, zaznacz narzędzie Ścinanie . Umieść narzędzie Ścinanie z dala od punktu odniesienia i przeciągnij. Przytrzymywanie podczas przeciągania klawisza Shift, ogranicza ścinanie do osi prostopadłych pionowych lub poziomych. Jeśli rozpocząłeś przeciąganie pod nieprostym kątem to przytrzymywanie klawisza Shift, powoduje ścinanie pod tym kątem.


      Obiekt ścinany przez przeciągnięcie narzędziem Ścinanie; punkt odniesienia znajduje się w środku obiektu

    Uwaga:

    Jeśli chcesz użyć innego punktu odniesienia dla ścinania, kliknij tam, gdzie ma być punkt odniesienia.

    • Aby ściąć używając ustalonej wartości, wybierz kąt z wyskakującego menu Ścinanie  w panelu Przekształć lub Sterowanie.
    • Aby ściąć używając określonej wartości, wpisz wartość dodatnią lub ujemną kąta w pole Ścinanie  w panelu Przekształć lub Sterowanie. Naciśnij Enter lub Return.
    • Aby utworzyć kopię obiektu z zastosowaniem do niej nowego ścięcia, wpisz wartość w polu Ścinanie w panelu Przekształć, a następnie przytrzymaj klawisz Alt (Windows) lub Option (Mac OS) i naciśnij klawisz Enter.

Jeśli ścinasz pojedynczy obiekt, określona wartość nadal jest wyświetlana w panelu Przekształć lub Sterowanie. Jeśli ścinasz wiele obiektów, Kąt ścinania jest ustawiany na 0 stopni, mimo ścięcia obiektów.

Uwaga:

Obiekty można ścinać także za pomocą narzędzia Przekształcanie swobodne.

Ścinanie obiektu przy pomocy polecenia Ścinanie

Za pomocą polecenia Pochyl można pochylić obiekt o zadaną wielkość. Polecenie to umożliwia również ścięcie kopii zaznaczonego obiektu podczas, gdy oryginał pozostaje na miejscu.

  1. Zaznacz obiekt do ścięcia. Aby ściąć ramkę wraz z zawartością, użyj narzędzia Zaznaczanie w celu zaznaczenia ramki. Aby ściąć zawartość bez jej ramki, kliknij Uchwyt zawartości, aby bezpośrednio zaznaczyć dany obiekt. Aby ściąć ramkę bez skalowania zawartości, zaznacz bezpośrednio ramkę i zaznacz wszystkie punkty kontrolne.
  2. Wykonaj jedną z następujących czynności, aby otworzyć okno dialogowe Ścinanie:
    • Wybierz polecenie Obiekt > Przekształć > Ścinanie.

    • Dwukrotnie kliknij narzędzie Ścinanie .

    • Zaznacz narzędzie Ścinanie i kliknij klawisz Alt (Windows) lub Option (Mac OS), aby zaznaczyć nowy punkt odniesienia.

  3. Wpisz nowy kąt ścinania.

    Kąt ten to stopień przechylenia obiektu względem linii prostopadłej do osi pochylania. (Kąt ścinania jest obliczany w kierunku zgodnym z ruchem wskazówek zegara względem bieżącej osi).

  4. Określ oś, wzdłuż której obiekt ma zostać ścięty. Obiekty można ścinać wzdłuż osi poziomej lub pionowej.
  5. Wykonaj dowolną z następujących czynności:
    • Aby obejrzeć efekt przed zastosowaniem go, zaznacz opcję Podgląd.

    • Aby ściąć obiekt, kliknij OK.

    • Aby ściąć kopię obiektu, kliknij Kopiuj.

Powtarzanie przekształceń

Przekształcenia takie jak przesuwanie, skalowanie, obracanie, zmianę rozmiaru, odbijanie, pochylanie i dopasowywanie można powtarzać. Powtórzyć można pojedyncze przekształcenie albo sekwencję transformacji. Można też nadawać te przekształcenia kilku obiektom równocześnie. InDesign zapamiętuje wszystkie przekształcenia, dopóki nie zaznaczy się innego obiektu lub nie wykona innego zadania.

Uwaga:

Nie wszystkie przekształcenia są rejestrowane. Na przykład, modyfikacja ścieżki lub jej punktów nie jest rejestrowana jako przekształcenie.

  1. Zaznacz co najmniej jeden obiekt i przeprowadź wszystkie przekształcenia, które mają zostać powtórzone.
  2. Zaznacz obiekty, do których mają zostać zastosowane przekształcenia.
  3. Wybierz polecenie Obiekt > Przekształć ponownie, a następnie wybierz jedną z następujących opcji:

    Przekształć ponownie

    Stosuje do zaznaczenia ostatnią pojedynczą operację przekształcania.

    Przekształć ponownie indywidualnie

    Stosuje ostatnią pojedynczą operację przekształcania do każdego z zaznaczonych obiektów z osobna, a nie do wszystkich jako grupy.

    Przekształć ponownie sekwencję

    Stosuje do zaznaczenia ostatnią sekwencję operacji przekształcania.

    Przekształć ponownie sekwencję indywidualnie

    Stosuje ostatnią sekwencję operacji przekształcania do każdego z zaznaczonych obiektów z osobna.

Usuwanie przekształceń

  1. Zaznacz obiekt lub obiekty, które były przekształcone.
  2. Wybierz Wyczyść przekształcenia z menu panelu Przekształć lub Sterowanie.

    Jeśli nie wszystkie wartości były domyślne, wyczyszczenie przekształceń powoduje zmianę wyglądu obiektów.

    Uwaga:

    Jeśli wartości skalowania były wyzerowane do 100%, wyczyszczenie przekształceń nie zmieni skali.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online