Публикация документов AS3

  1. Руководство пользователя Adobe Animate
  2. Введение в Animate
    1. Новые возможности Animate
    2. Визуальный глоссарий
    3. Системные требования Animate
    4. Сочетания клавиш Animate
    5. Разные типы файлов в Animate
  3. Анимация
    1. Основы анимации в Animate
    2. Кадры и ключевые кадры в Animate
    3. Покадровая анимация в Animate
    4. Классическая анимация движения в Animate
    5. Инструмент «Кисть»
    6. Руководство по движению
    7. Анимация движения и язык ActionScript 3.0
    8. Сведения об анимации движения
    9. Анимация движения
    10. Создание анимации движения
    11. Использование ключевых кадров свойств
    12. Положения в анимации движения
    13. Использование Редактора движения для анимаций
    14. Редактирование траектории анимации движения
    15. Управление анимациями движения
    16. Настраиваемое ускорение и замедление
    17. Создание и применение стилей движения
    18. Настройка диапазонов анимации движения
    19. Сохранение анимации движения в файлах XML
    20. Анимация движения и классическая анимация
    21. Анимация фигур
    22. Инструмент «Кость» в Animate
    23. Скелетная анимация персонажей в Animate
    24. Слои-маски в Adobe Animate
    25. Работа со сценами в Animate
  4. Интерактивность
    1. Создание кнопок в Animate
    2. Преобразование проектов Animate в другие форматы документов
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Добавление интерактивных возможностей с помощью фрагментов кода в Animate
    5. Создание пользовательских компонентов HTML5
    6. Использование компонентов в HTML5 Canvas
    7. Создание пользовательских компонентов: примеры
    8. Фрагменты кода для пользовательских компонентов
    9. Рекомендации: реклама в Animate
    10. Разработка и публикация контента для виртуальной реальности
  5. Рабочая среда и рабочий процесс
    1. Создание и использование малярных кистей
    2. Использование шрифтов Google в документах HTML5 Canvas
    3. Использование библиотек Creative Cloud Libraries и Adobe Animate
    4. Использование рабочей области и панели «Инструменты» в Animate
    5. Рабочие процессы и рабочая среда Animate
    6. Использование веб-шрифтов в документах HTML5 Canvas
    7. Временные шкалы и ActionScript
    8. Работа с несколькими временными шкалами
    9. Задание настроек
    10. Использование панелей разработки Animate
    11. Создание слоев временной шкалы в Animate
    12. Экспорт анимаций для мобильных приложений и игровых платформ
    13. Перемещение и копирование объектов
    14. Шаблоны
    15. Поиск и замена в Animate
    16. Отмена/повтор действий и панель «История»
    17. Сочетания клавиш
    18. Использование временной шкалы в Animate
    19. Создание HTML-расширений
    20. Параметры оптимизации изображений и GIF-анимаций
    21. Настройки экспорта для изображений и GIF
    22. Панель «Ресурсы» в Animate
  6. Мультимедиа и видео
    1. Преобразование и объединение графических объектов в Animate
    2. Создание экземпляров символов и работа с ними в Animate
    3. Трассировка изображения
    4. Использование звука в Adobe Animate
    5. Экспорт SVG-файлов
    6. Создание видеофайлов для использования в Animate
    7. Добавление видео в Animate
    8. Работа с ключевыми точками видео
    9. Рисование и создание объектов в Animate
    10. Изменение линий и фигур
    11. Обводки, заливки и градиенты в Animate CC
    12. Работа с Adobe Premiere Pro и After Effects
    13. Панели «Цвет» в Animate CC
    14. Открытие файлов Flash CS6 в Animate
    15. Работа с классическим текстом в Animate
    16. Размещение иллюстраций в Animate
    17. Импортированные растровые изображения в Animate
    18. Трехмерная графика
    19. Работа с символами в Animate
    20. Рисование линий и фигур в Adobe Animate
    21. Работа с библиотеками в Animate
    22. Экспорт звуков
    23. Выделение объектов в Animate CC
    24. Работа с AI-файлами Illustrator в Animate
    25. Нанесение узоров с помощью инструмента «Аэрограф»
    26. Применение режимов наложения
    27. Упорядочивание объектов
    28. Автоматизация задач с помощью меню «Команды»
    29. Многоязычный текст
    30. Использование камеры в Animate
    31. Использование Animate с Adobe Scout
    32. Работа с файлами Fireworks
    33. Графические фильтры
    34. Звук и ActionScript
    35. Настройки рисования
    36. Рисование инструментом «Перо»
  7. Платформы
    1. Преобразование проектов Animate в другие форматы документов
    2. Поддержка специализированных платформ
    3. Создание и публикация документов HTML5 Canvas в Animate
    4. Создание и публикация документа WebGL
    5. Упаковка приложений AIR for iOS
    6. Публикация приложений AIR for Android
    7. Публикация для Adobe AIR на настольных ПК
    8. Параметры публикации ActionScript
    9. Рекомендации: размещение ActionScript в приложении
    10. Использование ActionScript в Animate
    11. Рекомендации: специальные возможности
    12. Специальные возможности в среде Animate
    13. Создание и использование сценариев
    14. Обеспечение поддержки специализированных платформ
    15. Общие сведения о поддержке специализированных платформ
    16. Создание содержимого со специальными возможностями
    17. Работа с плагинами поддержки специализированных платформ
    18. Отладка сценариев ActionScript 3.0
    19. Обеспечение поддержки специализированных платформ
  8. Экспорт и публикация
    1. Экспорт файлов из Animate CC
    2. Публикация OAM
    3. Экспорт SVG-файлов
    4. Экспорт графики и видео из Animate
    5. Публикация документов AS3
    6. Экспорт анимаций для мобильных приложений и игровых платформ
    7. Экспорт звуков
    8. Экспорт видеофайлов в QuickTime
    9. Управление воспроизведением внешнего видео с помощью ActionScript
    10. Рекомендации: советы по созданию контента для мобильных устройств
    11. Рекомендации: правила работы с видео
    12. Рекомендации: руководство по созданию SWF-приложений
    13. Рекомендации: формирование структуры FLA-файлов
    14. Рекомендации: оптимизация FLA-файлов для Animate
    15. Параметры публикации ActionScript
    16. Задание параметров публикации для Animate
    17. Экспорт файлов-проекторов
    18. Экспорт изображений и анимированных файлов GIF
    19. Шаблоны публикации HTML
    20. Работа с Adobe Premiere Pro и After Effects
    21. Быстрая публикация анимаций

Описание процесса публикации

Оно может быть воспроизведено следующими способами.

  • В веб-браузерах с установленным приложением Flash Player.

  • В качестве автономного приложения, которое называется проектором.

  • С помощью элемента управления ActiveX Flash в Microsoft Office и других приложениях с поддержкой ActiveX.

  • С помощью программ Flash Xtra в Director® и Authorware® корпорации Adobe®

По умолчанию команда «Опубликовать» создает SWF-файл и документ HTML, который вставляет содержимое Flash в окно браузера. Команда «Опубликовать» также создает и копирует файлы определения Macromedia Flash 4 и более поздних версий из Adobe. При изменении параметров публикации Flash сохраняет эти изменения вместе с документом. После создания профиля публикации его можно экспортировать для использования в других документах или другими пользователями, работающими над тем же проектом.

При использовании команд «Опубликовать», «Тестировать ролик» или «Отладка ролика» Flash создает SWF-файл на основе вашего FLA -файла. Инспектор свойств документа позволяет просматривать размеры всех SWF-файлов, созданных на основе текущего FLA-файла.

Flash® Player 6 и более поздних версий поддерживает кодирование текста в Юникоде. Эта кодировка позволяет пользователям просматривать многоязычный текст, независимо от языка операционной системы, в которой выполняется проигрыватель.

FLA-файл может быть опубликован для отображения в окне браузера в одном из альтернативных форматов: GIF, JPEG и PNG — с HTML-кодом. Альтернативные форматы позволяют браузеру отображать анимацию и взаимодействовать с пользователями, не имеющими нужной версии проигрывателя Adobe Flash Player. При публикации FLA-файла в альтернативных форматах параметры для всех форматов сохраняются внутри FLA-файла.

FLA-файл может быть также экспортирован в нескольких форматах, и этот процесс полностью аналогичен публикации в альтернативных форматах, за исключением того, что параметры для форматов вместе с FLA-файлом не сохраняются.

Можно также в любом HTML-редакторе создать собственный HTML-документ, включив в него теги, необходимые для отображения SWF-файла.

Проверить работу SWF-файла перед публикацией можно командой тестирования ролика (меню «Управление» > «Тестировать ролик» > «Тест») или тестирования монтажного кадра («Управление» > «Тестировать монтажный кадр»).

Оболочка HTML для документов AS3

Для воспроизведения SWF-файла в веб-браузере и задания параметров браузера необходим HTML-документ. Чтобы отобразить SWF-файл в веб-браузере, HTML-документ должен содержать теги object и embed с соответствующими параметрами.

Примечание.

Документ HTML с правильными тегами object и embed создается через диалоговое окно «Параметры публикации» с выбором параметра «HTML». Дополнительные сведения см. в разделе «Задание параметров публикации для документов HTML».

 

Animate может создавать HTML-документ автоматически в момент публикации SWF-файла.

Определение наличия проигрывателя Flash Player

Чтобы опубликованное содержимое Animate было доступно для просмотра интернет-пользователям, в их веб-браузере должен быть установлен проигрыватель Flash Player.

Следующие ресурсы и статьи позволяют получить актуальную информацию о добавлении кода на веб-страницы для определения наличия установленного проигрывателя Flash Player и представления альтернативного содержимого на странице, если проигрыватель не установлен.

Инструкции по определению того, установлено ПО Flash Player или нет, см. в справке Flash Player.

Публикация для мобильных устройств

Adobe® AIR® для Android® и iOS® позволяет создавать активное содержимое на языке сценариев ActionScript® с использованием средств рисования и шаблонов. Дополнительные сведения о разработке для мобильных устройств см. в справочнике разработчика AIR.

Примечание.

В зависимости от типа мобильного устройства к командам ActionScript и звуковым форматам могут применяться некоторые ограничения. Дополнительные сведения см. в статьях о мобильных устройствах в центре разработок Mobile Articles on the Mobile and Devices Development Center.

Проверка мобильного содержимого с помощью Mobile Content Simulator

Эмулятор мобильного содержимого Mobile Content Simulator позволяющий проверить содержимое, созданное с использованием Adobe AIR в среде с эмуляцией ОС Android или ОС iOS. При использовании Mobile Content Simulator вы можете выбрать команду «Управление» > «Тестировать ролик», чтобы проверить файл в AIR Debug Launcher for Mobile, который, в свою очередь, запускает эмулятор.

После того как откроется окно эмулятора, можно посылать входные данные документу так, как если бы он работал на мобильном устройстве. Доступные входные данные:

  • акселерометр, оси X, Y и Z;
  • ориентация: пороговый угол;
  • касания экрана и жесты, включая чувствительность к давлению;
  • данные геолокации, направление и скорость;
  • аппаратные клавиши (присутствующие на устройствах Android).

Публикация защищенных документов AS3

Flash Player 8 и более поздних версий содержит следующие функции, помогающие обеспечить безопасность документов.

Защита от переполнения буфера

Эта функция включается автоматически и не допускает злонамеренного использования внешних файлов в документе с целью перезаписи пользовательской памяти или внедрения вирусов и другого деструктивного кода. Она также предотвращает чтение или запись данных за пределами области данных, отведенной документу в системе пользователя.

Точное сопоставление адресов доменов для совместного использования данных документами

Flash Player 7 и более поздние версии реализуют более строгую модель безопасности, чем предыдущие версии. Она имеет два важных отличия от модели безопасности Flash Player 6 и Flash Player 7.

Точное сопоставление адресов доменов

Flash Player 6 позволяет SWF-файлам в похожих доменах (например, www.adobe.com и store.adobe.com) свободно обмениваться данными друг с другом и с другими документами. В программе Flash Player 7 домен данных, к которым выполняется доступ, должен точно соответствовать домену поставщика данных.

Ограничение по протоколам HTTPS/HTTP

SWF-файл, загруженный через незащищенный протокол (не HTTPS), не может получить доступ к содержимому, загружаемому по защищенному протоколу (HTTPS), даже если оба протокола используются на одном домене.

Локальная и сетевая безопасность воспроизведения

Модель безопасности проигрывателя Flash Player 8 и более поздних версий обеспечивает локальную и сетевую безопасность воспроизведения опубликованных SWF-файлов. По умолчанию SWF-файлам предоставляется доступ для чтения локальных и сетевых файлов. Однако SWF-файл с локальным доступом не может подключаться к сети, а следовательно, никаким образом не может и отправлять файлы и информацию по сети.

Разрешив SWF-файлу доступ к сетевым ресурсам, можно позволить ему отправлять и получать данные. Однако при предоставлении SWF-файлу доступа к сетевым ресурсам локальный доступ запрещается, тем самым защищая информацию на локальном компьютере от потенциальной передачи в сеть.

Выбор локальной или сетевой модели безопасности воспроизведения для публикуемых SWF-файлов производится в диалоговом окне «Параметры публикации».

Проигрыватель Flash Player

Проигрыватель Flash Player воспроизводит содержимое Flash таким же образом, как веб-браузер или хост-приложение с поддержкой ActiveX. Проигрыватель Flash устанавливается вместе с приложением Flash Если дважды щелкнуть содержимое Flash, то операционная система запустит Flash Player, который начнет воспроизведение SWF-файла. Проигрыватель позволяет пользователям, не имеющим веб-браузера или хост-приложения с поддержкой ActiveX, просматривать содержимое.

Для управления содержимым в программе Flash Player применяются команды меню и функция fscommand().

Контекстное меню Flash Player позволяет производить печать кадров содержимого Flash Pro.

  1. Выполните одно из следующих действий.

    • Чтобы открыть новый или существующий файл, выберите меню Файл > Создатьили Открыть.

    • Чтобы изменить вид документа, выберите меню Просмотр > Масштаб просмотра, а затем нужный элемент.

    • Для управления воспроизведением содержимого выберите меню Управление > Воспроизвести, Перемотать назадили Цикл воспроизведения.

Обновление и повторная установка Flash Player

Если при установке проигрывателя Flash Player возникли проблемы, его можно обновить или переустановить. Открыть страницу загрузки Flash Player можно непосредственно из Flash, выбрав пункт меню «Справка» > «Получить последнюю версию Flash Player».

Если вы хотите вначале удалить Flash Player, сделайте следующее.

  1. Закройте браузер.
  2. Удалите любую ранее установленную версию проигрывателя.

    Инструкции см. в технической заметке 14157 в центре поддержки по адресу www.adobe.com/go/tn_14157_ru.

  3. Установите проигрыватель, следуя инструкциям на экране.

    Также можно запустить одну из следующих программ установки в папке «Players» Однако программа установки на веб-сайте Adobe обычно бывает актуальнее тех, что находятся в папке «Players».

    • Для элемента управления ActiveX для Windows® (Internet Explorer или AOL) запустите файл Install Flash Player 9 AX.exe.
    • Для внешнего модуля для Windows (Firefox, Mozilla, Netscape, Safari или Opera) запустите файл Install Flash Player 9.exe.
    • Для внешнего модуля для Macintosh® (AOL, Firefox, Internet Explorer для Macintosh, Netscape, Opera или Safari) запустите файл Install Flash Player 10 (Mac OS 10.x) или Install Flash Player 9 OS X (Mac OS X.x).
    Примечание.

    Чтобы проверить правильность установки, откройте страницу http://www.adobe.com/shockwave/welcome/ в своем браузере.

Настройка сервера для Flash Player

Чтобы содержимое Flash было доступно пользователям для просмотра по сети, веб-сервер должен быть правильно настроен для распознавания SWF-файлов.

Настройка сервера заключается в установке соответствующих типов многоцелевых расширений интернет-почты (Multipart Internet Mail Extension, MIME), которые позволяют серверу распознавать файлы с расширением swf в качестве файлов Flash

Получив корректный тип MIME, браузер загружает соответствующий модуль, управляющее или вспомогательное приложение для обработки и правильного отображения полученных данных. Если тип MIME отсутствует или неправильно передан сервером, браузер может отобразить сообщение об ошибке или пустое окно со значком фрагмента пазла.

  • Если сайт обслуживает поставщик услуг Интернета (ISP), попросите его добавить на сервер следующий тип MIME: application/x-shockwave-flash с расширением SWF.

  • Администратор веб-сервера должен прочесть документацию и инструкции по добавлению или настройке типов MIME.

  • Системные администраторы предприятий могут настроить Flash таким образом, чтобы ограничить доступ Flash Player к ресурсам в локальной файловой системе. Создайте файл конфигурации безопасности, ограничивающий функциональность Flash Player в локальной файловой системе.

Он представляет собой текстовый файл, помещаемый в ту же папку, что и программа установки Flash Player. Во время установки она считывает файл конфигурации и выполняет содержащиеся в нем инструкции по обеспечению безопасности. Проигрыватель Flash Player пользуется для передачи файла конфигурации в ActionScript объектом System.

Файл конфигурации позволяет запретить доступ Flash Player к камере и микрофону, ограничить отведенный для него объем локального хранения данных, обеспечить управление функцией автообновления и запретить чтение данных с локального жесткого диска пользователя.

Добавление типов MIME

Когда веб-сервер получает доступ к файлам, для их корректного отображения он должен правильно определить, что их содержимое относится к Flash Если тип MIME отсутствует или неправильно передан сервером, браузер может вывести сообщение об ошибке или пустое окно со значком фрагмента пазла.

Если сервер настроен неправильно, пользователь (или системный администратор) должен добавить к конфигурации сервера типы MIME для SWF-файлов, связав с ними следующие типы MIME.

  • Тип MIME «application/x-shockwave-flash» имеет расширение SWF.

  • Тип MIME «application/futuresplash» имеет расширение SPL.

Администратор сервера должен прочесть документацию и инструкции по добавлению или настройке типов MIME. Пользователю для добавления типов MIME необходимо обратиться к поставщику услуг Интернета, веб-мастеру или администратору сервера.

Если сайт находится на сервере, работающем под управлением Mac OS, то необходимо задать следующие параметры: Action: Binary; Type: SWFL и Creator: SWF2.

Оптимизация поисковой системы для содержимого SWF

В середине 2008 года компания Adobe объявила о революционном изменении технологии Flash Player: теперь текстовое содержимое SWF-файлов доступно для индексирования поисковыми системами, такими как Google и Yahoo!. Существует целый ряд способов, как сделать SWF-содержимое доступным для поисковых систем. Совокупность этих способов называется оптимизацией поисковых систем (SEO).

О программах Omniture и Flash

Содержимое Flash можно интегрировать в Omniture SiteCatalyst и Omniture Test&Target. SiteCatalyst позволяет продавцам узнать, какие разделы их сайтов пользуются наибольшей популярностью у посетителей и на какие веб-сайты они переходят с данного сайта, а также определить ключевые метрики успешного проведения онлайновых маркетинговых кампаний. Test&Target предоставляет продавцам возможности постоянно корректировать содержание веб-сайта для удовлетворения интересов посетителей. Test&Target предоставляет пользователю интерфейс для разработки и проведения тестов, создания сегментов аудитории и фокусировки на определенном содержимом.

Пользователи Omniture могут использовать SiteCatalyst и Test&Target вместе с Flash, загрузив и установив пакет Omniture Extension.

  • Для загрузки расширений Omniture и инструкций по их использованию выберите «Справка» > «Omniture».

Логотип Adobe

Вход в учетную запись