Importovať súbory SVG

Posledná aktualizácia dňa 30. 9. 2026

Naučte sa importovať SVG súbory ako natívne, editovateľné vrstvy tvarov, ktoré sú pripravené na animáciu bez potreby konverzie.

Dvakrát kliknite do panela Project alebo použite File > Import > File na prehľadávanie a import SVG súboru.

Poznámka

Najnovšia verzia programu After Effects vám umožňuje importovať súbor ako záber alebo kompozíciu.

Pretiahnite importovaný SVG súbor do panela Timeline.

Vyberte vrstvu a použite sekciu Layer Contents na paneli Properties na zobrazenie štruktúry SVG súboru.

Panel Properties je otvorený a pod Layer Contents sú uvedené obsahy SVG.
Použite panel Properties na zobrazenie obsahu SVG súboru a úpravu ich vlastností.

Môžete tiež kliknúť na šípku vedľa vrstvy, čím ju rozbalíte, a potom rozbaliť sekciu Contents.Uvidíte všetky jednotlivé prvky a ich vlastnosti, ako napríklad Path, Fill a Transform.

Vrstva so SVG súborom je vybraná a sekcia Contents je rozbalená na zobrazenie jej vlastností vrátane Path, Fill a Transform.
Rozbaľte sekciu Contents SVG vrstvy na prístup a úpravu jej vlastností vrátane Path, Fill a Transform.

Tieto vlastnosti môžete použiť na animáciu rovnako ako pri každej inej vrstve tvaru.Napríklad:

  • Animovanie Path na vytvorenie morfujúcich efektov
  • Zmena farby výplne v čase pre dynamické prechody
  • Použitie vlastností Transform na nezávislé škálovanie, otáčanie alebo posúvanie prvkov

Ak majú vrstvy prechodové výplne a ťahy, môžete použiť vlastnosti Scale a Rotation na animáciu prechodu.

Jedna z vrstiev s prechodovým prvkom je vybraná a Gradient Fill 1 je zvýraznený.
Použite vlastnosti Gradient Fill na úpravu prechodu alebo jeho animáciu.

Importovať súbor SVG ako záber alebo ako kompozíciu

Import SVG v programe Adobe After Effects ponúka flexibilnú a lepšiu kontrolu nad tým, ako sa SVG súbory importujú do vášho projektu.S najnovšou verziou, keď importujete SVG súbor, môžete si vybrať, či ho chcete importovať ako záber alebo ako kompozíciu.

Import ako záber

Import ako kompoziť

Importuje SVG ako jednu priebežne rastriteľnú vektorovú vrstvu.

Importuje SVG ako kompozíciu zostavenú z editovateľných vrstiev tvaru.

Udržiava spojenie s externým SVG súborom.

Každý element sa konvertuje na vlastný editovateľný tvar.

Dobré pre jednovrstvové vektorové grafiky, keď nepotrebujete rozložiť predlohu na časti.

Vhodné na úpravu kriviek, tvarov a detailov na úrovni vrstvy, keď potrebujete animovať jednotlivé prvky.

Môžete kontrolovať, ktorý importný prístup sa použije predvolene pri importovaní SVG súborov nastavením možnosti Presunúť viacero položiek súborov ako v preferenciách Import.

  • macOS: After Effects > Nastavenia > Import > Presunúť viacero položiek súborov ako
  • Windows: Upraviť > Preferencie > Import > Presunúť viacero položiek súborov ako
Dialógové okno Preferencie je otvorené.Na karte Import je otvorená rozbaľovacia ponuka Presunúť viacero položiek súborov ako, ktorá ponúka možnosti pre výber importnej metódy.
Nastavte predvolenú preferenciu pre importovanie SVG súboru, pričom si vyberte, či sa má importovať ako materiál alebo ako kompozícia.

Dvakrát kliknite do panela Projekt alebo použite Súbor > Import > Súbor na prehľadávanie a importovanie súboru SVG.

Použite rozbaľovaciu ponuku Import ako v dialógovom okne Import súboru na výber jednej z nasledujúcich možností:

  • Záber
  • Kompozícia – Zachovať veľkosti vrstiev

Výber Materiál importuje súbor ako jednu zloženú vrstvu bez prístupu k jednotlivým elementom, čo ho robí vhodným pre statické použitie alebo keď nie je potrebná animácia.Výber Kompozícia – Zachovať veľkosti vrstvy vytvorí novú kompozíciu, kde sa každá zdrojová vrstva importuje samostatne, s veľkosťou podľa jej skutočného obsahu, čím sa kotviace body stávajú čistejšími a transformácie jednoduchšími pre animáciu.

macOS

Dialógové okno Import súboru je otvorené a sú tam možnosti importovať súbor ako materiál alebo ako kompozíciu.

Windows

Dialógové okno Import súboru je otvorené a sú tam možnosti importovať súbor ako materiál alebo ako kompozíciu.

Ak je to možné, vyberte nasledujúce možnosti:

  • vytvoriť kompozíciu: Vytvorí novú kompozíciu pomocou predvolených nastavení a automaticky umiestni importovaný SVG, buď ako materiál alebo ako kompozíciu s vrstvami tvaru, do časovej osi, čím vás ušetrí manuálneho vytvárania kompozície a presúvania SVG súboru do nej.
  • Sekvencia škálovateľnej vektorovej grafiky: Importuje viacero číslovaných SVG súborov a zaobchádza s nimi ako so sekvenciou vektorových obrázkov záber po zábere.

Použite časť Obsah vrstvy na paneli Vlastnosti alebo časť Obsah vrstvy na časovej osi na zobrazenie a prácu s jednotlivými prvkami a ich vlastnosťami, ak ste súbor SVG importovali ako kompozíciu.Ak je importovaný ako záber, správa sa ako bežná vrstva a možno ju upraviť pomocou štandardných vlastností Zmeniť.

Rovnako ako pri súboroch programu Illustrator, ak je vektorový súbor importovaný ako záber, môžete vybrať vrstvu na časovej osi, potom pravým tlačidlom myši kliknite a vyberte Vytvoriť > Vytvoriť tvary a text z vektorovej vrstvy, aby ste ju skonvertovali do upraviteľných vrstiev, čo vám umožní animovať jednotlivé cesty, čiary a výplne.V najnovšej beta verzii programu After Effects sa text v zdrojovom súbore skonvertuje na upraviteľné textové vrstvy, ktoré zachovajú písmo, veľkosť, výplň, pozíciu, štýly, čiary a nastavenia premenlivého písma. 

Keď importujete SVG ako záber, After Effects zachová živé prepojenie s pôvodným súborom, takže všetky zmeny, ktoré urobíte v tomto SVG mimo aplikácie, sa automaticky aktualizujú vo vašom projekte.

Konvertovať text z programu Illustrator na upraviteľné textové vrstvy

Používanie nových beta funkcií

Upraviteľný text zo súborov programu Illustrator je teraz dostupný na testovanie a spätné väzby.Vyskúšajte teraz v programe After Effects (beta).

V najnovšej beta verzii programu After Effects, keď je vrstva programu Illustrator importovaná ako záber, akýkoľvek text v zdrojovom súbore sa skonvertuje na vlastnú upraviteľnú textovú vrstvu namiesto sploštenia do obrysov tvarov.To znamená, že písmo, veľkosť, výplň, pozícia, štýly (ako napríklad Tučné a kurzíva), čiary a nastavenia premenlivého písma sa všetky zachovajú, takže môžete pokračovať v úprave textu priamo v programe After Effects namiesto jeho opätovného vytvárania od začiatku alebo návratu do programu Illustrator na vykonanie zmien.

Vyberte Súbor > Import > Súbor a potom súbor programu Illustrator, ktorý chcete importovať.

V dialógovom okne Importovať súbor sa uistite, že Importovať ako je nastavené na Záber pri výbere súboru na import.

V dialógovom okne Import potvrďte, že Typ importu je nastavený na Záber a vyberte Možnosti vrstvy na základe toho, čo chcete importovať zo súboru programu Illustrator.

Pretiahnite importovaný súbor na panel Časová os.

Pravým tlačidlom myši kliknite na vrstvu programu Illustrator a vyberte Vytvoriť > Vytvoriť tvary a text z vektorovej vrstvy, alebo použite Vrstva > Vytvoriť > Vytvoriť tvary a text z vektorovej vrstvy.

Ponuka Vrstva > Vytvoriť s vyznačenou možnosťou Vytvoriť tvary a text z vektorovej vrstvy, ktorá konvertuje vektorový text na upraviteľné textové vrstvy.
Vyberte Vytvoriť tvary a text z vektorovej vrstvy na konvertovanie textu z programu Illustrator na upraviteľné textové vrstvy programu After Effects namiesto tvarov.

Text sa skonvertuje na upraviteľnú textovú vrstvu, ktorá sa veľmi podobá písmu, veľkosti, výplni a pozícii pôvodného súboru.Potom môžete upravovať a prispôsobovať text priamo v programe After Effects.

Textová vrstva Brightness nad plameňovou grafikou s panelom Znak zobrazujúcim písmo Adobe Clean Italic, veľkosť 74 px a povolenú výplň.
Po konverzii zostáva text plne upraviteľný — písmo, štýl, veľkosť a výplň možno stále zmeniť na paneli Znak.

Poznámka

Text len s čiarami sa stále konvertuje ako cesty, nie ako upraviteľná textová vrstva. 

Netextový vektorový obsah sa stále konvertuje na vrstvy tvaru ako predtým, a ak súbor programu Illustrator obsahuje oboje, získate kombináciu textových vrstiev a vrstiev tvaru.

Pripojte sa ku konverzácii v našej komunite podpory editovateľného textu zo súborov programu Illustrator pre After Effects (Beta).

Kopírovanie a vkladanie obsahu z programu Illustrator a SVG

SVG obsah v schránke teraz možno vložiť do programu After Effects pomocou Úpravy > Vložiť. Obsah sa importuje ako natívne, editovateľné vrstvy tvarov, ktoré sú pripravené na animáciu, bez potreby medzikroku importu.

Kopírovanie obsahu z aplikácie Illustrator

Otvorte svoju predlohu v programe Adobe Illustrator.

Skontrolujte, že je vybratá predvoľba Zahrnúť SVG kód.

  • macOS: Vyberte Illustrator > Nastavenia > Spracovanie schránky a vyberte Zahrnúť SVG kód.
  • Windows: Vyberte Úpravy > Preferencie > Spracovanie schránky a vyberte Zahrnúť SVG kód.
Dialógové okno Preferencie je otvorené v programe Illustrator a možnosť Zahrnúť SVG kód je vybratá.
Povoľte Zahrnúť SVG kód, aby vaša predloha zostala editovateľná a vysokokvalitná v iných aplikáciách Adobe.

Vyberte predlohu, ktorú chcete kopírovať.

Tip

Pred kopírovaním konvertujte akýkoľvek SVG text na krivky, pretože SVG text nie je podporovaný pri vkladaní.

Vyberte Úpravy > Kopírovať.

Prepnite do programu After Effects a vykonajte jednu z nasledujúcich možností v závislosti od stavu vášho projektu:

  • Ak nie je otvorený žiadny projekt, vyberte Úpravy > Vložiť na vytvorenie nového projektu s kompozíciou obsahujúcou SVG obsah ako vrstvu tvaru.
  • Ak je projekt otvorený, ale nie je vybratá žiadna kompozícia, vyberte Úpravy > Vložiť na vytvorenie novej kompozície v aktuálnom projekte obsahujúcej vložený obsah.
Je vybratá možnosť Úpravy > Vložiť a obsah sa importuje ako natívne, editovateľné vrstvy tvarov pripravené na animáciu.
Úpravy > Vložiť vnesie obsah ako editovateľné vrstvy tvarov pripravené na animáciu.

Ak je v programe After Effects vybratá kompozícia, vyberte Úpravy > Vložiť na pridanie SVG obsahu ako novej vrstvy tvaru do tejto kompozície.

Vkladanie SVG z iných aplikácií

SVG obsah skopírovaný z akejkoľvek aplikácie, ktorá zapisuje SVG do systémovej schránky, možno vložiť použitím toho istého pracovného postupu Úpravy > Vložiť. Podpora závisí od toho, či zdrojová aplikácia umiestni platné SVG údaje do schránky.