Importovanie a pridávanie 3D modelov do kompozície

Posledná aktualizácia dňa 9. 11. 2026

Zistite, ako importovať súbory 3D modelov v programe After Effects a používať ich v kompozícii.

S programom After Effects 24.1 a novšími verziami môžete importovať svoje 3D modely priamo do projektu a vkladať ich do kompozície spolu s ostatnými 2D a 3D vrstvami.

Práca s 3D modelmi v programe After Effects

Ako importovať 3D model, skombinovať všetky zdroje a vytvoriť z neho finálne 3D pohybové video v programe After Effects. 

Tip

Importovanie 3D modelov do projektu

Vyberte položku Súbor > Import > Súbor alebo použite možnosť Import v paneli Projekt.

Vyberte formáty súborov GLB, GLTF, OBJ alebo FBX, ktoré chcete importovať zo zariadenia, a kliknite na Otvoriť. 

Pre súbor 3D modelu sa v projekte vytvorí nový priečinok s názvom modelu. Ak súbor 3D modelu obsahuje závislé súbory (obrázky textúr a súbor BIN pre GLTF), tieto súbory sa tiež umiestnia do tohto priečinka. 

Poznámka

3D súbory bez ďalších závislých súborov môžete importovať v paneli Projekt. Ďalšie informácie nájdete v časti Prehľadný import 3D modelov.

Tip

Ak chcete manuálne zhromaždiť závislé súbory, vyberte položku Súbor > Závislosti > Zhromaždiť súbory.

Podporované formáty súborov 3D modelov na import

  • GLTF a GLB: GLTF (Graphics Language Transmission Format) je novšia, bezplatná špecifikácia na efektívny prenos a načítanie 3D scén, ktorú ako otvorený štandard vyvíja a udržiava skupina Khronos Group. GLTF a jeho binárny formát balíka GLB (Graphics Language Transmission Format Binary) ponúkajú širšiu škálu funkcií, vrátane kamier a svetiel v scéne, kompresie dát a animácie modelov. Súbory GLB a GLTF podporujú fyzikálne presné materiály, ktoré zabezpečujú realistickejší vzhľad.
  • OBJ (Wavefront Object): OBJ je jedným z najčastejšie používaných formátov súborov 3D modelov a môže sa importovať do kompozície a spracovať pomocou rovnakých pracovných postupov animácie ako súbory GLTF a GLB.
  • FBX (Filmbox): FBX je predvolený formát súborov pre animované modely z obľúbenej online platformy na vytváranie a sťahovanie animácií postáv. Súbory FBX môžete použiť na začlenenie vložených animácií do svojich 3D kompozícií. 
Poznámka

GLB je preferovaný formát súboru pre väčšinu použití v After Effects, pretože ide o balík s jedným súborom, ktorý obsahuje všetky závislé zdroje a údaje o textúre. GLTF sa spolieha na ďalšie súbory, ktoré môžu vyžadovať ďalšie sledovanie súborov projektom.

Pridanie importovaného 3D modelu do kompozície

Vyberte položku Súbor > Import > Súbor, alebo použite možnosť Import v paneli Projekt.

Na import vyberte formáty súborov GLB, GLTF, OBJ alebo FBX zo zariadenia.

Po importovaní 3D modelu do panela Projekt a výbere tohto modelu sa zobrazí miniatúra.

V paneli Projekt je vybratý 3D model s názvom „3d-model-2.obj“ a zobrazuje sa miniatúra s náhľadom vybratého 3D modelu spolu s ďalšími podrobnosťami.
Miniatúra s náhľadom vybratého 3D modelu umožňuje jeho rýchlu identifikáciu ešte pred jeho pridaním na časovú osu.

Importovaný 3D súbor pridajte do kompozície presunutím do panela Časová os.

V dialógovom okne Nastavenia modelu zadajte požadované nastavenia. Štandardne je zapnutá možnosť Náhľad a v paneli Kompozícia môžete vidieť náhľad vzhľadu modelu pri zmene nastavení.

Importovanie súborov 3D modelov vo formátoch GLTF, GLB alebo OBJ a ich pridanie do kompozície.

Mierka objektu

Zmeniť mierku objektu.

Veľkosť kompozície

Prispôsobiť importovaný model veľkosti kompozície.

Poloha objektu počas zmeny mierky

Umožniť zmeny polohy 3D modelu počas zmeny mierky.

Jednotky modelu

Zmeniť jednotky modelu v mierke objektu. 

Zvislá os

Zmeniť os 3D modelu na os Y alebo os Z.

Prevrátiť os Z

Prevrátiť 3D modely okolo osi Z.

Extrahovanie všetkých materiálov

Extrahovať materiály z importovaného 3D modelu. Tieto extrahované materiály sa ukladajú do priečinka Materials v paneli Project.

Tip

Dialógové okno Model Settings môžete kedykoľvek otvoriť tak, že vyberiete model v paneli Project, Timeline alebo Composition a vyberiete možnosť Layer > Model Settings.

Poznámka
  • Keď v dialógovom okne Model Settings nastavíte parametre importovaného 3D modelu, bude sa to v kompozícii považovať za mierku 100. 
  • Keď do kompozície pridáte 3D model, 3D Renderer sa zmení na nový Advanced 3D a môžete zapnúť možnosť Draft 3D, aby ste mohli použiť základnú rovinu alebo rozšírený prehliadač.

Vyberte položku OK a dokončite pridanie modelu do kompozície.

Tip

GLTF a GLB 3D modely môžete importovať aj z knižníc Creative Cloud Libraries.

Prehľadnejší import 3D modelov

V najnovšej verzii sa importované 3D modely umiestňujú na úroveň Root v paneli Project namiesto vlastného priečinka. Závislé a súvisiace súbory, ako napríklad .mtl, .mdl, .scene, .bin a priečinky s textúrami, už nebudú viditeľné v paneli Project. 

Predvolený stav, v ktorom sa v paneli Project zobrazujú všetky závislé a súvisiace súbory importovaného 3D súboru. 

Prehľadnejší import 3D modelov zabezpečuje, že všetky závislé a súvisiace súbory importovaného 3D súboru už nie sú viditeľné v paneli Project. 

Tu je niekoľko vecí, ktoré by ste mali zvážiť:

  • Funkcia Collect files stále pridáva súbory závislostí modelu do množiny zhromaždených súborov.
  • Pri otváraní staršieho projektu už After Effects nebude v paneli Project zobrazovať závislé súbory.
  • Pri ukladaní projektov s 3D súbormi v starších verziách vytvorí After Effects priečinok pre modely, aby tieto verzie mali pri otvorení projektu vyhradené miesto pre závislé súbory.

Viac podobných