Mises à jour de sécurité disponibles pour Adobe Flash Player

Date de publication : 12 mai 2015

Dernière mise à jour : 3 juillet 2015

Identifiant de vulnérabilité : APSB15-09

Priorité : Voir le tableau ci-dessous

Références CVE : CVE-2015-3044, CVE-2015-3077, CVE-2015-3078, CVE-2015-3079, CVE-2015-3080, CVE-2015-3081, CVE-2015-3082, CVE-2015-3083, CVE-2015-3084, CVE-2015-3085, CVE-2015-3086, CVE-2015-3087, CVE-2015-3088, CVE-2015-3089, CVE-2015-3090, CVE-2015-3091, CVE-2015-3092, CVE-2015-3093

Plate-forme : toutes plates-formes

Récapitulatif

Adobe a publié des mises à niveau de sécurité pour Adobe Flash Player pour Windows, Macintosh et Linux. Ces mises à niveau corrigent des vulnérabilités susceptibles de permettre à un pirate de prendre le contrôle du système concerné. Adobe recommande aux utilisateurs de mettre à niveau leurs installations vers la dernière version :

  • Les utilisateurs des environnements d’exécution pour bureau d’Adobe Flash Player pour Windows et Macintosh sont invités à passer à la version 17.0.0.188.
  • Les utilisateurs de la version de support approfondi Adobe Flash Player sont invités à passer à la version 13.0.0.289.
  • Les utilisateurs d’Adobe Flash Player pour Linux sont invités à passer à la version 11.2.202.460.
  • Adobe Flash Player, installé avec Google Chrome ou avec Internet Explorer sous Windows 8.x, sera automatiquement mis à jour vers la version 17.0.0.188.
  • Les utilisateurs de l’environnement d’exécution pour bureau d’Adobe AIR doivent installer la version 17.0.0.172.
  • Les utilisateurs du kit SDK Adobe AIR, et du kit SDK et compilateur Adobe AIR sont invités à installer la version 17.0.0.172.

Versions logicielles concernées

  • Adobe Flash Player versions 17.0.0.169 et antérieures
  • Adobe Flash Player version 13.0.0.281 et versions 13.x antérieures
  • Adobe Flash Player version 11.2.202.457 et versions 11.x antérieures
  • AIR Desktop Runtime versions 17.0.0.144 et antérieures
  • Kit SDK et compilateur AIR versions 17.0.0.144 et antérieures 

Pour vérifier le numéro de version d'Adobe Flash Player installé sur votre système, accédez à la page À propos de Flash Player ou cliquez avec le bouton droit de la souris sur du contenu exécuté dans Flash Player et sélectionnez À propos d'Adobe (ou de Macromedia) Flash Player dans le menu contextuel. Effectuez cette vérification pour tous les navigateurs utilisés sur votre système.

Pour vérifier le numéro de la version d'Adobe AIR installée sur votre système, suivez les instructions de la note technique sur Adobe AIR.

Solution

Adobe recommande aux utilisateurs d’effectuer la mise à niveau de leurs installations en procédant comme suit : 

  • Adobe recommande aux utilisateurs des environnements d’exécution pour bureau d’Adobe Flash Player pour Windows et Macintosh d’effectuer une mise à jour vers la version 17.0.0.188, en consultant le Centre de téléchargement Adobe Flash Player ou en utilisant le processus de mise à jour s’ils y sont invités. 

  • Adobe recommande aux utilisateurs de la version de support approfondi d’Adobe Flash Player d’effectuer une mise à jour vers la version 13.0.0.289, en consultant la page http://helpx.adobe.com/fr/flash-player/kb/archived-flash-player-versions.html

  • Adobe recommande aux utilisateurs d’Adobe Flash Player pour Linux d’installer la version 11.2.202.460 en la téléchargeant depuis le _frCentre de téléchargement Adobe Flash Player

  • La version d’Adobe Flash Player installée avec Google Chrome sera automatiquement mise à jour vers la dernière version de Google Chrome, qui inclut Adobe Flash Player 17.0.0.188. 

  • La version d’Adobe Flash Player installée avec Internet Explorer pour Windows 8.x sera automatiquement mise à jour avec la dernière version, qui inclut Adobe Flash Player 17.0.0.188. 

  • Adobe recommande aux utilisateurs des environnements d’exécution pour bureau d’Adobe AIR d’effectuer une mise à jour vers la version 17.0.0.172, en consultant le Centre de téléchargement Adobe AIR.  

  • Adobe recommande aux utilisateurs du kit SDK Adobe AIR d’effectuer une mise à jour vers la version 17.0.0.172, en consultant le Centre de téléchargement Adobe AIR.  

  • Adobe recommande aux utilisateurs du kit SDK et du compilateur Adobe AIR d’effectuer une mise à jour vers la version 17.0.0.172, en consultant le Centre de téléchargement Adobe AIR.

Degrés de priorité et de gravité

Adobe attribue à ces mises à jour les priorités suivantes et recommande aux utilisateurs concernés de mettre à jour leurs installations avec les dernières versions des logiciels :

Produit Versions concernées Plate-forme Priorité
Environnement d’exécution pour bureau d’Adobe Flash Player Versions 17.0.0.169 et antérieures
Windows et Macintosh
1
Version de support approfondi Adobe Flash Player Versions 13.0.0.281 et antérieures Windows et Macintosh
1
Adobe Flash Player pour Google Chrome  Versions 17.0.0.169 et antérieures Windows, Macintosh et Linux
1
Adobe Flash Player pour Internet Explorer 10 et  11 Versions 17.0.0.169 et antérieures Windows 8.0 et 8.1 1
Adobe Flash Player Versions 11.2.202.457 et antérieures Linux 3
Environnement d’exécution pour bureau d’Adobe AIR Versions 17.0.0.144 et antérieures Windows et Macintosh  3
Kit SDK AIR Versions 17.0.0.144 et antérieures Windows, Macintosh, Android et iOS  3
Kit SDK et compilateur AIR Versions 17.0.0.144 et antérieures Windows, Macintosh, Android et iOS  3

Ces mises à jour corrigent des vulnérabilités critiques du logiciel.

Détails

Adobe a publié des mises à niveau de sécurité pour Adobe Flash Player pour Windows, Macintosh et Linux.   Ces mises à jour corrigent des vulnérabilités susceptibles de permettre à un pirate de prendre le contrôle du système concerné.  Adobe recommande aux utilisateurs de mettre à jour leurs installations vers les dernières versions :

  • Les utilisateurs des environnements d’exécution pour bureau d’Adobe Flash Player pour Windows et Macintosh sont invités à passer à la version 17.0.0.188.

  • Les utilisateurs de la version de support approfondi Adobe Flash Player sont invités à passer à la version 13.0.0.289.

  • Les utilisateurs d’Adobe Flash Player pour Linux sont invités à passer à la version 11.2.202.460.

  • Adobe Flash Player, installé avec Google Chrome ou avec Internet Explorer sous Windows 8.x, sera automatiquement mis à jour vers la version 17.0.0.188.

  • Les utilisateurs de l’environnement d’exécution pour bureau d’Adobe AIR doivent installer la version 17.0.0.172.

  • Les utilisateurs du kit SDK Adobe AIR, et du kit SDK et compilateur Adobe AIR sont invités à installer la version 17.0.0.172.

Ces mises à jour corrigent des vulnérabilités de type « corruption de mémoire » susceptibles d’entraîner une exécution de code (CVE-2015-3078, CVE-2015-3089, CVE-2015-3090, CVE-2015-3093).

Ces mises à jour corrigent une vulnérabilité de type « débordement de tas » susceptible d’entraîner l’exécution de code (CVE-2015-3088). 

Ces mises à jour corrigent un état de concurrence de type « TOCTOU (time-of-check time-of-use) » susceptible d’être exploité pour contourner le mode protégé d’Internet Explorer (CVE-2015-3081). 

Ces mises à jour corrigent des problèmes de contournement de validation susceptibles d’être exploités pour l’écriture de données arbitraires sur le système de fichiers avec des autorisations utilisateur (CVE-2015-3082, CVE-2015-3083, CVE-2015-3085).  

Ces mises à jour corrigent une vulnérabilité de type « débordement d’entier » susceptible d’entraîner l’exécution de code (CVE-2015-3087). 

Ces mises à jour corrigent une vulnérabilité de confusion de type susceptible d’entraîner l’exécution de code (CVE-2015-3077, CVE-2015-3084, CVE-2015-3086).

Ces mises à jour corrigent une vulnérabilité de type « utilisation de zone désallouée » susceptible d’entraîner l’exécution de code (CVE-2015-3080).

Ces mises à jour corrigent des vulnérabilités de type « fuite de mémoire » susceptibles de contourner la randomisation du format d’espace d’adresse (ASLR) (CVE-2015-3091, CVE-2015-3092). 

Ces mises à jour corrigent une vulnérabilité de type « contournement de sécurité » susceptible d’entraîner la divulgation d’informations (CVE-2015-3079). Elles apportent également un renforcement supplémentaire pour protéger les systèmes contre la vulnérabilité CVE-2015-3044. 

Logiciels concernés   Mise à niveau recommandée Disponibilité
Environnements d’exécution pour bureau d’Adobe Flash Player
  17.0.0.188

Centre de téléchargement Flash Player

Distribution de Flash Player

Version de support approfondi d’Adobe Flash Player   13.0.0.289 Extension d'assistance
Flash Player pour Linux   11.2.202.460 Centre de téléchargement Flash Player
Flash Player pour Google Chrome   17.0.0.188 Versions Google Chrome
Flash Player pour Internet Explorer 10 et 11   17.0.0.188
Avis de sécurité Microsoft
Environnement d’exécution pour bureau d’Adobe AIR   17.0.0.172 Centre de téléchargement AIR
Kit SDK AIR   17.0.0.172 Téléchargement du kit SDK AIR
Kit SDK et compilateur AIR   17.0.0.172 Téléchargement du kit SDK AIR

Remerciements

Adobe tient à remercier les personnes et sociétés suivantes pour avoir signalé ces problèmes et joint leurs efforts aux nôtres pour protéger nos clients :

  • bilou pour sa contribution au Chromium Vulnerability Rewards Program (CVE-2015-3080, CVE-2015-3093, CVE-2015-3089, CVE-2015-3087, CVE-2015-3088)   

  • Chris Evans du projet Google Project Zero (CVE-2015-3078, CVE-2015-3090, CVE-2015-3091, CVE-2015-3092)

  • Jietao Yang et Jihui Lu de KeenTeam (@K33nTeam) (CVE-2015-3083)  

  • Jietao Yang de KeenTeam (@K33nTeam) (CVE-2015-3082) 

  • Jihui Lu de KeenTeam (@K33nTeam) (CVE-2015-3081) 

  • Jouko Pynnönen de Klikki Oy et Bas Venis (CVE-2015-3044, CVE-2015-3079)

  • Natalie Silvanovich du projet Google Project Zero (CVE-2015-3077, CVE-2015-3084, CVE-2015-3086) 

  • Nicolas Joly pour sa contribution au projet Zero Day Initiative d’HP (CVE-2015-3085)

Révisions

3 juillet 2015 : remerciements supplémentaires à Bas Venis qui avait signalé séparément les vulnérabilités CVE-2015-3044 et CVE-2015-3079.