Issue: "Licensing for this product has stopped working" error

Note:

This article is applicable to Creative Suite 5.5 and earlier.

When you try to start an Adobe application, do you receive a "Licensing for this product has stopped working" error message? If so, try the solutions on this page to resolve the issue.

Solutions

Important: Perform the solutions below in order. Do not continue to the next solution if a prior solution resolves the problem. After performing some of these solutions, sometimes you will be required to reenter licensing data or activate your product. Furthermore, trial editions of Adobe software can be prevented from starting.

Solution 1: Apply the Licensing Service Update.

  1. Close all Adobe applications.
  2. Run the License Service Update:

    1. Extract the LicenseRecovery109.zip.

      Important: Use a utility such as WinZip to extract the contents on the zipped file.
    2. Double-click LicenseRecover.exe.
  3. Follow the onscreen instructions.
  4. Start your Adobe application.

    Important: The patch applies to Creative Suite 3 or 4 products, Acrobat 8 or 9, Photoshop Elements 6, 7 or 8, Director, and Adobe Technical Communication Suite. If your issue was not resolved on the first attempt, run the patch again and enter option 0, when prompted to do so. If the issue persists after you run the patch a second time, proceed to Solution 2.

Solution 2: Set the FLEXnet Licensing Service to Manual and start the service.

  1. Choose Start > Control Panel.
  2. Double-click Administrative Tools.
  3. Double-click Services.
  4. Double-click the FLEXnet Licensing Service to open the Properties dialog box.
  5. Click the Startup Type menu, and then select Manual.
  6. Click Apply.
  7. In the Services Status section, click Start to start the service.
  8. Click Apply, and then click OK.
  9. Close all open dialogs.
  10. Launch your Adobe application.
 

Note: If you receive the error, "Error 5, access denied," when you try to start the FLEXnet Licensing Service, do the following:

  1. Choose Start > Run and type services.msc.
  2. Double-click the FLEXnet Licensing Service.
  3. Click the Log-On tab and select Log On As: This Account, and specify your account.
  4. Click OK and close the Services window.
  5. Restart the system, and repeat Solution 2.

Solution 3: Rename the FLEXnet folder.

Rename the FLEXnet folder to FLEXnetold in the following location:

  • On Windows XP:
    C:\Documents and Settings\All Users\Application Data\FLEXnet
  • On Windows Vista or Windows 7:
    C:\ProgramData\FLEXnet folder

Important: Deleting this file discontinues any active Adobe tryouts and you lose any remaining days. 

 

Solution 4: Reset your permissions on the FLEXnet folder.

Close all Adobe applications. The FLEXnet folder contains the licensing data for the installed Adobe Applications. Adjusting the file permissions for FLEXnet folder may allow the licensing information be written properly. Follow the instructions below for your operating system to modify permissions to the FLEXnet folder (which contains the licensing service data).

Note: This solution requires administrative privileges on your computer. On Windows XP, log in using an administrative account. On Windows 7 and Vista, provide administrative credentials.

On Windows XP Professional

  1. Choose Start > Control Panel.
  2. Double-click Folder Options, and then click the View tab.
  3. Scroll to the bottom of the Advanced Settings section, and then deselect the Use Simple File Sharing (Recommended) option.
  4. Click OK.
  5. In the Control Panel Explorer window, click the address bar, type %ALLUSERSPROFILE%\Application Data, and then press Enter.
  6. Right-click the FLEXnet folder, and choose Properties.
  7. In the Attributes section, deselect Read-Only.
  8. Click Apply, and then click OK to close the Confirm Attribute Changes dialog box.
  9. Click the Security tab.
  10. Make certain that Administrators and System are listed and permissions for security are set to Full Control.
  11. Click Advanced.
  12. Select the Replace Permission Entries On All Child Objects With Entries Shown Here That Apply To Child Objects option.
  13. Click the Owner tab.
  14. Select Administrators.
  15. Select the Replace Owner On Subcontainers and Objects option.
  16. Click OK, and then click Yes in the Security dialog box.
  17. Click OK to close the FLEXnet Properties dialog box.
  18. Launch your Adobe application.
 

On Windows XP Home

  1. Restart in Safe mode.
    1. Restart Windows.
    2. Press F8 before Windows starts (when you see a message such as For Advanced Startup Options).
    3. Select Safe Mode from the list of startup options.

      • If Safe Mode doesn't appear in each corner of the desktop, then repeat steps 1.1 through 1.3.
      • If Safe Mode does appear in each corner of the desktop, then log in as administrator of the local machine.
    4. If a dialog box indicates that Windows is running in Safe Mode, then click OK.
  2. Choose Start > Control Panel.
  3. Double-click Folder Options, and then click the View tab.
  4. Scroll to the bottom of the Advanced Settings section, and then deselect the Use Simple File Sharing (Recommended) option.
  5. Click OK.
  6. In the Control Panel Explorer window, click the address bar, type %ALLUSERSPROFILE%\Application Data, and then press Enter.
  7. Right-click the FLEXnet folder, and choose Properties.
  8. In the Attributes section, deselect Read-Only.
  9. Click Apply, and then click OK to close the Confirm Attribute Changes dialog box.
  10. Click the Security tab.
  11. Make certain that Administrators and System are listed and permissions for security are set to Full Control.
  12. Click Advanced.
  13. Click the Owner tab.
  14. Select Administrators.
  15. Select the Replace Owner On Subcontainers and Objects option.
  16. Click Apply and select the Permissions tab.
  17. Select the Replace Permission Entries On All Child Objects With Entries Shown Here That Apply To Child Objects option.
  18. Click OK, and then click Yes in the Security dialog box.
  19. Click OK to close the FLEXnet Properties dialog box.
  20. Launch your Adobe application.
 

On Windows 7 or Windows Vista

  1. Choose Start > Computer.
  2. Choose Organize > Folder and Search Options, and then click the View tab.
  3. Scroll to the bottom of the Advanced Settings section, and then deselect the Use Sharing wizard (Recommended) option.
  4. Click OK.
  5. In the Computer Explorer window, click the address bar, type%ALLUSERSPROFILE%, and then press Enter.
  6. Right-click the FLEXnet folder, and then choose Properties.
  7. In the Attributes section, deselect Read-Only.
  8. Click Apply, and then click OK to close the Confirm Attribute Changes dialog box.
  9. Click the Security tab.
  10. Make certain that Administrators and System are listed and permissions for security are set to Full Control. If not, do the following:
    1. Click Edit.
    2. If the User Account Control (UAC) elevation prompt appears, then follow the instructions to accept it.
    3. Make the necessary changes.
  11. Click Advanced.
  12. Click the Owner tab.
  13. Click Edit, and then accept the UAC elevation prompt if it appears.
  14. In the Change Owners Section, click Administrators.
  15. Select the Replace Owner On Subcontainers and Objects option.
  16. Click Apply and click Permissions tab.
  17. Click Edit, and then accept the UAC elevation prompt if it appears.
  18. Select the Replace Permission Entries On All Child Objects With Entries Shown Here That Apply To Child Objects option.
  19. Click OK, and then click Yes.
  20. Click OK, and then click OK in the Windows Security dialog box.
  21. Click OK to close the Advanced Security Settings for FLEXnet dialog box.
  22. Click OK to close the FLEXnet Properties dialog box.
  23. Launch your Adobe application.
 

Solution 5: Reset your permissions on the Adobe PCD folder. 

Follow the instructions in Solution 4, but apply it to the following folder:

C:/Program Files/Common FIles/Adobe PCD

Solution 6: Remove the SQLite journaling file.

The journaling file exists only under specific circumstances where a client is accessing the database file with certain options enabled. If the file does not exist, continue to the next solution.

  1. Using Explorer, navigate to \Program Files\Common Files\Adobe\Adobe PCD\cache.
  2. If present, delete cache.db-journal.
  3. Launch your Adobe application.

Solution 7: (Vista only) Synchronize the virtualized and non-virtualized PCD and caps files.

Having both Vista-aware and Vista-unaware applications can cause files to be out of sync in C:\Program Files and in the virtual store location. To synchronize the folders, do the following:

  1. Close all Adobe applications.
  2. From C:\Program Files (x86)\Common Files\Adobe, copy the "Adobe PCD" folder.
  3. Paste this folder into C:\Users\[user name]\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe.
  4. Select Yes when prompted if you want to replace/merge the existing files. In the following dialog box, select Copy And Replace for all files.
  5. Relaunch the application.
  6. If the problem persists, do the same with the "caps" folder found in the same location and copied to the same location

Note: This solution can lead to the problem application, as well as other Adobe applications, asking for the serial number again.

Alternatively, you can rename or delete the folders in the virtual store and relaunch the application:

  1. Close all Adobe applications.
  2. Browse to C:\Users\[user name]\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe.
  3. Rename the Adobe PCD folder to something else, for example AdobeoldPCD, or delete this folder.
  4. Launch the application.
  5. If the problem persists, do the same with the caps folder.

If the above suggestions fail to provide a solution, delete the virtual store\Adobe registry key:

  1. Close all Adobe applications.
  2. Log in to Windows as an administrator.
  3. Choose Start > All Programs > Accessories > Run, and type regedit.
  4. Click the continue button in the User Account Control dialogue box.
  5. Make a backup copy of the registry by choosing File > Export. Name the backup and save it to a location you can remember.
  6. Right-click HKEY_LOCAL_MACHINE > SOFTWARE > Classes > VirtualStore > MACHINE > SOFTWARE > Adobe
  7. Select Delete. Exit the registry.
  8. Launch the application.

Note: This solution can lead to the problem application, as well as other Adobe applications, asking for the serial number again.

Solution 8: Reinstall.

WARNING! This process requires you to completely uninstall and reinstall all Adobe CS3 and CS4 branded software, as well as Acrobat 8 and 9. Administrator privileges are required to install Adobe software. Log in to an administrator account to perform the steps below. See the operating system documentation for additional information.

  1. Choose Start > Control Panel.
  2. Double-click Features and Programs (Windows 7/Vista) or Add Or Remove Programs (XP).
  3. Select your Adobe product and click Change/Remove.
  4. Follow the onscreen instructions to remove the software.
  5. Repeat steps 3 and 4 for your remaining Adobe CS3/CS4, Acrobat 8/9 products.
  6. Delete the following folders:
    C:\Program Files\Common Files\Adobe\Adobe PCD
    C:\Program Files\Common Files\Adobe\caps
    C:\Program Files\Common Files\Adobe\backup

  7. Choose Start > Shut Down, select Restart, and click OK.
  8. Install your Adobe products from the original media.
  9. Launch your Adobe products.

Solution 9: Contact Adobe Technical Support.

Adobe Technical Support can obtain logs from your machine to determine additional information about the failure. Contact Adobe Technical Support if the information provided has not helped to resolve your issue.

Additional information

Various issues can cause this error, including the following:

  • If the error occurs immediately after installation, a component sometimes requires an update to be compatible with your operating system. Or, the component requires a slightly different configuration for your system.
  • If the application previously started successfully at least once, or if it has been in heavy use, the issue is likely related to a system resource.  (Causes include low memory, low disk space, or simultaneous launch of several programs.) The result could be a temporary failure in the licensing system or corruption of the permanent licensing data.
  • If an interruption occurred during the installation process, it can prevent the licensing system from functioning correctly.
  • If you previously had participated in a pre-release program, it's possible that you have a temporary serial number which was set to expire. If so, see Error "Licensing for this product has expired" | CS4, CS5.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy