ייבוא קבצי SVG

עודכן לאחרונה בתאריך 11 בספטמבר 2026

למדו כיצד לייבא קבצי SVG כשכבות צורה מקוריות וניתנות לעריכה שמוכנות לאנימציה ללא צורך בהמרה.

לחצו פעמיים בתוך לוח Project או השתמשו ב-File > Import > File כדי לעיין ולייבא את קובץ ה-SVG.

פתק

הגרסה החדשה של After Effects מאפשרת לכם לייבא את הקובץ כחומר או כקומפוזיציה.

גררו והשמטו את קובץ ה-SVG המיובא ללוח Timeline.

בחרו את השכבה כדי להשתמש בקטע Layer Contents בלוח Properties כדי להציג את המבנה של ה-SVG.

לוח ה-Properties פתוח ותחת Layer Contents, תכני ה-SVG מוצגים.
השתמשו בלוח Properties כדי להציג את תכני קובץ ה-SVG ולהתאים את המאפיינים שלהם.

אתם יכולים גם לבחור את החץ שליד השכבה כדי לפתוח אותה, ואז להרחיב את קטע Contents.תראו את כל האלמנטים הבודדים והמאפיינים שלהם, כמו Path, Fill ו-Transform.

השכבה עם קובץ ה-SVG נבחרה, וקטע Contents מורחב כדי להציג את המאפיינים שלה, כולל Path, Fill ו-Transform.
הרחיבו את קטע Contents של שכבת ה-SVG כדי לגשת ולערוך את המאפיינים שלה, כולל Path, Fill ו-Transform.

תוכלו להשתמש במאפיינים האלה להנפשה בדיוק כמו כל שכבת צורה אחרת.לדוגמה:

  • אנמציה של Path כדי ליצור Effects של מורפינג
  • שינוי צבע מילוי לאורך זמן למעברים דינמיים
  • השתמשו במאפייני Transform כדי להגדיל, לסובב או להזיז אלמנטים באופן עצמאי

אם לשכבות יש מילויי מעבר צבע וקווים, אתם יכולים להשתמש במאפיינים Scale ו-Rotation כדי להוסיף אנימציה למעבר הצבע.

אחת השכבות עם אלמנט מעבר צבע נבחרה, ו-Gradient Fill 1 מודגש.
השתמשו במאפייני Gradient Fill כדי להתאים את מעבר הצבע או להנפיש אותם.

ייבוא קובץ SVG כחומר או כקומפוזיציה

ייבוא SVG ב-After Effects מציע גמישות ובקרה טובה יותר על האופן שבו קבצי SVG מיובאים בפרויקט שלכם.עם הגרסה החדשה, כשאתם מייבאים קובץ SVG, אתם יכולים לבחור להכניס אותו כחומר או כקומפוזיציה.

ייבוא כ-footage

ייבוא כקומפוזיציה

מייבא את ה-SVG כשכבה וקטורית אחת הניתנת לרסטריזציה רציפה.

מייבא את ה-SVG כקומפוזיציה המורכבת משכבות צורה ניתנות לעריכה.

שומר על חיבור לקובץ ה-SVG החיצוני.

כל אלמנט מומר לצורה נפרדת הניתנת לעריכה.

מתאים לגרפיקה וקטורית חד-שכבתית כאשר אינכם צריכים לחלק את העבודה לחלקים.

מתאים לעריכת נתיבים, צורות ופרטים ברמת השכבה כאשר אתם צריכים להנפיש אלמנטים בודדים.

תוכלו לקבוע איזה גישת ייבוא משמשת כברירת מחדל בעת ייבוא קבצי SVG על ידי הגדרת האפשרות Drag Multiple File Items As תחת העדפות Import.

  • macOS: After Effects > Settings > Import > Drag Multiple File Items As
  • Windows: Edit > Preferences > Import > Drag Multiple File Items As
תיבת הדו-שיח Preferences פתוחה.בלשונית Import, התפריט הנפתח Drag Multiple File Items As פתוח ומציע אפשרויות לבחירת שיטת הייבוא.
הגדירו את העדפת ברירת המחדל לייבוא קובץ SVG, בחרו אם הוא מיובא כ-footage או כקומפוזיציה.

לחצו לחיצה כפולה בתוך לוח Project או השתמשו ב-File > Import > File כדי לעיין ולייבא את קובץ ה-SVG.

השתמשו בתפריט הנפתח Import As בתיבת הדו-שיח Import file כדי לבחור באחת מהאפשרויות הבאות:

  • Footage
  • Composition - Retain Layer Sizes

בחירה ב-Footage מייבאת את הקובץ כשכבה שטוחה אחת ללא גישה לאלמנטים בודדים, מה שמתאים לשימוש סטטי או כאשר אין צורך בהנפשה. בחירה ב-Composition – Retain Layer Sizes יוצרת קומפוזיציה חדשה שבה כל שכבת מקור מיובאת בנפרד, בגודל התוכן בפועל, מה שהופך נקודות עוגן לנקיות יותר ושינויים לקלים יותר עבור הנפשה.

macOS

תיבת הדו-שיח Import file פתוחה וישנן אפשרויות לייבא את הקובץ כ-footage או כקומפוזיציה.

Windows

תיבת הדו-שיח Import file פתוחה וישנן אפשרויות לייבא את הקובץ כ-footage או כקומפוזיציה.

בחרו באפשרויות הבאות במידת הצורך:

  • Create Composition: יוצר קומפוזיציה חדשה באמצעות הגדרות ברירת מחדל ומציב אוטומטית את ה-SVG המיובא, כ-footage או כקומפוזיציה עם שכבות צורה, לתוך ציר הזמן, וחוסך לכם את הצורך ליצור קומפוזיציה באופן ידני ולגרור את קובץ ה-SVG אליה.
  • Scalable Vector Graphics Sequence: מייבא מספר קבצי SVG ממוספרים ומתייחס אליהם כרצף תמונות וקטוריות לפי מסגרות.

השתמשו במקטע Layer Contents בלוח Properties או במקטע Contents של ה-layer בציר הזמן כדי להציג ולעבוד עם רכיבים בודדים והמאפיינים שלהם, אם ייבאתם את קובץ ה-SVG כקומפוזיציה. אם הוא יובא כ-footage, הוא יתנהג כמו Layer (שכבה) רגיל ואפשר יהיה להתאים אותו באמצעות מאפייני Transform הרגילים.

כמו בקובצי Illustrator, אם קובץ הווקטור מיובא כ-footage, תוכלו לבחור את ה-layer בציר הזמן, ללחוץ לחיצה ימנית ואז לבחור Create > Create Shapes and Text from Vector Layer כדי להמיר אותו לשכבות שניתנות לעריכה, וכך לאפשר לכם להנפיש נתיבים, קווים ומילויים נפרדים.בגרסת ה-Beta העדכנית של After Effects,‏ טקסט בקובץ המקור מומר לשכבות טקסט שניתנות לעריכה, ששומרות על גופן, גודל, מילוי, מיקום, סגנונות, קווי מתאר והגדרות של גופן משתנה. 

כשאתם מייבאים SVG כ-footage, ‏After Effects שומר על קישור חי לקובץ המקורי, כך שכל שינוי שתבצעו ב-SVG הזה מחוץ ליישום יתעדכן אוטומטית בתוך הפרויקט שלכם.

המרת טקסט מ-Illustrator לשכבות טקסט שניתנות לעריכה

  השתמשו בתכונות Beta חדשות

טקסט שניתן לעריכה מקובצי Illustrator זמין עכשיו לבדיקה ולמשוב. נסו עכשיו ב-After Effects (Beta).

בגרסת ה-Beta העדכנית של After Effects, כאשר layer של Illustrator מיובא כ-footage, כל טקסט בקובץ המקור מומר לשכבת טקסט נפרדת שניתנת לעריכה, במקום להשתטח לקווי מתאר של צורות.כלומר, הגופן, הגודל, המילוי, המיקום, הסגנונות (כמו מודגש ונטוי), קווי המתאר וההגדרות של גופן משתנה – כולם נשמרים, כך שתוכלו להמשיך לערוך את הטקסט ישירות ב-After Effects במקום ליצור אותו מחדש מאפס או לחזור ל-Illustrator כדי לבצע שינויים.

בחרו File > Import > File ואז את קובץ ה-Illustrator שברצונכם לייבא.

בתיבת הדו-שיח Import File, ודאו שהאפשרות Import As מוגדרת כ-Footage כשאתם בוחרים את הקובץ לייבוא.

בתיבת הדו-שיח של הייבוא, ודאו שהאפשרות Import Kind מוגדרת כ-Footage ובחרו את Layer Options בהתאם למה שברצונכם לייבא מקובץ ה-Illustrator.

גררו את הקובץ המיובא ללוח Timeline.

לחצו לחיצה ימנית על ה-Layer (שכבה) של Illustrator ובחרו Create > Create Shapes and Text from Vector Layer, או השתמשו ב-Layer > Create > Create Shapes and Text from Vector Layer.

תפריט המשנה Layer > Create, שבו האפשרות Create Shapes and Text from Vector Layer מודגשת, ממיר טקסט וקטורי לשכבות טקסט שניתנות לעריכה.
בחרו באפשרות Create Shapes and Text from Vector Layer כדי להמיר טקסט של Illustrator לשכבות טקסט של After Effects שניתנות לעריכה במקום לצורות.

הטקסט מומר לשכבת טקסט שניתנת לעריכה, שתואמת באופן קרוב לגופן, לגודל, למילוי ולמיקום של הקובץ המקורי. לאחר מכן תוכלו לערוך ולהתאים את הטקסט ישירות ב-After Effects.

שכבת הטקסט Brightness מעל גרפיקה של להבה, כאשר הלוח Character מציג את הגופן Adobe Clean Italic, בגודל 74px, עם מילוי מופעל.
אחרי ההמרה, הטקסט נשאר ניתן לעריכה באופן מלא – עדיין אפשר לשנות את הגופן, הסגנון, הגודל והמילוי בלוח Character.

פתק

טקסט עם קו מתאר בלבד עדיין מומר לנתיבים במקום לשכבת טקסט שניתנת לעריכה. 

תוכן וקטורי שאינו טקסט עדיין מומר לשכבות צורה כמו קודם, ואם קובץ ה-Illustrator כולל את שניהם, תקבלו שילוב של שכבות טקסט ושכבות צורה.

הצטרפו לשיחה בקהילת After Effects (Beta) שלנו על תמיכה בטקסט הניתן לעריכה מקבצי Illustrator.

העתיקו והדביקו תוכן מ-Illustrator ו-SVG

כעת ניתן להדביק תוכן SVG מהלוח לתוך After Effects באמצעות Edit > Paste. התוכן מיובא כשכבות צורה מקוריות הניתנות לעריכה ומוכנות לאנימציה, ללא צורך בשלב ייבוא ביניים.

העתיקו תוכן מ-Illustrator

פתחו את היצירה שלכם ב-Adobe Illustrator.

ודאו שההעדפה Include SVG Code נבחרה.

  • macOS: בחרו Illustrator > Settings > Clipboard Handling ובחרו Include SVG Code.
  • Windows: בחרו Edit > Preferences > Clipboard Handling ובחרו Include SVG Code.
תיבת הדו-שיח Preferences פתוחה ב-Illustrator והאפשרות Includes SVG Code נבחרה.
הפעילו את Include SVG Code כדי לשמור על היצירה שלכם הניתנת לעריכה ובאיכות גבוהה ביישומי Adobe אחרים.

בחרו את היצירה שברצונכם להעתיק.

עצה

המירו כל טקסט SVG לעקומות לפני ההעתקה, מכיוון שטקסט SVG אינו נתמך בהדבקה.

בחרו Edit > Copy.

עברו ל-After Effects ובצעו אחת מהפעולות הבאות בהתאם למצב הפרויקט שלכם:

  • אם אין פרויקט פתוח, בחרו Edit > Paste ליצירת פרויקט חדש עם קומפוזיציה המכילה את תוכן ה-SVG כשכבת צורה.
  • אם פרויקט פתוח אך לא נבחרה קומפוזיציה, בחרו Edit > Paste ליצירת קומפוזיציה חדשה בפרויקט הנוכחי המכילה את התוכן שהודבק.
האפשרות Edit > Paste נבחרה, והתוכן מיובא כשכבות צורה מקוריות הניתנות לעריכה ומוכנות לאנימציה.
Edit > Paste מכניס תוכן כשכבות צורה הניתנות לעריכה, מוכנות לאנימציה.

אם קומפוזיציה נבחרה ב-After Effects, בחרו Edit > Paste כדי להוסיף את תוכן ה-SVG כשכבת צורה חדשה באותה קומפוזיציה.

הדביקו SVG מיישומים אחרים

תוכן SVG שהועתק מכל יישום שכותב SVG ללוח המערכת ניתן להדבקה באמצעות אותו תהליך עבודה של Edit > Paste. התמיכה תלויה בשאלה האם יישום המקור מציב נתוני SVG תקינים בלוח.