• È possibile importare, copiare e incollare o esportare facilmente grafica vettoriale e immagini bitmap, animazioni e pulsanti a più stati da utilizzare in Adobe Flash®.

  • il testo TLF di Flash viene copiato come immagine bitmap vuota in Fireworks in esecuzione su Windows. Convertite il testo TLF in ASCII e importatelo in Fireworks.

  • Inoltre, la funzionalità di avvio e modifica semplifica la modifica degli elementi grafici di Fireworks dall’interno di Flash. Quando si utilizza Flash, le preferenze di avvio e modifica impostate in Fireworks vengono sempre applicate.

  • Lo stile dell’HTML di Flash non supporta il codice dei menu a comparsa. I comportamenti dei pulsanti di Fireworks e altri tipi di interattività non vengono importati in Flash.

Inserire elementi grafici di Fireworks in Flash

L’importazione o la copia di un file PNG di Fireworks forniscono il massimo controllo sulle modalità di importazione di elementi grafici e animazioni in Flash. È inoltre possibile importare file JPEG, GIF, PNG e SWF esportati da Fireworks.

Nota:

quando gli elementi grafici di Fireworks vengono importati o copiati e incollati in Flash, alcuni attributi vanno persi, quali ad esempio i filtri attivi e le texture. Non è possibile importare o copiare e incollare l’effetto gradiente contorni da Fireworks in un documento Flash. Inoltre, Flash supporta solo i riempimenti uniformi, i riempimenti a gradiente e i tratti base.

Importare file PNG di Fireworks in Flash

I file PNG sorgente di Fireworks possono essere importati direttamente in Flash, senza doverli esportare ad alcun altro formato grafico. Tutti gli elementi grafici vettoriali, bitmap, delle animazioni e dei pulsanti multistato di Fireworks possono essere importati in Flash.

Nota:

i comportamenti dei pulsanti di Fireworks e altri tipi di interattività non vengono importati in Flash poiché i comportamenti di Fireworks vengono abilitati da JavaScript, esterno al formato file. Flash utilizza un codice ActionScript interno.

  1. Salvate il documento in Fireworks.

  2. Passate a un documento aperto di Flash.

  3. (Facoltativo) Fate clic sullo stato chiave e sul livello nel quale importare il contenuto di Fireworks.

  4. Scegliete File > Importa.

  5. Individuate il file PNG e selezionatelo.

  6. Nella finestra di dialogo Importa documento Fireworks, effettuate una delle seguenti operazioni:

    • Selezionate l’opzione Importa come singolo bitmap appiattito.

    • Selezionate un’opzione di importazione dai due menu a comparsa.

  7. Selezionate la modalità di importazione del testo.

  8. Fate clic su OK.

    Nota:

    le selezioni effettuate nella finestra di dialogo Importa documento Fireworks vengono salvate e utilizzate come impostazioni predefinite.

Opzioni per l’importazione di testo, oggetti vettoriali ed elementi grafici di Fireworks

Opzioni per l’importazione di elementi grafici

Importa come singolo bitmap appiattito

Consente di importare una singola immagine non modificabile.

Importa tutte le pagine come clip filmato in stati nuovi

Importa tutte le pagine nel file PNG in un nuovo livello di Flash che prenderà lo stesso nome del file PNG. Nel nuovo livello, si crea uno stato chiave nella posizione attuale dello stato; la prima pagina del file PNG viene inserita in tale stato come clip filmato e tutte le altre pagine vengono quindi inserite negli stati seguenti come clip filmato. Vengono mantenuti sia la gerarchia dei livelli che gli stati all’interno del file PNG.

Importa Pagina 1 nello stato corrente come clip filmato

Il contenuto della pagina selezionata viene importato come clip filmato, il quale viene inserito nello stato e nel livello attivi del file di Flash. Vengono mantenuti sia la gerarchia dei livelli che gli stati all’interno del file PNG.

Importa tutte le pagine come clip filmato in scene nuove

Importa tutte le pagine dal file PNG e applica ciascuna di esse in una nuova scena come clip filmato. Vengono mantenuti tutti i livelli e gli stati all’interno del file PNG. Nel caso in cui nel file di Flash esistano già delle scene, il processo di importazione aggiunge le scene nuove di seguito a quelle già esistenti.

Importa Pagina 1 in un livello nuovo

La pagina selezionata viene importata come livello nuovo. Gli stati vengono importati nella sequenza cronologica come stati separati.

Opzioni per l’importazione degli oggetti vettoriali

Importa come bitmap per mantenere aspetto

Conserva la modificabilità degli oggetti vettoriali, a meno che siano disponibili riempimenti, tratti o effetti speciali non supportati da Flash. Per conservare l’aspetto di tali oggetti, Flash li converte in immagini bitmap non modificabili.

Importa come tracciati modificabili

Conserva la modificabilità di tutti gli oggetti vettoriali. Se gli oggetti presentano riempimenti, tratti o effetti speciali non supportati da Flash, le proprietà potrebbero sembrare diverse dopo l’importazione.

Opzioni per l’importazione di testo

Importa come bitmap per mantenere aspetto

Conserva la modificabilità del testo, a meno che siano presenti riempimenti, tratti o effetti speciali non supportati da Flash. Per conservare l’aspetto di tale testo, Flash lo converte in un’immagine bitmap non modificabile.

Nota:

Il testo TLF di Flash viene copiato come immagine bitmap vuota in Fireworks.

Mantieni modificabile tutto il testo

Conserva la modificabilità di tutto il testo. Se gli oggetti di testo presentano riempimenti, tratti o effetti speciali non supportati da Flash, potrebbero sembrare diversi dopo l’importazione.

Copiare o trascinare gli elementi grafici di Fireworks in Flash

Per copiare elementi grafici in versioni di Flash precedenti a Flash 8, scegliete Modifica > Copia contorni tracciati.

Nota:

potrebbe essere necessario separare gli oggetti (Modifica > Separa) per renderli modificabili come oggetti vettoriali separati in Flash.

  1. In Fireworks, selezionate l’oggetto o gli oggetti da copiare.

  2. Selezionate Modifica > Copia e scegliete Copia dal menu a comparsa Flash.

  3. In Flash, create un nuovo documento e scegliere Modifica > Incolla o trascinate il file direttamente da Fireworks a Flash.

  4. Nella finestra di dialogo Importa documento Fireworks, selezionate un’opzione:

    Stato corrente come clip filmato

    Il contenuto da incollare viene importato come clip filmato, che viene inserito nello stato e nel livello attivi nel file di Flash. Vengono mantenuti sia la gerarchia dei livelli che gli stati all’interno del file PNG.

    Nuovo livello

    Il contenuto incollato viene importato come nuovo livello. Gli stati vengono importati nella sequenza cronologica come stati separati.

  5. Selezionate la modalità di importazione degli oggetti vettoriali.

  6. Selezionate la modalità di importazione del testo.

  7. Fate clic su OK.

    Nota:

    le selezioni effettuate nella finestra di dialogo Importa documento Fireworks vengono salvate e utilizzate come impostazioni predefinite.

La struttura della libreria di Flash

Gli oggetti di Fireworks sono importati in una Cartella oggetti Fireworks nella libreria di Flash. La struttura all’interno di questa cartella è la seguente:

Cartella File 1 // Con lo stesso nome del file di Fireworks

  • Cartella Pagina 1 // Con lo stesso nome della pagina (se vi è più di una pagina)

    — Pagina 1 // Con lo stesso nome della pagina

    — — Cartella Stato 1 // Con lo stesso nome dello stato (se sono presenti più stati)

    — — Stato 1 // Con lo stesso nome dello stato

    — — — Simbolo 1 nello Stato 1 // Nome in base al nome del simbolo

    — — — Simbolo 2 nello Stato 1

    ...

    — Cartella Livelli condivisi // Livelli condivisi tra gli stati nella Pagina 1

    — — Cartella Livelli condivisi // Con lo stesso nome del livello condiviso

    — — Simbolo del Livello condiviso

  • Cartella Pagina 2

    — Pagina 2

    — Simbolo 1 nella Pagina 2 (per le pagine senza stati)

    ...

  • Cartella Pagina master

    — Pagina master

    — Simbolo 1 nella Pagina master

    ...

    — Cartella Livelli condivisi // Livelli condivisi tra le pagine

    — — Cartella Livelli condivisi // Con lo stesso nome del livello condiviso

    — — Simbolo del Livello condiviso

L’importazione dei simboli di Fireworks in Flash

Quando si importano simboli Fireworks in Flash, è necessario tenere presente quanto segue:

  • Se un simbolo utilizza il ridimensionamento a 9 sezioni, le quattro guide sezione vengono importate e mantenute in Flash. Tuttavia, il ridimensionamento a 9 sezioni non viene mantenuto per le animazioni. I simboli importati vengono salvati come simboli nella libreria di Flash.

  • Le piccole modifiche apportate ai simboli complessi vengono perse. Viene importata la copia master del simbolo.

  • I simboli grafici complessi vengono immagazzinati come file PNG e JSF. Viene importato solo il file PNG. Se il simbolo è formato da diversi tracciati, questi vengono combinati in un simbolo unico.

  • Per ottenere una piena funzionalità dei simboli complessi in Flash, sostituiteli con la versione Flash del simbolo.

La conservazione degli attributi di visibilità e blocco

Gli oggetti e i livelli che nel file PNG sono nascosti vengono importati e rimangono nascosti in Flash. Tuttavia, le parti non visibili di un simbolo grafico complesso non vengono importate (ad esempio, gli stati Sopra o Giù di un pulsante).

Se un livello è bloccato o nascosto, tutti gli oggetti e i sottolivelli al suo interno ereditano questa impostazione e la mantengono quando vengono importati in Flash.

Se si importa una singola pagina in un nuovo livello in Flash, viene creato un livello per l’intera pagina e vengono visualizzati tutti gli oggetti. Gli attributi di blocco e visibilità non vengono mantenuti.

Effetti livello Photoshop supportati

Effetti dal vivo Photoshop - Ombra esterna

La mappatura è la seguente:

  • La dimensione viene mappata su blurX, blurY.

  • La distanza viene mappata sulla distanza.

  • Il colore viene mappato sul colore.

  • L’angolo viene mappato su 180 - (angolo dell’effetto Photoshop).

Effetti dal vivo Photoshop - Ombra interna

La mappatura è la seguente:

  • La dimensione viene mappata su blurX, blurY.

  • La distanza viene mappata sulla distanza.

  • Il colore viene mappato sul colore.

  • L’angolo viene mappato su 180 - (angolo dell’effetto Photoshop).

Effetti dal vivo Photoshop - Bagliore esterno

La mappatura è la seguente:

  • L’opacità viene mappata sull’intensità.

  • Il colore viene mappato sul colore.

  • La dimensione viene mappata su blurX, blurY.

Effetti dal vivo Photoshop - Bagliore interno

La mappatura è la seguente:

  • L’opacità viene mappata sull’intensità.

  • Il colore viene mappato sul colore.

  • La dimensione viene mappata su blurX, blurY.

  • Gli oggetti con qualunque altro effetto livello Photoshop vengono rasterizzati.

Esportazione di elementi grafici di Fireworks in altri formati per Flash

È possibile esportare elementi grafici di Fireworks come file JPEG, GIF, PNG e Adobe Illustrator 8 (AI), quindi importarli in Flash.

Sebbene PNG sia il formato di file nativo di Fireworks, i file degli elementi grafici PNG esportati da Fireworks sono differenti dai file sorgente PNG salvati in Fireworks. Analogamente ai file GIF o JPEG, i file PNG esportati contengono solo dati dell’immagine, senza informazioni aggiuntive sulle porzioni, i livelli, l’interattività, i filtri attivi o altro contenuto modificabile.

Esportare elementi grafici e animazioni di Fireworks come file SWF

Elementi grafici e animazioni di Fireworks possono essere esportati come file SWF di Flash. Per conservare le dimensioni e la formattazione del colore del tratto, scegliete Mantieni aspetto nella finestra di dialogo delle opzioni di esportazione Flash SWF.

La seguente formattazione viene persa durante l’esportazione in formato SWF: modalità di fusione, livelli, maschere (applicate prima dell’esportazione), oggetti porzione, mappe immagine, comportamenti, riempimenti a motivo e gradienti contorni.

  1. Selezionate File > Salva con nome.

  2. Immettete un nome di file e scegliete la cartella di destinazione.

  3. Per il formato, selezionate Adobe Flash SWF.

  4. Fate clic su Opzioni. Quindi, selezionate un’opzione Oggetti:

    Mantieni tracciati

    Consente di mantenere la modificabilità dei tracciati. Gli effetti e la formattazione non vengono mantenuti.

    Mantieni aspetto

    Consente di convertire gli oggetti vettoriali in oggetti bitmap in base alle necessità e conservare l’aspetto dei tratti e del riempimento applicato. La modificabilità andrà perduta.

  5. Selezionare un’opzione per Testo:

    Mantieni modificabilità

    Consente di mantenere la modificabilità del testo. Gli effetti e la formattazione non vengono mantenuti.

    Converti in tracciati

    Consente di convertire il testo in tracciati e conservare le opzioni di spaziatura e crenatura personalizzate definite in Fireworks. La possibilità di modificarlo come testo va perduta.

  6. Impostate la qualità delle immagini utilizzando il dispositivo di scorrimento a comparsa Qualità JPEG.

  7. Selezionate gli stati da esportare e la frequenza stati in secondi.

  8. Fate clic su OK, quindi su Salva nella finestra di dialogo Esporta.

Esportare file PNG a 8 bit con trasparenza

Per esportare file PNG a 32 bit con trasparenza, è sufficiente importare i file sorgente PNG di Fireworks direttamente in Flash. Per esportare i file PNG a 8 bit con trasparenza, completate la procedura descritta di seguito:

  1. In Fireworks, scegliete Finestra > Ottimizza per aprire il pannello Ottimizza.

  2. Selezionate PNG 8 come formato di file di esportazione e Trasparenza alfa dal menu a comparsa Trasparenza.

  3. Selezionate File > Esporta.

  4. Selezionate Solo immagini dal menu a comparsa Esporta.

  5. Salvate il file con nome.

Importare in Flash immagini e animazioni esportate da Fireworks

  1. Create un nuovo documento in Flash.

    Nota:

    se si sta importando un elemento grafico di Fireworks in un file di Flash esistente, create un nuovo livello in Flash.

  2. Selezionate File > Importa e individuate l’elemento grafico o il file animazione.

  3. Fate clic su Apri per importare il file.

Utilizzare Fireworks per modificare gli elementi grafici di Flash

Mediante l’integrazione di avvio e modifica, è possibile utilizzare Fireworks per apportare modifiche agli elementi grafici precedentemente importati in Flash, anche se non sono stati esportati da Fireworks.

Nota:

i file PNG Fireworks nativi importati in Flash costituiscono un’eccezione; è necessario che il file PNG sia stato importato come immagine bitmap appiattita.

Se l’immagine è stata esportata da Fireworks e il file originale PNG era stato salvato, è possibile modificare il file PNG in Fireworks direttamente da Flash. Quando si ritorna a Flash, vengono aggiornati sia il file PNG che il file grafico di Flash.

  1. In Flash, fate clic con il pulsante destro del mouse (Windows) o tenete premuto il tasto Ctrl e fate clic (Mac OS) su un elemento grafico selezionato nel pannello Libreria documento.

  2. Selezionate Modifica con Fireworks dal menu a comparsa.

    Nota:

    se Modifica con Fireworks non compare nel menu a comparsa, scegliete Modifica con e individuate l’applicazione Fireworks.

  3. Fate clic su Sì nella casella Trova sorgente per individuare il file PNG originale per l’elemento grafico Fireworks, quindi fate clic su Apri.

  4. Apportate le modifiche necessarie, quindi fate clic su Fine.

    Un nuovo file viene esportato in Flash e il file PNG originale viene salvato.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online